Search Google Appliance

IS&T Releases CertAid 2.0 for Safari Users
June 10, 2010
Patrick McNeal
Share |

Information Services and Technology (IS&T) has released CertAid 2.0. This updated version manages the entire certificate setup procedure for Safari browsers on Mac OS X 10.5 (Leopard) and 10.6 (Snow Leopard), giving users a more reliable installation experience.

The setup procedure includes installing the MIT CA as well as the user's personal certificate, optionally deleting old certificates, and setting the correct identity preferences via a single, graphical application.

Who Should Upgrade
IS&T recommends that anyone installing or updating certificates with Safari on Mac OS X 10.5 (Leopard) or 10.6 (Snow Leopard) should upgrade to CertAid 2.0.

Known Issues
CertAid 2.0 does not support Mac OS X 10.4 (Tiger).

How to Obtain
You can download CertAid 2.0 by clicking the Download Software button on the CertAid 2.0 Version Page.

Getting Help
IS&T has published information on using CertAid 2.0 to install certificates on Mac OS X 10.5 & 10.6.

If you have questions or need assistance, send email to the IS&T Service Desk or call 617.253.1101. You can also submit a request online.