Welcome to FileMaker Pro version 11.

FileMaker Pro is an application that allows you to store and organize information in a database and to search and report out on that information. Sometimes FileMaker Pro is referred to as a database solution because it fulfills both storage and reporting needs.

This course begins with the assumption that you have inherited a database. You need to discover what information is stored in it, how that information is organized, and what reports have been created for data entry and reporting. You will need to keep the information up-to-date by creating, editing and deleting records and you will need to print out some reports.

Course Objectives:

- Understand the terms records, fields, field types, commit a record, indexed, found set, layout
- Understand FileMaker’s four modes Browse, Find, Layout, Print, and identify the tasks that can be performed in each mode.
- Understand the different views of data: Form view, List view, Table view.
- Navigate through fields, records, layouts and modes.
- Enter, edit, duplicate and delete data from a database.
- Perform simple and complex finds and sorts to locate and organize data as appropriate for reporting. [Compare Quick Find with Find mode finds]
- Save and reuse finds.
- Create a simple layout.
- Print out a report, create a pdf, or save data to a spreadsheet.
- Distinguish between a “flat” database and a relational database.

The business of creating a new database is reserved for a later class. In the next class in the suite, Reports, Layouts, and User Interface Design, we will explore the various ways FileMaker allows us to report out on the information stored in our database by exploring the myriad ways of creating layouts. We will also create a small, simple database that will serve as a way of exploring reporting and key database concepts. In the process, we will take a closer look at file attributes and field characteristics. In the third course, we will look at concepts of design and good practices when creating a multi-table database solution. We will work toward an understanding of relational data and how multiple tables can be joined to allow dynamic reporting capabilities.

In version 10 of FileMaker there was a significant change to the user interface. Almost since FileMaker’s inception, a status bar occupied the left-hand side of the FileMaker interface with the tools for each mode, buttons to switch between modes, and first a rolodex and then a book icon for moving through records, layouts, or report pages. This status area has been moved to the top of the screen and new buttons appear that allow switching modes.

Version 11 is yet another evolutionary step: Features have been added to table view allowing for the spreadsheet like creation of a database and data entry. Charts have been added as a reporting feature. In Layout mode, the Object information palette has been consolidated with other formatting commands to create a three-tabbed Inspector. FM 11 introduces Quick Finds which allow finds across fields. Portals have a new feature that simplifies the creation of filtered portals. Folders can now be created to group and organize

Copyright © 2012 by MIT IS&T.
**Introduction**

layouts. For a complete look at the new features in FileMaker Pro 11, go to Help -> FileMaker Pro Help and on the opening page click on New features in FileMaker Pro 11.
Module 1: Working with Existing Databases: An Overview of FileMaker 11

This class assumes you have inherited a database and need to maintain it, that is update and edit the data, run reports, and create new reports. How do you discover what is in this database and find your way around?

Objectives of this module:

Learn how to open and explore an existing database

Become familiar with FileMaker Pro’s four modes for performing database tasks.

Introduce the terms records, fields, tables, and layouts

Explore database and data reporting concepts such as the relational nature of data and aggregating and summarizing information.

What is a database? One author defined databases as any body of information that can be searched and sorted. This may be a very general description but these are important characteristics to keep in mind as we learn to use the FileMaker application and embark on the task of developing a database. The ability to search and to sort are key criteria when we design our database tables and fields.

A database is a collection of related pieces of information (data) organized into discrete records and fields. If you were to create a contact database with all the information pertaining to our contact, each person would be considered a single record. The separate pieces of information about that person, i.e., the person’s last name, first name, and phone number would be stored in separate fields within the record. These are sometimes referred to as attributes. Our entire address book could in turn be stored as a single FileMaker table, each entry a separate record.

Visually, as shown below, a database can be represented by a table-like structure. Each row in the table contains a record; each column is a field.

Field Name

<table>
<thead>
<tr>
<th>StudentID</th>
<th>LastName</th>
<th>FirstName</th>
<th>Street</th>
</tr>
</thead>
<tbody>
<tr>
<td>99850012</td>
<td>Rashmon</td>
<td>Kira</td>
<td>55 Oak St.</td>
</tr>
<tr>
<td>99850153</td>
<td>Feingold</td>
<td>John</td>
<td>12 Pine St.</td>
</tr>
<tr>
<td>99851542</td>
<td>Percy</td>
<td>Reginald</td>
<td>6 Gold Rd.</td>
</tr>
<tr>
<td>99612542</td>
<td>Hwong</td>
<td>Nan</td>
<td>2 Front St.</td>
</tr>
</tbody>
</table>

With this is mind many ask, “Can I convert my Excel spreadsheet into a FileMaker database?” The answer is yes. There are several ways

1 John M. Osborne, the author of FileMaker books and training CDs.  
[http://www.databasepros.com/about.html]
to do this depending upon your spreadsheet and your desired results. You can drag and drop the Excel icon onto the FM application icon in the Dock (Mac). You can launch FileMaker and from the Quick Start screen choose **Convert an Existing File:**

You can specify **File → Import Records** after you have defined your table and fields and then match (map) your spreadsheet fields to your database fields. This is one of the easiest ways to create a database. In essence, if you are using an Excel spreadsheet to maintain a list of one kind or another, you are using it like a database. FileMaker is an elegant way of maintaining lists and allows you to depict it in its relational nature. FileMaker also allows for the exporting of data into a spreadsheet.
Module 1: Working with Existing Databases: An Overview of FileMaker 11

FileMaker’s Modes
FileMaker has four modes of operation. In each mode, different tasks are preformed. Each has a distinctive status area and toolbar. They are

Browse Mode:

In Browse Mode you work with the data in your database: Enter data, view records, create new records, delete records, sort records. You will do the majority of your work in Browse mode. The results of a Find are displayed in Browse mode.

Layout Mode:

In Layout Mode you design the way information will appear on the screen or printed page using the many graphical tools to create reports and layouts.

Find:

In Find Mode you can search for a record or group of records. This is your query. The result of a search is called the “found set.” After the find is performed, you are returned to Browse mode viewing that set of records.

Preview:

In Preview mode you see reports and forms as they will print. Multicolumn reports and label runs are two examples of reports that need to be viewed in preview mode to see the final layout in preview mode.

Be aware that when resizing your FileMaker windows that toolbar icons appear and disappear depending on the size of the window. Sometimes the tools you need have disappeared from lack of space. Stretch and shrink the toolbar and observe!
Exploring an existing database

Let’s begin by opening the class file called **EmployeeRecords**. Double clicking on the icon will automatically launch the FileMaker application and open your database file.

We are opening a file that resides on each of our individual computers. Back in the workplace, many of us will click on an icon and it will be opening a database that resides in a remote location, on a shared server. We may be one of many people accessing that database at any one time. Clicking on the icon may launch a script that automatically takes you to that database. Alternatively, you may go to File ➔ Open ➔ Remote and then navigate to the appropriate server and FileMaker file.

There is the option to open FileMaker and go to File ➔ Open Recent. A drop-down menu of the recently visited database files is displayed.

**RESULTS:** You will see a screen like the following. What is this?

![EmployeeRecords](Image)

We are currently in **BROWSE** mode looking at a layout called “Salary.” Five fields are displayed across the layout and records are displayed in a **list**-like form.

In the lower frame of the window, is the designation of the mode. ![BROWSE](Image). This designation is also a pop-up menu that allows you to move between modes. Click on it and see.
Module 1: Working with Existing Databases: An Overview of FileMaker 11

The other designations on this lower frame are, first, a designation of the scale of the display. The second and third are buttons that look like mountain ranges allow you to shrink or magnify this view. The fourth item is a button allowing you to toggle the status bar on and off.

Browse mode can be distinguished by its status tool bar:

How many records are there in this database? What order are they in?

There are 30 records. The status area displays the count of total records. They are currently sorted. When “Unsorted” is displayed, it signifies that the records are in the order in which they were entered into the database with the newest entry last.

Notice the darkened vertical bar alongside a record in the list. This signifies that it is the current record. The status area it tells you that this current record is 2.

How is data displayed and what is a layout?

FileMaker Pro displays data on layouts. We are currently looking at the Salary layout which displays 5 fields in a list format. To switch layouts, go to the pull-down menu in the status bar area:

Here you will find a list of the layouts that have been designed for use with this database. Simply choose a layout from the menu and it will be displayed.

Copyright © 2012 by MIT IS&T.
Switch to the Standard layout.

Notice that in contrast to the Salary layout, the Standard layout displays only one record per screen.

Notice also there are many more fields displayed on this layout. To the left we see the field labels and to the right is the data, the field contents.

Navigating through records

To move through the records in the database, you can use the book icon. Clicking on the right hand page moves forward through the database records. Clicking on the left-hand page moves backwards. The counter increments as you move through the records. This number is relative to the order (sorted or unsorted) that the records are in.

To move through records, you can also move the slider. This is especially handy if you wish to move to the beginning or end of the file.

Finally, above the slider is the Current Record slot. You can click in the slot, type in a number and press Enter or Return. FileMaker will go to that number record in the current order.

If you prefer keystrokes,

CTRL + ↑ moves to previous record
CTRL + ↓ moves to next record.

The CTRL key is used with both the Mac and Window.

If you are using a mouse with a wheel (Windows), you can use it to scroll forward and backwards through the record.
These are just two examples of ways information can be viewed in FileMaker. Layouts allow you to view some or all your fields. Here are some other examples:

Above is a sampling of different ways that FileMaker layouts can be designed to display information: (going clockwise from the upper left) as a mail merge letter, as a layout with information grouped into different tab panels, as a list, as labels.

**Task:** Peruse the different layouts in the sample file. Search out: Which layouts include DateHired, BirthDate, work phone....Compare the tabbed layout where you see one record per screen with that of a list where you see multiple records.
Viewing information as forms, lists, tables

Layouts can be viewed in three different ways: as a form, as a list, as a table.

When creating a new layout, there is a default view associated with it.

You can switch between Form View, List View, and Table View by using the buttons in the Layout bar.

- Form View displays the layout with one record at a time. (Standard, Mail Merge are examples)
- List View displays layout as a list, displaying records one after the other.
- Table View removes all the embellishments and displaying fields and records as if they were in a grid or spreadsheet.

Manage ➔ Database

There may be even more fields than what we see in the Standard Layout. To determine how many fields are defined in the database, go to File ➔ Manage ➔ Database... The keystroke is Ctrl-Shift+D on Windows or Cmd-Shift+D on the Mac. (Think: Control–Capital D.)

RESULT: The Manage Database dialog box opens.

Be sure the Fields tab is selected. Here you see a list of the fields that have been defined for this database table.
Additional fields can be defined for the database here. Fields are named, assigned a type (text, number, date, calculation, etc.) and also given options. Click OK to exit this dialog box.

“I can't visit this dialog box from my database back in my office. Why?” Viewing this information is granted or prohibited by access privileges that have been set up. In this class we will be viewing sample databases as if we had created them, thereby having Administrator privileges which allow viewing, editing and deleting all.

Leveraging Table View

FileMaker 11 added some new features to table view. Within this spreadsheet-like view of the database, you have gained capabilities found in the Manage Database area.

- On the left edge after the last record, there is a plus sign. This can be used to add a new record.
- On the top margin to the far right there is a plus sign which allows you to define a new field in the database. [By default, it will be a text field.]
• Clicking at the top of the column, in the field name, exposes a downward arrow. Click on this arrow to bring up a menu of possibilities.

To the right, you see an example of how to change the field type from inside table view.
Switching Modes

There are a variety of ways to move between FileMaker modes. There are buttons, menu selections, and keystrokes.

Returning to the FileMaker application window, pull down the View menu and notice the list of modes. Alongside each mode is the keystroke designation for switching to that mode.

To the left are the Macintosh keystrokes. On Windows, use the Control key plus the letter designation.

In the lower left-hand corner of the application window is a pop-up menu that allows you to navigate from one mode to another:

BROWSE mode

Returning to the status bar in BROWSE mode, notice there are buttons to perform tasks (New Record, Delete Record, and Show All when a found set is in effect) and to switch to other modes (Find, Edit Layout, Preview).

While in Browse mode, there is a Records menu, comprised of tasks that can be performed in Browse mode:

> Click on the New Record.

RESULTS: A new blank record appears awaiting input. A few fields already have information in them. Why?

In some fields, data is automatically generated. For example, EmployeeID is set to “Auto-enter Serial, Can’t Modify.” You can see the specification of this option by returning to File ➔ Manage ➔ Database ... The two other fields, Salary Total and Salary Average, are calculation fields. The number you are seeing in the result of those calculations.

These are just a few of the things you will see as you peruse your database in Browse mode. If you are still in the “create new record” process, click outside the fields, that is, in a white space.
Unlike Word, Excel and other programs where you save your work frequently throughout a session, FileMaker saves your work automatically. Therefore it is important to be aware of what you are doing, especially when deleting or making large changes to your file. A backup copy of a file can be created.
Find Mode

Find mode allows you to search for records in the database. You can search based on a single criterion or on multiple criteria. Since FileMaker 10, finds are saved and may be reused.

In Browse mode, there is downward pointing triangle alongside the Find magnifying glass icon.

Clicking the triangle (Windows) or click and holding (the Mac) the mouse brings up a menu of recent finds and the tasks for saving finds, shown to the right. Up to 10 recent finds are saved. There are also options for creating and modifying previous finds.

In Find mode, they are listed under the Saved Finds icon.

Clicking on the magnifying glass icon takes you into Find mode. Here you will see a different toolbar, with options for creating finds:

An empty record is displayed with the field boundary boxes and once you click in a field, small magnifying glasses appear to cue you that you are in Find and not Browse mode:

Simply, if you enter information into a field and click Perform Find, FileMaker will find all records whose field matches that, returns to Browse mode and displays only the matching records, known as the found set. The Browse toolbar displays the number of records comprising the found set and a pie chart displaying the ratio of found records to the entirety. Each of the layouts now displays only this found set. Clicking on the book icon, you can march through the records in the found set.
Module 1: Working with Existing Databases: An Overview of FileMaker 11

This pie chart is also a button. Click on it and FileMaker displays the opposite of the found set, the omitted records. Click again and you return to the found set.

To see all records in the database again, click on the Show All button.

Layout Mode
A layout provides a means for displaying or reporting on the information in the database. It can be a screen that allows data to be input into the database. A layout can be as simple as name badge, or as complex as a report which organizes and displays records with totals, subtotals and other calculations. It can be a mail merge letter.

- Switch to Layout mode and observe the different tools for creating and modifying layouts. Designing a layout is a lot like working with a graphics program.

- In Layout mode, use the pull-down menu to move through the different layouts. Observe differences (headers, footers, report summary parts, tab panels). Alternatively, you can click on the book icon to move through the different layouts.
- Click on Exit Layout button and you return to Browse mode.

Preview Mode
Preview mode allows you to see what a layout will look like when it is printed.

Notice the buttons in the toolbar. Here you can quickly create a spreadsheet or a PDF of the layout you are viewing.

There are some report features that are not shown in Browse mode, but can be seen in Preview. For example, layouts such as labels are created in Form view, showing a single record at a time in Browse mode, while in Preview, the entire label run is displayed, sheet by sheet.

- View the label layout first in Browse and then in Preview.
Module 1: Working with Existing Databases: An Overview of FileMaker 11

Another example is a list that is multiple columns. Only a single column displays in Browse, but the multiple columns appear in Preview.

➤ View Sample Report 2 in Browse and Preview.

Exercise 1 – Determine the mode for each of the tasks
Specify the proper mode for the task in the left column:

<table>
<thead>
<tr>
<th>Function</th>
<th>Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Edit data</td>
<td></td>
</tr>
<tr>
<td>2. Create a new report</td>
<td></td>
</tr>
<tr>
<td>3. See how a layout will print</td>
<td></td>
</tr>
<tr>
<td>4. Create a new record</td>
<td></td>
</tr>
<tr>
<td>5. Search for a subset of data</td>
<td></td>
</tr>
<tr>
<td>6. The results of a find are displayed here</td>
<td></td>
</tr>
<tr>
<td>7. Create a PDF of the layout</td>
<td></td>
</tr>
<tr>
<td>8. Sort the database</td>
<td></td>
</tr>
</tbody>
</table>

Exercise 2 – Review Navigation Techniques
1. If not already open, open the Employee Records file in the class folder. Go to the Standard layout and navigate to record number 21. Whose record is it?

________________________________

2. Find Earl Dunn's record, What is Earl’s record number?

________________________________

3. Name at least one layout that has all of the following fields:

   First Name
   Last Name
   Date of Birth
   Date Hired

4. Where do you go to see a spreadsheet-like arrangement of the data in your database?
Module 2: Working in Find Mode

In this module, we will

- Locate records that match a single criterion
- Locate records that match more than one criterion
- Locate records that match at least one of two criteria
- Omit records from the found set
- Perform a find and replace
- Reuse finds/Create and modify Saved finds

Explore FileMaker's new Quick Find feature

Searching is one of the most important tasks in database use. Today we have advanced search engines to bring us information from the World Wide Web in answer to our everyday needs and curiosities. To create meaningful reports in FileMaker, selecting only the appropriate information from the database is crucial. With a few basic skills, it is easy to search a FileMaker database quickly and efficiently.

When you perform a find, FileMaker searches through all the records in a table. Those records that match the criteria become the found set. Thereafter, you are only working with those records until such time as another find is performed or until you request to see all records.

FileMaker Pro performs what is known as a “begins with” search, that is, it seeks to match the string beginning with the start of a word. To search for strings within words, wild cards can be used.

Quick Find

Before switching to Find Mode, be aware there are two quick finds that you can perform in Browse mode.

First, FileMaker 11 implemented a new search capability called Quick Find. Using the Quick Find search slot on the Browse toolbar, Quick Find will search across all fields in a layout. This search tool may not be evident because your Browse toolbar area may not be wide enough. Stretch the window wider to reveal this search box. To execute a Quick Find search, the capability must be enabled for the layout and the fields on the layout. By default, layouts are enabled for quick find and all fields that are supported for quick find are set to be included in the search. Type the search string into the box and press Enter or Return. Your find request returns a fount set. The only operator supported by Quick Find is the match phrase operator, the double quotation marks. One of the niceties of Quick Find is that you can include merge fields in your find. Like in other searches, the downward pointing arrow implies that searches are saved and can be revisited.
Module 2: Working in Find Mode

Secondly, a quick find/match [introduced in FM 8.5] on a specific field can be performed via the right-mouse click (cltr-click on the Mac) and the shortcut menu.

In the example below, we are looking at the Salary layout. If we wanted to find all employees who lived in Everett, we could select Everett in the city filed, right click (Windows) or ctrl –click (Mac) and from the shortcut menu, choose Find Matching Records.

Your find request returns two records for people who live in Everett. This is the found set.

The status bar displays the number of found records out of the total records in the database. The light green area of the pie chart displays the found set as a portion of the total records.

This pie chart was new to FileMaker 10. It is also a button. Clicking on it displays the reverse of the found set. Clicking a second time returns you to the found set.

Clicking on the book icon now, in all of the layouts, moves you through only those records in the found set.

Find Mode

Switching into Find mode, we can perform more complex searches using operators and multiple criteria. There are several ways to get into Find mode:

- From the popup menu, select Find.
- Go to View ➔ Find Mode
- In the Status toolbar, click the Find tool.
- Press Ctrl/⌘ + F

Copyright © 2012 by MIT IS&T.
Module 2: Working in Find Mode

As mentioned in our overview, when you go into Find mode, a blank record is displayed and magnifying glasses appear in the fields. In the appropriate field, enter the text, number, or date you want to find. This is referred to as a find request.

Click Perform Find (or press Enter or Return). Or if you changed your mind, click Cancel Find.

RESULTS: Perform Find places you in Browse mode displaying the results of the Find. The find sequence is added to the Recent Find list.

Cancel Find returns you to Browse mode with no change to the previous status. That is, if a found set were currently in effect, it still is. (This was not the case with previous versions of FileMaker where each time you went into Find mode it would cancel out the previous found set.)

Try it →

1. Find all people who have the job title of Secretary.
2. Find the individual whose last name is Dunn.
3. Find all people who live in Somerville.
4. Find all Professors.

The default search performed is a full text “begins with” search. This means that it will search for words beginning with the string you specify. For example, if you type Prof into the title field, any titles whose words begin with Prof will be returned. This would return “Professor”, “Assistant Professor” as well as “Professional Wrestler” if it were in the file. Just as an example, it would not return a record that had “FileMakerPro” in the field, because the string is embedded in the text. If you wanted to find any occurrence of the string pro in the job title field, you could use the wild card operator and supply the string *pro*.

---

2 FileMaker 11 sees the advent of little green and yellow magnifying glasses in fields in Layout mode. This has to do with Quick Find mentioned above. The green magnifying glass indicates the field is enabled for Quick Find. The yellow glass indicates that the field is searchable but may take longer than fields with the green glass. This may be because it is a related field, a calculation field or one that cannot be indexed. Later you will learn that you can turn on or off the ability to search fields with Quick Find.
Module 2: Working in Find Mode

Drawing Values from the Index
FileMaker automatically indexes the values in a field and we can draw from this list. For example, if we weren’t sure about a specific job title that we wanted to search on, selecting the field, go to Insert ➔ From Index… A dialog box like the one on the right opens. You can select from the list and choose Paste.

The check box labeled Show individual words does just that: it lists the occurrence of every word found in that field.

Click in the check box and observe the results. Click again to return to the original list.

Using Find with Search Operators
What if you wish to find a range of values, for example all people whose last names begin with D through M, or all hired between 2/10/94 and 2/10/2000? In Find mode, click on the Insert: Operators pull-down menu to display a list of operators that can be used in your search request. You can either type the characters into the find request or select them from the menu.

In the example above, if you wished to just retrieve individuals with the title Professor and not Assistant Professor you would prefix Professor with == (the double equal sign).

Note: There is no space between the values and the three dots for range.

To search for an empty field, use the double equal sign and nothing else in the request field.

To determine what your last find was, in Browse mode, go to Records ➔ Modify Last Find. This automatically takes you into Find mode and displays the last find request you performed.

Copyright © 2012 by MIT IS&T.
Exercise 3: Review of Find Techniques
For this exercise, go to the file Find_EmployeeRecords. Open the file and navigate to the Salary Layout.

1. Find all people who are professors
2. Find all people who live in Boston
3. Find all people who earn exactly $47,190
4. Find all people hired after March 1, 2000
5. Are there any records where the hire date is missing?
6. Find all people who earn between $33,000 and $42,000
7. Find all people whose last names begin with A to M and then sort the found set.
8. Show all records. What is the sort order now?

Refining Your Requests With AND, OR, OMIT

The AND request
You can refine you current Find request to match multiple criteria in separate fields. For example, you may want to find all professors who began working after March 1, 2000. This is known as an AND search. An AND search specifies multiple criteria in a single request.

1. Click Find in the status toolbar.
   
   RESULT: This places you in find mode, viewing the field boundary boxes with the magnifying glasses.

2. Enter Professor into the title field and the >3/1/00 in the date hired field.

3. Click Perform Find or press Enter/Return.
   
   RESULT: FileMaker will display all records matching the two criteria. If no records match, a dialog box appears giving you the choice to either Cancel or Modify the Find.

The OR Request
At times you may want to find records that match multiple criteria in the same field or multiple fields. For example you want to know all people who live in either Boston or Jamaica Plain. This is referred to as an OR request and is created by submitting multiple requests in Find mode.

1. In Find mode, type the first criterion into the appropriate field. Here we will enter Boston in the City field.
2. Click on the New Request button.
RESULT: This opens up another line in the form for entering the second criteria. If the layout is a form type,[one record per screen], it will open up another screen with a blank form. Observe the screen and the status bar:

A line is added where a second city can be specified. The book icon and the record counter slot in Find mode refer to Find Requests. It currently we are on the second request.

3. Enter the second criteria in the space created.

   In our case we will enter Jamaica Plain.

   You can add a third, and fourth requests, etc. as appropriate for the Find you need to perform.

   To move between requests, either click in that area of the screen or use the book icon to move. The Delete Request button is used to remove requests.

4. When ready, click either Perform Find or Enter/Return.

   RESULT: All records of people living in either Boston or Jamaica Plain are displayed in Browse mode.

OMIT: Exclude Records from the Found Set

Often times we know what we are NOT looking for. For example, maybe we want to do a mailing to everyone except those that live in Cambridge. In a case like this we use the Omit button in Find mode (of course you can find all that live in Cambridge and then press the little pie chart for the opposite of the found set). By default, Include is in effect. With your request selected, click on Omit.

For a Find with multiple criteria, move to the appropriate request and click Omit.

Once you have a found set and you wish to remove a record from it, in Browse mode, select the record, go to Records menu → Omit Record.

You can also omit multiple records, starting at the current record. See Records → Omit Multiple.

RESULT: The above dialog box appears allowing you to specify the number of consecutive records you wish to exclude.
Reusing Finds

FileMaker 10 introduced the ability to save finds. Your 10 most recent finds are automatically saved and can be reused from the pull-down menu.

In Browse mode, there is a triangle alongside the Find icon leading to a pull-down menu with the most recent Finds:

There is a similar menu in Find mode with the Saved Find icon:

To re-execute a find, simply select it from the list.

RESULTS: In Browse mode, it performs the find and displays the found set.

In Find mode, it sets up the request(s). You must now click on the Perform Find button or click Return/Enter.

Finds that you will use repeatedly, can be saved, assigned a name, even edited. This simplifies some of the need to script finds for later use.
Module 2: Working in Find Mode

To save your last find request:

1. In Windows, click the down arrow on the Find button and choose Save Current Find. On the Mac, click and hold the Find button and then choose Save Current Find.

   RESULT: The following dialog box opens, allowing you to rename the Find request if you so desire. The Advanced button takes you to a series of dialog boxes where you can delete, duplicate or edit your find request.

2. Assign it a new name if you so desire. Click Save.

   RESULT: The Find request will be added to your Saved Finds list.

Searching Merge Fields

When we study the creation of layouts in the next FileMaker class, we will see that Merge fields, like those found in Word Mail Merge documents, are different than ordinary fields. Merge fields allow you to combine field data and text in documents. Prior to FileMaker 11, you could not search on merge fields in a layout, that is, if you wanted to search for Professor Earl Dunn in your label run, you would have to do the search in a layout where you could search on either his first or last names. Now with the introduction of Quick Find in FileMaker 11, you can search on the contents of merge fields.

   • Try it! Go to the Mail Merge document and in Browse mode used the Quick Find search slot to search for any employees named Garcia.

Find and Replace

It is possible to edit multiple records, changing the entire contents of a field. For example, a job title or a department may need to be changed globally throughout the database records.

1. Perform your find request to arrive at the Found set.

2. Click in the field to be replaced.

3. Type in the field, replacing the entire contents of the field.

4. Go to Records ➜ Replace Field Contents...

   RESULT: The Replace Field Contents dialog box opens reflecting the change, awaiting your confirmation of the change.
Module 2: Working in Find Mode

Observe: Here we searched for all occurrences of E14 in the address field and found 5 records. We change the field contents of the Department field and before committing the record, go to Records → Replace Field Contents.

Pause in this dialog box to observe that here too you can add serial numbers to records (Try it!) or use a calculation in the replacement of the field contents.

5. Click on Replace.

RESULTS: This will change the department name to Media Arts and Sciences for all records in the found set.

➢ Try it!

In Browse mode, there is also a Find/Replace. This is different than Find mode. Find/Replace in Browse mode searches for pieces of text across fields and records whereas Find mode searches for Records based on field contents. In Browse mode, going to Edit → Find/Replace opens the following dialog box:

Observe the check boxes and radio buttons that allow you to restrict the Find/Replace action.
Module 2: Working in Find Mode

This can be used in conjunction with a find, performing an edit upon all records in a found set.

Exercise 4 - Review of AND and OR Searches

If not already open, open the Find_EmployeeRecord file and navigate to the Salary layout.

1. Find people who are Lab Techs or Consultants

2. Find all who are Professors or who live in Cambridge

3. Find people who live in Boston AND make over $45,000

4. Find people who earn less than $40,000 and started working at MIT before January 1, 1996.

5. Find all secretaries except those living in Cambridge.

6. Find all people who earn more than $45,000, excluding professors.

7. Revisit the find in #3 and change it to all that make over $35,000. (Use the Recent Find list).

8. Find all Professors, including Emeritus and Assistant but excluding Visiting.
Module 3: Working in Browse Mode

In Browse mode we will

- Navigate through the fields of a record
- Enter and edit data
- Delete and replace data
- Create a new record/Delete a record
- Sort records
- Export data
- Create a copy of the database

Moving within a Record

- Click in a field to make that field active.
- Pressing the TAB key repeatedly moves you field by field through the layout.
- Shift-Tab, moves you backwards through the fields.

Note: Using the Return/Enter key does **not** move you from the current field to the next. Instead, it places a carriage return in the field. To remove it backspace over it. Once you click outside the field boundary box, the stretched appearance of the field will disappear.

- Go to the Standard layout and tab through all the fields. backspace over it.
  Notice some fields are skipped. These are fields where data is not entered by you but instead is the result of a calculation or a summarization.

- Tab to the Salary field.
  Observe that the number is displayed without the currency formatting. This is because the dollar sign and comma separator are formatting that is applied to the data and is not the data itself.
  Click outside the field, and you see the number with the formatting applied.

Entering and Editing Data

1. Go to a record, locate your cursor in the appropriate field, and type.
2. When complete, click outside the field and you have **committed** the record. The database has been updated to reflect this change.

When selecting data in a field, the usual selection techniques are in effect:

- dragging across selects data,
- double clicking in a word selects just the word,
- triple clicking selects a paragraph.

Committing a record

FileMaker automatically updates the database as you work. Go to the File menu and notice there is no SAVE command but there is a Save A Copy As.
Module 3: Working in Browse Mode

When creating or updating a record, and you click outside of all fields or press enter, you do what is called *commit the record*. This tells FileMaker that you are committing the changes you just made and the database is updated accordingly.

**Revert Record**

Prior to committing a record, you can revert to the record’s original contents.

**Example:**

1. Go to the Salary layout and choose the record for Edgewater. Change his job title to Administrative Assistant. Tab to the salary field and change his salary.
2. Without clicking outside the record, go to **Records → Revert Record**.

   *RESULT: A dialog box appears asking if you want to “Revert all changes since it was last entered?”*
3. Click Revert and observe the fields returned to their original value.
4. Try this again with another record, but change the first field, click outside the record, change another field and then go to **Records → Revert Record**. *

**Delete Data and Replace Existing Data in a Field**

To clear a field, select the field contents and press *Backspace/Delete*.

To remove selected text or the character to the left of the cursor, press *Backspace/Delete*. To remove text to the right of the cursor, press the *Delete* key (in the keypad area, *fn+delete* on Mac laptop keyboards).

**Create a New Record**

- Press the **New Record** button.
- Go to **Records → New Record**
- Or use the keystroke Ctr/⌘ + N.)

**Example:** Go to the Standard layout in Browse mode and press *New Record*

*RESULTS: In this FORM layout, a blank screen appears; in the case of a LIST layout, as in the Salary layout, a blank record area appears ready for you to input data into the spaces for the fields.*

This new record will be placed at the end of the database and will be permanently assigned to that position in the default/unsorted record order.

*OBSERVE: The EmployeeID field already has information in it. Why? Try to change the number in the field. What happens?*

This is the result of creating a field with the options “Auto-Enter, Serial, Can’t Modify, Unique” to it. Go to **File → Manage → Database** and click on the Fields tab if it is not already selected. Notice the assignment of this option.

**Delete a Record**

To permanently delete a record from the database:

1. Navigate to the record in the database you wish to delete.
2. Press **Delete Record** button in the toolbar. (Or go to
Module 3: Working in Browse Mode

Records ➔ Delete Record.)

RESULT: You will get a confirmation message asking if you are sure you wish to “Permanently delete this ENTIRE record.”

BEWARE: Using the menu, Delete Record and Delete All Records are dangerously close to each other. When a found set is in effect, this will read Delete Found Records.

Duplicate Previous Record
The Duplicate Record command saves having to re-keying repeated data.

1. Navigate to the record you wish to duplicate.
2. Go to Records ➔ Duplicate Record.

RESULT: FileMaker creates a duplicate of the current record, placing it after the last record in the file.

You can now edit that record as appropriate. Notice in our case, a new EmployeeID is assigned, following in the sequence.

Duplicate Select Fields from Previous Record
If a new record contains some, but not all, fields of another record, with a simple keystroke, you can enter that repeated information. Here’s how:

1. Navigate to the record whose field(s) you wish to duplicate. Click IN the record. Clicking in one of the fields of the record signifies that you have “visited” the record.
2. Navigate to the record where you wish to duplicate this information. In our case we will create a new record: press the New Record button.
3. Click in the field where you wish to repeat the information from the other record and either go to Insert ➔ From Last Visited Record or use the keystroke Ctrl/⌘ + ‘ (single quote mark).

RESULT: The value of the field from the “visited” record is duplicated in the field of the current record.

You can repeat the command/keystroke to duplicate other fields from that record.

Try it: Let’s say that another employee with the same job title and salary as Connie Petricelli.

1. Find Connie Petricelli. (Go to Find, enter Petricelli in the LastName field) and click in the record.
2. Then create a new record by clicking on the Create Record button.
3. In that new record, click in the Title field and go to Insert ➔ From Last Visited Record.
4. Tab to the Salary field and repeat, this time using the keystroke Ctrl/⌘ + ‘.

Select Field Entries From a List of All Previous Entries
To guarantee uniformity of data values, it is possible to select from an index of existing values for that field. This can be used in Find mode as well.

1. Locate the cursor in the appropriate field.
2. Go to Insert ➔ Insert from Index (Ctrl/⌘ + I).
RESULT: You should see a list of all the current values for that field. By clicking in the Show individual words check box, all the field values are broken into individual words.

3. Select the appropriate value from the list.
4. Either double click the entry to select and paste it into the current field or select and Paste.

Exercise 5 – Review of Data Entry Techniques

1. In the Employee Record file create a new record for Gretchen Twitchell with the following additional data:

   MIT Bldg 24-110
   8-4577
gwitchell
44 Rose Ct.
Somerville, MA 02445
617 578-4586
$38,000 salary
Administrative Officer
DOB 05/24/60
Date of Hire 07/21/1999

2. Delete Steve Sawyer's record from the database.
3. Which shortcut could you use to repeat data that appeared in another record?

   Using this shortcut, add a new employee to the database who has the same job title and salary as Craig Garelli.
4. Which shortcut can you use to assure consistency with existing values?

   Using this shortcut, add a new employee and assign her the job title of Fiscal Officer.
Container Fields

FileMaker introduced container fields in version 7. These fields that can be used to store files including graphics, movies, photos, bitmaps, sounds up to 4 GB in size, multimedia file types supported by QuickTime 6, and documents, including Microsoft Word and Excel files, PDF files.

How you place information into the container field will determine what you can do with that information later.

You cannot search on container fields.

You can insert information into a container field in a variety of different ways. You can

- cut and paste
- insert
- insert a link (a reference) to the file.

Be aware that Windows and Macintosh handle these processes a little differently.

Try It > Go to the Layout called Personnel Info – Tabbed and click on the Personal tab. Navigate to Grace Baumgartner and insert her picture from the Employee Photos folder.

1. Click in the container field.
2. Go to Insert ➔ Picture

A navigational dialog box opens.

3. Navigate to the file you wish to insert.

Notice at the bottom of the dialog box the option to enter a link or reference to the file.

4. Click Open
5. Repeat for David Edgewater and insert his photo as a reference. Compare the two examples.
Module 3: Working in Browse Mode

Sorting Records

In Browse mode, you can temporarily change the order of the records by using Sort. This order will then be in effect for all layouts until another action such as a Find or an Unsort is performed.

Beginning in FileMaker 10, this sort became a kind of persistent sort, that is, whenever a record is added or changed in an already-sorted set, this new record will take its appropriate place in the sort order.

1. To sort, either click on the icon in the toolbar, go to Records → Sort or use the keystroke Ctrl/⌘ + S.

RESULT: The Sort Records dialog box appears. On the right hand side, you will see, if any, the criteria of the last sort performed.

2. If fields appear in the Sort Order box, click Clear All.
3. Double click (Select and Move) the fields you wish to sort by.

RESULTS: The field(s) you selected now appear in the Sort Order box. The double - pointed arrow alongside the field name is used to reset sort order priority.

Ascending order is assumed. To change to descending, select the field in the Sort Order box and then click on the Descending radio button. Observe the “Custom order based on a value list” option. Later we will discover that we can customize sort orders by defining a value list.

Observe the Unsort button.

4. Click Sort.
RESULT: The file is sorted, you are in Browse mode and the Status area reflects this sorted status.

Try it > Sort the records by Title in ascending order and by DateHired in descending order.
Module 3: Working in Browse Mode

If a sort and/or a found set are in effect when a file is closed, they will be in effect when it is reopened. (This is not true of databases on a shared server.)

Try it > Perform a sort, close the file and then reopen it.

Quick Sort

Alternatively, you can perform a sort using the right click in Windows and a Ctrl-Click on the Mac:

1. In Browse mode, move the cursor to the field you wish to sort on.
2. Right click (Win) or Ctrl-click (Mac).
3. From the context-sensitive menu, choose the desired sort.

Try it > Sort the employees in descending order for DateHired.

File Management topics

Before we leave Browse mode, there are two file management tasks we should visit: The ability to export data from a FileMaker file and “Save a Copy As.”

Export Records...

If you wish to export data from your database, you can do so by using the command Export Records...

1. 1. Go to File ➔ Export Records... You will be asked to specify where you wish to save the newly created file.
Module 3: Working in Browse Mode

FileMaker opens a Save dialog box, allowing you to navigate to where you wish to save the resultant file. Often times, it will suggest a Tab-Separated Text file by default. There are many other formats to choose from, including a FileMaker Pro file.

![Export Records to File dialog box](image)

2. Go to **Type** and notice the different file types. Select the desired type.

Notice the other options that are available. You can open this file or create an email with the file as an attachment. Remember to use the operating system's mail program (Outlook Express or Apple Mail).

![FileMaker options](image)

When you specify Excel, the **Excel Options** dialog box opens allowing you to use or not use the field names as column names. You can also name the Worksheet and assign title, subject and author information to it.

3. When you click **Continue...** the following dialog box opens:
Module 3: Working in Browse Mode

By default, FileMaker offers to export those fields on the current layout.

To include others, pull down the Current Layout menu and select Current Table.

4. Select the fields to be exported. Double click to select and move.

5. Use the up-down arrow to the left of each field name in the Field export order list to arrange the resulting columns in the desired order.

Try it --> Go to the Salary layout and export it to an Excel file, exporting only the fields FirstName, LastName, Salary, DateHired and DateofBirth.

Save a Copy As

As discussed above, there is no Save option on the File menu, however there is Save a Copy As.... Rather than you telling FileMaker when to save the file, it performs a save each time a record is committed. With that in mind, you may wish to save a copy of your database before you begin making changes to it as a backup.

One of the choices is “clone (no records).” This will create a copy of your file with all the tables, fields, relationships, layouts, and scripts defined but no data.

Try it →
1. Go to File → Save a Copy As
Module 3: Working in Browse Mode

2. Name the file, and save it to the desktop.
3. Under file type, chose clone (no records).
4. Open the file you just created and view the results: visit File ➔ Define ➔ Database ... view the Tables, Fields and Relationships tabs.
5. Visit the different layouts. Observe the absence of data but the presence of all other constructs of the database.

Exercise 6 – Sorting, etc
1. Using Fast sort and the EmployeeRecords database,
   • Who was hired first?
   • Who was hired last?
2. What are the two ways to enter a graphic or pdf into a container field? What is the difference between the two?
3. Why is a sort considered persistent?
4. Create an Excel spreadsheet from the database with just the FirstName, LastName, StreetAddress, City, State, Zip, and DateofBirth.
Module 4: Previewing and Printing

In this module, we will

* Reexamine the visual differences between Browse and Preview mode
* Print a FileMaker Document
* Save a FileMaker document as a PDF, as an Excel file
* Compare Mac versus Windows printer settings

In Preview Mode, we see how the document will print. As we have already seen, different objects are visible in Preview mode than in Browse. Layouts are restricted to the margins and spacing as established by page setup and print drivers.

- Layouts for things such as labels and multicolumn reports, show a single record or a single column in Browse mode, but all show records with the columns appropriately wrapped in Preview mode. (Compare the Label layout in Browse vs. Print modes.)
- Fields or objects can have “Sliding and Visibility” applied to them. Sliding reduces space between fields; visibility allows for the hiding of layout objects when printing.
- Variable information such as page numbers does not show up in Browse mode but does in Preview.

When it comes time to print a document, FileMaker offers some additional options. Going to File → Print, pull down the print menu and notice that you can print the

- Records being browsed (the found set),
- the current record
- or a copy of the layout without any record showing:
Module 4: Previewing and Printing

On the Mac, go to File ➔ Print. From the menu below Presets: choose FileMaker Pro. This automatically opens up the dialog box to display the three radio buttons:

![Print dialog box]

Save as PDF

Saving as PDF can be performed in both Preview mode and Browse mode, sometimes with differing results. In both places, there is the option (a pull down menu like above) to save either the Records being browsed, Current record, or a Blank record, showing fields.

In Browse mode to save as PDF, go to File ➔ Send/Save Record as … ➔ PDF.

In Preview mode simply click on the button.

For more detail and further elaboration of printing, exporting and saving possibilities in FileMaker 11, go to Lynda.com, and view Lesson 14 under FileMaker Pro 11 Essential Training.
"If the tables form the heart of a database, layouts give it a face."

Coffey & Prosser, 


In this module we will:

Define the term layout
Learn how a Standard layout is created

What is a Layout?

In FileMaker you usually have a choice of screens, each one set up to display your data in a slightly or sometimes dramatically different way. Regardless of appearance, all FileMaker screens are layouts which can be created, edited and even deleted in Layout Mode. Some layouts are designed to be used as data entry screens while others are better set up to display aggregate data in a report-like format. Whether it is referred to as a Layout, a Report, or a Form Letter, in FileMaker, it is still called a layout. Layouts may range from the very simple to the complex, the latter employing an array of colors, interactive buttons, the display of web pages, the compartmentalization of information into tabs, and other graphical tools to help users better navigate through or to interpret data.

Data is shared in a FileMaker file by all layouts even if some layouts don't show all the fields stored in the file. Consider your FileMaker database a single-room structure. The exterior windows and doors are equivalent to your layouts. If you created a new window, you are still looking at the same contents inside the structure. Just as when you create a new layout you are still seeing the same data in FileMaker that you would see from another layout. If while looking at the data from one layout you decide to change, delete or add new data, that data will change in every other layout in the current file. How layouts display data gets to be a trickier more complex thing when multiple tables i.e. a relational database, are at play. Even then, the layout is the vehicle that makes it possible to view this relational data drawn from numerous tables.

Much like a list of files, FileMaker displays a drop-down menu of layouts.

To switch from one layout to another, simply select it from the list.
In layout mode, a status toolbar across the top of the screen has icons for the various tools that are used in creating layouts. Hover the mouse over each button to see a tool tip explaining each button.

In the work area of the window you see the components of the layout. Layouts are comprised of fields, text and graphics.

In previous versions of FileMaker, there was an Info palette that allowed you to view and edit information about the currently-selected object. FileMaker 11 replaces this with a three-tabbed palette which has absorbed toolbar and menu options for **Position, Appearance** and **Data**, a kind of “one-stop shopping” for grooming and controlling layout objects.
The previous Info Palette:  

The new FileMaker 11 Inspector:  

Explore the many options of the **Inspector**. To open and close it, use the → on the toolbar or the menu selection **View → Inspector** or the keystroke ⌘+1 (Mac) and Ctrl+1 (Windows).

**Exercise 6 – Accessing Existing Layouts**

1. In Browse mode peruse the different layouts that have been created for the database.
2. In the Salary layout, observe how fields are designated. Go to Labels and compare. In Labels, you are seeing something called **Merge Fields**. If you have created a mail merge in Word you may be familiar with these angle brackets.
Compare layout mode for labels with the final product in Preview. Observe how the label is repeated three across and as many down as there are records in the found set and what fits on the page.

3. View the Subsummary report and notice the appearance of additional report parts. Notice also the button in the upper right-hand corner. Double click on the button and notice it opens a script dialog box. This is what is executed when you click on the button. Click Cancel to close.

**Exercise 7: Creating a New Layout**

Layout mode is a rich environment of tools and toolbars that are familiar if you have worked with graphics programs before, but this environment can also be overwhelming for the person who never has.

1. To create a new layout either click the New Layout/Report button or go to the menu Layouts → New Layout/Report, or use the keystroke Ctrl+\+N.

*RESULT: This opens the New Layout/Report dialog box:*

- Take a minute and sample the different layout types and its resulting preview.

This dialog box is referred to as the Report/Layout Assistant because it is designed to step you through the process of making a layout. It allows you to create a layout in seconds, but a note of caution: Just because it is easy to create layouts should not be cause to over indulge in the creation of new layouts, particularly when a database is used by many people. If you need a particular layout be sure to check if one doesn’t already exist that may serve your needs. And if you create a new one
that renders a previous layout obsolete, don’t forget to delete the older layout. This can be done by going to **Layouts → Delete Layout**.

2. **Show records from**: should display the name of the table that layout is based on. In our case, that is Employee Records

Every layout has a context, that is it is based on a specific table. In our database there is only one table, so this is not an issue now, but will become important when there are multiple tables in a database.

Every layout should be given a unique and descriptive name. If you are a member of a group using a database, you may wish to decide upon a naming convention. For example a two-letter prefix on layout names would designate the “owner” or creator of the layout.

3. We will call this layout Class Example. Click the check box for Include in Layout menu.

4. We will begin by creating a simple standard layout. Choose **Standard form** from the layout type list and click **Next >**


5. Choose the fields that will be included in the report. Select the field names in the left-hand scroll box and click **Move** or double click the field name to perform a select and move.

   *EmployeeID*
   *LastName*
   *FirstName*
   *MIT Address*
   *StreetAddress*
Module 5: Layout Basics

City
State
Zip
Email

6. Use the small north-south arrow icon to the left of the field name to drag the Email field before the EmployeeId. You will see this character throughout dialog boxes in FileMaker. It allows for the reordering of elements.

7. When all the fields are specified and in the desired order, click Next >
RESULT: The New Layout/Report, Select a Theme dialog box opens. These are themes for report layouts. As it says, a theme sets background colors, text size, text color and style.

8. Peruse the different themes that are available, viewing the previewed sample to the right. Some themes are more appropriate for viewing on a screen while others are for printing.

FileMaker 10 saw a refurbishing of the old themes and the creation of new ones.

9. Choose a theme of your liking, or just go with Standard, and click Finish.

RESULT: You are in layout mode viewing the constructs of your new layout.

10. Click on the Exit Layout button.

RESULTS: You are in Browse mode viewing your newly created layout. The Standard layout, by default, is in form view, that is, one record per screen. The layout contains the fields you specified. The fields are left aligned and their respective field labels are right aligned.

11. Peruse the records of the database using this layout.

We will leave layout mode here for a while. The next FileMaker class concentrated on the creation of layouts. Why? Why not jump right into database design? Because an understanding of FileMaker’s reporting capabilities will better inform your design consideration for that database solution.

Module 6: Resources

FileMaker resources are especially plentiful for reference and self-study.

Lynda.com

Lynda.com has a very broad spectrum of online course offerings, available to the MIT community. As of January 2012, we now subscribe to what is known as Lynda Campus. This enhanced version of Lynda creates an individual profile for each user where a history is kept of all courses and modules taken. The student can bookmark courses and modules of interest. A Certificate of Completion can also be received for those courses viewed in their entirety.

Industry experts have been sought out to teach courses in Lynda.com. The lessons for FileMaker are excellent, taught by guru Cris Ippolite of iSolutions, Inc.

To access the Lynda catalog of courses, simply open your browse to lynda.mit.edu

and authenticate via Touchstone. In addition to the tutorials, our agreement with Lynda.com allows us to download and use the example files. Click on the tab on the course page to learn more.

Explore the many chapters and modules. Modules, which review the information covered in today's course, are the modules:

1. Getting Started
2. Database Creation Essentials
6. Working with Records
8. Creating Layouts
11. Finding Data
12. Sorting Data
14. Printing and Savings (Previewing pages and print options, Printing in different views, Savings as a PDF or Excel file)

In preparation for the next FileMaker course, review the modules 2, 3, 7, 8, 9, 10 and 15.

Bundled with the Software

Self-study resources come bundled with the FileMaker application. One of the first places you may want to look is on the Quick Start screen that opens when you launch FileMaker. If you don't see this screen, go to Help \(\rightarrow\) Quick Start Screen. It looks like this:
Explore the Video Tutorials and the Hands-on Tutorial. The first takes you to the FileMaker web pages and their selection of videos. The second utilizes files that get downloaded when you install the FileMaker software on your computer. There are tutorials, example files, and a reference manual. Look in the folder marked English Extras. On both Windows and the Mac, go to FileMaker 11 folder within Program Files (Win) or Applications (Mac), and locate a folder called English Extras. Within this folder is another called Electronic Documentation. You will find two pdfs: The fmp11_tutorial and fmp11_users_guide.

A Definitive Text

A handy and very readable book on FileMaker is Susan Prosser and Stuart Gripman’s FileMaker 11: The Missing Manual. Why missing? This is the book that should’ve been in the box with the software. It is from O’Reilly Press. O’Reilly press books are available through Safari (not the browse, the electronic bookshelf) and can be accessed by MIT faculty, staff, and students via the Library’s VERA, the Virtual Electronic Resource Access.

2. Select E-Journals & Databases, and enter SAFARI into the search slot.
3. Click on the Safari Technical Books Online (O’Reilly Books) link that comes up. You will arrive at a page where you can search for books by title or topic.
4. From the list of hits, select the book, navigate to the table of contents, or search the book by key word.

TechNet

For years, FileMaker, Inc. has promoted a user community called FileMaker Technical Network, or TechNet, charging a membership fee. As of January 2012, membership is free! With membership, you have access to many valuable resources such as technical briefs, how-to articles, white papers, and a community of FileMaker users and developers and the forums they participate in. Information can be found at
Module 6: Resources

www.filemaker.com/technet/

FileMaker Training series
FileMaker, Inc. produces the finest (of course) self-study materials available. Their FileMaker Training series is a self-paced learning package designed for the individual who wishes to build knowledge and skills in the design and development of FileMaker databases. These are the training materials that will prepare one for the FileMaker Developer's certification exam. To obtain these materials go to the FileMaker site: www.filemaker.com/support/training and view the FileMaker Training Series under Self-Paced Training. The price is usually about $99, but with a membership to TechNet, FileMaker 11 materials can be purchased at a discount.