Maple User Manual

Copyright © Maplesoft, a division of Waterloo Maple Inc.
1996-2008
Contents

Preface ........................................................................................................... xiii

1 Document Mode .......................................................................................... 1
  1.1 Introduction .............................................................................................. 1
  1.2 In This Chapter ........................................................................................ 4
  1.3 Simple Mathematical Expressions .......................................................... 5
    Rational Expressions (Fractions) .............................................................. 5
    Powers ........................................................................................................ 5
    Products ..................................................................................................... 6
    Shortcuts for Entering Mathematical Expressions .................................. 7
    Other Expressions .................................................................................. 8
  1.4 Evaluating Expressions ........................................................................... 9
  1.5 Editing Expressions and Updating Output ............................................. 10
  1.6 Entering Expressions ............................................................................. 11
    Palettes ..................................................................................................... 12
    Symbol Names ........................................................................................ 17
  1.7 Performing Computations ....................................................................... 20
    Computing with Palettes ....................................................................... 20
    Context Menus ......................................................................................... 21
    Assistants and Tutors ............................................................................. 27
  1.8 Document Mode Summary ..................................................................... 31
  1.9 Getting Help ......................................................................................... 33

2 Worksheet Mode ............................................................................................ 35
  2.1 In This Chapter ....................................................................................... 36
  2.2 Input Prompt ............................................................................................ 37
    Suppressing Output .................................................................................. 38
    1-D Math Input ........................................................................................ 38
    Input Separators ....................................................................................... 39
  2.3 Commands ............................................................................................... 40
    The Maple Library .................................................................................... 40
    Top-Level Commands ............................................................................. 40
    Package Commands .................................................................................. 42
  2.4 Palettes .................................................................................................... 43
  2.5 Context Menus ......................................................................................... 46
  2.6 Assistants and Tutors .............................................................................. 48
## Contents

4 Mathematical Computations .............................................................. 123

4.1 In This Chapter ............................................................................ 125

4.2 Algebra ........................................................................................ 126
  Polynomial Algebra ...................................................................... 126

4.3 Linear Algebra ............................................................................ 135
  Creating Matrices and Vectors ...................................................... 136
  Accessing Entries in Matrices and Vectors ................................... 144
  Linear Algebra Computations ....................................................... 145
  Student LinearAlgebra Package .................................................... 152

4.4 Calculus ....................................................................................... 153
  Limits ............................................................................................ 153
  Differentiation ............................................................................... 155
  Series ............................................................................................. 161
  Integration ..................................................................................... 163
  Differential Equations .................................................................... 166
  Calculus Packages ......................................................................... 166

4.5 Optimization ............................................................................... 168
  Point-and-Click Interface .............................................................. 169
  Large Optimization Problems ....................................................... 171
  MPS(X) File Support .................................................................... 173
  Additional Information .................................................................. 173

4.6 Statistics ...................................................................................... 173
  Probability Distributions and Random Variables .......................... 173
  Statistical Computations .............................................................. 175
  Plotting .......................................................................................... 177
  Additional Information .................................................................. 179

4.7 Teaching and Learning with Maple ............................................ 180
  Student Packages and Tutors ........................................................ 181

5 Plots and Animations .......................................................................... 189

5.1 In This Chapter ............................................................................ 189

5.2 Creating Plots .............................................................................. 190
  Interactive Plot Builder ................................................................. 191
  Context Menu ................................................................................ 205
  Dragging to a Plot Region ............................................................. 208
  The plot and plot3d Commands .................................................... 209
  The plots Package ......................................................................... 212
6.4 Creating Graded Assignments ................................................. 273
  Creating a Question ........................................................................ 274
  Viewing Questions in Maple ......................................................... 274
  Saving Test Content ...................................................................... 274
6.5 Auto-Execute ............................................................................. 275
  Setting the Auto-Execute Feature ................................................ 275
  Removing the Auto-Execute Setting ............................................. 275
  Repeating Auto-Execution ............................................................ 275
  Security Levels ............................................................................. 276
6.6 Canvas ...................................................................................... 276
  Insert a Canvas ............................................................................. 277
  Drawing ........................................................................................ 278
  Canvas Style ................................................................................ 278
6.7 Spell Checking ........................................................................... 280
  How to Use the Spellcheck Utility ................................................. 281
  Selecting a Suggestion .................................................................. 282
  Spellcheck Usage and the Document ........................................... 282
  User Dictionary ............................................................................ 282
6.8 Hyperlinks .............................................................................. 284
  Inserting a Hyperlink in a Document ........................................... 284
6.9 Worksheet Compatibility ........................................................... 287

7 Maple Expressions ...................................................................... 289
7.1 In This Chapter .......................................................................... 289
7.2 Creating and Using Data Structures .......................................... 289
  Expression Sequences .................................................................. 290
  Sets ............................................................................................. 291
  Lists ............................................................................................. 292
  Arrays ......................................................................................... 293
  Tables ........................................................................................ 294
  Matrices and Vectors ................................................................... 295
  Functional Operators ................................................................... 296
10.2 Writing to Files ................................................................. 369
  Saving Data to a File ............................................................. 369
  Saving Expressions to a File .................................................. 371
10.3 Reading from Files ............................................................. 372
  Reading Data from a File ....................................................... 372
  Reading Expressions from a File .......................................... 373
10.4 Exporting to Other Formats ................................................. 374
  Exporting Documents ............................................................. 374
  MapleNet .............................................................................. 378
  Maple T.A. ........................................................................... 379
10.5 Connectivity ................................................................. 380
  Translating Maple Code To Other Programming Languages ...... 380
  Accessing External Products from Maple ................................ 380
  Accessing Maple from External Products ................................ 381
Index ................................................................................... 383
List of Tables

Table 1.1: Shortcuts for Entering Mathematical Expressions .......................... 7
Table 1.2: Entering a Definite Integral .................................................................. 14
Table 1.3: Symbol Completion Shortcut Keys .................................................. 18
Table 1.4: Summary of Document Mode Tools ................................................. 32
Table 1.5: Maple Help Resources ......................................................................... 33
Table 3.1: Select Integer Commands ..................................................................... 73
Table 3.2: Modular Arithmetic Operators ........................................................... 76
Table 3.3: Overview of Solution Methods for Important Equation Types .......... 78
Table 3.4: Sample Dimensions ............................................................................. 98
Table 3.5: Scientific Constants ........................................................................... 106
Table 4.1: Maple Resources for Mathematical Computation ......................... 123
Table 4.2: Polynomial Arithmetic Operators ...................................................... 127
Table 4.3: Polynomial Coefficient and Degree Commands ............................... 133
Table 4.4: Select Other Polynomial Commands ................................................ 134
Table 4.5: Additional Polynomial Help ............................................................... 135
Table 4.6: Matrix and Vector Arithmetic Operators ........................................... 146
Table 4.7: Select Matrix and Vector Operators .................................................. 148
Table 4.8: Select LinearAlgebra Package Commands ......................................... 150
Table 4.9: Limits ................................................................................................... 154
Table 4.10: Student and Instructor Resources .................................................... 180
Table 5.1: Windows of the Interactive Plot Builder ............................................ 192
Table 5.2: Displaying a Plot of a Single Variable Expression ............................. 194
Table 5.3: Displaying a Plot of Multiple Expressions of 1 Variable .................. 196
Table 5.4: Displaying a Plot of a Multi-variable Expression ............................... 197
Table 5.5: Displaying a Conformal Plot ............................................................. 199
Table 5.6: Displaying a Plot in Polar Coordinates .............................................. 201
Table 5.7: Interactive Plotting ............................................................................. 203
Table 5.8: The plot and plot3d Commands ........................................................ 209
Table 5.9: Customizing Plots Using Interactive Plot Builder .............................. 218
Table 5.10: Customizing 2-D Plots Using the Context Menu ............................. 220
Table 5.11: Customizing 3-D Plots Using the Context Menu ............................. 221
Table 5.12: Popular Plot Options ........................................................................ 221
Table 5.13: Plot Analysis Options ....................................................................... 224
Table 5.14: Creating Animations Using the Interactive Plot Builder ..... 225
Table 5.15: The animate Command .......................................................... 227
Table 5.16: Animation Options ............................................................... 228
Table 5.17: Customizing Animations Using the Context Menu ............ 231
Table 8.1: Default Clause Values ............................................................ 331
Table 8.2: Iterative Commands .............................................................. 337
Table 8.3: The seq Command ................................................................ 337
Table 8.4: The add and mul Commands ................................................ 338
Table 8.5: The select, remove, and selectremove Commands ............... 339
Table 8.6: The map Command ............................................................... 340
Table 8.7: The zip Command ................................................................. 341
Table 10.1: Summary of Content Translation When Exporting to Different Formats ............................................................. 376
Preface

The Maple Software

The Maple\textsuperscript{TM} software is a powerful system that you can use to solve complex mathematical problems. You can also create professional quality documents, presentations, and custom interactive computational tools in the Maple environment.

You can access the power of the Maple computational engine through a variety of interfaces.

<table>
<thead>
<tr>
<th>Interface</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Standard Worksheet</td>
<td>A full-featured graphical user interface that helps you create electronic documents to show all your calculations, assumptions, and any margin of error in your results. You can also hide the computations to allow your reader to focus on the problem setup and final results. The advanced formatting features lets you create the customized document you need. Because the documents are \textit{live}, you can edit the parameters and, with the click of a button, compute the new results. The Standard interface has two modes: \textit{Document} mode and \textit{Worksheet} mode. An interactive version of this manual is available in the Standard Worksheet interface. From the \textbf{Help} menu, select \textbf{Manuals, Dictionary, and more} → \textbf{Manuals} → \textbf{User Manual}.</td>
</tr>
<tr>
<td>Classic Worksheet</td>
<td>A basic worksheet environment for older computers with limited memory. The Classic interface does not offer all of the graphical user interface features that are available in the Standard interface. The Classic interface has only one mode, \textit{Worksheet} mode.</td>
</tr>
<tr>
<td>Command-line version</td>
<td>A command-line interface for solving very large complex problems or batch processing with scripts. No graphical user interface features are available.</td>
</tr>
</tbody>
</table>
This manual describes how to use the Standard interface. As mentioned, the Standard interface offers two modes: Document mode and Worksheet mode. Using either mode, you can create high quality interactive mathematical documents. Each mode offers the same features and functionality, the only difference is the default input region of each mode.

**Document Mode vs. Worksheet Mode**

Before you can begin using Maple, you need to decide if you want to interact in an interface that hides all commands used to perform calculations by default (Document mode) or to show all commands by default (Worksheet mode). Regardless of which mode you are working in, you have the opportunity to show or hide your calculations, i.e. you can hide commands in Worksheet mode by adding a Document Block from the Format menu, Format → Create Document Block or you can show commands in Document mode by adding a Maple prompt from the Insert menu, Insert → Execution Group → Before / After Cursor.

**Document Mode**

Document mode uses Document Blocks as the default input region to hide Maple syntax. The Document Block region is indicated by two triangles located in the vertical Markers column along the left pane of the Maple Document, ⬐ ula. If the Markers column is not visible, select View →
Markers. This allows you to focus on the problem instead of the commands used to solve the problem. For example, when using context menus on Maple input in Document mode (invoked by right-clicking or Control-clicking for Macintosh), input and output are connected using an arrow or equal sign with self-documenting text indicating the calculation that had taken place. The command used to solve this expression is hidden.

\[ x^2 + 7x + 10 \rightarrow \text{solve} \{x = -2\}, \{x = -5\} \]

When starting Standard Maple, the default mode is Document mode.

**Worksheet Mode**

Worksheet mode uses a Maple prompt as the default input region. The Maple input prompt is a red greater then symbol where the black square bracket indicates the full execution region, `[>]. When using content menus on Maple input in Worksheet mode, all commands are displayed.

```
> x^2 + 7*x + 10
> solve( { x^2 + 7*x + 10 = 0 } )
{ x = -2 }, \{ x = -5 \}
```

To work in Worksheet mode, select File → New → Worksheet Mode.

**Math Mode vs. Text Mode**

Within each interface mode, you have the choice of entering input using *Math mode* or *Text mode*. Math mode allows you to enter input as 2-D Math regardless if you are working in Document mode or Worksheet mode. Text mode is quite different depending on where you are working. Toggling modes is done using the Text and Math buttons on the toolbar.
<table>
<thead>
<tr>
<th>Entry mode $\rightarrow$</th>
<th>Math mode (default setting)</th>
<th>Text mode</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Document</strong> (default setting)</td>
<td>• Input is made at a Document Block with slanted cursor, $\begin{array}{c} x^2 \ \frac{x^3}{3} \end{array}$ &lt;br&gt; • Input is entered using 2-D Math, $\begin{array}{c} x^2 + 7x + 10 \end{array}$ $\text{solve} { x = -2 }, { x = -5 }$</td>
<td>• Input is made at a Document Block with vertical cursor, $\begin{array}{c} x^3 \ \frac{x^3}{3} \end{array}$ &lt;br&gt; • Input is entered as regular text, $\begin{array}{c} \text{Enter some text} \end{array}$</td>
</tr>
<tr>
<td><strong>Worksheet</strong></td>
<td>• Input is made at an input prompt with a slanted cursor, $\begin{array}{c} x^2 \ \frac{x^3}{3} \end{array}$ &lt;br&gt; • Input is entered using 2-D Math, $\begin{array}{c} x^2 + 7x + 10 \end{array}$ $\text{solve} { x^2 + 7x + 10 = 0 }$ ${ x = -2 }, { x = -5 }$</td>
<td>(Default setting for earlier versions of Maple) &lt;br&gt; • Input is made at an input prompt with a vertical cursor, $\begin{array}{c} x^2 \ \frac{x^3}{3} \end{array}$ &lt;br&gt; • Input is entered using 1-D Math and requires a semi-colon or colon to end your input, $\begin{array}{c} x^2/3; \end{array}$ &lt;br&gt; • Commands display when using context menus on the expression output, $\begin{array}{c} x^2/3; \end{array}$ $\frac{x^2}{3} \quad (1)$ &lt;br&gt; $\begin{array}{c} \text{solve} { (1) = 0 }; \end{array}$ ${ x = 0 }, { x = 0 } \quad (2)$</td>
</tr>
</tbody>
</table>
Invoking Context Menus and Command Completion

This manual will frequently refer to context menus and command completion when entering expressions. The keyboard keys used to invoke these features differ based on the operating system you're using.

Context Menus

- **Right-click**, Windows and UNIX®
- **Control-click**, Macintosh®

Command Completion

- **Ctrl + Space** or **Esc**, Windows
- **Command + Shift + Space** or **Esc**, Macintosh
- **Ctrl + Shift + Space** or **Esc**, UNIX

This manual will only refer to the keyboard keys needed for a Windows operating system. When working through the examples, use the keyboard keys needed for your operating system.

In This Manual

This manual provides an overview of all Maple features including:

- Performing computations
- Creating plots and animations
- Creating interactive documents
- The Maple programming language
- Using and creating custom Maplet applications
• File input and output, and using Maple with third party products
• Data structures

For a complete list of manuals, study guides, toolboxes, and other resources, visit the Maplesoft Web site at http://www.maplesoft.com.

Audience

The information in this manual is intended for Maple users who have read the Maple Getting Started Guide.

Conventions

This manual uses the following typographical conventions.

• **bold** font - Maple command, package name, option name, dialog, menu, and text field
• *italics* - new or important concept
• **Note** - additional information relevant to the section
• **Important** - information that must be read and followed

Customer Feedback

Maplesoft welcomes your feedback. For suggestions and comments related to this and other manuals, contact doc@maplesoft.com
1 Document Mode

Using the Maple software, you can create powerful interactive documents. You can visualize and animate problems in two and three dimensions. You can solve complex problems with simple point-and-click interfaces or easy-to-modify interactive documents. You can also devise custom solutions using the Maple programming language. While you work, you can document your process, providing text descriptions.

1.1 Introduction

Maple has two modes: Document mode and Worksheet mode.

Document mode is designed for quickly performing calculations. You can enter a mathematical expression, and then evaluate, manipulate, solve, or plot it with a few keystrokes or mouse clicks. This chapter provides an overview of Document mode.

Document mode sample:

Find the value of the derivative of \( \ln(x^2 + 1) \) at \( x = 4 \).

\[
\ln(x^2 + 1) \quad \frac{\text{differentiate w.r.t. } x}{\text{evaluate at point}} \quad \frac{2x}{x^2 + 1} \quad 8 \quad 17
\]

Integrate \( \sin\left(\frac{1}{x}\right) \) over the interval \( [0, \pi] \).

\[
\int_{0}^{\pi} \sin\left(\frac{1}{x}\right) \, dx = \sin\left(\frac{1}{\pi}\right) \pi - \text{Ci}\left(\frac{1}{\pi}\right)
\]

Worksheet mode is designed for interactive use through commands and programming using the Maple language. The Worksheet mode supports the features available in Document mode described in this chapter. After review-
ing the information in this chapter, see Chapter 2, *Worksheet Mode (page 35)*, for information on using Worksheet mode. **Note:** to enter a Maple input prompt while in Document mode, click $\text{[>]}$ in the Maple toolbar.

Worksheet mode sample:

Find the value of the derivative of $\ln(x^2 + 1)$ at $x = 4$.

\[
> \quad \ln(x^2 + 1) \\
\quad \ln(x^2 + 1) \tag{1.1}
\]

\[
> \quad \text{diff}(1.1, x) \\
\quad \frac{2x}{x^2 + 1} \tag{1.2}
\]

\[
> \quad \text{eval}(1.2, x=4) \\
\quad \frac{8}{17}
\]

**Note:** The previous two examples make use of equation labels when using (1.1) and (1.2) to specify the expression. Equation labels allow you to refer to the unique equation label for the output of a command, which is displayed to the right of the output. To insert an equation label, from the **Insert** menu, select **Label**. In the dialog that displays, enter the equation label. For more information on equations labels, see *Equation Labels (page 59)*.
Integrate $\sin\left(\frac{1}{x}\right)$ over the interval $[0, \pi]$.

$$\int_{0}^{\pi} \sin\left(\frac{1}{x}\right) \, dx$$

$$\sin\left(\frac{1}{\pi}\right) \pi - \text{Ci}\left(\frac{1}{\pi}\right)$$

**Important:** In any Maple document, you can use Document mode and Worksheet mode.

Using either mode:

- You have access to the full mathematical engine.
- You can create high quality interactive documents: easy-to-use computational tools, presentations, or publications.

Interactive document features include:

- Embedded graphical interface components, like buttons, sliders, and check boxes
- Automatic execution of marked regions when a file is opened
- Tables
- Character and paragraph formatting styles
- Hyperlinks

These features are described in Chapter 6, *Creating Mathematical Documents* (page 235).

**Note:** This chapter was created using Document mode. All other chapters were created using Worksheet mode.
# 1.2 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| Simple Mathematical Expressions - Introduction to Math and Text modes, and how to easily enter simple expressions | • Text and Math Modes  
• Rational Expressions  
• Powers  
• Products  
• Shortcuts for Entering Mathematical Expressions  
• Other Expressions |
| Evaluating Expressions - How to evaluate expressions                    | • Displaying the Value Inline  
• Displaying the Value on the Following Line |
| Editing Expressions and Regenerating Output - How to update expressions and results | • Updating a Single Computation  
• Updating a Group of Computations  
• Updating All Computations in a Document |
| Entering Expressions - Overview of tools for creating complex mathematical expressions | • Palettes  
• Symbol Names |
| Performing Computations - Overview of tools for computing and plotting  | • Computing with Palettes  
• Context Menus  
• Assistants and Tutors |
| Document Mode Summary - Summary of key Document mode features          | • Table of Document Mode Tools |
| Getting Help - A list of resources available in the Maple Help System   | • Table of Maple Help Resources |
1.3 Simple Mathematical Expressions

In Document mode, you can enter two types of content: Text and Math. The Text mode and Math mode icons at the left end of the toolbar indicate the current mode. The toolbar is located near the top of the Maple window, immediately below the menu bar.

To switch between Text and Math modes, press the F5 key. (Alternatively, click the Text mode or Math mode toolbar icon.) Consequently, it is easy to enter sentences containing text and inline mathematical expressions.

Entering mathematical expressions, such as \( \frac{35}{99} + \frac{1}{9} \), \( x^2 + x \), and \( x \cdot y \) is natural in Math mode.

**Rational Expressions (Fractions)**

To enter a fraction:

1. Enter the numerator.
2. Press the forward slash (/) key.
3. Enter the denominator.
4. To exit the denominator, press the right arrow key.

**Powers**

To enter a power:

1. Enter the base.
2. Press the caret (^) key.
3. Enter the exponent, which displays in math as a superscript.
4. To exit the exponent, press the right arrow key.

**Products**

To enter a product:

1. Enter the first factor.

2. Press the asterisk (*) key, which displays in math as \( \cdot \).

3. Enter the second factor.

**Implied Multiplication**

In most cases, you do not need to include the multiplication operator, \( \cdot \). Insert a space character between two quantities to multiply them.

**Note:** In some cases, you do not need to enter the multiplication operator or a space character. For example, Maple interprets a number followed by a variable as multiplication.

**Important:** Maple interprets a sequence of letters, for example, \( xy \), as a single variable. To specify the product of two variables, you must insert a space character (or multiplication operator), for example, \( x \cdot y \) or \( x \cdot y \). For more information, refer to the [?2DMathDetails](#) help page.
# Shortcuts for Entering Mathematical Expressions

Table 1.1 lists shortcut keys for entering and navigating mathematical expressions.

## Table 1.1: Shortcuts for Entering Mathematical Expressions

<table>
<thead>
<tr>
<th>Symbol/Format</th>
<th>Key</th>
<th>Automatically Generated in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>implicit multiplication</td>
<td><strong>Space</strong> key</td>
<td>((x^2 - 7xy + 3y^2)xy)</td>
</tr>
<tr>
<td>explicit multiplication</td>
<td>* (asterisk)</td>
<td>2·3</td>
</tr>
<tr>
<td>fraction</td>
<td><code>/</code> (forward slash)</td>
<td>(\frac{1}{4})</td>
</tr>
<tr>
<td>exponent (superscript)</td>
<td><code>^</code> (<strong>Shift</strong> + 6 or caret key)</td>
<td>(x^2)</td>
</tr>
<tr>
<td>subscript</td>
<td><code>_</code> (<strong>Shift</strong> + underscore)</td>
<td>(x_a)</td>
</tr>
<tr>
<td>navigating expressions</td>
<td>Arrow keys</td>
<td></td>
</tr>
<tr>
<td>subscript</td>
<td><code>_</code> (<strong>Shift</strong> + underscore)</td>
<td>(x_a)</td>
</tr>
</tbody>
</table>
| overscript | • **Ctrl** + **Shift** + ", Windows and UNIX  
• **Command** + **Shift** + ", Macintosh | \(\overrightarrow{x}\) |
| fraction | `/` (forward slash) | \(\frac{1}{4}\) |

1 required for products of numbers

2 use right arrow key to leave denominator, superscript, or subscript region
<table>
<thead>
<tr>
<th>Symbol/Format</th>
<th>Key</th>
<th>Automatically Generated in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>command/symbol</td>
<td>• <strong>Ctrl</strong> + <strong>Space</strong>, Windows</td>
<td><img src="image" alt="Image" /></td>
</tr>
<tr>
<td>completion</td>
<td>• <strong>Command</strong> + <strong>Shift</strong> + <strong>Space</strong>, Macintosh</td>
<td><img src="image" alt="Image" /></td>
</tr>
<tr>
<td></td>
<td>• <strong>Ctrl</strong> + <strong>Shift</strong> + <strong>Space</strong>, UNIX</td>
<td><img src="image" alt="Image" /></td>
</tr>
<tr>
<td>square root</td>
<td><strong>sqrt</strong> then command completion</td>
<td>$\sqrt{25}$</td>
</tr>
<tr>
<td>exponential function</td>
<td><strong>exp</strong> then command completion</td>
<td>$e^x$</td>
</tr>
<tr>
<td>enter/exit 2-D Math</td>
<td><strong>F5 or Math</strong> and <strong>Text</strong> icons in the toolbar</td>
<td>$\frac{1}{4}$ versus $\frac{1}{4}$</td>
</tr>
</tbody>
</table>

For a complete list of shortcut keys, refer to the 2-D Math Shortcut Keys and Hints help page. To access this help page in the Maple software, in Math mode enter `?MathShortcuts` and then press Enter. For information on the Maple Help System, see Getting Help (page 33).

**Other Expressions**

It is also easy to enter mathematical expressions, such as:

- **Piecewise — continuous functions:** $|x| = \begin{cases} -x & x < 0 \\ 0 & x = 0 \\ x & 0 < x \end{cases}$

- **Limits:** $\delta(x) = \lim_{\epsilon \to 0} \epsilon |x|^{\epsilon} - 1$
• Continued fractions: \[ \sqrt{2} = 1 + \frac{1}{2 + \frac{1}{2 + \frac{1}{2 + \cdots}}}. \]

and more complex expressions. For information, see *Entering Expressions* (page 11).

## 1.4 Evaluating Expressions

To evaluate a mathematical expression, place the cursor in the expression and press *Ctrl* + = (*Command* + =, for Macintosh). That is, *press and hold* the *Ctrl* (or *Command*) key, and then press the equal sign (=) key.

To the right of the expression, Maple inserts an equal sign and then the value of the expression.

\[ \frac{2}{9} + \frac{7}{11} = \frac{85}{99} \]

You can replace the inserted equal sign with text or mathematical content.

**To replace the equal sign:**

1. Select the equal sign. Press *Delete*.

2. Enter the replacement text or mathematical content.

For example, you can replace the equal sign with the text "is equal to".

\[ \frac{2}{9} + \frac{7}{11} \text{ is equal to } \frac{85}{99} \]

In mathematical content, pressing *Enter* evaluates the expression and displays it centered on the following line. The cursor moves to a new line below the output.
\[
\frac{2}{9} + \frac{7}{11} = \frac{85}{99}
\]

By default, Maple labels output that is generated by pressing Enter. For information on equation labels, see Equation Labels (page 59). In this manual, labels are generally not displayed.

In text, pressing Enter inserts a line break.

You can use the basic algebraic operators, such as $+$ and $-$, with most expressions, including polynomials—see Polynomial Algebra (page 126)—and matrices and vectors—see Linear Algebra (page 135).

\[
(2x^2 - x + 1) - (x^2 + 2x + 12) = x^2 - 3x - 11
\]

\[
3 \cdot \begin{bmatrix}
-4 \\
27
\end{bmatrix}
= \begin{bmatrix}
-12 & 24 & 297 \\
81 & 207 & 87
\end{bmatrix}
\]

### 1.5 Editing Expressions and Updating Output

One important feature of Maple is that your documents are live. That is, you can edit expressions and quickly recalculate results.

**To update one computation:**

1. Edit the expression.
2. Press Ctrl + = (Command + =, for Macintosh) or Enter.

The result is updated.
1.6 Entering Expressions

To update a group of computations:

1. Edit the expressions.

2. Select all edited expressions and the results to recalculate.

3. Click the Execute toolbar icon !.

All selected results are updated.

To update all output in a Maple document:

• Click the Execute All toolbar icon !!!.

All results in the document are updated.

1.6 Entering Expressions

Mathematical expressions can contain the following symbols.

• Numbers: integers, rational numbers, complex numbers, floating-point values, finite field elements, $i$, $\infty$, ...

• Operators: $+$, $-$, $!$, $/$, $\cdot$, $\int$, $\lim_{x \to a}$, $\frac{\partial}{\partial x}$, ...

• Constants: $\pi$, $e$, ...

• Mathematical functions: $\sin(x)$, $\cos(\pi/3)$, $\Gamma(2)$, ...

• Names (variables): $x$, $y$, $z$, $\alpha$, $\beta$, ...

• Data structures: sets, lists, Arrays, Vectors, Matrices, ...

Maple contains over a thousand symbols. For some numbers, operators, and names, you can press the corresponding key, for example, 9, =, >, or x. Most symbols are not available on the keyboard, but you can insert them easily using two methods.
To insert a symbol, you can use:

- Palettes
- Symbol names

**Palettes**

Palettes are collections of related items that you can insert by clicking or dragging. Palettes contain:

- Numbers and constants, like \( i \) (the imaginary unit), \( \pi \), and \( \infty \). For example, see the **Common Symbols** palette (Figure 1.1).
- Layouts, like an item with a superscript and subscript. For example, see the **Layout** palette (Figure 1.2).
- Mathematical operations, like a definite integral with placeholders for the integrand, variable of integration, and endpoints of the interval of integration. For example, see the **Expression** palette (Figure 1.3).
- Specialized tools. For example, see the **Matrix** palette (Figure 1.4). For information on the **Matrix** palette, see *Creating Matrices* (page 136).

Figure 1.1: Common Symbols Palette  
Figure 1.2: Layout Palette
Using Palettes

To insert a palette item:

1. In the palette, click the item to insert. The item is inserted at the cursor location.

2. If the item has colored placeholders, specify values for them.
   - To move to the next placeholder, press the Tab key.

Note: You can drag palette items to any location in the document.

For example, to insert the constant $\pi$:

- In the Common Symbols palette, click the $\pi$ symbol.

or

- From the Common Symbols palette, drag the $\pi$ symbol to the appropriate location in the document.
Table 1.2 shows how to enter a definite integral.

**Table 1.2: Entering a Definite Integral**

<table>
<thead>
<tr>
<th>Action</th>
<th>Result in Document</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. In the <strong>Expression</strong> palette, click the definite integration item [ \int_{a}^{b} f(x) , dx ]. Maple inserts the definite integral. The left endpoint placeholder is selected.</td>
<td>[ \int_{a}^{b} f(x) , dx ]</td>
</tr>
<tr>
<td>2. Enter 0, and then press <strong>Tab</strong>. The right endpoint placeholder is selected.</td>
<td>[ \int_{0}^{b} f(x) , dx ]</td>
</tr>
<tr>
<td>3. Enter 1, and then press <strong>Tab</strong>. The integrand placeholder is selected.</td>
<td>[ \int_{0}^{1} f(x) , dx ]</td>
</tr>
<tr>
<td>4. Enter ( e^{-x^2} ), and then press <strong>Tab</strong>. The variable of integration placeholder is selected.</td>
<td>[ \int_{0}^{1} e^{-x^2} , dx ]</td>
</tr>
<tr>
<td>5. Enter x.</td>
<td>[ \int_{0}^{1} e^{-x^2} , dx ]</td>
</tr>
</tbody>
</table>

To evaluate the integral and display the result inline, press **Ctrl+=** (Command+=, for Macintosh) or **Enter**. For more information, see *Computing with Palettes* (page 20).

**Defining a Mathematical Function**

To define a function of one or two variables:
1. In the **Expression** palette, click one of the function definition items (Figure 1.5). Maple inserts the function definition.

2. Replace the placeholder \( f \) with the function name. Press **Tab**.

3. Replace the parameter placeholders, \( x \) or \( x_1, x_2 \), with the independent variable names. Press **Tab**.

4. Replace the final placeholder, \( y \), with the expression that defines the function value. Press **Enter**.

\[
\begin{align*}
  f & = a \rightarrow y \\
  f & = (a, b) \rightarrow z
\end{align*}
\]

**Figure 1.5: Function Definition Palette Items**

For example, define a function that doubles its input.

\[
twice := x \rightarrow 2x
\]

\[
x \rightarrow 2x
\]  
(1.4)

\[
twice(1342) = 2684
\]

\[
twice(y - z) = 2y - 2z
\]

**Note:** To insert the right arrow symbol \( \rightarrow \), you can also enter the characters `->`.

**Important:** The expression \( 2x \) is different from the function \( x \rightarrow 2x \).

For more information on functions, see *Functional Operators* (page 296).

**Viewing and Arranging Palettes**

By default, palettes are displayed in palette docks at the sides of the Maple window. If no palette dock is visible, use the following procedure.
To view palette docks:

- From the View menu, select Palettes, and then Expand Docks.

To expand a palette in a palette dock:

- Click the triangle at the left of the palette title.

To move a palette in a palette dock:

- Drag the palette (by clicking its title) to the new location.

Adding Palettes to the Palette Docks

Maple has over 20 palettes. By default, only a few palettes are in the palette docks. To add a palette to a palette dock, use the following procedure.

To add a palette:

1. Right-click (Control-click, for Macintosh) a palette dock. Maple displays a context menu—a menu that lists actions you can perform on the object—near the palette.

2. From the context menu, select Show Palette, and then select the palette.

Handwriting Palette

Finding the right symbol to insert can be time consuming. The Handwriting palette provides an efficient way to find and insert the right symbol. You draw the symbol with your mouse and then Maple matches your input against items available in the system. See Figure 1.6.
To use the Handwriting palette:

1. With your mouse, draw a symbol in the handwriting recognition region (sketch area).

2. Click the button. A list of potential matching symbols is displayed. To view more symbols (where indicated), click the drop-down arrows associated with the displayed symbols.

3. To insert a symbol, click the displayed symbol.

Symbol Names

Each symbol has a name, and some have aliases. By entering its name (or an alias) in Math mode, you can insert the symbol.

Note: If you hover the mouse pointer over a palette item, a tooltip displays the symbol's name.

Using Symbol Names

To insert a symbol by entering its name:
1. In Math mode, enter the symbol name.

2. Press the symbol completion shortcut key. See Table 1.3.

Maple inserts the corresponding symbol.

**Table 1.3: Symbol Completion Shortcut Keys**

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Shortcut Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows</td>
<td>Ctrl + Space or Escape</td>
</tr>
<tr>
<td>Macintosh</td>
<td>Escape</td>
</tr>
<tr>
<td>UNIX</td>
<td>Ctrl + Shift + Space or Escape</td>
</tr>
</tbody>
</table>

For example, to find the square root of 603729:

1. Enter `sqrt`.

2. Press the completion shortcut key. Maple displays a pop-up list of exact matches.

3. In the completion list, select `\(\sqrt{x}\)`. Maple inserts the symbol with the `x` placeholder selected.

4. Enter 603729.

5. Press `Ctrl + =` (Command + =, for Macintosh).

\[\sqrt{603729} = 777\]

**Using Partial Symbol Names**

To enter a symbol quickly, you can enter the first few characters of its name and then press the completion shortcut key (see Table 1.3).
• If a unique symbol name matches the characters entered, Maple inserts the corresponding symbol.

• If multiple symbol names match the characters entered, Maple displays the completion list, which lists all matches. To select an item, click its name or symbol.

For example, if you enter $i$ and then press the completion shortcut key, Maple displays:

For example, to multiply two complex numbers:

• Use the symbol name and completion list to enter the imaginary unit, $I = \sqrt{-1}$.

\[
(-0.123 + 0.745I) \cdot (4.2 - I) = 0.2284 + 3.2520I
\]

**Example: Indefinite Integral**

You can enter any expression using symbol names and the completion list.

**For example, to enter the indefinite integral** $\int \sin(x)\,dx$:

1. In Math mode, enter `int`. Press the completion shortcut key.

2. From the completion list, select the indefinite integral item $\int$. 
3. Enter \( \sin(x) \).

4. Enter \( d \). Press the completion shortcut key.

5. From the completion list, select \( d \) (differential).

6. Enter \( x \).

Note: From the int completion list, you can directly insert \( \int \! dx \).

1.7 Performing Computations

Using the Document mode, you can access the power of the advanced Maple mathematical engine without learning Maple syntax. In addition to solving problems, you can also easily plot expressions.

The primary tools for syntax-free computation are:

- Palettes
- Context menus
- Assistants and tutors

Note: The Document mode is designed for quick calculations, but it also supports Maple commands. For information on commands, see Commands (page 40) in Chapter 2, Worksheet Mode (page 35).

Important: In Document mode, you can execute a statement only if you enter it in Math mode. To use a Maple command, you must enter it in Math mode.

Computing with Palettes

As discussed in Palettes (page 12), some palettes contain mathematical operations.

To perform a computation using a palette mathematical operation:
1. In a palette that contains operators, such as the Expression palette, click an operator item.

2. In the inserted item, specify values in the placeholders.

3. To execute the operation and display the result, press $\text{Ctrl}+=\ (\text{Command}+=\,\text{for Macintosh})$ or Enter.

For example, to evaluate $\int_{0}^{1} e^{-x^2} \, dx$ inline:

1. Using the Expression palette, enter the definite integral. See Table 1.2 (page 14).

2. Press $\text{Ctrl}+=\ (\text{Command}+=\,\text{for Macintosh}).$

$$\int_{0}^{1} e^{-x^2} \, dx = \frac{1}{2} \text{erf}(1) \sqrt{\pi}$$

**Context Menus**

A context menu is a pop-up menu that lists the operations and actions you can perform on a particular expression. See Figure 1.7.
To display the context menu for an expression:

- Right-click (Control-click, for Macintosh) the expression.

The context menu is displayed beside the mouse pointer.

You can evaluate expressions using context menus.

- The **Evaluate and Display Inline** operation (see Figure 1.7) is equivalent to pressing `Ctrl+=` (Command+=, for Macintosh). That is, it inserts an equal sign (=) and then the value of the expression.

- The **Evaluate** operation (see Figure 1.7) is equivalent to pressing **Enter**. That is, it evaluates the expression and displays the result centered on the following line.

For more information on evaluation, see *Evaluating Expressions (page 9)*.

From the context menu, you can also select operations different from evaluation. To the right of the expression, Maple inserts a right arrow symbol (→) and then the result.
For example, use the **Approximate** operation to approximate a fraction:
\[
\frac{2}{3} \quad \text{at 10 digits} \rightarrow 0.6666666667
\]

You can perform a sequence of operations by repeatedly using context menus. For example, to compute the derivative of \( \cos(x^2) \), use the **Differentiate** operation on the expression, and then to evaluate the result at a point, use the **Evaluate at a Point** operation on the output and enter 10:
\[
\cos(x^2) \quad \text{differentiate w.r.t. } x \rightarrow -2\sin(x^2)x \quad \text{evaluate at point} \rightarrow -20\sin(100)
\]

The following subsections provide detailed instructions on performing a few of the numerous operations available using context menus. Figures in the subsections show related context menus or palettes.

**Approximating the Value of an Expression**

To approximate a fraction numerically:

1. Enter a fraction.
2. Display the context menu. See Figure 1.8.
3. From the context menu, select **Approximate**, and then the number of significant digits to use: **5, 10, 20, 50**, or **100**.
Figure 1.8: Approximating the Value of a Fraction

\[ \frac{2}{3} \rightarrow 0.666666667 \]

You can replace the inserted right arrow with text or mathematical content.

**To replace the right arrow ( \( \rightarrow \)):**

1. Select the arrow. Press **Delete**.
2. Enter the replacement text or mathematical content.

**Note:** To replace the right arrow with text, you must first press **F5** to switch to Text mode.

For example, you can replace the arrow with the text "is approximately equal to" or the symbol \( \approx \).

\[ \frac{2}{3} \text{ is approximately equal to } 0.666666667 \]
Solving an Equation

You can find an exact (symbolic) solution or an approximate (numeric) solution of an equation. For more information on symbolic and numeric computations, see Symbolic and Numeric Computation (page 66).

To solve an equation:

1. Enter an equation.
2. Display the context menu.
3. From the context menu, select Solve or Numerically Solve in the Solve menu item.

\[ \frac{7x^2}{3} - x = 12 \quad \text{solve} \quad \left\{ x = \frac{3}{14} + \frac{3}{14} \sqrt{113} \right\}, \left\{ x = \frac{3}{14} - \frac{3}{14} \sqrt{113} \right\} \]

\[ \frac{7x^2}{3} - x = 12 \quad \text{solve} \quad -2.063602674, 2.492174103 \]

For more information on solving equations, including solving inequations, differential equations, and other types of equations, see Solving Equations (page 77).

Using Units

You can create expressions with units. To specify a unit for an expression, use the Units palettes. The Units (FPS) palette (Figure 1.9) contains important units from the foot-pound-second (FPS) system of units used in the United States. The Units (SI) palette (Figure 1.10) contains important units from the international system (SI) of units.
To insert an expression with a unit:

1. Enter the expression.
2. In a unit palette, click a unit symbol.

Note: To include a reciprocal unit, divide by the unit.

To evaluate an expression that contains units:

1. Enter the expression using the units palettes to insert units.
2. Right-click (Control-click, for Macintosh) the expression.
3. From the context menu, select Units and then Simplify.

For example, compute the electric current passing through a wire that conducts 590 coulombs in 2.9 seconds.

\[
\frac{590 [C]}{2.9 [s]} \quad \text{simplify units} \quad 203.4482759 [A]
\]

For more information on using units, see Units (page 97).
Assistants and Tutors

Assistants and tutors provide point-and-click interfaces with buttons, text input regions, and sliders.

Assistants

Assistants help you accomplish many tasks, such as solving ordinary differential equations (ODEs) and ODE systems, creating plots, curve fitting, importing data, and building an installer (Figure 1.11).

- From the **Tools** menu, select **Assistants**, and then one of the topic sub-menus.

![Installer Builder Assistant](image)

**Figure 1.11: Installer Builder Assistant**

Tutors

Over 40 interactive tutors help student users gain insight and understanding of topics in courses such as precalculus, calculus, multivariate calculus,
vector calculus, and linear algebra. Some tutors help you work through a problem step-by-step.

- From the **Tools** menu, select **Tutors**, and then one of the topic submenus.

For example, you can create a plot of the compositions of two functions using the **Function Composition Tutor**.

**To use the Function Composition Tutor:**

1. From the **Tools** menu, select **Tutors, Precalculus**, and then **Compositions**. The **Function Composition Tutor** is displayed. See Figure 1.12.

2. In the $f(x) =$ and $g(x) =$ text fields, enter the two functions.

3. Click the **Display** button. The tutor displays the compositions $g(f(x))$ and $f(g(x))$.

4. To insert the plot into your document, click the **Close** button.
You can plot a mathematical expression using the Interactive Plot Builder.

The Plot Builder can be launched from the Tools menu or the context menu for an expression.

To create a plot using a context menu:

1. Enter or compute a mathematical expression with one or two independent variables.
2. Right-click (Control-click, for Macintosh) the expression to plot.

3. From the context menu, select Plots, and then Plot Builder. The Interactive Plot Builder is displayed. See Figure 1.13.

4. In the Select Plot Type dialog, select the plot type, for example, 3-D plot or 2-D contour plot.

5. To immediately create a plot, click the Plot button. To customize the plot before generating it, click the Options button.

![Interactive Plot Builder: Select Plot Type Dialog](image)

Figure 1.13: Interactive Plot Builder: Select Plot Type Dialog

For example, Figure 1.14 shows a plot of \( x^2 + y^2 \).
Figure 1.14: 3-D Plot of an Expression

For more information on plots, see *Plots and Animations* (page 189).

1.8 Document Mode Summary

The key features of Document mode are summarized in Table 1.4.
Table 1.4: Summary of Document Mode Tools

<table>
<thead>
<tr>
<th>Action</th>
<th>Methods</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entering Mathematical Expressions</td>
<td>• Math editing shortcut keys, including symbol name completion</td>
</tr>
<tr>
<td>For example:</td>
<td>• Palettes</td>
</tr>
</tbody>
</table>
| \[
\sin \left( \frac{\pi}{3} \right) + i \cos \left( \frac{\pi}{4} \right)
\]
| \[
\int_{0}^{1.9} x^2 \sin(x^2 + 1) \, dx
\]                                                   |                                                                         |
| Evaluating Mathematical Expressions (Result Inline)* | • Ctrl + = (Command + =, for Macintosh)                                  |
| For example:                                     | • From the context menu, select Evaluate and Display Inline.            |
| \[
\sin \left( \frac{\pi}{3} \right) + i \cos \left( \frac{\pi}{4} \right) = \frac{1}{2} \sqrt{3} + \frac{1}{2} i \sqrt{2}
\] |                                                                         |
| Evaluating Mathematical Expressions (Result Centered on Following Line) | • Enter key                                                             |
| For example:                                     | • From the context menu, select Evaluate.                               |
| \[
\int_{0}^{1.9} x^2 \sin(x^2 + 1) \, dx
\]                                                   |                                                                         |
|                                                     | -0.1213460375 (1.5)                                                    |
| Performing Computations and Other Operations on Expressions | • Context menus                                                         |
| For example, differentiate an expression:        | • Assistants                                                            |
| \[
\sin(x^2 + 1) \rightarrow 2 \cos(x^2 + 1) x
\]                                                | • Tutors                                                                |
| Executing a Group of Evaluations, Computations, or Other Operations | • Execute toolbar icon ![ ]                                              |
|                                                                 | • Execute All toolbar icon ![!!!]                                      |

* Inline evaluation is available in Document mode and document blocks. For information on document blocks, see Document Blocks (page 251).
1.9 Getting Help

The Maple Help System contains resources to help you use Maple. See Table 1.5.

Table 1.5: Maple Help Resources

<table>
<thead>
<tr>
<th>Resource</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maple Tour</td>
<td>An interactive overview of Maple.</td>
</tr>
<tr>
<td></td>
<td>• From the Help menu, select Take a Tour of Maple.</td>
</tr>
<tr>
<td>Online Manuals</td>
<td>Online manuals, including the Maple Getting Started Guide and this manual.</td>
</tr>
<tr>
<td></td>
<td>You can execute examples, copy content into other documents, and search the</td>
</tr>
<tr>
<td></td>
<td>contents using the Maple Help System.</td>
</tr>
<tr>
<td></td>
<td>The Maple Getting Started Guide provides extensive information for new</td>
</tr>
<tr>
<td></td>
<td>users on using Maple and the resources available on the Maplesoft Web site</td>
</tr>
<tr>
<td></td>
<td>(<a href="http://www.maplesoft.com">http://www.maplesoft.com</a>). Each procedure and concept is accompanied by</td>
</tr>
<tr>
<td></td>
<td>visual depictions of actions to help you identify Maple resources and tools.</td>
</tr>
<tr>
<td></td>
<td>• From the Help menu, select Manuals, Dictionary, and more and then Manuals.</td>
</tr>
<tr>
<td>Quick Help</td>
<td>A list of key commands and concepts.</td>
</tr>
<tr>
<td></td>
<td>• From the Help menu, select Quick Help. Alternatively, press F1. For</td>
</tr>
<tr>
<td></td>
<td>additional information, click an item in the Quick Help.</td>
</tr>
<tr>
<td>Quick Reference</td>
<td>A table of commands and information for new users that opens in a new</td>
</tr>
<tr>
<td></td>
<td>window. It contains hyperlinks to help pages for more information.</td>
</tr>
<tr>
<td></td>
<td>• From the Help menu, select Quick Reference. Alternatively, press Ctrl + F2</td>
</tr>
<tr>
<td></td>
<td>(Command + F2, for Macintosh).</td>
</tr>
<tr>
<td>Resource</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Help Pages</td>
<td>Help for Maple features, commands, packages, and more. Help pages include examples and screenshots to help you quickly learn.</td>
</tr>
<tr>
<td></td>
<td>• From the Help menu, select Maple Help. You can search for a help topic, perform a text search, or browse the Table of Contents. You can also open a help page by entering ?&lt;topic_name&gt; at the input prompt (in Worksheet mode) or in Math mode (in Document mode).</td>
</tr>
<tr>
<td>Task Templates</td>
<td>Set of commands with placeholders that you can use to quickly perform a task.</td>
</tr>
<tr>
<td></td>
<td>• From the Tools menu, select Tasks, and then Browse.</td>
</tr>
<tr>
<td>Applications and Example Worksheets</td>
<td>Executable documents that demonstrate the power and flexibility of the Maple interactive document or provide an overview of computations in a particular field.</td>
</tr>
<tr>
<td></td>
<td>• From the Help menu, select Manuals, Dictionary, and more, and then Applications and Examples.</td>
</tr>
<tr>
<td>Mathematics and Engineering Dictionary</td>
<td>Over 5000 definitions, including 300 figures and plots.</td>
</tr>
<tr>
<td></td>
<td>• From the Help menu, select Manuals, Dictionary, and more, and then Dictionary.</td>
</tr>
</tbody>
</table>

For a complete list of resources, refer to the ?MapleResources help page.

For more information on the Maple Help System, refer to the Maple Getting Started Guide.
2 Worksheet Mode

The Worksheet mode of the Standard Worksheet interface is designed for:

- Interactive use through Maple commands, which may offer advanced functionality or customized control not available using context menus or other syntax-free methods
- Programming using the powerful Maple language

Using Worksheet mode, you have access to most of the Maple features described in Chapter 1 including:

- Math and Text modes
- Palettes
- Context menus
- Assistants and tutors

For information on these features, see Chapter 1, Document Mode (page 1). (For a summary, see Table 1.4 (page 31).)

Note: Using a document block, you can use all Document mode features in Worksheet mode. For information on document blocks, see Document Blocks (page 251).

Note: This chapter and the following chapters were created using Worksheet mode.
## 2.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| Input Prompt - Where you enter input         | • The Input Prompt (>)
|                                              | • Suppressing Output                                    |
|                                              | • 2-D and 1-D Math Input                                |
|                                              | • Input Separators                                      |
| Commands - Thousands of routines for         | • The Maple Library                                     |
| performing computations and other operations | • Top-Level Commands                                    |
|                                              | • Package Commands                                      |
| Palettes - Items that you can insert by      | • Using Palettes                                        |
| clicking or dragging                        |                                                        |
| Context Menus - Pop-up menus of common      | • Using Context Menus                                   |
| operations                                   |                                                        |
| Assistants and Tutors - Graphical interfaces| • Launching Assistants and Tutors                       |
| with buttons and sliders                    | • Example: Using the Interactive Plot Builder           |
| Task Templates - Sets of commands with      | • Viewing Task Templates                                |
| placeholders that you can insert and use to | • Inserting a Task Template                             |
| perform a task                              | • Performing the Task                                   |
| Text Regions - Areas in the document in     | • Inserting a Text Region                               |
| which you can enter text                    | • Formatting Text                                       |
| Names - References to the expressions you   | • Assigning to Names                                    |
| assign to them                              | • Unassigning Names                                     |
|                                              | • Valid Names                                           |
### 2.2 Input Prompt

In Worksheet mode, you enter input at the Maple *input prompt* (>). The default mode for input is Math mode (2-D Math).

To evaluate input:

- Press **Enter**.

Maple displays the result (output) below the input.

For example, to find the value of \( \sin^3 \left( \frac{\pi}{3} \right) \), enter the expression, and then press **Enter**.

\[
> \sin^3 \left( \frac{\pi}{3} \right) \\
\frac{3}{8} \sqrt{3}
\]

For example, compute the sum of two fractions.
Suppressing Output

To suppress the output, enter a colon (:) at the end of the input.

> \frac{2}{9} + \frac{7}{11} :

A set of Maple input and its output are referred to as an execution group.

1-D Math Input

You can also insert input using Text mode (1-D Math). The input is entered as a one-dimensional sequence of characters. 1-D Math input is red.

To enter input using 1-D Math:

• At the input prompt, press **F5** to switch from 2-D Math to 1-D Math.

> 123^2 - 29857/120;

Important: 1-D Math input must end with a semicolon or colon. If you use a semicolon, Maple displays the output. If you use a colon, Maple suppresses the output.

> 123^2 - 29857/120:
To set the default input mode to 1-D Math:

1. From the Tools menu, select Options. The Options dialog is displayed.
2. On the Display tab, in the Input display drop-down list, select Maple Notation.
3. Click Apply to Session (to set for only the current session) or Apply Globally (to set for all Maple sessions).

To convert 2-D Math input to 1-D Math input:

1. Select the 2-D Math input.
2. From the Format menu, select Convert To, and then 1-D Math Input.

Important: In Document mode, you can execute a statement only if you enter it in Math mode.

Input Separators

In 1-D and 2-D Math input, you can use a semicolon or colon to separate multiple inputs in the same input line.

```maple
> sqrt(4.4) ; tan(3.2)
```

```
2.097617696
```

```
0.05847385446
```

If you do not specify a semicolon or colon, Maple interprets it as a single input.

```maple
> sqrt(4.4) tan(3.2)
```

```
0.1226557919
```
2.3 Commands

Maple contains a large set of commands and a powerful programming language. Most Maple commands are written using the Maple programming language.

You can enter commands using 1-D or 2-D Math. You must use 1-D Math input when programming in Maple. Basic Programming (page 325) provides an introduction to Maple programming.

To learn how to use Maple commands, use task templates. See Task Templates (page 50).

The Maple Library

Commands are contained in the Maple library, which is divided into two groups: the top-level commands and packages.

- The top-level commands are the most frequently used Maple commands.
- Packages contain related specialized commands in areas such as student calculus, linear algebra, vector calculus, and code generation.

For a complete list of packages and commands, refer to the index help pages. To access the index overview help page, enter ?index, and then press Enter. For information on the Maple Help System, see Getting Help (page 33).

Top-Level Commands

To use a top-level command, enter its name followed by parentheses (( )) containing any parameters. This is referred to as a calling sequence for the command.

\[
\text{command}(\text{arguments})
\]

Note: In 1-D Math input, include a semicolon or colon at the end of the calling sequence.
For example, to differentiate an expression, use the `diff` command. The required parameters are the expression to differentiate, which must be specified first, and the independent variable.

\[ \texttt{diff( \tan(x) \sin(x), x) } \]

\[ (1 + \tan(x)^2) \sin(x) + \tan(x) \cos(x) \]

For a complete list of functions (commands that implement mathematical functions), for example, `BesselI` and `AiryAi`, available in the library, refer to the `?initialfunctions` help page. (To display this help page, enter `?initialfunctions` at the input prompt.)

\[ \texttt{BesselI(0.1, 1) \quad AiryAi(2.2) } \]

\[ 47.53037086 \]

For detailed information on the properties of a function, use the `FunctionAdvisor` command.

\[ \texttt{FunctionAdvisor( 'definition', BesselI) } \]

\[ \texttt{BesselI(a, z) = \frac{z^a \text{hypergeom}\left([\ ], [1 + a], \frac{1}{4} z^2\right)}{\Gamma(1 + a) 2^a},} \]

\[ \texttt{with no restrictions on (a, z)} \]

For detailed information on how to use a function in Maple, refer to its help page.

For example:

\[ \texttt{? Bessel} \]
Note: In 1-D and 2-D Math input, when accessing a help page using ?, you do not need to include a trailing semicolon or colon.

Package Commands

To use a package command, the calling sequence must include the package name, and the command name enclosed in brackets ([ ]).

\[
\text{package[command](arguments)}
\]

If you are frequently using the commands in a package, load the package.

To load a package:

• Use the with command, specifying the package as an argument.

The with command displays a list of the package commands loaded (unless you suppress the output by entering a colon at the end of the calling sequence).

After loading a package, you can use its commands as top-level commands, that is, without specifying the package name.

For example, use the NLPSolve command from the Optimization package to find a local minimum of an expression and the value of the independent variable at which the minimum occurs.

\[
> \text{Optimization[NLPSolve]}\left( \frac{\sin(x)}{x}, x = 1 .. 15 \right)
\]

\[
[ -0.0913252028230576718, [x = 10.9041216700744900] ]
\]

\[
> \text{with(Optimization)}:
\]
> \( \text{NLPSolve}\left(\frac{\sin(x)}{x}, x = 1..15\right) \)

\[ [-0.0913252028230576718, [x = 10.9041216700744900]] \]

For more information on optimization, see *Optimization (page 168)*.

**To unload a package:**

- Use the `unwith` command, specifying the package as an argument.

> `unwith(Optimization);`

To use the examples in this manual, you may be required to use the `unwith` command between examples.

Some packages contain commands that have the same name as a top-level command. When you load one of these packages, Maple returns a warning.

For example, the `plots` package contains a `changecoords` command. Maple also contains a top-level `changecoords` command.

> `with(plots);`

In general, this manual does not include the warning messages Maple returns.

To use the top-level command, unload the package. (For alternative methods of accessing the top-level command, see the `?with` help page.)

### 2.4 Palettes

Palettes are collections of related items that you can insert by clicking or dragging. See Figure 2.1.
You can use palettes to enter input.

For example, evaluate a definite integral using the definite integration item in the Expression palette.

In 2-D Math, clicking the definite integration item inserts:

\[ \int_{a}^{b} f(x) \, dx \]

1. Enter values in the placeholders. To move to the next placeholder, press Tab. Note: If pressing the Tab key inserts a tab, click the Tab icon \( \square \) in the toolbar.

2. To evaluate the integral, press Enter.
In 1-D Math, clicking the definite integration item inserts the corresponding command calling sequence.

\[ \int_{0}^{1} \tanh(x) \, dx \]

\[ -\ln(2) + \ln(e^{-1} + e) \]

In 1-D Math, clicking the definite integration item inserts the corresponding command calling sequence.

\[ > \text{int}(f, x=a..b); \]

\[ f(b - a) \] (2.1)

Specify the problem values (using the \textbf{Tab} to move to the next placeholder), and then press \textbf{Enter}.

\[ > \text{int}((\tanh(x), x=0..1)); \]

\textbf{Note:} Some palette items cannot be inserted into 1-D Math because they are not defined in the Maple language. When the cursor is in 1-D Math input, unavailable palette items are dimmed.

For more information on palettes, see \textit{Palettes (page 12)} and \textit{Performing Computations (page 20)} in Chapter 1.
2.5 Context Menus

A *context menu* is a pop-up menu that lists the operations and actions you can perform on a particular expression. See Figure 2.2.

![Integer Context Menu](image)

**Figure 2.2: Integer Context Menu**

In Worksheet mode, you can use context menus to perform operations on 2-D Math and output.

**To use a context menu:**

1. Right-click (*Control*-click, for Macintosh) the expression. The context menu is displayed.

2. From the context menu, select an operation.

Maple inserts a new execution group containing:

- The calling sequence that performs the operation
- The result of the operation
For example:

**To determine a rational expression (fraction) that approximates a floating-point number:**

1. Right-click *(Control-click, for Macintosh)* the floating-point number.
2. From the context menu, select **Conversions**, and then **Rational**.

The inserted calling sequence includes an equation label reference to the number you are converting.

\[
\begin{align*}
0.3463678 + 1.7643 &= 2.1106678 \\
\text{convert}( (2.2), '\text{rational}') &= \frac{32270}{15289}
\end{align*}
\]

For information on equation labels and equation label references, see *Equation Labels (page 59)*.

For more information on context menus, see *ContextMenus (page 21)* in Chapter 1.
2.6 Assistants and Tutors

Assistants and tutors provide point-and-click interfaces, with buttons, text input regions, and sliders. See Figure 2.3.

![Interactive Plot Builder: Select Plot Type Dialog](image)

Figure 2.3: Interactive Plot Builder: Select Plot Type Dialog

**Launching an Assistant or Tutor**

To launch an assistant or tutor:

1. Open the **Tools** menu.
2. Select **Assistants** or **Tutors**.
3. Navigate to and select one of the assistants or tutors.
Example: Using the Interactive Plot Builder

To plot an expression using the Interactive Plot Builder:

1. From the Tools menu, select Assistants, and then Plot Builder. Maple inserts the following command in the document and launches the Interactive Plot Builder.

\> plots[interactive]( );

2. In the Interactive Plot Builder: Specify Expressions window (Figure 2.4), click Add. The Add/Edit Expression dialog is displayed.

![Interactive Plot Builder: Specify Expressions Window](image)

Figure 2.4: Interactive Plot Builder: Specify Expressions Window

3. In the Add/Edit Expression dialog, enter the expression to plot using 1-D Math. See Figure 2.5.
4. Repeat steps 2 and 3 for each expression to add to the plot.

5. After adding the expressions, in the Interactive Plot Builder: Specify Expressions window (Figure 2.4), click Done.

6. In the Interactive Plot Builder: Select Plot Type dialog (Figure 2.3), select the type of plot, for example, 3-D Plot or 3-D Contour Plot, and specify the variable ranges, for example, \( x = [-2, 2], y = [-2, 2] \).

7. To immediately create a plot, click Plot. To customize the plot before generating it, click Options. Set the plot options, and then click Plot.

Maple inserts the plot in the document.

For more information on assistants and tutors, see Assistants and Tutors (page 27) in Chapter 1.

## 2.7 Task Templates

Maple can solve a diverse set of problems. The task template facility helps you quickly find and use the commands required to perform common tasks.

After inserting a task template, specify the parameters of your problem in the placeholders, and then execute the commands, or click a button.
Viewing Task Templates

The Task Browser (Figure 2.6) organizes task templates by subject.

To launch the Task Browser:

- From the Tools menu, select Tasks, and then Browse.

You can also browse the task templates in the Table of Contents of the Maple Help System.
Volume of Revolution

Description

Calculate the volume of revolution for a solid of revolution when a function is rotated about the horizontal or vertical axis.

Enter the function as an expression and specify the range:

\[
\int_{\frac{\pi}{2}}^{\frac{\pi}{2} + \frac{1}{2}} \sin(x) \cos(x) + 1, 0, 1, 0, 1\frac{\pi}{2} \quad (1)
\]

Calculate the volume of revolution:

\[
\text{\texttt{Student[Calculus7][VolumeOfRevolution]}(1)}
\]

\[
\text{\texttt{Pi + \frac{9}{14} Pi^2}} \quad (2)
\]

Display the floating-point value using the evallf command:

\[
\text{\texttt{evallf(2)}}
\]

\[
8.093245131 \quad (3)
\]

Display a plot using the output=plot option:

\[
\text{\texttt{Student[Calculus7][VolumeOfRevolution](1), output = plot, scaling = constrained, title = \_\_\_}}} \]

Figure 2.6: Task Browser
Inserting a Task Template

To insert a task template from the Task Browser or Help Navigator:

1. Navigate to the task.

2. Click one of the insertion or copy buttons.

   - Click the **Insert Default Content** button. Maple inserts the *default content*. The default content level is set using the **Options** dialog. For details, see the following steps.
   
   - Click the **Insert Minimal Content** button. Maple inserts only the commands and embedded components, for example, a button to launch the related assistant or tutor.
   
   - Click the **Copy Task to Clipboard** button. Place the cursor where you want to insert the task, and then paste the task. Maple inserts the default content. Use this method to quickly insert a task multiple times.

To change the default content level, use the **Options** dialog.

1. From the **Tools** menu, select **Options**. The **Options** dialog opens.

2. In the **Options** dialog, select the **Display** tab.

3. In the **Task content to insert** drop-down list, select **All Content**, **Standard Content**, or **Minimal Content**.
   
   - Minimal Content - Only the commands and embedded components
   
   - Standard Content - Commands, embedded components, and instructions for using the template
   
   - All Content - All content in the task template, including hyperlinks to related help pages

Maple stores a list of the most recently inserted task templates.

To insert a recently inserted task:

- From the **Tools** menu, select **Tasks**, and then the task name.
Performing the Task

After you insert a task template, enter the parameters for your task, and then compute the result.

To use an inserted task template:

1. Specify values for the parameters in placeholders or using graphical interface components. You can move to the next placeholder by pressing Tab.

2. Execute all commands in the task by:
   • Placing the cursor in the first task command, and then pressing Enter repeatedly to execute each command.
   • Selecting all the template commands, and then clicking the execute toolbar icon !.

3. If the template contains a button that computes the result, click it.

For more information on task templates, refer to the Maple Getting Started Guide or the ?tasks help page.

2.8 Text Regions

To add descriptive text in Worksheet mode, use a text region.

To insert a text region:

• In the toolbar, click the Text region icon T.

The default mode in a text region is Text mode.

In a text region, you can:

• Enter text with inline mathematical content by switching between Text and Math modes. To toggle between Text mode and Math mode, press
F5. **Note:** The mathematical content in a text region is not evaluated. To enter mathematical content that is evaluated, enter it at an *Input Prompt* (page 37).

- Insert any palette item. Palette items are inserted in Math mode (2-D Math).

You can format text in a text region. Features include:

- Character styles
- Paragraph styles
- Sections and subsections
- Tables

For more information on formatting documents, see *Creating Mathematical Documents* (page 235).

## 2.9 Names

Instead of re-entering an expression every time you need it, you can assign it to a *name* or add an *equation label* to it. Then you can quickly refer to the expression using the name or an equation label reference. For information on labels, see the following section *Equation Labels* (page 59).

### Assigning to Names

You can assign any Maple expression to a name: numeric values, data structures, procedures (a type of Maple program), and other Maple objects.

Initially, the value of a name is itself.

```maple
> a

a
```

The assignment operator (\(\equiv\)) associates an expression with a name.
Recall that you can enter $\pi$ using the following two methods.

- Use the **Common Symbols** palette
- In 2-D Math enter $pi$, and then press the symbol completion short cut key. See *Shortcuts for Entering Mathematical Expressions (page 7)*.

When Maple evaluates an expression that contains a name, it replaces the name with its value. For example:

\[
\text{\$cos(a)\$}
\]

\[-1\]

For information on Maple evaluation rules, see *Evaluating Expressions (page 314)*.

**Mathematical Functions**

To define a function, assign it to a name.

For example, define a function that computes the cube of its argument.

\[
\text{\$cube := x \rightarrow x^3\$}
\]

For information on creating functions, see *Defining a Mathematical Function (page 14)*.

\[
\text{\$cube(3); cube(1.666)\$}
\]

\[27\]

\[4.624076296\]
Note: To insert the right arrow, enter the characters ->. In 2-D Math, Maple replaces -> with the right arrow symbol →. In 1-D Math, the characters are not replaced.

For example, define a function that squares its argument.

```maple
> square := x -> x^2:

> square(32);

1024
```

For more information on functions, see Functional Operators (page 296).

Protected Names

Protected names are valid names that are predefined or reserved.

If you attempt to assign to a protected name, Maple returns an error.

```maple
> sin := 2

Error, attempting to assign to `sin` which is protected
```

For more information, refer to the ?type/protected and ?protect help pages.

Unassigning Names

The unassign command resets the value of a name to itself. Note: You must enclose the name in right single quotes (').

```maple
> unassign( 'a' )

> a

a
```
Right single quotes (unevaluation quotes) prevent Maple from evaluating the name. For more information on unevaluation quotes, see Delaying Evaluation (page 321) or refer to the ?uneval help page.

See also Unassigning a Name Using Unevaluation Quotes (page 324).

### Unassigning All Names

The restart command clears the Maple internal memory. The effects include unassigning all names and unloading all packages. For more information, refer to the ?restart help page.

**Note:** To use the examples in this manual, you may be required to use the unassign or restart command between examples.

### Valid Names

A Maple name must be one of the following.

- A sequence of alphanumeric and underscore (_) characters that begins with an alphabetical character. **Note:** To enter an underscore character in 2-D Math, enter a backslash character followed by an underscore character, that is, \_.
- A sequence of characters enclosed in left single quotes (``).

**Important:** Do not begin a name with an underscore character. Maple reserves names that begin with an underscore for use by the Maple library.

Examples of valid names:

- a
- a1
- polynomial
- polynomial1_divided_by Polynomial2
- `2a`
- `x y`
2.10 Equation Labels

Maple marks the output of each execution group with a unique equation label.

**Note:** The equation label is displayed to the right of the output.

\[
\int \sin(x) \, dx
\]

\[= -\cos(x) \quad (2.3)\]

Using equation labels, you can refer to the result in other computations.

\[
\int (2.3) \, dx
\]

\[= -\sin(x) \quad (2.4)\]

**Displaying Equation Labels**

**Important:** By default, equation labels are displayed. If equation label display is turned off, complete both the following operations.

- From the **Format** menu, select **Labels**, and then ensure that **Worksheet** is selected.
- In the **Options** dialog (**Tools**→**Options**), on the **Display** tab, ensure that **Show equation labels** is selected.

**Referring to a Previous Result**

Instead of re-entering previous results in computations, you can use equation label references. Each time you need to refer to a previous result, insert an equation label reference.
To insert an equation label reference:

• From the **Insert** menu, select **Label**. (Alternatively, press **Ctrl+L**. For Macintosh, **Command+L**.)

• In the **Insert Label** dialog, enter the label value, and then click **OK**. Maple inserts the reference.

For example:

**To integrate the product of** (2.3) **and** (2.4):

1. In the **Expression** palette, click the indefinite integration item \( \int f \, dx \). The item is inserted and the cursor moves to the integrand placeholder.


3. In the **Insert Label** dialog, enter **2.2**. Click **OK**.

4. Press *****.

5. Press **Ctrl+L** (**Command+L**, for Macintosh).

6. In the **Insert Label** dialog, enter **2.3**. Click **OK**.

7. To move to the variable of integration placeholder, press **Tab**.

8. Enter **x**. Press **Enter**.

\[
\int (2.3) \cdot (2.4) \, dx
\]

\[\frac{1}{2} \cos(x)^2\]

**Execution Groups with Multiple Outputs**

An equation label is associated with the *last output* within an execution group.
Label Numbering Schemes

You can number equation labels in two ways:

- **Flat** - Each label is a single number, for example, 1, 2, or 3.
- **Sections** - Each label is numbered according to the section in which it occurs. For example, 2.1 is the first equation in the second section, and 1.3.2 is the second equation in the third subsection of the first section.

To change the equation label numbering scheme:

- From the **Format** menu, select **Labels**, and then **Label Display**. In the **Format Labels** dialog (Figure 2.7), select one of the formats.
- Optionally, enter a prefix.
Features of Equation Labels

Although equation labels are not descriptive names, labels offer other important features.

- Each label is unique, whereas a name may be inadvertently assigned more than once for different purposes.
- Maple labels the output values sequentially. If you remove or insert an output, Maple automatically renumbers all equation labels and updates the label references.
- If you change the equation label format (see Label Numbering Schemes (page 61)), Maple automatically updates all equation labels and label references.

For information on assigning to, using, and unassigning names, see Names (page 55).

For more information on equation labels, refer to the ?equationlabels help page.

The following chapters describe how to use Maple to perform tasks such as solving differential (and other types of) equations, producing plots and anim-
ations, and creating mathematical documents. The chapters were created using Worksheet mode. Except where noted, all features are available in both Worksheet mode and Document mode.
3 Performing Computations

This chapter discusses key concepts related to performing computations with Maple. It discusses important features that are relevant to all Maple users. After learning about these concepts, you will learn how to use Maple to solve problems in specific areas in the following chapter.

3.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| Symbolic and Numeric Computation - An overview of exact and floating-point computation | • Exact Computations  
• Floating-Point Computations  
• Converting Exact Quantities to Floating-Point Values  
• Sources of Error |
| Integer Operations - How to perform integer computations     | • Important Integer Commands  
• Non-Base 10 Numbers  
• Finite Rings and Fields  
• Gaussian Integers |
| Solving - How to solve standard mathematical equations      | • Equations and Inequations  
• Ordinary Differential Equations  
• Partial Differential Equations  
• Integer Equations  
• Integer Equations in a Finite Field  
• Linear Systems  
• Recurrence Relations |
<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Units, Scientific Constants, and Uncertainty - How to construct and compute with expressions that have units, scientific constants, or uncertainty</td>
<td>Units</td>
</tr>
<tr>
<td></td>
<td>• Conversions</td>
</tr>
<tr>
<td></td>
<td>• Applying Units to an Expression</td>
</tr>
<tr>
<td></td>
<td>• Performing Computations with Units</td>
</tr>
<tr>
<td></td>
<td>• Changing the Current System of Units</td>
</tr>
<tr>
<td></td>
<td>• Extensibility</td>
</tr>
<tr>
<td></td>
<td>Scientific Constants</td>
</tr>
<tr>
<td></td>
<td>• Scientific Constants</td>
</tr>
<tr>
<td></td>
<td>• Element and Isotope Properties</td>
</tr>
<tr>
<td></td>
<td>• Value, Units, and Uncertainty</td>
</tr>
<tr>
<td></td>
<td>• Performing Computations</td>
</tr>
<tr>
<td></td>
<td>• Modification and Extensibility</td>
</tr>
<tr>
<td></td>
<td>Uncertainty Propagation</td>
</tr>
<tr>
<td></td>
<td>• Quantities with Uncertainty</td>
</tr>
<tr>
<td></td>
<td>• Performing Computations with Quantities with Uncertainty</td>
</tr>
<tr>
<td>Restricting the Domain - How to restrict the domain for computations</td>
<td>• Real Number Domain</td>
</tr>
<tr>
<td></td>
<td>• Assumptions on Variables</td>
</tr>
</tbody>
</table>

### 3.2 Symbolic and Numeric Computation

*Symbolic computation* is the mathematical manipulation of expressions involving symbolic or abstract quantities, such as variables, functions, and operators; and exact numbers, such as integers, rationals, $\pi$, and $e^2$. The goal of such manipulations may be to transform an expression to a simpler form or to relate the expression to other, better understood formulas.
**Numeric computation** is the manipulation of expressions in the context of finite-precision arithmetic. Expressions involving exact numbers, for example, \( \sqrt{2} \), are replaced by close approximations using floating-point numbers, for example 1.41421. These computations generally involve some error. Understanding and controlling this error is often of as much importance as the computed result.

In Maple, numeric computation is normally performed if you use floating-point numbers (numbers containing a decimal point) or the `evalf` command. The `plot` command (see *Plots and Animations* (page 189)) uses numeric computation, while commands such as `int`, `limit`, and `gcd` (see *Integer Operations* (page 71) and *Mathematical Computations* (page 123)) generally use only symbolic computation to achieve their results.

### Exact Computations

In Maple, integers, rational numbers, mathematical constants such as \( \pi \) and \( \infty \), and mathematical structures such as matrices with these as entries are treated as exact quantities. Names, such as `x`, `y`, `my_variable`, and mathematical functions, such as `sin(x)` and `LambertW(k, z)`, are symbolic objects. Names can be assigned exact quantities as their values, and functions can be evaluated at symbolic or exact arguments.

\[
> \frac{3}{2} + \frac{1}{3}, 1 + \frac{\pi}{2} \\
\frac{11}{6}, 1 + \frac{1}{2} \pi
\]

**Important:** Unless requested to do otherwise (see the following section), Maple evaluates expressions containing exact quantities to exact results, as you would do if you were performing the calculation by hand, and not to numeric approximations, as you normally obtain from a standard hand-held calculator.
Floating-Point Computations

In some situations, a numeric approximation of an exact quantity is required. For example, the `plot` command requires the expression it is plotting to evaluate to numeric values that can be rendered on the screen: π cannot be so rendered, but 3.14159 can be. Maple distinguishes *approximate* from *exact* quantities by the presence or absence of a decimal point: \( \sin(x) \) is approximate, while \( \frac{19}{10} \) is exact.

**Note:** An alternative representation of floating-point numbers, called *e-notation*, may not include an explicit decimal point: \( 1e5 = 100000 \), \( 3e-2 = .03 \).

In the presence of a floating-point (approximate) quantity in an expression, Maple generally computes using numeric approximations. Arithmetic involving mixed exact and floating-point quantities results in a floating-point result.
If a mathematical function is passed a floating-point argument, it normally attempts to produce a floating-point approximation to the result.

\[
> 1.5 + \frac{2}{3}
\]

\[
2.166666667
\]

Converting Exact Quantities to Floating-Point Values

To convert an exact quantity to a numeric approximation of that quantity, use the \texttt{evalf} command or the \texttt{Approximate} context menu operation (see \textit{Approximating the Value of an Expression} (page 23)).

\[
> \text{evalf}(\pi), \text{evalf}(\sin(3)), \text{evalf}\left(\frac{3}{2} + \frac{1}{3}\right)
\]

\[
3.141592654, 0.1411200081, 1.833333333
\]

By default, Maple computes such approximations using 10 digit arithmetic. You can modify this in one of two ways:

- \textit{Locally}, you can pass the precision as an index to the \texttt{evalf} call.

\[
> \text{evalf}[20](\exp(2)), \text{evalf}\left(\Gamma\left(\frac{2}{3}\right)\right)
\]

\[
7.3890560989306502272, 1.354117939
\]

- \textit{Globally}, you can set the value of the \texttt{Digits} environment variable.
For more information, see the `evalf` and `Digits` help pages.

**Note:** When appropriate, Maple performs floating-point computations directly using your computer’s underlying hardware.

### Sources of Error

By its nature, floating-point computation normally involves some error. Controlling the effect of this error is the subject of active research in Numerical Analysis. Some sources of error are:

- An exact quantity may not be exactly representable in decimal form: \( \frac{1}{3} \) and \( \pi \) are examples.
- Small errors can accumulate after many arithmetic operations.
- Subtraction of nearly equal quantities can result in essentially no useful information. For example, consider the computation \( x - \sin(x) \) for \( x \approx 0 \).

\[
> \lim_{x \to 0} (x - \sin(x)) |_{x = .00001}
\]

No correct digits remain. If, however, you use Maple to analyze this expression, and replace this form with a representation that is more accurate for small values of \( x \), a fully accurate 10-digit result can be obtained.
For information on evaluating an expression at a point, see *Substituting a Value for a Subexpression* (page 314). For information on creating a series approximation, see *Series* (page 161).

For more information on floating-point numbers, refer to the `float` and `type/float` help pages.

### 3.3 Integer Operations

In addition to the basic arithmetic operators, Maple has many specialized commands for performing more complicated integer computations, such as factoring an integer, testing whether an integer is a prime number, and determining the greatest common divisor (GCD) of a pair of integers.

**Note:** Many integer operations are available as task templates (`Tools→Tasks→Browse`).

You can quickly perform many integer operations using context menus. Selecting an integer, and then right-clicking (for Macintosh, Control-clicking) displays a context menu with integer commands, for example, *Integer Factors*, which applies the `ifactor` command. See Figure 3.1.
Figure 3.1: Context Menu for an Integer

In Worksheet mode, Maple uses an equation label reference in the \texttt{ifactor} calling sequence.

\begin{verbatim}
> 9469629
\end{verbatim}

\begin{verbatim}
9469629
\end{verbatim}

\begin{verbatim}
Cut      Ctrl+X
Copy     Ctrl+C
Copy full precision
Paste    Ctrl+V

Apply a Command
Approximate
Assign to a Name

Integer Factors
Next Prime
Test Primality

Integer Functions
Units

Number Theory Functions
\end{verbatim}

\begin{verbatim}
> ifactor(3.1)
\end{verbatim}

\begin{verbatim}
(3)^4 (13) (17) (23)^2
\end{verbatim}

For more information on equation labels, see \textit{Equation Labels (page 59)}.

For more information on using context menus in Worksheet mode, see \textit{Context Menus (page 46)}. For information on using context menus in Document mode, see \textit{Context Menus (page 21)}.

You can also enter the \texttt{ifactor} command and specify the integer to factor as an argument.
Maple has many other integer commands, including those listed in Table 3.1.

Table 3.1: Select Integer Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>abs</td>
<td>absolute value (displays in 2-D math as (</td>
</tr>
<tr>
<td>factorial</td>
<td>factorial (displays in 2-D math as (a!) )</td>
</tr>
<tr>
<td>ifactor</td>
<td>factorization</td>
</tr>
<tr>
<td>igcd</td>
<td>greatest common divisor</td>
</tr>
<tr>
<td>iquo</td>
<td>quotient of integer division</td>
</tr>
<tr>
<td>irem</td>
<td>remainder of integer division</td>
</tr>
<tr>
<td>iroot</td>
<td>integer approximation of nth root</td>
</tr>
<tr>
<td>isprime</td>
<td>test primality</td>
</tr>
<tr>
<td>isqrt</td>
<td>integer approximation of square root</td>
</tr>
<tr>
<td>max, min</td>
<td>maximum and minimum of a set</td>
</tr>
<tr>
<td>mod</td>
<td>modular arithmetic (See Finite Rings and Fields (page 75)</td>
</tr>
<tr>
<td>numtheory[divisors]</td>
<td>set of positive divisors</td>
</tr>
</tbody>
</table>
For information on finding integer solutions to equations, see Integer Equations (page 94).

**Non-Base 10 Numbers and Other Number Systems**

Maple supports:

- Non-base 10 numbers
- Finite ring and field arithmetic
- Gaussian integers

**Non-Base 10 Numbers**

To represent an expression in another base, use the `convert` command.

```maple
> convert(6000, 'binary')

1011101110000
```

```maple
> convert(34271, 'hex')

85DF
```

For information on enclosing keywords in right single quotes ('), see Delaying Evaluation (page 321).

You can also use the `convert/base` command.
Note: The `convert/base` command returns a list of digit values in order of increasing significance.

**Finite Rings and Fields**

Maple supports computations over the integers modulo m.

The `mod` operator evaluates an expression over the integers modulo m.

> 27 mod 4

3

By default, the `mod` operator uses positive representation (`modp` command). Symmetric representation is available using the `mods` command.

> modp(27, 4)

3

> mods(27, 4)

-1

For information on setting symmetric representation as the default, refer to the `?mod` help page.

The modular arithmetic operators are listed in Table 3.2.
Table 3.2: Modular Arithmetic Operators

<table>
<thead>
<tr>
<th>Operation</th>
<th>Operator</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Addition</td>
<td>+</td>
<td>( 7 + 6 \mod 5 ) \rightarrow 3</td>
</tr>
<tr>
<td>Subtraction</td>
<td>-</td>
<td>( \text{mods}(3 - 16, 11) ) \rightarrow -2</td>
</tr>
<tr>
<td>Multiplication (displays in 2-D Math as ( \cdot ))</td>
<td>(\ast)</td>
<td>(13 \cdot 5 \mod 3) \rightarrow 2</td>
</tr>
<tr>
<td>Multiplicative inverse (displays in 2-D Math as a superscript)</td>
<td>(^{-1})</td>
<td>(3^{-1} \mod 5) \rightarrow 2</td>
</tr>
<tr>
<td>Division (displays in 2-D Math as ( \frac{a}{b} ))</td>
<td>(\backslash)</td>
<td>(\frac{2}{3} \mod 5) \rightarrow 4</td>
</tr>
<tr>
<td>Exponentiation(^1)</td>
<td>&amp;(^\backslash)</td>
<td>((100&amp;100) \mod 7) \rightarrow 2</td>
</tr>
</tbody>
</table>

\(^1\)To enter a caret (\(^\backslash\)) in 2-D Math, enter a backslash character followed by a caret, that is, \(\backslash\). \(^\backslash\).

For information on solving an equation modulo an integer, see *Integer Equations in a Finite Field* (page 95).

The `mod` operator also supports polynomial and matrix arithmetic over finite rings and fields. For more information, refer to the `mod` help page.
Gaussian Integers

Gaussian integers are complex numbers in which the real and imaginary parts are integers.

The \texttt{GaussInt} package contains commands that perform Gaussian integer operations.

The \texttt{GIfactor} command returns the Gaussian integer factorization.

\[
\text{GaussInt}[\text{GIfactor}](173 + 16 I) = (1 + 2 i) (41 - 66 i)
\]

You can enter the imaginary unit using the following two methods.

- In the \texttt{Common Symbols} palette, click the \texttt{i} or \texttt{j} item. See \textit{Palettes (page 12)}.
- Enter \texttt{i} or \texttt{j}, and then press the symbol completion key. See \textit{Symbol Names (page 17)}.

\textbf{Note:} In 1-D Math input, enter the imaginary unit as an uppercase \texttt{i} (\texttt{I}).

The \texttt{GIsqrt} command approximates the square root in the Gaussian integers.

\[
\text{GaussInt}[\text{GIsqrt}](9 - 5 j) = 3 - i
\]

For more information on Gaussian integers including a list of \texttt{GaussInt} package commands, refer to the \texttt{?GaussInt} help page.

3.4 Solving Equations

You can solve a variety of equation types, including those described in Table 3.3.
Table 3.3: Overview of Solution Methods for Important Equation Types

<table>
<thead>
<tr>
<th>Equation Type</th>
<th>Solution Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equations and inequations</td>
<td>solve and \texttt{fsolve} commands</td>
</tr>
<tr>
<td>Ordinary differential equations</td>
<td>\texttt{ODE Analyzer Assistant} (and \texttt{dsolve} command)</td>
</tr>
<tr>
<td>Partial differential equations</td>
<td>\texttt{pdsolve} command</td>
</tr>
<tr>
<td>Integer equations</td>
<td>\texttt{isolve} command</td>
</tr>
<tr>
<td>Integer equations in a finite field</td>
<td>\texttt{msolve} command</td>
</tr>
<tr>
<td>Linear integral equations</td>
<td>\texttt{intsolve} command</td>
</tr>
<tr>
<td>Linear systems</td>
<td>\texttt{LinearAlgebra[LinearSolve]} command</td>
</tr>
<tr>
<td>Recurrence relations</td>
<td>\texttt{rsolve} command</td>
</tr>
</tbody>
</table>

Note: Many solve operations are available as task templates (\texttt{Tools}→\texttt{Tasks}→\texttt{Browse}) and in context menus. This section focuses on other methods.

Solving Equations and Inequations

Using Maple, you can symbolically solve equations and inequations. You can also solve equations numerically.

To solve an equation or set of equations using context menus:

1. Right-click (for Macintosh, \textbf{Control}-click) the equations.
2. From the context menu, select \textbf{Solve} (or \textbf{Solve Numerically}). See Figure 3.2.
In Worksheet mode, Maple inserts a calling sequence that solves the equation followed by the solutions.

If you select **Solve**, Maple computes exact solutions.

\[
> \quad \frac{7x^2}{3} - x = 12
\]

\[
\quad \frac{7}{3}x^2 - x = 12
\]

(3.2)
If you select **Solve Numerically**, Maple computes floating-point solutions.

\[
\frac{7x^2}{3} \quad x = 12
\]

\[
\frac{7}{3} x^2 - x = 12 \quad (3.3)
\]

If you select **Solve Numerically**, Maple computes floating-point solutions.

\[
\frac{7x^2}{3} \quad x = 12
\]

\[
\frac{7}{3} x^2 - x = 12
\]

(3.3)

\[
> \text{fsolve( \{3.3\} )}
\]

\[
\{x = -2.063602674, x = 2.492174103\}
\]

For information on solving equations and inequations symbolically using the *solve* command, see the following section. For information on solving equations numerically using the *fsolve* command, see *Numerically Solving Equations* (page 84).

**Symbolically Solving Equations and Inequations**

The *solve* command is a general solver that determines exact symbolic solutions to equations or inequations. The solutions to a single equation or inequation are returned as an expression sequence. If Maple does not find any solutions, the *solve* command returns the empty expression sequence.

\[
> \text{solve}(x^2 + x = 256)
\]

\[
-\frac{1}{2} + \frac{5}{2} \sqrt{41}, \quad -\frac{1}{2} - \frac{5}{2} \sqrt{41}
\]

It is recommended that you verify the solutions returned by the *solve* command. For details, see *Working with Solutions* (page 86).
Expressions You can specify expressions instead of equations. The solve command automatically equates them to zero.

\[ \text{solve}(e^z + z) \]

\[-\text{LambertW}(1)\]

\(W\) represents the Lambert W function.

Multiple Equations To solve multiple equations or inequations, specify them as a set or list.

\[ \text{solve}([x y^2 - y = 5, x > 0]) \]

\[ \left\{ \frac{y + 5}{y^2}, \frac{y + 5}{y^2}, -5 < y, y < 0 \right\} \]

\[ \left\{ \frac{y + 5}{y^2}, 0 < y \right\} \]

\[ \text{solve}(\{x y^2 - y = 5, x < 0\}) \]

\[ \left\{ \frac{y + 5}{y^2}, \frac{y + 5}{y^2}, y < -5 \right\} \]

Solving for Specific Unknowns By default, the solve command returns solutions for all unknowns. You can specify the unknowns for which to solve.
To solve for multiple unknowns, specify them as a list.

\[
\begin{align*}
\text{solve} \left( \frac{q^2}{r} - \frac{q}{r} = 5, q \right) \\
\frac{1}{2} \left( -1 + \sqrt{1 + 4 r^3 s + 20 r^2} \right), -\frac{1}{2} \left( 1 + \sqrt{1 + 4 r^3 s + 20 r^2} \right) 
\end{align*}
\]

To produce all solutions, set the \texttt{EnvAllSolutions} environment variable to \texttt{true}.

\textbf{Transcendental Equations} In general, the \texttt{solve} command returns one solution to transcendental equations.

\[
\begin{align*}
\text{solve} \left( \left\{ \frac{q}{s} - \frac{r}{s+1} + \frac{q}{r} = 5, rs = 1 \right\}, [q, r] \right) \\
\begin{bmatrix}
q = \frac{1 + 5 s^2 + 5 s}{s + 1 + s^3 + s^2}, \\
r = \frac{1}{s}
\end{bmatrix}
\end{align*}
\]

\textbf{Note:} To enter an underscore character (\_\) in 2-D Math, enter \textbackslash\_.

\[
\begin{align*}
\text{solve} & (\texttt{equation1}) \\
\frac{1}{4} \pi \\
\frac{1}{4} \pi + \pi \_Z\_I
\end{align*}
\]
Maple uses variables of the form \( _{\text{ZN}} \), where \( N \) is a positive integer, to represent arbitrary integers. The tilde (\( \sim \)) indicates that it is a quantity with an assumption. For information about names with assumptions, see \textit{Assumptions on Variables} (page 116).

**RootOf Structure** The \texttt{solve} command may return solutions, for example, to higher order polynomial equations, in an implicit form using \texttt{RootOf} structures.

\[
> \ [\text{solve}(x^5 - 2x^4 + 3x^3 - 2)]
\]

\[
[1, \text{RootOf}(\_Z^4 - \_Z^3 + 2\_Z^2 + 2\_Z + 2, index = 1), \text{RootOf}(\_Z^4 - \_Z^3 + 2\_Z^2 + 2\_Z + 2, index = 2), \text{RootOf}(\_Z^4 - \_Z^3 + 2\_Z^2 + 2\_Z + 2, index = 3), \text{RootOf}(\_Z^4 - \_Z^3 + 2\_Z^2 + 2\_Z + 2, index = 4)]
\]

These \texttt{RootOf} structures are placeholders for the roots of the equation \( z^4 - z^3 + 2z^2 + 2z + 2 \). The \texttt{index} parameter numbers and orders the four solutions.

Like any symbolic expression, you can convert \texttt{RootOf} structures to a floating-point value using the \texttt{evalf} command.

\[
> \ \text{evalf}(3.4)
\]

\[
[1., 0.9840010519 + 1.526590834 I, -0.4840010519 + 0.6099471405 I, -0.4840010519 - 0.6099471405 I, 0.9840010519 - 1.526590834 I]
\]

Some equations are difficult to solve symbolically. For example, polynomial equations of order five and greater do not in general have a solution in terms of radicals. If the \texttt{solve} command does not find any solutions, it is recommended that you use the Maple numerical solver, \texttt{fsolve}. For information, see the following section, \textit{Numerically Solving Equations}.

For more information on the \texttt{solve} command, including how to solve equations defined as procedures and how to find parametric solutions, refer to the \texttt{?solve/details} help page.
For information on verifying and using solutions returned by the `solve`
command, see `Working with Solutions (page 86)`.

**Numerically Solving Equations**

The `fsolve` command solves equations numerically. The behavior of the
`fsolve` command is similar to that of the `solve` command.

\[
\text{for} \quad equation2 := z \cos(z) = 2:
\]

\[
\text{fsolve(equation2, z)}
\]

\[
23.64662473
\]

(3.5)

**Note:** You can also numerically solve equations using the context menus. See `Solving Equations and Inequalities (page 78)`.

It is recommended that you verify the solutions returned by the `fsolve` command. For details, see `Working with Solutions (page 86)`.

**Multiple Equations** To solve multiple equations, specify them as a set. The `fsolve` command solves for all unknowns.

\[
\text{for} \quad fsolve(\{\ln(x) = y^2 + 1, x, y = e^y\})
\]

\[
\{x = 3.396618823, y = 0.4719962637\}
\]

**Univariate Polynomial Equations** In general, the `fsolve` command finds
one solution. However, for a univariate polynomial equation, the `fsolve`
command returns all real roots.

\[
\text{for} \quad equation3 := y^4 - 3 y^2 - 2 y + 1:
\]

\[
\text{fsolve(equation3, y)}
\]

\[
0.3365322739, 1.940392664
\]
Controlling the Number of Solutions To limit the number of roots returned, specify the `maxsols` option.

```maple
> fsolve(equation3, y, 'maxsols' = 1)

0.3365322739
```

To find additional solutions to a general equation, use the `avoid` option to ignore known solutions.

```maple
> fsolve(equation2, z, 'avoid' = {z = 3.5})

-2.498755763
```

Complex Solutions To search for a complex solution, or find all complex and real roots for a univariate polynomial, specify the `complex` option.

```maple
> fsolve(equation3, y, 'complex')

-1.138462469 - 0.4850624941 I, -1.138462469 + 0.4850624941 I,
0.3365322739, 1.940392664
```

If the `fsolve` command does not find any solutions, it is recommended that you specify a range in which to search for solutions, or specify an initial value.

Range To search for a solution in a range, specify the range in the calling sequence. The range can be real or complex.

```maple
> fsolve(equation2, z, {z = 100..200})

149.2390528
The syntax for specifying a region in the complex plane is **lower-left point..upper-right point**.

\[ \text{fsolve}(equation3, y, \{y = -2 - 1.0\}, 'complex'); \]

\[-1.138462469 - 0.4850624941 \text{I}\]

**Initial Values** You can specify a value for each unknown. The **fsolve** command uses these as initial values for the unknowns in the numerical method.

\[ \text{fsolve}(equation2, \{z = 100\}) \]

\[ \{z = 98.98037599\} \]  \hspace{1cm} (3.6)

For more information and examples, refer to the ?**fsolve/details** help page.

For information on verifying and using solutions returned by the **fsolve** command, see the following section, **Working with Solutions**.

**Working with Solutions**

**Verifying** It is recommended that you always verify solutions (that the **solve** and **fsolve** commands return) using the **eval** command.

\[ \text{equation4} := \sin(x) = -\cos(x); \]

\[ \text{solve}(equation4) \]

\[ -\frac{1}{4} \pi \]  \hspace{1cm} (3.7)

\[ \text{eval}(equation4, x = 3.7) \]

\[ -\frac{1}{2} \sqrt{2} \approx -0.70710678118750 \]
For more information, see Substituting a Value for a Subexpression (page 314).

Assigning the Value of a Solution to a Variable To assign the value of a solution to the corresponding variable as an expression, use the assign command.

For example, consider the numeric solution to equation2, \( z = 98.98037599 \) (3.6), found using the starting value \( z = 100 \).

\[
\text{> assign(3.6)}
\]

\[
\text{> z}
\]

\[98.98037599\]

Creating a Function from a Solution The assign command assigns a value as an expression to a name. It does not define a function. To convert a solution to a function, use the unapply command.

Consider one of the solutions for \( q \) to the equation \( q^2 - rs + \frac{q}{r} = 5 \).

\[
\text{> solutions := solve}\left( q^2 - rs + \frac{q}{r} = 5, q \right) : \]

\[\]
For more information on defining and using functions, see Functional Operators (page 296).

Other Specialized Solvers

In addition to equations and inequations, Maple can solve other equations including:

- Ordinary differential equations (ODEs)
- Partial differential equations (PDEs)
- Integer equations
- Integer equations in a finite field
• Linear systems
• Recurrence relations

**Ordinary Differential Equations (ODEs)**

Maple can solve ODEs and ODE systems, including initial value and boundary value problems, symbolically and numerically.

**ODE Analyzer Assistant** The ODE Analyzer Assistant is a point-and-click interface to the Maple ODE solving routines.

**To launch the ODE Analyzer:**

• From the **Tools** menu, select **Assistants**, and then **ODE Analyzer**.

Maple inserts the `dsolve[interactive]()` calling sequence in the document. The **ODE Analyzer Assistant** (Figure 3.3) is displayed.

![ODE Analyzer Assistant](image)

**Figure 3.3: ODE Analyzer Assistant**

In the main **ODE Analyzer Assistant** window, you can define ODEs, initial or boundary value conditions, and parameters. To define derivatives, use the `diff` command. For example, `diff(x(t), t)` corresponds to $\frac{dx(t)}{dt}$, and
diff(x(t), t, t) corresponds to \( \frac{d^2x(t)}{dt^2} \). For more information on the `diff` command, see *The diff Command* (page 157).

After defining an ODE, you can solve it numerically or symbolically.

To solve a system numerically using the ODE Analyzer Assistant:

1. Ensure that the conditions guarantee uniqueness of the solution.
2. Ensure that all parameters have fixed values.
3. Click the **Solve Numerically** button.
4. In the **Solve Numerically** window (Figure 3.4), you can specify the numeric method and relevant parameters and error tolerances to use for solving the problem.
5. To compute solution values at a point, click the **Solve** button.
To solve a system symbolically using the ODE Analyzer Assistant:

1. Click the **Solve Symbolically** button.

2. In the **Solve Symbolically** window (Figure 3.5), you can specify the method and relevant method-specific options to use for solving the problem.

3. To compute the solution, click the **Solve** button.
When solving numerically or symbolically, you can view a plot of the solution by clicking the Plot button.

- To plot the solution to a symbolic problem, all conditions and parameters must be set.
- To customize the plot, click the Plot Options button to open the Plot Options window.

To view the corresponding Maple commands as you solve the problem or plot the solution, select the Show Maple commands check box.
You can control the return value of the ODE Analyzer using the **On Quit, Return** drop-down list. You can select to return nothing, the displayed plot, the computed numeric procedure (for numeric solutions), the solution (for symbolic solutions), or the Maple commands needed to produce the solution values and the displayed plot.

For more information, refer to the ?ODEAnalyzer help page.

**The dsolve Command**

The ODE Analyzer provides a point-and-click interface to the Maple `dsolve` command.

For ODEs or systems of ODEs, the `dsolve` command can find:

- Closed form solutions
- Numerical solutions
- Series solutions

In addition, the `dsolve` command can find:

- Formal power series solutions to linear ODEs with polynomial coefficients
- Formal solutions to linear ODEs with polynomial coefficients

To access all available functionality, use the `dsolve` command directly. For more information, refer to the ?dsolve help page.

**Partial Differential Equations (PDEs)**

To solve a PDE or PDE system symbolically or numerically, use the `pdsolve` command. PDE systems can contain ODEs, algebraic equations, and inequalities.

For example, solve the following PDE symbolically.

\[
> x \left( \frac{\partial}{\partial y} f(x, y) \right) - y \left( \frac{\partial}{\partial x} f(x, y) \right) = 0
\]
\[ x \left( \frac{\partial}{\partial y} f(x, y) \right) - y \left( \frac{\partial}{\partial x} f(x, y) \right) = 0 \]  \hspace{1cm} (3.9)

\[ > \text{pdsolve(3.9)} \]

\[ f(x, y) = _F1(x^2 + y^2) \]

The solution is an arbitrary univariate function applied to \( x^2 + y^2 \).

Maple generally prints only the return value, errors, and warnings during a computation. To print information about the techniques Maple uses, increase the \texttt{infolevel} setting for the command.

To return all information, set \texttt{infolevel} to 5.

\[ > \text{infolevel[pdsolve]} := 5 : \]

\[ > \text{pdsolve(3.9)} \]

Checking arguments ...
First set of solution methods (general or quase general solution) Second set of solution methods (complete solutions) Trying methods for first order PDEs Second set of solution methods successful

\[ f(x, y) = _F1(x^2 + y^2) \]

For more information on solving PDEs, including numeric solutions and solving PDE systems, refer to the \texttt{?pdsolve} help page.

**Integer Equations**

To find only integer solutions to an equation, use the \texttt{isolve} command. The \texttt{isolve} command finds solutions for all variables. For more information, refer to the \texttt{?isolve} help page.
Integer Equations in a Finite Field

To solve an equation modulo an integer, use the `msolve` command. For more information, refer to the `?msolve` help page. The `msolve` command finds solutions for all variables.

\[ msolve(\{x^2 = 1\}, 13) \]

\[ \{x = 1\}, \{x = 12\} \]

Solving Linear Systems

To solve a linear system, use the `LinearAlgebra[LinearSolve]` command. For more information, refer to the `?LinearAlgebra[LinearSolve]` help page. The `LinearSolve` command returns the vector \( \mathbf{x} \) that satisfies \( \mathbf{A} \cdot \mathbf{x} = \mathbf{B} \).

For example, construct an augmented matrix using the `Matrix` palette (see `Creating Matrices and Vectors (page 136)`) in which the first four columns contain the entries of \( \mathbf{A} \) and the final column contains the entries of \( \mathbf{B} \).

\[
\text{linear system} := \begin{bmatrix}
59 & 44 & 17 & 1 & 1 \\
10 & 25 & 2 & 100 & 1 \\
1 & 0 & 7 & 533 & 61 \\
98 & 21 & 3 & 100 & 50 \\
23 & 9 & 12 & 51 & 786 \\
10 & 25 & 25 & 25 & 25
\end{bmatrix}
\]
For more information on using Maple to solve linear algebra problems, see *Linear Algebra (page 135)*.

### Solving Recurrence Relations

To solve a recurrence relation, use the **rsolve** command. For more information, refer to the ?rsolve help page. The **rsolve** command finds the general term of the function.

\[
\text{rsolve}\left(\left\{ f(n) = f(n - 1) + f(n - 2), f(0) = 1, f(1) = 1 \right\}; \{ f(n) \} \right)
\]

\[
\left\{ f(n) = \left( -\frac{1}{10} \sqrt{5} + \frac{1}{2} \right) \left( -\frac{1}{2} \sqrt{5} + \frac{1}{2} \right)^n + \left( \frac{1}{10} \sqrt{5} + \frac{1}{2} \right) \left( \frac{1}{2} + \frac{1}{2} \sqrt{5} \right)^n \right\}
\]

### 3.5 Units, Scientific Constants, and Uncertainty

In addition to manipulating exact symbolic and numeric quantities, Maple can perform computations with units and uncertainties.
Maple supports hundreds of units, for example, miles, coulombs, and bars, and provides facilities for adding custom units.

Maple has a library of hundreds of scientific constants with units, including element and isotope properties.

To support computations with uncertainties, Maple propagates errors through computations.

**Units**

The **Units** package in Maple provides a library of units, and facilities for using units in computations. It is fully extensible so that you can add units as required.

**Note:** Some unit operations are available as task templates (see Tools→Tasks→Browse) and through context menus.

**Overview of Units**

A *dimension* is a measurable quantity, for example, length or force. The set of dimensions that are fundamental and independent are known as *base dimensions*.

In Maple, the base dimensions include length, mass, time, electric current, thermodynamic temperature, amount of substance, luminous intensity, information, and currency. For a complete list, run `Units[GetDimensions]()`.

Complex dimensions (or *composite dimensions*) measure other quantities in terms of a combination of base dimensions. For example, the complex dimension force is a measurement of \( \frac{mass \cdot length}{time^2} \).

Each dimension, base or complex, has associated units. (Base units measure a base dimension. Complex units measure a complex dimension.) Maple supports over forty units of length, including feet, miles, meters, angstroms, microns, and astronomical units. A length must be measured in terms of a unit, for example, a length of 2 parsecs.
Table 3.4 lists some dimensions, their corresponding base dimensions, and example units.

<table>
<thead>
<tr>
<th>Dimension</th>
<th>Base Dimensions</th>
<th>Example Units</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time</td>
<td>time</td>
<td>second, minute, hour, day, week, month, year, millennium, blink, lune</td>
</tr>
<tr>
<td>Energy</td>
<td>$\frac{\text{length}^2 \text{mass}}{\text{time}^2}$</td>
<td>joule, electron volt, erg, watt hour, calorie, Calorie, British thermal unit</td>
</tr>
<tr>
<td>Electric potential</td>
<td>$\frac{\text{length}^2 \text{mass}}{\text{time}^2 \text{electric current}}$</td>
<td>volt, abvolt, statvolt</td>
</tr>
</tbody>
</table>

For the complete list of units (and their contexts and symbols) available for a dimension, refer to the corresponding help page, for example, the ?Units/length help page for the units of length.

Each unit has a context. The context differentiates between different definitions of the unit. For example, the standard and US survey miles are different units of length, and the second is a unit of time and of angle. You can specify the context for a unit by appending the context as an index to the unit, for example, mile[US_survey]. If you do not specify a context, Maple uses the default context.

Units are collected into systems, for example, the foot-pound-second (FPS) system and international system, or système international, (SI). Each system has a default set of units used for measurements. In the FPS system, the foot, pound, and second are used to measure the dimensions of length, mass, and time. The unit of speed is the foot/second. In SI, the meter, kilogram, and second are used to measure the dimensions of length, mass, and time. The units of speed, magnetic flux, and power are the meter/second, weber, and watt.
Conversions

To convert a value measured in a unit to the corresponding value in a different unit, use the **Units Calculator**.

- In the worksheet, enter `UnitsCalculator`.

The **Units Calculator** application (Figure 3.6) opens.

### Units Calculator

Convert between over 500 units of measurement. See [Units help index](#) for details.

First, select a dimension from the drop-down box. Then select the units to convert from and to. Click the "Perform Unit Conversion" button. The "Convert Back" button converts in the opposite direction.

<table>
<thead>
<tr>
<th>Convert: 100</th>
<th>Result: 2.831684659</th>
</tr>
</thead>
<tbody>
<tr>
<td>From: cubic feet (ft³)</td>
<td>To: cubic meters (m³)</td>
</tr>
<tr>
<td>Dimension: volume</td>
<td></td>
</tr>
</tbody>
</table>

**Figure 3.6: Unit Converter Assistant**

**To perform a conversion:**

1. In the **Convert** text field, enter the numeric value to convert.

2. In the **Dimension** drop-down list, select the dimensions of the unit.

3. In the **From** and **To** drop-down lists, select the original unit and the unit to which to convert.

4. Click **Perform Unit Conversion**.

Maple inserts the corresponding `convert/units` command into the document.
Important: Using the Units Calculator, you can convert temperatures and temperature changes.

- To perform a temperature conversion, in the Dimension drop-down list, select temperature(absolute).
- To perform a temperature change conversion, in the Dimension drop-down list, select temperature(relative).

To convert temperature changes, the Units Calculator uses the convert/units command. For example, an increase of 32 degrees Fahrenheit corresponds to an increase of almost 18 degrees Celsius.

> convert(32.0, 'units', 'degF', 'degC')

17.7777778

To convert absolute temperatures, the Unit Converter uses the convert/temperature command. For example, 32 degrees Fahrenheit corresponds to 0 degrees Celsius.

> convert(32, 'temperature', 'degF', 'degC')

0

Applying Units to an Expression

To insert a unit, use the Units palettes. The Units (FPS) palette (Figure 3.7) contains important units from the foot-pound-second system of units. The Units (SI) palette (Figure 3.8) contains important units from the international system of units.
To insert a unit:

- In a Units palette, click a unit symbol.

\[
3 \, [ft]
\]

3 \, [ft]

To insert a unit that is unavailable in the palettes:

1. In a Units palette, click the unit symbol \([unit]\). Maple inserts a Unit object with the placeholder selected.

2. In the placeholder, enter the unit name (or symbol).

For example, to enter 0.01 standard (the default context) miles, you can specify the unit name, mile, or symbol, mi.

\[
0.01 \, [mile]
\]

0.01 \, [mi]

The context of a unit is displayed only if it is not the default context.
Important: In 1-D Math input, the quantity and unit (entered using the top-level Unit command) are a product, not a single entity. The following calling sequences define different expressions.

\[
> 1*\text{Unit}(m)/(2*\text{Unit}(s));
\]

\[
\frac{1}{2} \text{ [m]} \quad \frac{1}{2} \text{ [m] [s]}
\]

Some units support prefixes. For example, SI units support prefixes to names and symbols. You can specify 1000 meters using kilometer or km. For more information, refer to the ?Units/prefixes help page.

\[
> 1.5 \text{ [km}_{\text{SI}}]]
\]

\[
1.5 \text{ [km]}
\]

Performing Computations with Units

In the default Maple environment, you cannot perform computations with quantities that have units. You can perform only unit conversions. For more information about the default environment, refer to the ?Units/default help page.

To compute with expressions that have units, you must load a Units environment, Natural or Standard. It is recommended that you use the Standard environment.

\[
> \text{with(Units[Standard]) :}
\]

In the Standard Units environment, commands that support expressions with units return results with the correct units.
For information on differentiation and integration, see *Calculus (page 153).*

**Changing the Current System of Units**

If a computation includes multiple units, all units are expressed using units from the current system of units.

\[ 132.25 \text{[mile]} \]

\[ 132.25 \text{[mi]} \]  

(3.12)

By default, Maple uses the SI system of units, in which length is measured in meters and time is measured in seconds.
\[\frac{3.12}{3\text{[hour]}}\]

\[19.70701333\left[\frac{m}{s}\right]\]

To view the name of the default system of units, use the `Units[UsingSystem]` command.

\[
> \text{with(Units):}
\]

\[
> \text{UsingSystem( )}
\]

\[SI\]

To change the system of units, use the `Units[UseSystem]` command.

\[
> \text{UseSystem(FPS):}
\]

\[
> (3.12) \cdot 3\text{[m]} \cdot 1.1\text{[kg]}
\]

\[1.666720741\times10^7\left[\text{ft}^2\text{lb}\right]\]

**Extensibility**

You can extend the set of:

- Base dimensions and units
- Complex dimensions
- Complex units
- Systems of units


For more information about units, refer to the `?Units` help page.
Scientific Constants and Element Properties

Computations often require not only units (see Units (page 97)), but also the values of scientific constants, including properties of elements and their isotopes. Maple supports computations with scientific constants. You can use the built-in constants and add custom constants.

Overview of Scientific Constants and Element Properties

The ScientificConstants package provides the values of constant physical quantities, for example, the velocity of light and the atomic weight of sodium. The ScientificConstants package also provides the units for the constant values, allowing for greater understanding of the equation as well as unit-matching for error checking of the solution.

The quantities available in the ScientificConstants package are divided into two distinct categories.

- Physical constants
- Chemical element (and isotope) properties

Scientific Constants

Maple contains many built-in scientific constants, which you can easily include in your computations.

List of Scientific Constants

You have access to scientific constants important in engineering, physics, chemistry, and other fields. Table 3.5 lists some of the supported constants. For a complete list of scientific constants, refer to the ?ScientificConstants/PhysicalConstants help page.
Table 3.5: Scientific Constants

<table>
<thead>
<tr>
<th>Name</th>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>Newtonian_constant_of_gravitation</td>
<td>$G$</td>
</tr>
<tr>
<td>Planck_constant</td>
<td>$h$</td>
</tr>
<tr>
<td>elementary_charge</td>
<td>$e$</td>
</tr>
<tr>
<td>Bohr_radius</td>
<td>$a[0]$</td>
</tr>
<tr>
<td>deuteron_magnetic_moment</td>
<td>$\mu[d]$</td>
</tr>
<tr>
<td>Avogadro_constant</td>
<td>$N[A]$</td>
</tr>
<tr>
<td>Faraday_constant</td>
<td>$F$</td>
</tr>
</tbody>
</table>

You can specify a constant using either its name or symbol.

**Accessing Constant Definition**

The `GetConstant` command in the `ScientificConstants` package returns the complete definition of a constant.

To view the definition of the Newtonian gravitational constant, specify the symbol $G$ (or its name) in a call to the `GetConstant` command.

```plaintext
> with(ScientificConstants):

> GetConstant('G')

Newtonian_constant_of_gravitation, symbol = G, value = 6.6730 10^{-11},
uncertainty = 1.00 10^{-13}, units = \frac{m^3}{kg \cdot s^2}
```

For information on accessing a constant's value, units, or uncertainty, see *Value, Units, and Uncertainty* (page 108).

**Element Properties**

Maple also contains element properties and isotope properties.
Elements

Maple supports the first 112 elements of the periodic table, plus elements number 114 and 116. Each element has a unique name, atomic number, and chemical symbol. You can specify an element using any of these labels. For a complete list of supported elements, refer to the ?ScientificConstants/elements help page.

Maple supports key element properties, including atomic weight (atomic-weight), electron affinity (electronaffinity), and density. For a complete list of element properties, refer to the ?ScientificConstants/properties help page.

Isotopes

Isotopes, variant forms of an element that contain the same number of protons but a different number of neutrons, exist for many elements.

To see the list of supported isotopes for an element, use the GetIsotopes command.

> GetIsotopes( 'element' = 'Li' )

\[ \text{Li}_4, \text{Li}_5, \text{Li}_6, \text{Li}_7, \text{Li}_8, \text{Li}_9, \text{Li}_{10}, \text{Li}_{11}, \text{Li}_{12} \]

Maple supports isotopes and has a distinct set of properties for isotopes, including abundance, binding energy (bindingenergy), and mass excess (massexcess). For a complete list of isotope properties, refer to the ?ScientificConstants/properties help page.

Accessing an Element or Isotope Property Definition

The GetElement command in the ScientificConstants package returns the complete definition of an element or isotope.
> GetElement('Li')

3, symbol = Li, name = lithium, names = {lithium}, boilingpoint = [value = 1615., uncertainty = undefined, units = K], electronaffinity = [value = 0.6180, uncertainty = 0.0005, units = eV], density = [value = 0.534, uncertainty = undefined, units = g/cm³], electronegativity = [value = 0.98, uncertainty = undefined, units = 1], meltingpoint = [value = 453.65, uncertainty = undefined, units = K], atomicweight = [value = 6.941, uncertainty = 0.002, units = amu], ionizationenergy = [value = 5.3917, uncertainty = undefined, units = eV]

> GetElement('Li[4]')

Li₄, bindingenergy = [value = 4618.058, uncertainty = 212.132, units = keV], atomicmass = [value = 4.027182329 10⁶, uncertainty = 227.733, units = uamu], massexcess = [value = 25320.173, uncertainty = 212.132, units = keV]

Value, Units, and Uncertainty

To use constants or element properties, you must first construct a Scientific-Constants object.

To construct a scientific constant, use the Constant command.

> G := Constant('G')

\[ G := Constant(G) \]

To construct an element (or isotope) property, use the Element command.

> LiAtomicWeight := Element('Li', atomicweight)

\[ LiAtomicWeight := Element(Li, atomicweight) \]
Value

To obtain the value of a `ScientificConstants` object, use the `evalf` command.

> `evalf(G)`

\[
6.673 \times 10^{-11}
\]

> `evalf(LiAtomicWeight)`

\[
1.152580953 \times 10^{-26}
\]

**Note:** The value returned depends on the current system of units. For information on controlling the system of units, see *Changing the Current System of Units (page 103)*.

Units

To obtain the units for a `ScientificConstants` object, use the `GetUnit` command.

> `GetUnit(G)`

\[
\left[ \frac{m^3}{kg \cdot s^2} \right]
\]

> `GetUnit(LiAtomicWeight)`

\[
[kg]
\]

For information on changing the default system of units, for example, from SI to foot-pound-second, see *Changing the Current System of Units (page 103)*.
Value and Units

If performing computations with units, you can access the value and units for a `ScientificConstants` object by specifying the `units` option when constructing the object, and then evaluating the object.

```mathematica
> evalf( Constant( 'G', units ) )

6.673 \times 10^{-11} \left[ \frac{m^3}{kg \cdot s^2} \right]
```

```mathematica
> evalf( Element( 'Li[5]', atomicmass, units ) )

8.323520514 \times 10^{-27} [kg]
```

Uncertainty

The value of a constant is often determined by direct measurement or derived from measured values. Hence, it has an associated uncertainty. To obtain the uncertainty in the value of a `ScientificConstants` object, use the `GetError` command.

```mathematica
> GetError( G )

1.0 \times 10^{-13}
```

```mathematica
> GetError( LiAtomicWeight )

3.321080400 \times 10^{-30}
```

Performing Computations

You can use constant values in any computation. To use constant values with units, use a `Units` environment as described in `Performing Computations with Units` (page 102). For information on computing with quantities that have an uncertainty, see the following section.
Modification and Extensibility

You can change the definition of a scientific constant or element (or isotope) property.

For more information, refer to the \texttt{ScientificConstants[ModifyConstant]} and \texttt{ScientificConstants[ModifyElement]} help pages.

You can extend the set of:

- Constants
- Elements (and isotopes)
- Element (or isotope) properties

For more information, refer to the \texttt{ScientificConstants[AddConstant]}, \texttt{ScientificConstants[AddElement]}, and \texttt{ScientificConstants[AddProperty]} help pages.

For more information about constants, refer to the \texttt{ScientificConstants} help page.

Uncertainty Propagation

Some computations involve uncertainties (or errors). Using the \texttt{ScientificErrorAnalysis} package, you can propagate the uncertainty in these values through the computation to indicate the possible error in the final result.

The \texttt{ScientificErrorAnalysis} package does not perform interval arithmetic. That is, the error of an object does not represent an interval in which possible values must be contained. (To perform interval arithmetic, use the \texttt{Tolerances} package. For more information, refer to the \texttt{Tolerances} help page.) The quantities represent unknown values with a central tendency. For more information on central tendency, refer to any text on error analysis for the physical sciences or engineering.
Quantities with Uncertainty

Creating To construct quantities with uncertainty, use the Quantity command. You must specify the value and uncertainty. The uncertainty can be defined absolutely, relatively, or in units of the last digit. For more information on uncertainty specification, refer to the ?ScientificErrorAnalysis[Quantity] help page.

The output displays the value and uncertainty of the quantity.

> with(ScientificConstants): with(ScientificErrorAnalysis):

> Quantity(105, 1.2)

\[ \text{Quantity}(105, 1.2) \]

> Quantity(105, 0.03, 'relative')

\[ \text{Quantity}(105, 3.15) \] (3.13)

To specify the error in units of the last digit, the value must be of floating-point type.

> Quantity(105.0, 12,’uld’)

\[ \text{Quantity}(105.0, 1.2) \]

To access the value and uncertainty of a quantity with uncertainty, use the evalf and ScientificErrorAnalysis[GetError] commands.

> evalf((3.13))

105.
Rounding To round the error of a quantity with uncertainty, use the `ApplyRule` command. For a description of the predefined rounding rules, refer to the `?ScientificErrorAnalysis/rules` help page.

```maple
> GetError(ApplyRule(3.13, 'round[2]'))
```

3.2

Units Quantities with errors can have units. For example, the scientific constants and element (and isotope) properties in the `ScientificConstants` packages are quantities with errors and units.

To construct a new quantity with units and an uncertainty, include units in the `Quantity` calling sequence.

For an absolute error, you must specify the units in both the value and error.

```maple
> with(Units[Standard]) :

> Quantity(3.5 [m], 0.1 [m])

Quantity(3.5 [m], 0.1 [m])
```

For a relative error, you can specify the units in only the value.

```maple
> Quantity(3.5 [m], 0.1, 'relative')

Quantity(3.5 [m], 0.35 [m])
```

For information on the correlation between, variance of, and covariance between quantities with uncertainty, refer to the `?ScientificErrorAnalysis` help page.
Performing Computations with Quantities with Uncertainty

Many Maple commands support quantities with uncertainty.

\[ q1 := Quantity(31., 2.); \]
\[ q2 := Quantity(20., 1.); \]

Compute the value of the derivative of \( q1 \cdot x^2 + \sin(q2 \cdot x) \) at \( x = \sin(\pi/4) \).

\[ d1 := \text{diff}(q1 \cdot x^2 + \sin(q2 \cdot x), x) \]
\[ d1 := 2 \cdot \text{Quantity}(31., 2.) \cdot x + \cos(\text{Quantity}(20., 1.) \cdot x) \cdot \text{Quantity}(20., 1.) \]

\[ d2 := \text{eval}(d1, x=\sin(\pi/4)); \]

To convert the solution to a single quantity with uncertainty, use the \texttt{combine/errors} command.

\[ \text{result} := \text{combine}(d2, 'errors'); \]

The value of the result is:

\[ \text{evalf(result)} \]

43.74124725

The uncertainty of the result is:

\[ \text{GetError(result)} \]

14.42690612
Additional Information

For information on topics including:

- Creating new rounding rules
- Setting the default rounding rule
- Creating a new interface to quantities with uncertainty

refer to the ?ScientificErrorAnalysis help page.

3.6 Restricting the Domain

By default, Maple computes in the complex number system. Most computations are performed without any restrictions or assumptions on the variables. Maple often returns results that are extraneous or unsimplified when computing in the field of complex numbers. Using restrictions, you can more easily and efficiently perform computations in a smaller domain.

Maple has facilities for performing computations in the real number system and for applying assumptions to variables.

Real Number Domain

To force Maple to perform computations in the field of real numbers, use the RealDomain package.

The RealDomain package contains a small subset of Maple commands related to basic precalculus and calculus mathematics, for example, arccos, limit, and log, and the symbolic manipulation of expressions and formulae, for example, expand, eval, and solve. For a complete list of commands, refer to the ?RealDomain help page.

After you load the RealDomain package, Maple assumes that all variables are real. Commands return simplified results appropriate to the field of real numbers.

> with(RealDomain):
Some commands that generally return NULL instead return a numeric result when you use the RealDomain package.

\[ \texttt{\textgreater{} simplify}(\sqrt{x^2}) \]

\[ |x| \]

\[ \texttt{\textgreater{} ln}(e^x) \]

\[ x \]

Some commands that generally return NULL instead return a numeric result when you use the RealDomain package.

\[ \texttt{\textgreater{} (-32)(\frac{1}{5})} \]

\[ -2 \]

Complex return values are excluded or replaced by undefined.

\[ \texttt{\textgreater{} solve}(x^2 = -1) \]

\[ \texttt{\textgreater{} arcsin}(e^2) \]

\[ \texttt{undefined} \]

**Assumptions on Variables**

To simplify problem solving, it is recommended that you always apply any known assumptions to variables. You can impose assumptions using the assume command. To apply assumptions for a single computation, use the assuming command.

**Note:** The assume and assuming commands are not supported by the RealDomain package.
The assume Command

You can use the `assume` command to set variable properties, for example, `x::real`, and relationships between variables, for example, `x < 0` or `x < y`. For information on valid properties, refer to the `?assume` help page. For information on the double colon (::) operator, refer to the `?type` help page.

The `assume` command allows improved simplification of symbolic expressions, especially multiple-valued functions, for example, computing the square root.

To assume that `x` is a positive real number, use the following calling sequence. Then compute the square root of `x^2`.

```
> assume(0 < x): \sqrt{x^2}

x~
```

The trailing tilde (~) on the name `x` indicates that it carries assumptions.

When you use the `assume` command to place another assumption on `x`, all previous assumptions are removed.

```
> assume(x < 0): \sqrt{x^2}

-x~
```

Displaying Assumptions To view the assumptions on an expression, use the `about` command.

```
> about(x)

Originally x, renamed x~:

is assumed to be: RealRange(-infinity,Open(0))
```
**Imposing Multiple Assumptions** To simultaneously impose multiple conditions on an expression, specify multiple arguments in the `assume` calling sequence.

```plaintext
> assume(0 < x, x < 2)
```

To specify additional assumptions without replacing previous assumptions, use the `additionally` command. The syntax of the `additionally` calling sequence is the same as that of the `assume` command.

```plaintext
> additionally(x :: integer): about(x)
```

*Originally x, renamed x~: is assumed to be: 1*

The only integer in the open interval (0, 2) is 1.

**Testing Properties** To test whether an expression always satisfies a condition, use the `is` command.

```plaintext
> assume(15 < x, 7 < y): is(100 < x*y)
```

```
true
```

The following test returns `false` because there are values of x and y (x = 0, y = 10) that satisfy the assumptions, but do not satisfy the relation in the `is` calling sequence.

```plaintext
> assume(x :: nonnegint, 10 ≤ y): is(10 < x + y)
```

```
false
```

To test whether an expression can satisfy a condition, use the `coulditbe` command.

```plaintext
> coulditbe(10 < x + y)
```

```
true
```
Removing Assumptions To remove all assumptions on a variable, unassign its name.

> unassign ('x', 'y')

For more information, see Unassigning Names (page 57).

For more information on the assume command, refer to the ?assume help page.

The assuming Command

To perform a single evaluation under assumptions on the names in an expression, use the assuming command.

The syntax of the assuming command is expression assuming <property or relation>. Properties and relations are introduced in The assume Command (page 117).

The frac command returns the fractional part of an expression.

> frac(x) assuming x :: integer

0

Using the assuming command is equivalent to imposing assumptions with the assume command, evaluating the expression, and then removing the assumptions.
If you do not specify the names to which to apply a property, it is applied to all names.

\[ \sqrt{\left(\frac{a}{b}\right)^2} \text{ assuming positive} \]

\[ \frac{a}{b} \]

Assumptions placed on names using the \texttt{assume} command are ignored by the \texttt{assuming} command, unless you include the \texttt{additionally} option.

\[ \text{assume}(x < 1) \]

\[ \text{is}(1 - x^2 > 0) \text{ assuming } x > -1 \]

\[ \text{false} \]

\[ \text{is}(1 - x^2 > 0) \text{ assuming additionally }, x > -1 \]

\[ \text{true} \]

The \texttt{assuming} command does not affect variables inside procedures. (For information on procedures, see \textit{Procedures (page 342).}) You must use the \texttt{assume} command.

\[ f := \text{proc}(x) \sqrt{a^2} + x \text{ end proc}; \]

\[ f := \text{proc}(x) \sqrt{a^2} + x \text{ end proc} \]
For more information on the `assuming` command, refer to the `?assuming` help page.
4 Mathematical Computations

As discussed in previous chapters, Maple contains numerous built-in resources for computations.

These resources—and others on the Maplesoft Web site—are available for the areas discussed in this chapter, and many more. Your first step in solving a problem should be to review the related Maple resources available. This will help you to quickly and easily solve problems. See Table 4.1.

<table>
<thead>
<tr>
<th>Resource</th>
<th>Description</th>
</tr>
</thead>
</table>
| Point-and-click assistants | Graphical interfaces with buttons and sliders to easily perform a computation, create a plot, or perform other operations.  
• From the Tools menu, select Assistants. |
| Context menus          | Pop-up menu of common operations for the selected object, based on its type.  
• Select the expression in 2-D Math input or output, and then right-click (for Macintosh, Control-click). |
| Palettes               | Collections of related items that you can insert by clicking or dragging. Some palettes contain mathematical operations with placeholders for parameters.  
• From the View menu, select Palettes, and then Expand Docks. |
| Task templates         | Set of commands with placeholders that you can use to quickly perform a task. Some tasks contain graphical components such as buttons.  
• From the Tools menu, select Tasks, and then Browse. |
| FunctionAdvisor command | Provides detailed information about mathematical functions, for example, definitions, identities, and mathematical properties.  
• Refer to the FunctionAdvisor help page. |
<table>
<thead>
<tr>
<th>Resource</th>
<th>Description</th>
</tr>
</thead>
</table>
| Maple Help System | Over 5000 help pages and example worksheets with an integrated search engine.  
  • From the Help menu, select Maple Help. |
| Package index help page | A complete list of the over 100 Maple packages, which contain thousands of commands.  
  • From the Help menu, select Manuals, Dictionary, and more, and then List of Packages. |
| Command index help page | A complete list of the over 600 top-level Maple commands.  
  • From the Help menu, select Manuals, Dictionary, and more, and then List of Commands. |
| Maplesoft Web site ([http://www.maplesoft.com](http://www.maplesoft.com)) | Maple Application Center - Free documents and point-and-click Maplet applications for mathematics, engineering, finance, and science.  
  • Visit [http://www.maplesoft.com/applications](http://www.maplesoft.com/applications)  
  Toolboxes - Add-on products from Maplesoft, for example, the Global Optimization Toolbox.  
  • Visit [http://www.maplesoft.com/products/toolboxes](http://www.maplesoft.com/products/toolboxes)  
  Third-Party Products - Add-on products developed by the Maple user community for specialized computation.  
  • Visit [http://www.maplesoft.com/products/thirdparty](http://www.maplesoft.com/products/thirdparty) |

For instructor and student resources, see *Table 4.10 (page 180).*

For information on basic computations, including integer operations and solving equations, see *Performing Computations (page 65).*
## 4.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Algebra - Performing algebra computations</td>
<td>• Polynomial Algebra</td>
</tr>
<tr>
<td>Linear Algebra - Performing linear algebra computations</td>
<td>• Creating Matrices and Vectors&lt;br&gt;• Accessing Entries in Matrices and Vectors&lt;br&gt;• Linear Algebra Computations&lt;br&gt;• <strong>Student LinearAlgebra</strong> Package</td>
</tr>
<tr>
<td>Calculus - Performing calculus computations</td>
<td>• Limits&lt;br&gt;• Differentiation&lt;br&gt;• Series&lt;br&gt;• Integration&lt;br&gt;• Differential Equations&lt;br&gt;• Calculus Packages</td>
</tr>
<tr>
<td>Optimization - Performing optimization computations using the <strong>Optimization</strong> package</td>
<td>• Point-and-Click Interface&lt;br&gt;• Efficient Computation&lt;br&gt;• MPS(X) File Support</td>
</tr>
<tr>
<td>Statistics - Performing statistics computations using the <strong>Statistics</strong> package</td>
<td>• Probability Distributions and Random Variables&lt;br&gt;• Statistical Computations&lt;br&gt;• Plotting</td>
</tr>
<tr>
<td>Teaching and Learning with Maple - Student and Instructor resources for using Maple in an academic setting</td>
<td>• Table of Student and Instructor Resources&lt;br&gt;• <strong>Student</strong> Packages and Tutors</td>
</tr>
</tbody>
</table>
4.2 Algebra

Maple contains a variety of commands that perform integer operations, such as factoring and modular arithmetic, as described in Integer Operations (page 71). In addition, it supports polynomial algebra.

For information on matrix and vector algebra, see Linear Algebra (page 135).

Polynomial Algebra

A Maple polynomial is an expression in powers of an unknown. Univariate polynomials are polynomials in one unknown, for example, \( x^3 - 2x + 13 \). Multivariate polynomials are polynomials in multiple unknowns, such as \( x^3 y - \frac{3}{2} xy^2 + 7x \).

The coefficients can be integers, rational numbers, irrational numbers, floating-point numbers, complex numbers, variables, or a combination of these types.

\[
> a x^2 + 7x - \frac{b}{2}
\]

\[
ax^2 + 7x - \frac{1}{2} b
\]

Arithmetic

The polynomial arithmetic operators are the standard Maple arithmetic operators excluding the division operator (/). (The division operator accepts polynomial arguments, but does not perform polynomial division.)

Polynomial division is an important operation. The quo and rem commands find the quotient and remainder of a polynomial division. See Table 4.2. (The iquo and irem commands find the quotient and remainder of an integer division. For more information, see Integer Operations (page 71).)
### Table 4.2: Polynomial Arithmetic Operators

<table>
<thead>
<tr>
<th>Operation</th>
<th>Operator</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Addition</td>
<td>+</td>
<td>((x^2 + 1) + (3x^3 - 5x + 2))</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(x^2 + 3 + 3x^3 - 5x)</td>
</tr>
<tr>
<td>Subtraction</td>
<td>-</td>
<td>((x^2 + 1) - (3x^3 - 5x + 2))</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(x^2 - 1 - 3x^3 + 5x)</td>
</tr>
<tr>
<td>Multiplication(^1)</td>
<td>*</td>
<td>((x^2 + 1) \cdot (3x^3 - 5x + 2))</td>
</tr>
<tr>
<td></td>
<td></td>
<td>((x^2 + 1)(3x^3 - 5x + 2))</td>
</tr>
<tr>
<td>Division: Quotient and Remainder</td>
<td>quo rem</td>
<td>(\text{quo}(2x^2 + x - 3, x + 5, x))</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(\frac{2}{3}x - \frac{7}{9})</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(\text{rem}(2x^2 + x - 3, x + 5, x))</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(\frac{8}{9})</td>
</tr>
<tr>
<td>Exponentiation(^2)</td>
<td>^</td>
<td>((x^2 + 1)^3)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>((x^2 + 1)^3)</td>
</tr>
</tbody>
</table>

\(^1\)You can specify multiplication explicitly by entering \(*\), which displays in 2-D Math as \(*\). In 2-D Math, you can also implicitly multiply by placing a space character between two expressions. In some cases, the space character is optional. For example, Maple interprets a number followed by a name as an implicit multiplication.

\(^2\)In 2-D Math, exponents display as superscripts.

To expand a polynomial, use the **expand** command.
If you need to determine whether one polynomial divides another, but do not need the quotient, use the `divide` command. The `divide` command tests for exact polynomial division.

\[
> \text{divide}(3x^2 \cdot (3x+5) - (x^2 - 2))
\]

\[
9x^3 + 14x^2 + 2
\]

Important: You must insert a space character or a multiplication operator (\( \cdot \)) between adjacent variables names. Otherwise, they are interpreted as a single variable.

For example, \( x \) does not divide the single variable \( xy \).

\[
> \text{divide}(xy, x)
\]

\[
false
\]

But, \( x \) divides the product of \( x \) and \( y \).

\[
> \text{divide}(xy, x); \text{divide}(x \cdot y, x)
\]

\[
true
\]

\[
true
\]

For information on polynomial arithmetic over finite rings and fields, refer to the `?mod` help page.

**Sorting Terms**

To sort the terms of a polynomial, use the `sort` command.
\textbf{Note:} The \texttt{sort} command returns the sorted polynomial, and updates the order of the terms in the polynomial.

The terms of \texttt{p1} are sorted.

\[
p1 := x^2 + x^3 - x + x^4
\]

\[
\texttt{sort}(p1)
\]

\[
x^4 + x^3 + x^2 - x
\]

To specify the unknowns of the polynomial and their ordering, include a list of names.

\[
\texttt{sort}(a^2 x^3 + x^2 + x \cdot a + a + b, [a])
\]

\[
x^3 a^2 + x a + a + x^2 + b
\]

\[
\texttt{sort}(a^2 x^3 + x^2 + x \cdot a + a + b, [x, b])
\]

\[
a^2 x^3 + x^2 + a x + b + a
\]

By default, the \texttt{sort} command sorts a polynomial by decreasing total degree of the terms.

\[
p2 := x^3 + y^3 + x^2 y^2:
\]

\[
\texttt{sort}(p2, [x, y])
\]
The first term has total degree 4. The other two terms have total degree 3. The order of the final two terms is determined by the order of their names in the list.

To sort the terms by *pure lexicographic order*, that is, first by decreasing order of the first unknown in the list option, and then by decreasing order of the next unknown in the list option, specify the 'plex' option.

\[ x^2 y^2 + x^3 + y^3 \]

For information on enclosing keywords in right single quotes ('), see *Delaying Evaluation* (page 321).

The first term has a power of \( x \) to the 3. The second, a power of \( x \) to the 2. The third, a power of \( x \) to the 0.

Using context menus, you can perform operations, such as sorting, for polynomials and many other Maple objects.

**To sort a polynomial:**

1. Right-click (Control-click, for Macintosh) the polynomial.
2. The context menu displays. From the **Sorts** menu, select:
   - **Single-variable**, and then the unknown
   - **Two-variable** (or **Three-variable**), **Pure Lexical** or **Total Degree**, and then the sort priority of the unknowns

See Figure 4.1.
Maple sorts the polynomial.
In Worksheet mode, Maple inserts the calling sequence that performs the sort followed by the sorted polynomial.

\[ x^3 + y^3 + x^2 y^2 : \]

\[ \text{sort} \left( x^3 + y^3 + x^2 y^2, [y, x], '\text{plex}' \right) \]

\[ y^3 + y^2 x^2 + x^3 \]

You can use context menus to perform operations on 2-D Math content including output. For more information, see Context Menus (page 21) (for Document mode) or Context Menus (page 46) (for Worksheet mode).

**Collecting Terms**

To collect the terms of polynomial, use the `collect` command.

\[ \text{collect} \left( 2axy + c x^2 y - z y^2 + a z - 13by + \frac{3y^2}{x}, y \right) \]

\[ \left( -z + \frac{3}{x} \right) y^2 + \left( 2ax + cx^2 - 13b \right) y + az \]

**Coefficients and Degrees**

Maple has several commands that return coefficient and degree values for a polynomial. See Table 4.3.
Table 4.3: Polynomial Coefficient and Degree Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>coeff</td>
<td>Coefficient of specified degree term</td>
<td>( \text{coeff}\left(\frac{1}{2}x^3 - 2x + 5, x^3\right) )</td>
</tr>
<tr>
<td>lcoeff</td>
<td>Leading coefficient</td>
<td>( \text{lcoeff}\left(\frac{1}{2}x^3 - 2x + 5\right) )</td>
</tr>
<tr>
<td>tcoeff</td>
<td>Trailing coefficient</td>
<td>( \text{tcoeff}\left(\frac{1}{2}x^3 - 2x + 5\right) )</td>
</tr>
<tr>
<td>coeffs</td>
<td>Sequence of all coefficients in increasing degree order. <strong>Note:</strong> It does not return zero coefficients.</td>
<td>( \text{coeffs}\left(\frac{1}{2}x^3 - 2x + 5\right) )</td>
</tr>
<tr>
<td>degree</td>
<td>(Highest) degree</td>
<td>( \text{degree}\left(\frac{1}{2}x^3 - 2x + 5\right) )</td>
</tr>
<tr>
<td>ldegree</td>
<td>Lowest degree term with a non-zero coefficient</td>
<td>( \text{ldegree}\left(\frac{1}{2}x^3 - 2x\right) )</td>
</tr>
</tbody>
</table>

**Factorization**

To express a polynomial in fully factored form, use the **factor** command.
\[ \text{factor}(x^4 - 1) \]

\[ (x - 1)(x + 1)(x^2 + 1) \]

The `factor` command factors the polynomial over the ring implied by the coefficients, for example, integers. You can specify an algebraic number field over which to factor the polynomial. For more information, refer to the `?factor` help page. (The `ifactor` command factors an integer. For more information, see *Integer Operations* (page 71).)

To solve for the roots of a polynomial, use the `solve` command. For information on the `solve` command, see *Solving Equations and Inequalities* (page 78). (The `isolve` command solves an equation for integer solutions. For more information, see *Integer Equations* (page 94).)

**Other Commands**

Table 4.4 lists other commands available for polynomial operations.

**Table 4.4: Select Other Polynomial Commands**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>content</code></td>
<td>Content (multivariate polynomial)</td>
</tr>
<tr>
<td><code>compoly</code></td>
<td>Decomposition</td>
</tr>
<tr>
<td><code>discrim</code></td>
<td>Discriminant</td>
</tr>
<tr>
<td><code>gcd</code></td>
<td>Greatest common divisor (of two polynomials)</td>
</tr>
<tr>
<td><code>gcdex</code></td>
<td>Extended Euclidean algorithm (for two polynomials)</td>
</tr>
<tr>
<td><code>CurveFitting[PolynomialInterpolation]</code></td>
<td>Interpolating polynomial (for list of points)</td>
</tr>
<tr>
<td>See also the <code>CurveFitting Assistant</code> (Tools→Assistants→Curve Fitting)</td>
<td></td>
</tr>
<tr>
<td><code>lcm</code></td>
<td>Least common multiple (of two polynomials)</td>
</tr>
<tr>
<td><code>norm</code></td>
<td>Norm</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>------------------------------------------</td>
</tr>
<tr>
<td>prem</td>
<td>Pseudo-remainder (of two multivariate polynomials)</td>
</tr>
<tr>
<td>primpart</td>
<td>Primitive part (multivariate polynomial)</td>
</tr>
<tr>
<td>randpoly</td>
<td>Random polynomial</td>
</tr>
<tr>
<td>PolynomialTools[IsSelfReciprocal]</td>
<td>Determine whether self-reciprocal</td>
</tr>
<tr>
<td>resultant</td>
<td>Resultant (of two polynomials)</td>
</tr>
<tr>
<td>roots</td>
<td>Exact roots (over algebraic number field)</td>
</tr>
<tr>
<td>sqrfree</td>
<td>Square free factorization (multivariate polynomial)</td>
</tr>
</tbody>
</table>

### Additional Information

#### Table 4.5: Additional Polynomial Help

<table>
<thead>
<tr>
<th>Topic</th>
<th>Resource</th>
</tr>
</thead>
<tbody>
<tr>
<td>General polynomial information</td>
<td>?polynom help page</td>
</tr>
<tr>
<td>PolynomialTools package</td>
<td>?PolynomialTools package overview help page</td>
</tr>
<tr>
<td>Algebraic manipulation of numeric polynomials</td>
<td>?SNAP (Symbolic-Numeric Algorithms for Polynomials) package overview help page</td>
</tr>
<tr>
<td>Efficient arithmetic for sparse polynomials</td>
<td>?SDMPolynom (Sparse Distributed Multivariate Polynomial data structure) help page</td>
</tr>
<tr>
<td>Polynomial information and commands</td>
<td>Maple Help System Table of Contents: Mathematics→Algebra→Polynomials section</td>
</tr>
</tbody>
</table>

## 4.3 Linear Algebra

Linear algebra operations act on Matrix and Vector data structures.

You can perform many linear algebra operations using task templates. In the Task Browser (Tools→Tasks→Browse), expand the Linear Algebra folder.
Creating Matrices and Vectors

You can easily define matrices using the Matrix palette. To define vectors, use the angle-bracket (<> notation.

Creating Matrices

To create a matrix, use the Matrix palette. See Figure 4.2.

![Matrix Palette](image)

**Figure 4.2: Matrix Palette**

In the Matrix palette, you can specify the matrix size (see Figure 4.3) and properties. To insert a matrix, click the Insert Matrix button.
Figure 4.3: Matrix Palette: Choosing the Size

After inserting the matrix:

1. Enter the values of the entries. To move to the next entry placeholder, press Tab.

2. After specifying all entries, press Enter.

\[
\begin{bmatrix}
1 & e^2 & 0 \\
\pi & \sin(r) & 0 \\
0 & \frac{87}{2} & 5e
\end{bmatrix}
\]
Creating Vectors

To create a vector, use angle brackets (< >).

To create a column vector, specify a comma-delimited sequence, \(<a, b, c>\). The number of elements is inferred from the number of expressions.

\[
\begin{pmatrix}
1 \\
2 \\
3
\end{pmatrix}
\]

To create a row vector, specify a vertical-bar-delimited (|) sequence, \(<a | b | c>\). The number of elements is inferred from the number of expressions.

\[
\begin{pmatrix}
1 & 2 & 3
\end{pmatrix}
\]

Editing and Viewing Large Matrices and Vectors

Matrices \(10 \times 10\) and smaller, and vectors with 10 or fewer elements display in the document. Larger objects are displayed as a placeholder.

For example, insert a \(15 \times 15\) matrix.
In the Matrix palette:

1. Specify the dimensions: 15 rows and 15 columns.

2. In the **Type** drop-down list, select a matrix type, for example, **Custom values**.

3. Click **Insert Matrix**. Maple inserts a placeholder.

\[
\begin{bmatrix}
\text{15 x 15 Matrix} \\
\text{Data Type: anything} \\
\text{Storage: rectangular} \\
\text{Order: Fortran_order}
\end{bmatrix}
\]

To edit or view a large matrix or vector, double-click the placeholder. This launches the Matrix Browser. See Figure 4.4.
To specify the value of entries using the Matrix Browser:

1. Select the Table tab.
2. Double-click an entry, and then edit its value. Press Enter.
3. Repeat for each entry to edit.
4. When you have finished updating entries, click Done.
You can view the matrix or vector as a table or as an image, which can be inserted into the document. For more information, refer to the `?MatrixBrowser` help page.

To set the maximum dimension of matrices and vectors displayed inline:

- Use the `interface` command with the `rtablesize` option.

For example, `interface(rtablesize = 15)`.

For more information, refer to the `?interface` help page.

**Creating Matrices and Vectors for Large Problems**

By default, matrices and vectors can store any values. To increase the efficiency of linear algebra computations, create matrices and vectors with properties. You must specify the properties, for example, the matrix or vector type or the data type, when defining the object.

The `Matrix` palette (Figure 4.2) supports several properties.

To specify the matrix type:

- Use the `Shape` and `Type` drop-down lists.

To specify the data type:

- Use the `Data type` drop-down list.

For example, define a diagonal matrix with small integer coefficients.

In the `Matrix` palette:

1. Specify the size of the matrix, for example, $3 \times 3$.

2. In the `Shapes` drop-down list, select `Diagonal`.


4. Click the `Insert Matrix` button.
5. Enter the values in the diagonal entries.

\[
\begin{bmatrix}
-23 & 0 & 0 \\
0 & 17 & 0 \\
0 & 0 & 32
\end{bmatrix}
\]

**Note:** To create a matrix with randomly-generated entries, select the **Random Type**.

You cannot specify properties when defining vectors using the angle-bracket notation. You must use the **Vector** constructor.

**To define a column vector using the Vector constructor, specify:**

- The number of elements. If you explicitly specify all element values, this argument is not required.
- A list of expressions that define the element values.
- Parameters such as **shape**, **datatype**, and **fill** that set properties of the vector.

The following two calling sequences are equivalent.

```plaintext
> Vector([0, 0, 0])

\[
\begin{bmatrix}
0 \\
0 \\
0
\end{bmatrix}
\]

> Vector(3, 'shape' = 'zero')

\[
\begin{bmatrix}
0 \\
0 \\
0
\end{bmatrix}
\]```
To create a row vector using the `Vector` constructor, include `row` as an index.

```latex
greater than \text{Vector}[\text{row}](3, 'fill' = 1)\end{verbatim}

$$\begin{bmatrix} 1 & 1 & 1 \end{bmatrix}$$

```latex
greater than \text{Vector}[\text{row}]([127, 0, 34], 'datatype' = 'integer[1]')\end{verbatim}

$$\begin{bmatrix} 127 & 0 & 34 \end{bmatrix}$$

The `Matrix` palette does not support some properties. To set all properties, use the `Matrix` constructor.

**To define a matrix using the Matrix constructor, specify:**

- The number of rows and columns. If you explicitly specify all element values, these arguments are not required.
- A list of lists that define the element values row-wise.
- Parameters such as `shape`, `datatype`, and `fill` that set properties of the matrix.

For example:

```latex
greater than \text{Matrix}([[1, 2, 3], [4, 5, 6]])\end{verbatim}

$$\begin{bmatrix} 1 & 2 & 3 \\ 4 & 5 & 6 \end{bmatrix}$$

The `Matrix` palette cannot fill the matrix with an arbitrary value. Use the `fill` parameter.
For more information on the constructors, including other calling sequence syntaxes and parameters, refer to the `?storage`, `?Matrix`, and `?Vector` help pages.

See also *Numeric Computations (page 152).*

**Accessing Entries in Matrices and Vectors**

To select an entry in a vector, enter the vector name with a non-zero integer index.

```plaintext
> a := <85.3, 47.1, 59.9, 38.1>

> a[1]

85.3
```

Negative integers select entries from the end of the vector.

```plaintext
> a[−1]

38.1
```
To create a Vector consisting of multiple entries, specify a list or range of integers in the index. For more information, refer to the ?list and ?range help pages.

\[ a[[1,2]] \]

\[
\begin{bmatrix}
85.3 \\
47.1
\end{bmatrix}
\]

\[ a[2..4] \]

\[
\begin{bmatrix}
47.1 \\
59.9 \\
38.1
\end{bmatrix}
\]

Similarly, you can access submatrices using an index. In the following two-dimensional matrix, the first entry selects rows and the second, columns.

\[ b := \begin{bmatrix}
1 & 0 & 0 \\
0 & \cos(t) & -\sin(t) \\
0 & \sin(t) & \cos(t)
\end{bmatrix} : \\
\]

\[ b[2..-1,2..-1] \]

\[
\begin{bmatrix}
\cos(t) & -\sin(t) \\
\sin(t) & \cos(t)
\end{bmatrix}
\]

**Linear Algebra Computations**

You can perform matrix and vector computations using context menus and the **LinearAlgebra** package.
**Matrix Arithmetic**

The matrix and vector arithmetic operators are the standard Maple arithmetic operators up to the following two differences.

- The scalar multiplication operator is the asterisk (*), which displays in math as $\cdot$. The noncommutative matrix and vector multiplication operator is the period (.)
- There is no division operator (/) for matrix algebra. (You can construct the inverse of a matrix using the exponent $-1$.)

See Table 4.6.

\[
> a := \begin{bmatrix} 93 & 43 \\ 19 & 37 \end{bmatrix} ; b := \begin{bmatrix} 48 & 20 \\ 19 & 37 \end{bmatrix} ; c := <23, 6> : 
\]

<table>
<thead>
<tr>
<th>Operation</th>
<th>Operator</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Addition</td>
<td>$+$</td>
<td>$a+b$</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$\begin{bmatrix} 141 &amp; 63 \ 38 &amp; 74 \end{bmatrix}$</td>
</tr>
<tr>
<td>Subtraction</td>
<td>$-$</td>
<td>$a-b$</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$\begin{bmatrix} 45 &amp; 23 \ 0 &amp; 0 \end{bmatrix}$</td>
</tr>
<tr>
<td>Multiplication</td>
<td>$\cdot$</td>
<td>$a\cdot c$</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$\begin{bmatrix} 2397 \ 659 \end{bmatrix}$</td>
</tr>
</tbody>
</table>
A few additional matrix and vector operators are listed in Table 4.7.

Define two column vectors.

\[
\begin{align*}
&d := <1, 2, 3>: e := <4, 5, 6>:
\end{align*}
\]
Table 4.7: Select Matrix and Vector Operators

<table>
<thead>
<tr>
<th>Operation</th>
<th>Operator</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transpose</td>
<td>$^%T$</td>
<td>$d^%T$</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$\begin{bmatrix} 1 &amp; 2 &amp; 3 \end{bmatrix}$</td>
</tr>
<tr>
<td>Hermitian Transpose</td>
<td>$^%H$</td>
<td>$I - 2I %H$</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$\begin{bmatrix} I &amp; -2I \ 3 + 4I &amp; 2 - I \ -1 &amp; 3 - 4I \ 21 &amp; 2 + 1 \end{bmatrix}$</td>
</tr>
<tr>
<td>Cross Product</td>
<td>$&amp;x$</td>
<td>$\text{with(LinearAlgebra):}$</td>
</tr>
<tr>
<td>(3-D vectors only)</td>
<td></td>
<td>$d &amp;x , e$</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$\begin{bmatrix} -3 \ 6 \ -3 \end{bmatrix}$</td>
</tr>
</tbody>
</table>

1 Exponential operators display in 2-D Math as superscripts.

2 After loading the \texttt{LinearAlgebra} package, the cross product operator is available as the infix operator \texttt{&x}. Otherwise, it is available as the \texttt{LinearAlgebra[CrossProduct]} command.

For information on matrix arithmetic over finite rings and fields, refer to the \texttt{?mod} help page.

**Point-and-Click Interaction**

Using context menus, you can perform many matrix and vector operations.

Matrix operations available in the context menu include the following.
• Standard operations: determinant, inverse, norm (1, Euclidean, infinity, or Frobenius), transpose, and trace
• Compute eigenvalues, eigenvectors, and singular values
• Compute the dimension or rank
• Convert to the Jordan form, or other forms
• Perform Cholesky decomposition and other decompositions

For example, compute the infinity norm of a matrix. See Figure 4.5.

```
> [ 18735.6985  349723.234987
  9859.459    798124.14089 ]
```

![Figure 4.5: Computing the Infinity Norm of a Matrix](image)

Figure 4.5: Computing the Infinity Norm of a Matrix
In Document mode, Maple inserts a right arrow followed by the norm. See Figure 4.6.

\[
\begin{bmatrix}
18725.6985 & 349723.234987 \\
9859.459 & 798124.14089
\end{bmatrix}
\xrightarrow{\text{infinity-norm}} 8.0793359990 \times 10^5
\]

Figure 4.6: Computing Norm in Document Mode

Vector operations available in the context menu include the following.

- Compute the dimension
- Compute the norm (1, Euclidean, and infinity)
- Compute the transpose
- Select an element

For more information on context menus, see Context Menus (page 21) (for Document mode) or Context Menus (page 46) (for Worksheet mode).

**LinearAlgebra Package Commands**

The LinearAlgebra package contains commands that construct and manipulate matrices and vectors, compute standard operations, perform queries, and solve linear algebra problems.

Table 4.8 lists some LinearAlgebra package commands. For a complete list, refer to the ?LinearAlgebra/Details help page.

Table 4.8: Select LinearAlgebra Package Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basis</td>
<td>Return a basis for a vector space</td>
</tr>
<tr>
<td>CrossProduct</td>
<td>Compute the cross product of two vectors</td>
</tr>
<tr>
<td>DeleteRow</td>
<td>Delete the rows of a matrix</td>
</tr>
<tr>
<td>Dimension</td>
<td>Determine the dimension of a matrix or a vector</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>------------------------------------------------------------------</td>
</tr>
<tr>
<td>Eigenvectors</td>
<td>Compute the eigenvalues and eigenvectors of a matrix</td>
</tr>
<tr>
<td>FrobeniusForm</td>
<td>Reduce a matrix to Frobenius form</td>
</tr>
<tr>
<td>GaussianElimination</td>
<td>Perform Gaussian elimination on a matrix</td>
</tr>
<tr>
<td>HessenbergForm</td>
<td>Reduce a square matrix to Hessenberg form</td>
</tr>
<tr>
<td>HilbertMatrix</td>
<td>Construct a generalized Hilbert matrix</td>
</tr>
<tr>
<td>IsOrthogonal</td>
<td>Test if a matrix is orthogonal</td>
</tr>
<tr>
<td>LeastSquares</td>
<td>Compute the least-squares approximation to $A \cdot x = b$</td>
</tr>
<tr>
<td>LinearSolve</td>
<td>Solve the linear system $A \cdot x = b$</td>
</tr>
<tr>
<td>MatrixInverse</td>
<td>Compute the inverse of a square matrix or pseudo-inverse of a non-square matrix</td>
</tr>
<tr>
<td>QRDecomposition</td>
<td>Compute a QR factorization of a matrix</td>
</tr>
<tr>
<td>RandomMatrix</td>
<td>Construct a random matrix</td>
</tr>
<tr>
<td>SylvesterMatrix</td>
<td>Construct the Sylvester matrix of two polynomials</td>
</tr>
</tbody>
</table>

For information on arithmetic operations, see *Matrix Arithmetic* (page 146).

For information on selecting entries, subvectors, and submatrices, see *Accessing Entries in Matrices and Vectors* (page 144).

**Example** Determine a basis for the space spanned by the set of vectors $\{(2, 13, -15), (7, -2, 13), (5, -4, 9)\}$. Express the vector $(25, -4, 9)$ with respect to this basis.

```plaintext
> with(LinearAlgebra);

> v1 := <2, 13, -15>: v2 := <7, -2, 13>: v3 := <5, -4, 9>:
```

Find a basis for the vector space spanned by these vectors, and then construct a matrix from the basis vectors.
To express \((25, -4, 9)\) in this basis, use the \texttt{LinearSolve} command.

\begin{align*}
\texttt{LinearSolve(basis, \langle 25, -4, 9 \rangle)}
\end{align*}

```
\begin{bmatrix}
170 \\
91 \\
-285 \\
91 \\
786 \\
91
\end{bmatrix}
```

**Numeric Computations**

You can very efficiently perform computations on large matrices and vectors that contain floating-point data using the built-in library of numeric linear algebra routines. Some of these routines are provided by the Numerical Algorithms Group (NAG®). Maple also contains portions of the CLAPACK and optimized ATLAS libraries.

For information on performing efficient numeric computations using the \texttt{LinearAlgebra} package, refer to the \texttt{EfficientLinearAlgebra} help page.

See also *Creating Matrices and Vectors for Large Problems* (page 141).

**Student LinearAlgebra Package**

The \texttt{Student} package contains subpackages that help instructors teach concepts and allow students to visualize and explore ideas. These subpackages also contain computational commands.
In the Student[LinearAlgebra] subpackage, the environment differs from that of the LinearAlgebra package in that floating-point computations are generally performed using software precision, instead of hardware precision, and symbols are generally assumed to represent real, rather than complex, quantities. These defaults, and others, can be controlled using the SetDefault command. For more information, refer to the ?Student[LinearAlgebra][SetDefault] help page.

For information on using Maple as a teaching and learning tool, see Teaching and Learning with Maple (page 180).

4.4 Calculus

The Task Browser (Tools→Tasks→Browse) contains numerous calculus task templates. For a list of tasks, navigate to one of the related folders, such as Calculus, Differential Equations, Multivariate Calculus, or Vector Calculus.

This section describes the key Maple calculus commands, many of which are used in task templates or available in the context menus.

For a complete list of calculus commands, refer to the Mathematics (including Calculus, Differential Equations, Power Series, and Vector Calculus subfolders) and Student Package sections of the Maple Help System Table of Contents.

Limits

To compute the limit of an expression as the independent variable approaches a value:

1. In the Expression palette, click the limit item $\lim_{x \to a} f$.

2. Specify the independent variable, limit point, and expression, and then evaluate it.
For example:

\[
> \lim_{x \to 0} \left( \frac{x}{\sin(x)} \right)
\]

\[
1
\]

**The limit Command**

By default, Maple searches for the real bidirectional limit (unless the limit point is \(\infty\) or \(-\infty\)). To specify a direction, include one of the options *left*, *right*, *real*, or *complex* in a call to the *limit* command. See Table 4.9.

<table>
<thead>
<tr>
<th>Limit</th>
<th>Command Syntax</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>(\lim_{x \to 0} \left( \frac{1}{x} \right))</td>
<td>&gt; limit((\frac{1}{x}), x = 0)</td>
<td><em>undefined</em></td>
</tr>
<tr>
<td>(\lim_{x \to 0^+} \left( \frac{1}{x} \right))</td>
<td>&gt; limit((\frac{1}{x}), x = 0, 'right')</td>
<td>(\infty)</td>
</tr>
<tr>
<td>(\lim_{x \to 0^-} \left( \frac{1}{x} \right))</td>
<td>&gt; limit((\frac{1}{x}), x = 0, 'left')</td>
<td>(-\infty)</td>
</tr>
</tbody>
</table>

Using the *limit* command, you can also compute multidimensional limits.

\[
> \text{limit}\left( \frac{x^2}{y}, \{x = 1, y = \infty\} \right)
\]

\[
0
\]

For more information on multidimensional limits, refer to the *?limit/multi* help page.
**Numerically Computing a Limit**

To numerically compute a limit:

- Use the `evalf(Limit(arguments))` calling sequence.

**Important:** Use the inert `Limit` command, not the `limit` command. For more information, refer to the `?limit` help page.

The `Limit` command accepts the same arguments as the `limit` command.

For example:

```maple
> evalf(Limit(sin(x)/(cos(x)+tan(x)), x = 1.225))
```

```
0.3020605357
```

For information on the `evalf` command, see *Numerical Approximation* (page 317).

The `Limit` command does not compute the limit. It returns an unevaluated limit.

```maple
> Limit(sin(x)/(cos(x)+tan(x)), x = 1.225)
```

```
\lim_{x \to 1.2250000000000000} \left( \frac{\sin(x)}{\cos(x) + \tan(x)} \right)
```

For more information on the `Limit` command, refer to the `?Limit` help page.

**Differentiation**

Maple can perform symbolic and numeric differentiation.
To differentiate an expression:

1. In the Expression palette, click the differentiation item \( \frac{d}{dx} \) or the partial differentiation item \( \frac{\partial}{\partial x} \).

2. Specify the expression and independent variable, and then evaluate it.

For example, to differentiate \( x \sin(ax) \) with respect to \( x \):

\[
> \quad \frac{d}{dx} (x \sin(ax))
\]

\[
\sin(ax) + x \cos(ax) a
\]

You can also differentiate using context menus. For more information, see Context Menus (page 21).

To calculate a higher order or partial derivative, edit the derivative symbol inserted. For example, to calculate the second derivative of \( x \sin(ax) + x^2 \) with respect to \( x \):

\[
> \quad \frac{d^2}{dx^2} (x \sin(ax)+x^2)
\]

\[
2 \cos(ax) a - x \sin(ax) a^2 + 2
\]

To calculate the mixed partial derivative of \( x \sin(3y) + y x^5 \):

\[
> \quad \frac{\partial^2}{\partial y \partial x} (x \sin(3y)+yx^5)
\]
The diff Command

Maple computes derivatives using the `diff` command. To directly use the `diff` command, specify the expression to differentiate and the variable.

```
> x \sin(ax) + x^2
```

```
x \sin(ax) + x^2
```

(4.1)

```
> diff((4.1), x)
```

```
sin(ax) + x \cos(ax) a + 2x
```

For information on equation labels such as (4.1), see Equation Labels (page 59).

To calculate a higher order derivative, specify a sequence of differentiation variables. Maple recursively calls the `diff` command.

```
> diff((4.1), x, x)
```

```
2 \cos(ax) a - x \sin(ax) a^2 + 2
```

To calculate a partial derivative, use the same syntax. Maple assumes that the derivatives commute.

```
> diff(x \sin(3y) + y \sqrt{x}, x, y)
```

```
3 \cos(3y) + \frac{1}{2 \sqrt{x}}
```

To enter higher order derivatives, it is convenient to use the sequence operator ($\ldots$). For more information, refer to the `$\ldots$` help page.
To compute the $n^{\text{th}}$ derivative of an expression $f$ in the independent variable $t$, you can use the syntax $\text{diff}(f, t^n)$.

For example:

\begin{verbatim}
> diff(cos(t), t^5)

         -sin(t)
\end{verbatim}

**Differentiating an Operator**

You can also specify a mathematical function as a *functional operator* (a mapping). For a comparison of operators and other expressions, see Distinction between Functional Operators and Other Expressions (page 297).

**To find the derivative of a functional operator:**

- Use the D operator.

The D operator returns a functional operator.

For example, find the derivative of an operator that represents the mathematical function $x \cos(x)$.

First, define the mathematical function $x \cos(x)$ as the operator $F$.

1. In the Expression palette, click the single-variable function definition item $\text{f := a \rightarrow y}$.

2. Enter placeholder values.

- To move to the next placeholder, press the Tab key. **Note:** If pressing the Tab key inserts a tab, click the Tab icon $\text{[Tab]}$ in the toolbar.

\begin{verbatim}
> F := x \rightarrow x \cos(x):
\end{verbatim}

Now, define the operator, $G$, that maps $x$ to the derivative of $x \cos(x)$. 

For more information on the D operator, refer to the ?D help page. For a comparison of the diff command and D operator, refer to the ?diffVersusD help page.

**Directional Derivative**

To compute and plot a directional derivative, use the **Directional Derivative Tutor**. The tutor computes a floating-point value for the directional derivative.

**To launch the tutor:**

From the Tools menu, select Tutors, Calculus - Multi-Variable, and then Directional Derivatives. Maple launches the Directional Derivative Tutor. See Figure 4.7.
To compute a symbolic value for the directional derivative, use the `Student[MultivariateCalculus][DirectionalDerivative]` command. The first list of numbers specifies the point at which to compute the derivative. The second list of numbers specifies the direction in which to compute the derivative.

For example, at the point [1, 2], the gradient of $x^2 + y^2$ points in the direction [2, 4], which is the direction of greatest increase. The directional derivative in the orthogonal direction [-2, 1] is zero.

```maple
> with(Student[MultivariateCalculus]):
```
> DirectionalDerivative\( (x^2 + y^2, [x, y] = [1, 2], [1, 2]) \);

\[2 \sqrt{5}\]

> DirectionalDerivative\( (x^2 + y^2, [x, y] = [1, 2], [-2, 1]) \);

0

**Series**

To generate the Taylor series expansion of a function about a point, use the `taylor` command.

> taylor\( (\sin(4x)\cos(x), x=0) \)

\[4x - \frac{38}{3} x^3 + \frac{421}{30} x^5 + O(x^6)\]

**Note:** If a Taylor series does not exist, use the `series` command to find a general series expansion.

For example, the cosine integral function does not have a Taylor series expansion about 0. For more information, refer to the `?Ci` help page.

> taylor\( (\operatorname{Ci}(x), x=0) \)

Error, does not have a Taylor expansion, try series()

To generate a truncated series expansion of a function about a point, use the `series` command.

> series\( (\operatorname{Ci}(x), x=0) \)

\[\gamma + \ln(x) - \frac{1}{4} x^2 + \frac{1}{96} x^4 + O(x^6)\]
By default, Maple performs series calculations up to order 6. To use a different order, specify a non-negative integer third argument.

> expansion := series(Ci(t), t = 0, 4)

\[
\text{expansion} := \gamma + \ln(t) - \frac{1}{4} t^2 + O(t^4)
\]

To set the order for all computations, use the \textbf{Order} environment variable. For information about the \textbf{Order} variable and the \(O(t^4)\) term, refer to the \texttt{?Order} help page.

The expansion is of type \textbf{series}. Some commands, for example, \texttt{plot}, do not accept arguments of type \textbf{series}. To use the expansion, you must convert it to a polynomial using the \texttt{convert/polynom} command.

> plot([Ci(t), convert(expansion, polynom)], t = \frac{1}{100} .. 2)
For information on Maple types and type conversions, see *Maple Expressions* (page 289).

For information on plotting, see *Plots and Animations* (page 189).

**Integration**

Maple can perform symbolic and numeric integration.

**To compute the indefinite integral of an expression:**

1. In the **Expression** palette, click the indefinite integration item $\int f \, dx$.
2. Specify the integrand and variable of integration, and then evaluate it.

For example, to integrate $x \sin(ax)$ with respect to $x$:

```maple
> int(x*sin(a*x), x)
```

$$\frac{\sin(ax) - x \cos(ax) a}{a^2}$$

Recall that you can also enter symbols, including $\int$ and $d$, using symbol completion.

- Enter the symbol name (or part of the name), for example, *int* and *d*, and then press the completion shortcut key.

For more information, see *Symbol Names* (page 17).

You can also compute an indefinite integral using context menus. For more information, see *Context Menus* (page 21).
To compute the definite integral of an expression:

1. In the Expression palette, click the definite integration item \( \int_{a}^{b} \).

2. Specify the endpoints of the interval of integration, integrand expression, and variable of integration, and then evaluate it.

For example, to integrate \( e^{-at} \ln(t) \) over the interval \((0, \infty)\):

\[
\lim_{t \to \infty} \left( -\frac{e^{-at} \ln(t) + \text{Ei}(1, at) + \gamma + \ln(a)}{a} \right)
\]

Maple treats the parameter \( a \) as a complex number. As described in Assumptions on Variables (page 116), you can compute under the assumption that \( a \) is a positive, real number using the assuming command.

\[
> \int_{0}^{\infty} e^{-at} \ln(t) \, dt \text{ assuming } a > 0
\]

The int Command

\[
\int_{a}^{b} f(x) \, dx \text{ and } \int_{a}^{b} f(x) \, dx \text{ use the int command. To use the int command directly, specify the following arguments.}
\]

- Expression to integrate
- Variable of integration
For a definite integration, set the variable of integration equal to the interval of integration.

\[ \int (4.3), x \]

\[ \sin(a \cdot x) - x \cos(a \cdot x) \cdot a \quad \frac{a}{a^2} \]

For a definite integration, set the variable of integration equal to the interval of integration.

\[ \int (4.3), x = 0., \frac{\pi}{a} \]

\[ \frac{\pi}{a^2} \]

**Numeric Integration**

**To perform numeric integration:**

- Use the `evalf(Int(arguments))` calling sequence.

**Important:** Use the inert `Int` command, not the `int` command. For more information, refer to the `?int` help page.

In addition to the arguments accepted by the `int` command, you can include optional arguments such as `method`, which specifies the numeric integration method.
Note: To enter an underscore character (\_) in 2-D Math, enter \_.

For information on the `evalf` command, see Numerical Approximation (page 317).

For information on numeric integration, including iterated integration and controlling the algorithm, refer to the `?evalf/Int` help page.

To compute iterated integrals, line integrals, and surface integrals, use the task templates (Tools→Tasks→Browse) in the Multivariate and Vector Calculus folders.

**Differential Equations**

Maple has a powerful set of solvers for ordinary differential equations (ODEs) and partial differential equations (PDEs), and systems of ODEs and PDEs.

For information on solving ODEs and PDEs, see Other Specialized Solvers (page 88).

**Calculus Packages**

In addition to top-level calculus commands, Maple contains calculus packages.

**VectorCalculus Package**

The VectorCalculus package contains commands that perform multivariate and vector calculus operations on VectorCalculus vectors (vectors with an additional coordinate system attribute) and vector fields (vectors with additional coordinate system and vectorfield attributes), for example, Curl, Flux, and Torsion.
> with(VectorCalculus):

> SetCoordinates( 'cartesian'[x,y,z]):

> VectorField1 := VectorField( < -y, x, z > )

$$
\text{VectorField1} := \begin{bmatrix}
-y \\
x \\
z
\end{bmatrix}
$$

Find the curl of VectorField1.

> Curl(VectorField1);

$$
\begin{bmatrix}
0 \\
0 \\
2
\end{bmatrix}
$$

Find the flux of VectorField1 through a sphere of radius r at the origin.

> Flux(VectorField1, Sphere( < 0,0,0>, r ))

$$\frac{4}{3} r^3 \pi$$

Compute the torsion of a space curve. The curve must be a vector with parametric function components.

> simplify(Torsion( < t, t^2, t^3 >, t )) assuming t::real

$$\frac{3}{9 t^4 + 9 t^2 + 1}$$

For information on the assuming command, see The assuming Command (page 119).
For more information on the VectorCalculus package, including a complete list of commands, refer to the ?VectorCalculus help page.

To find other calculus packages, such as VariationalCalculus, refer to the ?index/package help page.

Student Calculus Packages

The Student package contains subpackages that help instructors teach concepts and allow students to visualize and explore ideas. These subpackages also contain computational commands. The Student calculus subpackages include Calculus1, MultivariateCalculus, and VectorCalculus. The Student[VectorCalculus] package provides a simple interface to a limited subset of the functionality available in the VectorCalculus package.

For information on using Maple as a teaching and learning tool, and some computational examples, see Teaching and Learning with Maple (page 180).

4.5 Optimization

Using the Optimization package, you can numerically solve optimization problems. The package uses fast Numerical Algorithms Group (NAG) algorithms to minimize or maximize an objective function.

The Optimization package solves constrained and unconstrained problems.

• Linear programs
• Quadratic programs
• Nonlinear programs
• Linear and nonlinear least-squares problems

The Optimization package contains local solvers. In addition, for univariate finitely-bounded nonlinear programs with no other constraints, you can compute global solutions using the NLPSolve command. To find global solutions generally, purchase the Global Optimization Toolbox. For more information, visit http://www.maplesoft.com/products/toolboxes.
Point-and-Click Interface

The primary method for solving optimization problems is the Optimization Assistant.

To launch the Optimization Assistant:

- From the Tools menu, select Assistants, and then Optimization.

Maple inserts the Optimization[Interactive]() calling sequence (in Worksheet mode), and launches the Optimization Assistant. See Figure 4.8.

![Optimization Assistant](image)

Figure 4.8: Optimization Assistant
To solve a problem:

1. Enter the objective function, constraints, and bounds.

2. Select the Minimize or Maximize radio button.

3. Click the Solve button. The solution is displayed in the Solution text box.

You can also enter the problem (objective function, constraints, and bounds) in the calling sequence.

For example, find the maximum of $x^3y - y^2$ subject to the constraints $x + y \leq 6, x \in [0,5], y \in [0,5]$.

\[
> \quad \text{Optimization[Interactive]}(x^3y - y^2, \{x + y \leq 6, x = 0..5, y = 0..5\})
\]

\[
[134.491161539748162, [x = 4.53559292539129189, y = 1.46440707460870746]]
\]

After finding a solution, you can plot it. To plot a solution:

In the Optimization Assistant window, click the Plot button. The Optimization Plotter window is displayed. See Figure 4.9.
For information on the algorithms used to solve optimization problems, refer to the \texttt{\textasciitilde Optimization/Methods} help page.

**Large Optimization Problems**

The \texttt{Optimization Assistant} accepts input in an algebraic form. You can specify input in other forms, described in the \texttt{\textasciitilde Optimization/InputForms} help page, in command calling sequences.
The Matrix form, described in the ?Optimization/MatrixForm help page, is more complex but offers greater flexibility and efficiency.

For example, solve the quadratic program:

\[
\text{maximize} \quad c^T x + \frac{1}{2} x^T H x \quad \text{subject to} \quad A x \leq b, \text{ where } x \text{ is the vector of problem variables.}
\]

Define the column vector, \( c \), of the quadratic objective function.

> \( c \) := Vector([2, 5], 'datatype'='float');

Define the symmetric Hessian matrix, \( H \), of the quadratic objective function.

> \( H \) := Matrix([[6,3],[3,4]],'datatype'='float');

Define the matrix \( A \), the coefficient matrix for the linear inequality constraints.

> \( A \) := Matrix([[-1,1]],'datatype'='float');

Define the column vector \( b \), the linear inequality constraints.

> \( b \) := Vector([-2],'datatype'='float');

The \texttt{QPSolve} command solves quadratic programs.

\[
\text{interface(displayprecision}=18):
\]

> \texttt{Optimization[QPSolve]}([[c,H],[A,b]])

\[
\begin{bmatrix}
-3.53333333333333 & 0.466666666666666664 \\
-1.6000000000000030 & 1
\end{bmatrix}
\]
Note: For information on creating matrices and vectors (including how to use the Matrix palette to easily create matrices), see Linear Algebra (page 135).

For additional information on performing efficient computations, refer to the ?Optimization/Computation help page.

MPS(X) File Support

To import linear programs from a standard MPS(X) data file, use the Import-MPS command.

Additional Information

For a complete list of commands and other Optimization package information, refer to the ?Optimization help page.

4.6 Statistics

The Statistics package is a collection of commands and the point-and-click Data Analysis Assistant—refer to the ?Statistics[InteractiveDataAnalysis] help page—for performing computations in mathematical statistics and data analysis. The package supports a wide range of common statistical tasks including quantitative and graphical data analysis, simulation, and curve fitting.

In addition to standard data analysis tools, the Statistics package provides a wide range of symbolic and numeric tools for computing with random variables. The package supports over 35 major probability distributions and can be extended to include new distributions.

Probability Distributions and Random Variables

The Statistics package supports:

- Continuous distributions, which are defined along the real line by probability density functions. Maple supports many continuous distributions, including the normal, Student-t, Laplace, and logistic distributions.
• Discrete distributions, which have nonzero probability only at discrete points. A discrete distribution is defined by a probability function. Maple supports many discrete distributions, including the Bernoulli, geometric, and Poisson distributions.

For a complete list of distributions, refer to the ?Statistics/Distributions help page.

You can define random variables by specifying a distribution in a call to the RandomVariable command.

\[ \text{with}(\text{Statistics}) : \]

\[ X := \text{RandomVariable}(\text{Poisson}(\lambda)) : \]

Find the probability distribution function for \(X\). (For information on statistics computations, see Statistical Computations (page 175)).

\[ PDF(X,t) \]

\[ \sum_{k=0}^{\infty} \frac{\lambda^k e^{-\lambda} \Delta(t-k)}{k!} \]

(4.4)

Adding Custom Distributions

To add a new distribution, specify a probability distribution in a call to the Distribution command.

\[ U := \text{Distribution} \left( t \rightarrow \begin{cases} \frac{1}{3} & t < 3 \\ 0 & \text{otherwise} \end{cases} \right) : \]

To construct a piecewise-continuous function in 1-D Math, use the piecewise command, for example, \( t \rightarrow \text{piecewise}(t < 0, 0, t < 3, \frac{1}{3}, 0) \).
Define a new random variable with this distribution.

> \( Z := \text{RandomVariable}(U) : \text{PDF}(Z, t) \)

\[
\begin{align*}
0 & \quad t < 0 \\
\frac{1}{3} & \quad t < 3 \\
0 & \quad \text{otherwise}
\end{align*}
\]

Calculate the mean value of the random variable.

> \( \text{Mean}(Z) \)

\[
\frac{3}{2}
\]

For more information, refer to the ?Statistics/Distributions help page.

**Statistical Computations**

In addition to basic functions, like mean, median, standard deviation, and percentile, the Statistics package contains commands that compute, for example, the interquartile range and hazard rate.

**Example 1**

Compute the average absolute range from the interquartile of the Rayleigh distribution with scale parameter 3.

> \( \text{InterquartileRange}(\text{Rayleigh}(3)) \)

\[
\sqrt{36 \ln(2)} - \sqrt{-18 \ln\left(\frac{3}{4}\right)}
\]

To compute the result numerically:

- Specify the 'numeric' option.
Example 2

Compute the hazard rate of the Cauchy distribution with location and scale parameters \( a \) and \( b \) at an arbitrary point \( t \).

\[
\text{HazardRate}(\text{Cauchy}(a, b), t) = \frac{1}{\pi b \left( 1 + \frac{(t - a)^2}{b^2} \right) \left( \frac{1}{2} - \frac{\arctan \left( \frac{t - a}{b} \right)}{\pi} \right)}
\]

You can specify a value for the point \( t \).

\[
\text{HazardRate} \left( \text{Cauchy}(a, b), \frac{1}{2} \right)
\]

You can also specify that Maple compute the result numerically.

\[
\text{HazardRate} \left( \text{Cauchy}(10, 1), \frac{1}{2}, \text{'numeric'} \right)
\]

For more information, refer to the \texttt{?Statistics/DescriptiveStatistics} help page.
Plotting

You can generate statistical plots using the visualization commands in the Statistics package. Available plots include:

- Bar chart
- Frequency plot
- Histogram
- Pie Chart
- Scatter Plot

For example, create a scatter plot for a distribution of points that vary from $\sin\left(\frac{2 \pi x}{200}\right)$ by a small value determined by a normally distributed sample.

> $N := 200$:

> $U := Sample(Normal(0, 1), N)$:

> $X := \langle seq(x, x = 1 .. N) \rangle$:

> $Y := \langle seq(\sin\left(\frac{2 \pi x}{N}\right) + \frac{U[x]}{5}, x = 1 .. N) \rangle$:
For information on plotting options, such as title, see Plots and Animations (page 189).

To fit a curve to the data points, include the optional fit equation parameter.

Using the plots[display] command, create a plot that contains the:

- Scatter plot of the data points
- Quartic polynomial fitted to the data points:
  \[ f(x) = ax^4 + bx^3 + cx^2 + dx + e \]
- Function \( \sin(2\pi x/N) \)

\[
> \text{P := ScatterPlot}(X, Y, \text{fit} = [ax^4 + bx^3 + cx^2 + dx + e, x], \text{thickness} = 2); 
\]
For more information on statistical plots, refer to the `Statistics/Visualization` help page.

For an overview of plotting, see *Plots and Animations (page 189)*.

**Additional Information**

For more information on the `Statistics` package, including regression analysis, estimation, data manipulation, and data smoothing, refer to the `Statistics` help page.
4.7 Teaching and Learning with Maple

Table 4.10 resources for instructors and students. For additional resources see Table 4.1 (page 123).

Table 4.10: Student and Instructor Resources

<table>
<thead>
<tr>
<th>Resource</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Student Packages and Tutors</td>
<td>The Student package contains computational and visualization (plotting and animation) functionality, and point-and-click interfaces for explaining and exploring concepts (Tools→Tutors). For more information, refer to the ?Student help page.</td>
</tr>
<tr>
<td>Mathematics and Engineering Dictionary</td>
<td>The Maple Help System has an integrated dictionary of over 5000 mathematics and engineering terms. You can search the dictionary using the Help System search engine. (Help→Manuals, Dictionary, and more→Dictionary)</td>
</tr>
<tr>
<td>Maple Application Center™</td>
<td>The Maple Application Center contains tutorials and applications that help instructors begin using Maple and use Maple in the classroom. Browse the many resources in the Education and Education PowerTools categories. (<a href="http://www.maplesoft.com/applications">http://www.maplesoft.com/applications</a>)</td>
</tr>
</tbody>
</table>
The Maple Student Help Center contains tutorials and applications that help students learn how to use Maple, explore mathematical concepts, and solve problems. Available resources include:

- Study guides - Complete lessons with examples for academic courses, including precalculus and calculus. For example, the Interactive Precalculus Study Guide contains worked problems, each solved as in a standard textbook, using Maple commands and custom Maplet graphical interfaces.

- Free course lessons for many subjects including precalculus to vector calculus; high school, abstract, and linear algebra; engineering; physics; differential equations; cryptography; and classical mechanics. ([http://www.maplesoft.com/academic/students](http://www.maplesoft.com/academic/students))

### Student Packages and Tutors

The **Student** package is a collection of subpackages for teaching and learning mathematics and related subjects. The **Student** package contains packages for a variety of subjects, including precalculus, calculus, and linear algebra.

Instructors can:

- Teach concepts without being distracted by the mechanics of the computations.

- Create examples and quickly update them during a lesson to demonstrate different cases or show the effect of the variation of a parameter.

- Create plots and animations to visually explain concepts, for example, the geometric relationship between a mathematical function and its derivatives ([Tools→Tutors→Calculus - Single Variable→Derivatives]). See Figure 4.10.
Students can:

- Perform step-by-step computations, for example, compute a derivative by applying differentiation rules using commands or a tutor (Tools→Tutors→Calculus - Single Variable→Differentiation Methods). See Figure 4.11.
- Perform computations.
- Visually explore concepts.
Tutors provide point-and-click interfaces to the Student package functionality.

To launch a tutor:

1. From the Tools menu, select Tutors.
2. Select a subject, for example, Calculus - Multi-Variable.
3. Select a tutor, for example, Gradients.
Maple inserts the `Student[MultivariateCalculus][GradientTutor]()` calling sequence (in Worksheet mode), and launches the **Multivariate Calculus Gradient Tutor**.

By rotating the three-dimensional plot, you can show that the gradient points in the direction of greatest increase of the surface (see Figure 4.12) and show the direction of the gradient vector in the x-y plane (see Figure 4.13).

![Multivariate Calculus Gradient Tutor](image)

Figure 4.12: Multivariate Calculus Gradient Tutor
When you close the tutor, Maple inserts the 3-D plot.

```maple
> Student[MultivariateCalculus][GradientTutor]( );
```

**Figure 4.13: Multivariate Calculus Gradient Tutor Showing x-y Plane**
Many Student package commands can return a value, mathematical expression, plot, or animation. This allows you to compute the final answer, see the general formula applied to a specific problem, or visualize the underlying concepts.

For example, the Student[VectorCalculus][LineInt] (line integral) command can return the following.

- Plot that visually indicates the vector field, path of integration, and tangent vectors to the path
- Unevaluated line integral
- Numeric value of the line integral

```markdown
> with(Student[VectorCalculus]):
```
To evaluate the integral returned by the `output = integral` calling sequence, use the `value` command.

\[ \int_{0}^{2\pi} \left( -\sin(t)^2 - \cos(t)^2 \right) \, dt \quad (4.5) \]

By default, the `LineInt` command returns the value of the integral.
\[ \text{LineInt}(\text{VectorField}( <y-x, -x-y> ), \text{Circle}( <0,0>, r )) \]

\[ -2 \pi r^2 \]

For more information on the \textbf{Student} package, refer to the \texttt{?Student} help page.
5  Plots and Animations

Maple can generate many forms of plots, allowing you to visualize a problem and further understand concepts.

- Maple accepts explicit, implicit, and parametric forms to display 2-D and 3-D plots and animations.
- Maple recognizes many coordinate systems.
- All plot regions in Maple are active; therefore, you can drag expressions to and from a plot region.
- Maple offers numerous plot options, such as axes styles, title, colors, shading options, surface styles, and axes ranges, which give you complete control to customize your plots.

5.1  In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| Creating Plots - Interactive and command-driven methods to display 2-D and 3-D plots | • **Interactive Plot Builder**  
  • Context Menu  
  • Dragging to a Plot Region  
  • The `plot` and `plot3d` Commands  
  • The `plots` Package  
  • Multiple Plots in the Same Plot Region |
| Customizing Plots - Methods for applying plot options before and after a plot displays | • **Interactive Plot Builder** Options  
  • Context Menu Options  
  • The `plot` and `plot3d` Command Options |
<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Analyzing Plots - Plot analyzing tools</td>
<td>• Point Probe</td>
</tr>
<tr>
<td></td>
<td>• Rotate</td>
</tr>
<tr>
<td></td>
<td>• Pan</td>
</tr>
<tr>
<td></td>
<td>• Zoom</td>
</tr>
<tr>
<td>Creating Animations - Interactive and command-driven methods to display animations</td>
<td>• <strong>Interactive Plot Builder</strong></td>
</tr>
<tr>
<td></td>
<td>• The <code>plots[animate]</code> Command</td>
</tr>
<tr>
<td>Playing Animations - Tools to run animations</td>
<td>• Animation Context Bar</td>
</tr>
<tr>
<td>Customizing Animations - Methods for applying plot options before and after an animation displays</td>
<td>• <strong>Interactive Plot Builder</strong> Animation Options</td>
</tr>
<tr>
<td></td>
<td>• Context Menu Options</td>
</tr>
<tr>
<td></td>
<td>• The <code>animate</code> Command Options</td>
</tr>
<tr>
<td>Exporting - Methods for exporting plots</td>
<td>• Saving Plots to File Formats</td>
</tr>
<tr>
<td>Code for Color Plates - Information on color plates</td>
<td>• Accessing Code for the Color Plates</td>
</tr>
</tbody>
</table>

## 5.2 Creating Plots

Maple offers several methods to easily plot an expression. These methods include:

- The **Interactive Plot Builder**
- Context menus
- Dragging to a plot region
- Commands

Each method offers a unique set of advantages. The method you use depends on the type of plot to display, as well as your personal preferences.
Interactive Plot Builder

The **Interactive Plot Builder** is a point-and-click interface to the Maple plotting functionality. The interface displays plot types based on the expression you specify. The available plot types include plots, interactive plots, animations, or interactive animations. Depending on the plot type you select, you can create a:

- 2-D / 3-D plot
- 2-D polar plot
- 2-D / 3-D conformal plot of a complex-valued function
- 2-D / 3-D complex plot
- 2-D density plot
- 2-D gradient vector-field plot
- 2-D implicit plot

Using the **Interactive Plot Builder**, you can:

1. Specify the plotting domain before you launch the graph
2. Specify the endpoints of the graph as symbolic, for example, Pi, sqrt(2)
3. Select different kinds of graphs such as animations, and interactive with slider control of the parameter, that is, customize and display a plot by selecting from the numerous plot types and applying plot options without any knowledge of plotting command syntax
4. Apply the `discont=true` option for a discontinuous graph

The output from the **Interactive Plot Builder** is a plot of the expression or the command used to generate the plot in the document.
To launch the **Interactive Plot Builder**:

- From the **Tools** menu, select **Assistants**, and then **Plot Builder**. Note: The **Tools** menu also offers tutors to easily generate plots in several academic subjects. For more information, see *Teaching and Learning with Maple* (page 180).

### Table 5.1: Windows of the Interactive Plot Builder

<table>
<thead>
<tr>
<th>1. Specify Expressions window</th>
<th>2. Select Plot Type window</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Specify Expressions window" /></td>
<td><img src="image2.png" alt="Select Plot Type window" /></td>
</tr>
</tbody>
</table>

**1. Specify Expressions window** - Add, edit, or remove expressions and variables. Once finished, you can advance to the **Select Plot Type** window.

**2. Select Plot Type window** - Select the plot type and corresponding plot, and edit the ranges. Once finished, you can display the plot or advance to the **Plot Options** window.
3. **Plot Options window** - Apply plot options. Once finished, you can display the plot or return the command that generates the plot to the document.
Example 1 - Display a plot of a single variable expression

Maple can display two-dimensional graphs and offers numerous plot options such as color, title, and axes styles to customize the plot.

Table 5.2: Displaying a Plot of a Single Variable Expression

<table>
<thead>
<tr>
<th>Step</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Launch the <strong>Interactive Plot Builder</strong>.</td>
<td>1. Ensure the cursor is in a Maple input region.</td>
</tr>
<tr>
<td></td>
<td>2. From the <strong>Tools</strong> menu, select <strong>Assistants</strong>, and then <strong>Plot Builder</strong>.</td>
</tr>
<tr>
<td></td>
<td>Notes: 1. Maple inserts <code>plots[interactive]()</code>; in the Maple document. Entering this command</td>
</tr>
<tr>
<td></td>
<td>at the Maple prompt also invokes the Plot Builder.</td>
</tr>
<tr>
<td></td>
<td>2. Interaction with the document is disabled while the <strong>Plot Builder</strong> is running.</td>
</tr>
<tr>
<td>Enter an expression.</td>
<td>1. In the <strong>Specify Expressions</strong> window:</td>
</tr>
<tr>
<td></td>
<td>a. Add the expression, <code>sin(x)/x</code>.</td>
</tr>
<tr>
<td></td>
<td>b. Click <strong>Done</strong> to proceed to the <strong>Select Plot Type</strong> window.</td>
</tr>
</tbody>
</table>
## 5.2 Creating Plots • 195

<table>
<thead>
<tr>
<th>Step</th>
<th>Details</th>
</tr>
</thead>
</table>
| Plot the expression. | 1. In the **Select Plot Type** window, notice the default setting of a 2-D plot type and an x axis range, `-10 .. 10`. Notice also the various plot types available for this expression.  
2. Click **Plot**. |

To see the Maple syntax used to generate this plot, see *Maple commands from Creating Plots: Interactive Plot Builder* (page 209)

**Example 2 - Display a plot of multiple expressions of 1 variable**

Maple can display multiple expressions in the same plot region to compare and contrast. The **Interactive Plot Builder** accepts multiple expressions.
Table 5.3: Displaying a Plot of Multiple Expressions of 1 Variable

<table>
<thead>
<tr>
<th>Step</th>
<th>Details</th>
</tr>
</thead>
</table>
| Launch the **Interactive Plot Builder** and enter the expressions. | 1. Launch the **Interactive Plot Builder**.  
The **Plot Builder** accepts expressions and performs basic calculations on expressions. For example, entering 
\( \text{diff}(\sin(x^2), x) \) in the **Specify Expression** window  
performs the calculation and displays the expression  
as \( 2*\cos(x^2)*x \) in the **Expression** group box.  
2. In the **Specify Expressions** window:  
a. In three separate steps, add the expressions  
\( \sin(x^2), \text{diff}(\sin(x^2), x), \text{and int}(\sin(x^2), x) \). |
| Change the x-axis range.                                             | In the **Select Plot Type** window:  
a. Change the x Axis range to -3 .. 3.  
b. Click **Options** to proceed to the **Plot Options** window. |
| Launch the **Plot Options** window and return the **plot** command syntax to the document. | Click **Command**. |
| Display the actual plot.                                            | Execute the inserted command, that is, display the plot. |
By default, Maple displays each plot in a plot region using a different color. You can also apply a line style such as solid, dashed, or dotted for each expression in the graph. For more information, refer to the \texttt{plot/options} help page. To see the Maple syntax used to generate this plot, see \textit{Maple commands from Creating Plots: Interactive Plot Builder} (page 209)

\textbf{Example 3 - Display a plot of a multi-variable expression}

Maple can display three-dimensional plots and offers numerous plot options such as light models, surface styles, and shadings to allow you to customize the plot.

\begin{table}[h]
\centering
\begin{tabular}{|l|l|}
\hline
\textbf{Step} & \textbf{Details} \\
\hline
Launch the \textbf{Interactive Plot Builder} and enter an expression. & Add the expression $\frac{(1+\sin(xy))}{x^2+y^2}$. \\
\hline
\end{tabular}
\end{table}
<table>
<thead>
<tr>
<th>Step</th>
<th>Details</th>
</tr>
</thead>
</table>
| Launch the **Plot Options** window. | In the **Select Plot Type** window:  
  a. Notice the available plot types for an expression with 2 variables, as well as the plot objects for each type.  
  b. Click **Options**. |
| Set plot options. | In the **Plot Options** window:  
  a. From the **Variables** column at the top of the dialog, change the **Range from** field to  
     \[0 \ldots 0.05\].  
  b. From the **Label** column, enter \(z\).  
  c. From the **Style** group box, select **patch w/o grid**.  
  d. From the **Color** group box, in the **Light Model** drop-down menu, select **green-red**.  
  e. From the **Color** group box, in the **Shading** drop-down menu, select **z (grayscale)**.  
  f. From the **Miscellaneous** group box, in the **Grid Size** drop-down menu, select **40, 40**. |
To see the Maple syntax used to generate this plot, see *Maple commands from Creating Plots: Interactive Plot Builder* (page 209)

**Example 4 - Display a conformal plot**

Maple can display a conformal plot of a complex expression mapped onto a two-dimensional grid or plotted on the Riemann sphere in 3-D.

**Table 5.5: Displaying a Conformal Plot**

<table>
<thead>
<tr>
<th>Step</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Launch the <strong>Interactive Plot Builder</strong> and enter an expression.</td>
<td>Add the expression $z^3$.</td>
</tr>
</tbody>
</table>
### Details

In the Select Plot Type window:

a. From the Select Plot group box, select **2-D conformal plot of a complex-valued function**.

b. Change the range of the \( z \) parameter to \( 0 \ldots 2+2i \).

Set plot options.

In the Plot Options window:

a. From the Axes group box, select **normal**.

b. From the Miscellaneous group box, select the Grid Size drop-down menu option **30, 30**.

Plot the expression.

Click **Plot**.

![Plot of the expression](image)
Example 5 - Display a plot in polar coordinates

Cartesian (ordinary) coordinates is the Maple default. Maple also supports numerous other coordinate systems, including hyperbolic, inverse elliptic, logarithmic, parabolic, polar, and rose in two-dimensions, and bipolar cylindrical, bispherical, cylindrical, inverse elliptical cylindrical, logarithmic cosh cylindrical, Maxwell cylindrical, tangent sphere, and toroidal in three-dimensional plots. For a complete list of supported coordinate systems, refer to the ?coords help page.

Table 5.6: Displaying a Plot in Polar Coordinates

<table>
<thead>
<tr>
<th>Step</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Launch the <strong>Interactive Plot Builder</strong> and enter an expression.</td>
<td>Add the expression $1+4\cos(4\theta)$.</td>
</tr>
<tr>
<td>Change the x-axis range.</td>
<td>In the <strong>Select Plot Type</strong> window:</td>
</tr>
<tr>
<td></td>
<td>a. With 2-D polar plot selected, change the <strong>Angle</strong> of theta to $0 .. 8\pi$.</td>
</tr>
<tr>
<td>Set plot options.</td>
<td>In the <strong>Plot Options</strong> window:</td>
</tr>
<tr>
<td></td>
<td>a. From the <strong>Color</strong> group box, select <strong>Magenta</strong>.</td>
</tr>
<tr>
<td>Plot the expression.</td>
<td><strong>Click Plot</strong>.</td>
</tr>
</tbody>
</table>
To see the Maple syntax used to generate this plot, see *Maple commands from Creating Plots: Interactive Plot Builder* (page 209)

**Example 6 - Interactive Plotting**

Using the **Interactive Plot Builder**, you can plot an expression with several of its variables set to numeric values. The **Interactive Parameter** window allows you to interactively adjust these numeric values within specified ranges to observe their effect. To access this window, enter an expression with two or more variables and select **Interactive Plot with x parameter** from the **Select Plot Type and Functions** drop-down menu.
5.2 Creating Plots

Figure 5.1: Interactive Parameter Window

Table 5.7: Interactive Plotting

<table>
<thead>
<tr>
<th>Steps</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Launch the <strong>Interactive Plot Builder</strong> and enter an expression.</td>
<td>Add the expression $x+3\sin(xt)$.</td>
</tr>
<tr>
<td>Steps</td>
<td>Details</td>
</tr>
<tr>
<td>-------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Select a plot type.</td>
<td>In the <strong>Select Plot Type</strong> window:</td>
</tr>
<tr>
<td></td>
<td>a. From the <strong>Select Plot</strong> group box, select <strong>Interactive Plot with 1 parameter</strong>.</td>
</tr>
<tr>
<td></td>
<td>b. Change the range of the <strong>x-axis</strong> to 0 .. 5.</td>
</tr>
<tr>
<td></td>
<td>c. Change the <strong>t</strong> range to 0 .. 10.</td>
</tr>
<tr>
<td></td>
<td>d. Click <strong>Plot</strong> to launch the <strong>Interactive Parameter</strong> window.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> To apply plot options before interactively adjusting the plot, click <strong>Options</strong> to launch the <strong>Plot Options</strong> window.</td>
</tr>
<tr>
<td></td>
<td>After setting the plot options, click <strong>Plot</strong> to display the <strong>Interactive Parameter window</strong>.</td>
</tr>
<tr>
<td>Adjust the plot.</td>
<td>1. To adjust the numeric values, use the slider.</td>
</tr>
<tr>
<td></td>
<td>2. Click <strong>Done</strong> to return the plot to the Maple document.</td>
</tr>
</tbody>
</table>
To see the Maple syntax used to generate this plot, see *Maple commands from Creating Plots: Interactive Plot Builder* (page 209)

For information on customizing plots using the **Interactive Plot Builder**, refer to *Customizing Plots: Interactive Plot Builder Options* (page 217).

**Context Menu**

A context menu in Maple displays a list of commands to manipulate, display, or calculate using a Maple expression. The commands in the menu depend on the type of the expression. To display the context menu for a Maple expression, right-click (**Control**-click for Macintosh) the expression.

For expressions, the context menu lists:

- 2-D or 3-D plot
- 2-D or 3-D implicit plot
- **Interactive Plot Builder**

based on the expression selected.
By invoking the **Interactive Plot Builder** through the context menu, the expression automatically passes to the builder and Maple does not display the **Specify Expression** window.

One advantage of using the context menu is the simplicity of creating an expression using menus. By using this method, you do not need any knowledge of plot command syntax.

1. Enter and evaluate an expression, for example, \( \frac{xy}{x^2+y^2} \).

2. Right-click (Control-click for Macintosh) the expression.

3. From the context menu, select **Plots → 3-D Plot → x,y**.
\[ \frac{xy}{x^2 + y^2} \]
For information on customizing plots using the context menu, see *Context Menu Options* (page 219).

## Dragging to a Plot Region

To use the drag-and-drop method, use the plot region created by one of the other methods or insert an empty plot region into the document. Empty plot regions can be two-dimensional or three-dimensional.

Advantages of the drag-and-drop method include the ease of adding and removing plots and the independence from plotting command syntax.

1. From the **Insert** menu, select **Plot**, and then **2D**.

2. Enter the expression \( \sin(x) \) in an input region.

3. When dragging an expression to a plot region, you can either make a copy of the expression from the input region or you can cut the expression thereby removing it from the input region. To make a copy of the expression, select the full expression in the input region and press **Ctrl** (Command for Macintosh) while you drag the expression into the plot region. To cut the expression and paste it in the plot region, highlight the expression and drag it into the plot region.

4. Repeat steps 2 and 3 using the following expressions: \( \sin(2x) \), \( \sin(x+2) \), and \( \sin(x)^2 \).

5. To remove an expression from the plot region, drag-and-drop the expression plot from the plot region to a Maple input region.
The plot and plot3d Commands

The final method for creating plots is entering plotting commands.

The main advantages of using plotting commands are the availability of all Maple plot structures and the greater control over the plot output. Plot options are discussed in Customizing Plots (page 217).

Table 5.8: The plot and plot3d Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>plot(plotexpression, x=a..b, ...)</td>
<td>expression to be plotted</td>
</tr>
<tr>
<td>plot3d(plotexpression, x=a..b, y=a..b, ...)</td>
<td>name and horizontal range</td>
</tr>
<tr>
<td>plot(expression)</td>
<td>name and vertical range</td>
</tr>
</tbody>
</table>

Maple commands from Creating Plots: Interactive Plot Builder

The following examples show the plotting commands returned by the examples in Interactive Plot Builder (page 191).

Example 1 - Display a plot of a single variable expression

\[
> \text{plot} \left( \frac{\sin(x)}{x}, x = -10 .. 10 \right)
\]
Example 2 - Display a plot of multiple expressions of 1 variable

To display multiple expressions in a plot, include the expressions in a list. To enter \( \frac{d}{dx} \sin(x^2) \) and \( \int \sin(x^2) \, dx \), use the **Expression** palette. For more information, see *Entering Expressions (page 11)*.

\[
> \quad \text{plot}\left[ \left[ \sin(x^2), \frac{d}{dx} \sin(x^2), \int \sin(x^2) \, dx \right], x=-3..3 \right]
\]

Example 3 - Display a plot of a multi-variable expression

\[
> \quad \text{plot3d}\left( \frac{1 + \sin(xy)}{x^2 + y^2}, x=-5..5, y=-5..5, \text{view}=0..0.5, \text{lightmodel} = \text{light1}, \text{shading} = \text{zgrayscale}, \text{style} = \text{patchnogrid}, \text{grid} = [40, 40] \right)
\]

Example 4 - Display a conformal plot

A collection of specialized plotting routines are available in the **plots** package. For access to a single command in a package, use the long form of the command.

\[
> \quad \text{plots}[\text{conformal}](z^3, z=0..2 + 2 I, \text{axes} = \text{normal}, \text{grid} = [20, 20])
\]

Example 5 - Display a plot in polar coordinates

\[
> \quad \text{plot}\left( 1 + 4 \cos(4 \theta), \theta = 0..8 \pi, \text{coords} = \text{polar}, \text{color} = \text{magenta} \right)
\]

Example 6 - Interactive Plotting

\[
> \quad \text{plots}[\text{animate}](\text{plot}, [x + 3 \sin(x t), x=0..5], t=0..10)
\]

For more information on the plot options described in this section, refer to the **plot/options** and **plot3d/options** help pages.
Display a Parametric Plot

Some graphs cannot be specified explicitly. In other words, you cannot write the dependent variable as a function of the independent variable, $y=f(x)$. One solution is to make both the $x$-coordinate and the $y$-coordinate depend upon a parameter.

> $\text{plot}\left([\cos(3\,t), \sin(5\,t), t = 0..2\,\pi]\right)$

Display a 3-D Plot

Maple can plot an expression of two variables as a surface in three-dimensional space. To customize the plot, include `plot3d` options in the calling sequence. For a list of plot options, see *The plot and plot3d Options (page 221).*
The plots Package

The plots package contains numerous plot commands for specialized plotting. This package includes: animate, contourplot, densityplot, fieldplot, odeplot, matrixplot, spacecurve, textplot, and tubeplot. For details about this package, refer to the ?plots help page.

\[ \text{plot3d} \left( \frac{xy}{x^2+y^2}, x=-2..2, y=-2..2, \text{glossiness}=0.5, \text{style} = \text{patchnogrid}, \text{light}=[100, 345, 50, 255, 255], \text{ambientlight}=[0.5, 0, 1] \right) \]

The pointplot Command

To plot numeric data, use the pointplot command in the plots package with the data organized in a list of lists structure of the form \([[[x_1, y_1], [x_2, y_2], \ldots, [x_n, y_n]]\]. By default, Maple does not connect the points. To draw a line through the points, use the style = line option. For further analysis of data points, use the Curve Fitting Assistant, (Tools→Assistants→CurveFitting) which fits and plots a curve through the points. For more information, refer to the ?CurveFitting[Interactive] help page.
The matrixplot Command

The `matrixplot` command plots the values of a plot object of type `Matrix`. The `matrixplot` command accepts options such as `heights` and `gap` to control the appearance of the plot. For more information on Matrices, see Linear Algebra (page 135).

> `pointplot([ [0, 1], [1, -1], [3, 0], [4, -3], [2, 0], [4, 1], [3, -2], [4, 1] ], axes=BOXED, symbolsize=25, symbol=circle)`

> `with(LinearAlgebra) :`
\[ A := \text{HilbertMatrix}(6) \]
\[
A := \begin{bmatrix}
1 & \frac{1}{2} & \frac{1}{3} & \frac{1}{4} & \frac{1}{5} & \frac{1}{6} \\
\frac{1}{2} & \frac{1}{3} & \frac{1}{4} & \frac{1}{5} & \frac{1}{6} & 1 \\
\frac{1}{3} & \frac{1}{4} & \frac{1}{5} & \frac{1}{6} & 1 & 1 \\
\frac{1}{4} & \frac{1}{5} & \frac{1}{6} & 1 & 1 & 1 \\
\frac{1}{5} & \frac{1}{6} & 1 & 1 & 1 & 1 \\
\frac{1}{6} & 1 & 1 & 1 & 1 & 1 \\
\end{bmatrix}
\]

\[ B := \text{ToeplitzMatrix}([1, 2, 3, 4, 5, 6], \text{symmetric}) \]
\[
B := \begin{bmatrix}
1 & 2 & 3 & 4 & 5 & 6 \\
2 & 1 & 2 & 3 & 4 & 5 \\
3 & 2 & 1 & 2 & 3 & 4 \\
4 & 3 & 2 & 1 & 2 & 3 \\
5 & 4 & 3 & 2 & 1 & 2 \\
6 & 5 & 4 & 3 & 2 & 1 \\
\end{bmatrix}
\]

\[ \text{matrixplot}(A + B, \text{heights = histogram, axes = normal, gap = 0.25, style = patch}) \]
The contourplot Command

The `contourplot` command generates a topographical map for an expression or function. To create a smoother, more precise plot, increase the number of points using the `numpoints` option.

```
> contourplot(cos(x*y), x = -4 .. 4, y = -4 .. 4, filled = true, numpoints = 750)
```

Multiple Plots in the Same Plot Region

List of Expressions

To display multiple expressions in the same plot region, enter the expressions in a list data structure. To distinguish the surfaces, apply different shading options, styles, or colors to each surface.
To display different types of plots in the same plot region, use the `display` command in the `plots` package.

This example plots a curve over a hill with the shadow of the curve projected onto the hill.

```maple
> with(plots) :

> z := 10 \left( x^2 + y^5 + \frac{x}{5} \right) e^{-x^2-y^2} :

> hill := plot3d(5 \cdot x + cos(5 \cdot y), x=-2 ..2, y=-1 ..1, shading=[zgrayscale, none], color=[default, grey], style=[patchnogrid, patch], lightmodel=light3, transparency=0.1):

> xt := \cos(t) :

> yt := 2 \sin(t) :

Maple can draw curves in three-dimensional space.
Now that you have seen how easy it is to incorporate a plot into your work, the next section illustrates how to customize plots.

5.3 Customizing Plots

Maple provides many plot options to display the most aesthetically pleasing, illustrative results. Plot options include line styles, colors, shadings, axes styles, and titles where applicable. Plot options are applied using the Interactive Plot Builder, the context menus, or as options in the command syntax.

Interactive Plot Builder Options

The Interactive Plot Builder offers most of the plot options available in Maple in an easy-to-use interface.
Table 5.9: Customizing Plots Using Interactive Plot Builder

<table>
<thead>
<tr>
<th>Steps</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Launch the <strong>Interactive Plot Builder</strong> and enter the expression.</td>
<td>Add the expression (2x^5-10x^3+6x-1). For information on interacting with the <strong>Interactive Plot Builder</strong>, see Example 1 - Display a plot of a single variable expression (page 194)</td>
</tr>
<tr>
<td>Set the x-axis range.</td>
<td>In the <strong>Select Plot Type</strong> window, change the x-axis range to (-2 \ldots 2).</td>
</tr>
</tbody>
</table>
| Set plot options. | In the **Plot Options** window:  
  a. From the **Line** group box, select **dot** from the left drop-down menu.  
  b. From the **Color** group box, select **Blue**.  
  c. From the **Axes** group box, select **frame**.  
  d. From the **Title** group box, enter **My Plot** in the text field. |
| Plot the expression. | **Click Plot**. |
Context Menu Options

Using the context menu, you can alter a plot by right-clicking (Control-click for Macintosh) the plot output. You can also access a large subset of plot options using the Plot toolbar and Plot menu options. These menus display when a plot region is selected. Regardless of the method used to insert a plot into Maple, you can use the context menu to apply different plot options. For a list of options available when plotting in two and three dimensions, see *The plot and plot3d Options* (page 221).

2-D Plot Options

Some plots do not display as you would expect using default option values. A expression with a singularity is one such example.

\[
\text{plot} \left( \frac{1}{(x-1)^2}, x = -5..5 \right)
\]

In the previous plot, all interesting details of the plot are lost because there is a singularity at \( x = 1 \). The solution is to view a narrower range, for example, from \( y = 0 \) to 7.
### Table 5.10: Customizing 2-D Plots Using the Context Menu

<table>
<thead>
<tr>
<th>Steps</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alter the y-axis range.</td>
<td>1. Right-click the plot region. Select Axes, and then Properties.</td>
</tr>
<tr>
<td></td>
<td>2. In the Axes Properties dialog, click the Vertical tab.</td>
</tr>
<tr>
<td></td>
<td>3. De-select the Use data extents check box and enter 0 and 7 in the Range min and Range max text regions accordingly.</td>
</tr>
<tr>
<td>Change the color.</td>
<td>Place the mouse pointer on the curve and right-click (Control-click for Macintosh). <strong>Note:</strong> The curve is selected when it becomes highlighted. Select Color, and then Green.</td>
</tr>
<tr>
<td>Change the line style.</td>
<td>Select Style, and then Point.</td>
</tr>
</tbody>
</table>

### 3-D Plot Options

By default, Maple displays the graph as a shaded surface and scales the plot to fit the window. To change these options, use the context menu.

\[
> \text{plot3d}\left(\frac{xy}{x^2 + y^2}, x = -10 .. 10, y = -5 .. 5\right)
\]

Maple has many preselected light source configurations.
Table 5.11: Customizing 3-D Plots Using the Context Menu

<table>
<thead>
<tr>
<th>Steps</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the style.</td>
<td>Right-click the plot region. Select <strong>Style</strong>, and then <strong>Surface</strong>.</td>
</tr>
<tr>
<td>Apply a light scheme.</td>
<td>Select <strong>Lighting</strong>, and then <strong>Light Scheme 1</strong>.</td>
</tr>
<tr>
<td>Change the color.</td>
<td>Select <strong>Color</strong>, and then <strong>Z (Grayscale)</strong>.</td>
</tr>
<tr>
<td>Change the axes style.</td>
<td>Select <strong>Axes</strong>, and then <strong>Boxed</strong>.</td>
</tr>
<tr>
<td>Alter the glossiness.</td>
<td>Select <strong>Glossiness</strong>. Using the slider, adjust the level of glossiness.</td>
</tr>
</tbody>
</table>

**The plot and plot3d Options**

If you are using commands to insert a plot, you can specify plot options as arguments at the end of the calling sequence. You can specify the options in any order. Applying plot options in the command syntax offers a few more options and greater control than what is available in the **Interactive Plot Builder** and context menus.

Table 5.12: Popular Plot Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>axes</td>
<td>Defines the type of axes, one of: <strong>boxed, frame, none, or normal</strong></td>
</tr>
<tr>
<td>caption</td>
<td>Defines the caption for the plot</td>
</tr>
<tr>
<td>color</td>
<td>Defines a color for the curves to be plotted</td>
</tr>
<tr>
<td>font</td>
<td>Defines the font for text objects in the plot</td>
</tr>
<tr>
<td>glossiness (3-D)</td>
<td>Controls the amount of light reflected from the surface</td>
</tr>
<tr>
<td>gridlines (2-D)</td>
<td>Defines gridlines in the plot</td>
</tr>
<tr>
<td>lightmodel (3-D)</td>
<td>Controls the light model to illuminate the plot, one of: <strong>none, light1, light2, light3, or light4</strong></td>
</tr>
<tr>
<td>linestyle</td>
<td>Defines the dash pattern used to render lines in the plot, one of: <strong>dot, dash, dashdot, longshot, solid, spacedash, and spacedot</strong></td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>legend (2-D)</td>
<td>Defines a legend for the plot</td>
</tr>
<tr>
<td>numpoints</td>
<td>Controls the minimum total number of points generated</td>
</tr>
<tr>
<td>scaling</td>
<td>Controls the scaling of the graph, one of: constrained or unconstrained</td>
</tr>
<tr>
<td>shading (3-D)</td>
<td>Defines how the surface is colored, one of: xyz, xy, z, zgrayscale, zhue, or none</td>
</tr>
<tr>
<td>style</td>
<td>Defines how the surface is to be drawn, one of: line, point, polygon, or polygonoutline for 2-D plots; contour, point, surface, surfacecontour, surfacewireframe, wireframe, or wireframeopaque for 3-D plots</td>
</tr>
<tr>
<td>symbol</td>
<td>Defines the symbol for points in the plot, one of: asterisk, box, circle, cross, diagonalcross, diamond, point, solidbox, solidcircle, or soliddiamond for 2-D plots; asterisk, box, circle, cross, diagonalcross, diamond, point, solidsphere, or sphere for 3-D plots</td>
</tr>
<tr>
<td>title</td>
<td>Defines a title for the plot</td>
</tr>
<tr>
<td>thickness</td>
<td>Defines the thickness of lines in the plot</td>
</tr>
<tr>
<td>transparency (3-D)</td>
<td>Controls the transparency of the plot surface</td>
</tr>
<tr>
<td>view</td>
<td>Defines the minimum and maximum coordinate values of the curve displayed on the screen</td>
</tr>
</tbody>
</table>

For a complete list of plot options, refer to the `plot/options` and `plot3d/options` help pages.
To create a smoother or more precise plot, calculate more points using the \texttt{numpoints} option.

\begin{verbatim}
> plot3d \left( \frac{xy^2}{x^2 + y^4} \right), \ x = -10 .. 10, \ y = -10 .. 10, \ axes=boxed, numpoints = 1500, \ lightmodel=light3, shading=zgrayscale, orientation = [160, 20], \ style=patchnogrid
\end{verbatim}
5.4 Analyzing Plots

Point Probe, Rotate, Pan, and Zoom Tools

To gain further insight into a plot, Maple offers various tools to analyze plot regions. These tools are available in the Plot menu menu, Context Bar and in the context menu under Transform when the plot region is selected.

Table 5.13: Plot Analysis Options

<table>
<thead>
<tr>
<th>Name</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Point probe (2-D)</td>
<td><img src="image" alt="Icon" /></td>
<td>Display the coordinates corresponding to the cursor position on a two-dimensional plot in the context bar (upper left-hand corner)</td>
</tr>
<tr>
<td>Rotate (3-D)</td>
<td><img src="image" alt="Icon" /></td>
<td>Rotate a three-dimensional plot to see it from a different point of view</td>
</tr>
<tr>
<td>Pan</td>
<td><img src="image" alt="Icon" /></td>
<td>Pan the plot by changing the view ranges for 2-D plots. Smartplots will resample to reflect the new view. Change the position of the plot in the plot region for 3-D plots</td>
</tr>
<tr>
<td>Zoom</td>
<td><img src="image" alt="Icon" /></td>
<td>Zoom into or out of the plot by changing the view ranges for 2-D plots. Smartplots will resample to reflect the new view. Make the plot larger or smaller in the plot window for 3-D plots</td>
</tr>
</tbody>
</table>

5.5 Creating Animations

Plotting is an excellent way to represent information. Animations allow you to emphasize certain graphical behavior, such as the deformation of a bouncing ball, clearer then in a static plot. A Maple animation is a number of plot frames displayed in sequence, similar to the action of movie frames. To create an animation, use the Interactive Plot Builder or commands.
## Interactive Plot Builder

### Table 5.14: Creating Animations Using the Interactive Plot Builder

<table>
<thead>
<tr>
<th>Steps</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Launch the <strong>Interactive Plot Builder</strong> and enter the expression.</td>
<td>Add the expression $\sin(i\sqrt{x^2+y^2}/10)$. For information on interacting with the <strong>Interactive Plot Builder</strong>, see Example 1 - Display a plot of a single variable expression (page 194).</td>
</tr>
<tr>
<td>Set axes and animation parameter range.</td>
<td>In the <strong>Select Plot Type</strong> window:</td>
</tr>
<tr>
<td></td>
<td>a. From the <strong>Select Plot Type</strong> drop-down menu, select <strong>Animation</strong>.</td>
</tr>
<tr>
<td></td>
<td>b. Change the <strong>x Axis</strong> range to -6 .. 6.</td>
</tr>
<tr>
<td></td>
<td>c. Change the <strong>y Axis</strong> range to -6 .. 6.</td>
</tr>
<tr>
<td></td>
<td>d. Change the <strong>Animation Parameter</strong> ($i$) range to 1 .. 30.</td>
</tr>
<tr>
<td>Set plot options.</td>
<td>In the <strong>Plot Options</strong> window:</td>
</tr>
<tr>
<td></td>
<td>a. From the <strong>Style</strong> group box, select <strong>surface</strong>.</td>
</tr>
<tr>
<td></td>
<td>b. From the <strong>Color</strong> group box, in the <strong>Light Model</strong> drop-down menu, select <strong>red-turquoise</strong>.</td>
</tr>
<tr>
<td></td>
<td>b. From the <strong>Color</strong> group box, in the <strong>Shading</strong> drop-down menu, select <strong>z (grayscale)</strong>.</td>
</tr>
<tr>
<td></td>
<td>c. In the <strong>View</strong> group box, select the <strong>Constrained Scaling</strong> check box.</td>
</tr>
</tbody>
</table>
Plot the expression.

> plots[interactive]();

For information on playing the animation, see *Playing Animations* (page 228). To see the Maple syntax used to generate this plot, see *Maple Syntax for Creating Animations: Interactive Plot Builder Example* (page 227).

**The plots[animate] Command**

You can also use the *animate* command, in the *plots* package, to generate animations.
Table 5.15: The animate Command

| animate(plotcommand, plotarguments, t=a..b, ...) |
| animate(plotcommand, plotarguments, t=L, ...) |
  | • plotcommand - Maple procedure that generates a 2-D or 3-D plot |
  | • plotarguments - arguments to the plot command |
  | • t=a..b - name and range of the animation parameter |
  | • t=L - name and list of real or complex constants |

To access the command, use the short form name after invoking the with(plots) command.

> with(plots):

**Maple Syntax for Creating Animations: Interactive Plot Builder Example**

The following example shows the plotting command returned by the example in *Interactive Plot Builder* (page 225).

> animate(plot3d, \sin\left(\frac{i \sqrt{x^2 + y^2}}{10}\right), x = -6..6, y = -6..6, style = patchnogrid, lightmodel = light3, shading = zgrayscale, scaling = constrained, i = 1..30)

**Animate a 2-D plot**

> animate(plot, [5 \cos(2 \theta), \theta = 0..t, coords = polar], t = 0..2\pi, frames = 50)
For more information on the `animate` command, refer to the `?plots[animate]` help page.

## 5.6 Playing Animations

### Animation Context Bar

To run the animation, click the plot to display the `Animate` context bar.

<table>
<thead>
<tr>
<th>Name</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Previous Frame</td>
<td><img src="icon.png" alt="Icon" /></td>
<td>View the previous frame in the animation.</td>
</tr>
<tr>
<td>Stop</td>
<td><img src="icon.png" alt="Icon" /></td>
<td>Stop the animation.</td>
</tr>
<tr>
<td>Play</td>
<td><img src="icon.png" alt="Icon" /></td>
<td>Play the selected animation.</td>
</tr>
<tr>
<td>Next Frame</td>
<td><img src="icon.png" alt="Icon" /></td>
<td>View the next frame in the animation.</td>
</tr>
</tbody>
</table>
### Playing Animations

<table>
<thead>
<tr>
<th>Name</th>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current Frame</td>
<td>![Current Frame Icon]</td>
<td>Slider control for viewing individual frames of an animated plot. The frame speed in frames per second (FPS) is displayed when increasing or decreasing the animation speed of a plot.</td>
</tr>
<tr>
<td>Forward</td>
<td>![Forward Icon]</td>
<td>• Forward - Play the animation forward.</td>
</tr>
<tr>
<td>Oscillate</td>
<td>![Oscillate Icon]</td>
<td>• Oscillate - Play the animation forward and backward.</td>
</tr>
<tr>
<td>Backward</td>
<td>![Backward Icon]</td>
<td>• Backward - Play the animation backward.</td>
</tr>
<tr>
<td>Single</td>
<td>![Single Icon]</td>
<td>• Single - Run the animation in single cycle mode. The animation is displayed only once.</td>
</tr>
<tr>
<td>Continuous</td>
<td>![Continuous Icon]</td>
<td>• Continuous - Run the animation in continuous mode. The animation repeats until you stop it.</td>
</tr>
<tr>
<td>Frames per second</td>
<td>![Frames per second Icon]</td>
<td>Set the animation to play at a faster or slower speed.</td>
</tr>
<tr>
<td>Point probe</td>
<td>![Point probe Icon]</td>
<td>Determine the coordinates of a 2-D plot at the position of the cursor.</td>
</tr>
<tr>
<td>Name</td>
<td>Icon</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Scale plot axes</td>
<td>![Icon]</td>
<td>Zoom into or out of the plot by changing the view ranges.</td>
</tr>
<tr>
<td>Translate plot axes</td>
<td>![Icon]</td>
<td>Pan the plot by changing the view ranges.</td>
</tr>
</tbody>
</table>

You can also run the animation using the context menu or the **Plot** menu.

## 5.7 Customizing Animations

The display options that are available for static plots are also available for Maple animations.

### Interactive Plot Builder Animation Options

Using the **Interactive Plot Builder**, you can apply various plot options within the **Plot Options** window. See the **Interactive Plot Builder** (page 225) example.

### Context Menu Options

As with static plots, you can apply plot options to the animation by right-clicking (**Control**-click for Macintosh) the animation output.

```maple
> with(plots):

> animate(plot, [sin(x) e^(-x/5), x=t-2 .. 2, t=0 .. 20, frames = 50, view=[0 .. 20, -1 .. 1])
```
Table 5.17: Customizing Animations Using the Context Menu

<table>
<thead>
<tr>
<th>Step</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the line style</td>
<td>Right-click the plot region. Select <strong>Style</strong>, and then <strong>Point</strong>.</td>
</tr>
<tr>
<td>Remove the axes</td>
<td>Select <strong>Axes</strong>, and then <strong>None</strong>.</td>
</tr>
</tbody>
</table>

The **animate** Command Options

The `animate` command offers a few options that are not available for static plots. Refer to the `animate` help page for information on these additional options. By default, a two-dimensional animation consists of sixteen plots (frames) and a three-dimensional animation consists of eight plots (frames). To create a smoother animation, increase the number of frames using the `frames` option.

**Note:** Computing more frames increases time and memory requirements.

```plaintext
> sinewave := plot(sin(x) * exp(-x/5), x = 0 .. 20)
```
5.8 Exporting

You can export a generated graph or animation to an image in various file formats, including DXF, EPS, GIF, JPEG/JPG, POV, Windows BMP, and WMF. Exporting an animation to GIF produces an animated image file. The exported images can be included in presentations, Web pages, Microsoft Word, or other software.

To export an image:

1. Right-click the plot region (Control-click for Macintosh).
2. Select Export and the file format.

Alternatively:

1. Click the plot.
2. From the Plot menu, select Export, and then the file format.

Maple has various plot drivers. By setting the plotdevice, a file can be automatically created without returning the image to the document. For more information, refer to the ?plot,device help page.

\[
\text{animate}(\text{pointplot}, \left[\left[ t, \sin(t) e^{-t/5}\right] \right], \text{symbol=circle, symbolsize=20, t=0 ..20, frames=60, background=sinewave})
\]
5.9 Code for Color Plates

Generating impressive graphics in Maple can require only a few lines of code, as shown by the examples in this chapter. However, other graphics require many lines of code. Code for the color plates is available at the Maple Application Center.

From the Help menu, select Web and then Application Center.

To access the color plate code:

1. Go to the Maple Application Center.
2. In the Keyword or phrase region, enter Color Plate.
6 Creating Mathematical Documents

Maple allows you to create powerful documents as business and education tools, technical reports, presentations, assignments, and handouts.

You can:

• Place instructions and equations side by side
• Format text for reports or course material
• Insert hyperlinks to other Maple files, Web sites, or email addresses
• Insert images, tables, and symbols
• Generate two- and three-dimensional plots and animations
• Sketch in the document
• Copy, cut, and paste information
• Bookmark specific areas
• Easily update, revise, and distribute your documents

This User Manual was written using Maple.
# 6.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| Document Formatting - Add various formatting elements | • Quick Character Formatting  
• Quick Paragraph Formatting  
• Copy and Paste  
• Sections  
• Displaying Hidden Formatting Attributes  
• Indentation and the Tab Key  
• Character and Paragraph Styles  
• Document Blocks  
• Typesetting  
• Using Tables for Layout  
• Formatting Lists: Bullets, Numbers, Indent  
• Bookmarks  
• Inserting Images  
• Show or Hide Document Content |
| Embedded Components - Insert buttons, sliders, and more in your document | • Adding Graphical Interface Components  
• Editing Component Properties  
• Removing Graphical Interface Components  
• Example Component Properties  
• Printing and Exporting with Embedded Components |
| Creating Graded Assignments - Create documents for automated testing and assessment | • Creating a Question  
• Viewing Questions in Maple  
• Saving Test Content |
<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| Auto-execute - Execute selected regions of your document | • Setting the Auto-Execute Feature  
• Removing the Auto-Execute Setting  
• Repeating Auto-Execution  
• Security Levels |
| Canvas - Sketch an idea in the document by inserting a canvas | • Insert a Canvas  
• Drawing  
• Canvas Style  
• Erase or Clear Content  
• Selection Tool |
| Spell Checking - Verify text with the Maple spell checking utility | • How to Use the Spellcheck Utility  
• Selecting a Suggestion  
• Spellcheck Usage and the Document  
• User Dictionary |
| Hyperlinks - Add hyperlinks to various sources | • Inserting a Hyperlink in the Document  
• Linking to an Email Address, Dictionary Topic, Help Page, Maplet Application, Web Page, or Document |
| Worksheet Compatibility - Classic Worksheet interface does not support all Standard Worksheet interface features | • Compatibility Issues |

# 6.2 Document Formatting

## Quick Character Formatting

The **Format→Character** menu provides access to the following quick formatting features: **Bold, Italic, Underline, Superscript, Subscript**, font **Color**, and **Highlight Color**.
To modify text:

1. In the document, select the text to modify.

2. From the **Format** menu, select **Character**, and then the appropriate feature.

   Alternatively, use the context bar icons.

   - Font Color Context Bar Icon
   - Highlight Color Context Icon

   For font and highlight colors, you can select from Swatches, a color wheel, RGB values, or choose a color using the eye dropper tool. See Figure 6.1.

   ![Select Color Dialog](Image)

   **Figure 6.1: Select Color Dialog**

**Attributes Submenu: Setting Fonts, Character Size, and Attributes**

You can change various character attributes such as font, character size, style, and color in one dialog.

To modify text:

1. In the document, select text to modify.

2. From the **Format** menu, select **Character**, and then **Attributes**. The **Character Style** dialog opens. See Figure 6.2.
Quick Paragraph Formatting

The **Format→Paragraph** menu provides access to the following quick alignment features: **Align Left**, **Center**, **Align Right**, and **Justify**.

**To modify a paragraph:**

1. In the document, select the paragraph to modify.

2. From the **Format** menu, select **Paragraph**, and then the appropriate feature.
Attributes Submenu: Spacing, Indent, Alignment, Bullets, Line Break, and Page Break

You can change various paragraph attributes in one dialog.

- From the **Format** menu, select **Paragraph**, and then **Attributes**. The **Paragraph Style** dialog opens. See Figure 6.3.
- When changing spacing, you must indicate units (inches, centimeters, or points) in the **Units** drop-down list.

![Figure 6.3: Paragraph Style Dialog](image)

**Copy and Paste**

You can cut, copy, and paste content in Maple documents.

**To copy an expression, or part of an expression, to another location on the document:**

1. Select the expression, or part of the expression, to copy.
2. From the **Edit** menu, select **Copy**.

3. Place the cursor at the insertion point.

4. From the **Edit** menu, select **Paste**.

If you paste into an input region, Maple interprets all the pasted content as input. If you paste into a text region, Maple interprets all the pasted content as text. Note, however, that 2-D Math retains its format in both input and text regions.

When you copy and paste to another application, in general, Maple retains the original structure.

**Sections**

You can organize your document into sections.

**First Section**

\[
\begin{align*}
\text{The introductory sentence.} \\
\text{\textbf{The expression:}} \\
> \int \cos(x) \, dx
\end{align*}
\]

**Subsection**

\[
\begin{align*}
\text{\textbf{The expression:}} \\
> \int \sin(x) \, dx
\end{align*}
\]

**Using the Insert Menu to Add Sections**

1. Place the cursor in the paragraph or execution group above the location at which to insert a new section.

   - If the cursor is inside a section, Maple inserts the new section after the current section.
   - If the cursor is in an execution group, Maple inserts the new section after the execution group.
2. From the **Insert** menu, select **Section**. An arrow marks the start of the section.

3. Enter the section heading.

4. Press the **Enter** key.

5. Enter the body of the section.

**Using the Indent and Outdent Toolbar Icons**

You can shift sections to create or remove subsections.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Indent Icon]</td>
<td>Enclose the selection in a subsection</td>
</tr>
<tr>
<td>![Outdent Icon]</td>
<td>Outdent the selection</td>
</tr>
</tbody>
</table>

**Display Hidden Formatting Attributes**

You can display icons that indicate the presence of hidden formatting attributes in the document, such as document block boundaries, execution groups marked for autoexecute, and bookmarks.

**To activate the marker feature:**

- From the **View** menu, select **Markers**. A vertical bar is displayed along the left pane of the document. Icons for hidden elements are displayed in the vertical bar next to the associated content in the document.

**Indentation and the Tab Key**

The Tab icon allows you to set the **Tab** key to move between placeholders or to indent. For example, with the Tab icon off, click the exponent button in the **Expression** palette. The expression is inserted with the first placeholder highlighted. To move to the next placeholder, use the **Tab** key.
Character and Paragraph Styles

Maple has predefined styles for characters and paragraphs. A style is a set of formatting characteristics that you can apply to text in your document to change the appearance of that text. When you apply a style, you apply a group of formats in one simple action.

- A **paragraph style** controls all aspects of a paragraph's appearance, such as text alignment, line spacing, and indentation. In Maple, each paragraph style includes a character style.

- A **character style** controls text font, size, and color, and attributes, such as bold and italic. To override the character style within a paragraph style, you must apply a character style or character formatting.

![Style Management Dialog](image)

**Figure 6.4: Style Management Dialog**
Applying Character Styles

By using the drop-down list in the document context bar, you can apply:

- Existing Maple character styles.
- New styles that you have created through the Style Management (Figure 6.4) and Character Style (Figure 6.5) dialogs.

To apply a character style to text in your document:

1. Select the text to modify.

2. In the styles drop-down list in the context bar of your document, select an appropriate character style. All character styles are preceded by the letter C. The selected text now reflects the attributes of the character style you have chosen.

3. (Optional) If necessary, you can remove this style. From the Edit menu, select Undo.

Creating Character Styles

You can create custom character styles to apply to text. New styles are listed in the styles drop-down list in the context bar of your document.

1. From the Format menu, select Styles. The Style Management dialog opens. See Figure 6.4.

2. Click Create Character Style. The Character Style dialog opens. See Figure 6.5.
3. In the first row of the dialog, enter a style name in the blank text region.

4. Select the properties for the new character style, such as font, size, attributes, and color. In the font attributes, the **Superscript** and **Subscript** check boxes are mutually exclusive. When you select one of the two check boxes, the other is disabled. You must clear one before selecting the other.

**Note**: A preview of the style is displayed in the last row of the **Character Style** dialog.

5. To create the style, click **OK** or to abandon creation, click **Cancel**.

---

**Figure 6.5: Character Style Dialog**
Modifying Character Styles

To modify character styles:

1. From the Format menu, select Styles. The Style Management dialog opens. See Figure 6.4.

2. From the style list, select the character style to modify. Recall that all character styles are preceded by the letter C while paragraph styles are preceded by the letter P.

3. Click Modify. The Character Style dialog opens with the current attributes displayed. See Figure 6.5.

4. Select the properties for the new character style, such as font, size, attributes, and color. In the font attributes, the Superscript and Subscript check boxes are mutually exclusive. When you select one of the two check boxes, the other is disabled. You must clear one before selecting the other.

A preview of the style is displayed in the last row of the Character Style dialog.

5. To accept changes, click OK or to cancel changes, click Cancel.

Applying Paragraph Styles

By using the drop-down list in the document context bar, you can apply:

- Existing Maple paragraph styles.
- New styles that you have created through the Style Management (Figure 6.4) and Paragraph Style (Figure 6.6) dialogs.

To apply a Maple paragraph style to text in your document:

1. Select the text to modify.

2. In the styles drop-down list in the context bar of your document, select an appropriate paragraph style. All Maple paragraph styles are preceded by the letter P. The selected text now reflects the attributes of the paragraph style you have chosen.
3. (Optional) If necessary, you can remove this style. From the Edit menu, select Undo.

**Creating Paragraph Styles**

You can create custom paragraph styles to apply to text. New styles are listed in the styles drop-down list in the context bar of your document.

1. From the Format menu, select Styles. The Style Management dialog opens. See Figure 6.4.

2. Click Create Paragraph Style. The Paragraph Style dialog opens. See Figure 6.6.

3. In the first row of the dialog, enter a style name in the blank text field.

4. In the Units drop-down menu, select the units used to determine spacing and indentation. Select from inches (in), centimeters (cm), or points (pt).

5. Select the properties to use for this paragraph style, such as Spacing, Indent, Alignment, Bullets and Numbering, Page Break Before, and Linebreak.

6. To add a font style, click Font. The Character Style dialog opens. For detailed instructions, see Creating Character Styles (page 244).

7. To create the style, click OK, or to abandon creation, click Cancel.
Modifying Paragraph Styles

To modify a paragraph style:

1. From the Format menu, select Styles. The Style Management dialog opens. See Figure 6.4.

2. Select a paragraph style to modify and click Modify. Recall that all character styles are preceded by the letter P. The Paragraph Style dialog opens with the current attributes displayed.

3. Select the properties you want to modify, such as Units, Spacing, Indent, Alignment, Bullets and Numbering, and Linebreak.

4. To modify the existing font style, click Font. The Character Style dialog opens.
5. To accept changes, click OK, or to cancel changes, click Cancel.

**Style Set Management: Saving Styles for Future Use**

You can use the style set of a particular document as the default style for all documents.

![Style Set Management Dialog](image)

**Creating and Applying Style Sets**

- Task 1 - Create Styles
- Task 2 - Create a New Style Set
- Task 3 - Apply a (New) Style Set

**TASK 1 - Create Styles:**

- Create paragraph or character styles for the current document.

**TASK 2 - Create a New Style Set:**

1. From the Format menu, select Manage Style Sets. The Style Set Management dialog opens. See Figure 6.7.

2. In the Style Set Operations group box, click New Style Set. The Choose Styles dialog opens. See Figure 6.8.
3. Select all the styles that are part of your document style set. For example, if you modified the Author paragraph style to justify left versus the default style of centered, ensure that you have selected the Author check box in the Choose Styles dialog.

4. Click OK. The Choose Filename dialog opens.

5. Save your style set. The style is now available for future use in other documents.

**TASK 3 - Apply a (New) Style Set:**

1. From the Format menu, select Manage Style Sets. The Style Set Management dialog opens. See Figure 6.7.

2. In the Style Set Operations group box, click Apply Style Set. The Choose Filename dialog opens.

3. Select the style file and click Open. The Choose Styles dialog opens. At this point, you can overwrite all the styles in your current document with the new style set or apply only a few.

4. Click OK. The style set is applied to your document.

**Reverting to a Style Set**

At any point, you can revert your document style set to the Default Maple Style Set or to a User-defined Style Set.
To revert to a style set:

1. From the **Format** menu, select **Manage Style Sets**. The **Style Set Management** dialog opens.

2. In the **Current Style Set** group box, select the **Default Maple Style Set** or **User-defined Style Set**. For user-defined style sets, navigate (click **Browse**) to the file (**Choose Filename** dialog) and open the file (click **Open**).

3. In the **Style Set Operations** group box, click **Revert to StyleSet**.

4. In the **Choose Styles** dialog, select all the styles to revert, that is, overwrite with either the **Default Maple Style Set** or the **User-defined Style Set**.

5. Click **OK**.

**Document Blocks**

With document blocks, you can create documents that present text and math in formats similar to those found in business and education documents.

In a document block an input prompt or execution group is not displayed.

By hiding Maple input such that only text and results are visible, you create a document with better presentation flow. Before using document blocks, it is recommended that you display **Markers**. A vertical bar is displayed along the left pane of the document. Icons representing document blocks are displayed in this vertical bar next to associated content.

**To activate Markers:**

- From the **View** menu, select **Markers**.
Applying Document Blocks: General Process

**Important:** The following instructions are for **Worksheet mode**.

**To apply a document block to selected content:**

1. Enter input at the Maple command prompt, creating input that can be referenced elsewhere in the document. See the ?EquationLabels help page.

2. Execute the area, creating output that can be referenced elsewhere in the document.

3. Intersperse the area with content that is to remain visible, adding references to the input and output in the appropriate locations.

   \[
   \begin{align*}
   \text{The answer to} & \quad \int \sin(x) \, dx \\
   \text{is} & \quad -\cos(x) \\ 
   > \text{value} & (1) \\
   \end{align*}
   \]

4. Select the entire area (text and math content) to format.

5. From the **Format** menu, select **Create Document Block**.

6. Select the entire area. From the **View** menu, select **Inline Document Output**.
The block displays text and output only. You can select areas to display input only.

7. Select the output region you want to display as input. From the View menu, select Toggle Input/Output Display. The selected region displays input.

Working in Document Mode

You can work directly in Document mode, entering text and expressions, and then evaluating expressions.

To start a document in Document mode:

1. From the File menu, select New, and then Document Mode. A document opens with the Document mode markers indicated in the left margin. Note that margin markers are visible if you select View → Markers.

2. Enter text and an expression to evaluate.

3. Select the expression and right-click (Control-click, for Macintosh) to display the context menu.

4. Click the Evaluate and Display Inline menu item. The expression is evaluated.


In the following figures, note how the expression is entered as part of the text and then evaluated with the context menu option Evaluate and Display Inline.
Before

After

You can solve this problem \( \int \sin(x) \, dx \) in the same line.

**Figure 6.9: Working in Document Mode**

**View Document Code**

To view the contents, that is, all code and expanded execution groups within a document block, you must expand the document block.

1. Place the cursor in the document block region.

2. From the View menu, select **Expand Document Block**.
3. To hide code again, select View and then **Collapse Document Block**.

**Expand an Execution Group within a Document Block**

An execution group is a grouping of Maple input with its corresponding Maple output. It is distinguished by a large square bracket at the left called a group boundary.

As document blocks can contain many execution groups, you can select to expand an execution group within a document block.

1. Place the cursor in the document block region.
2. From the View menu, select **Expand Execution Group**.
3. To hide the group, select View and then **Collapse Execution Group**.

**Switch between Input and Output**

1. Place the cursor in the document block region.
2. From the View menu, select **Toggle Input-Output Display**.

Input is displayed in one instance, or only output is displayed.

**Inline Document**

Document blocks can display content inline, that is, text, input, and output in one line as presented in business and education documents.

**To display content inline:**

1. Place the cursor in the document block.
2. From the View menu, select **Inline Document Output**.
Typesetting

You can control typesetting and 2-D Math equation parsing options in the Standard Worksheet interface. Extended typesetting uses a customizable set of rules for displaying expressions.

The rule-based typesetting functionality is available when Typesetting level is set to Extended (Tools→Options→Display tab). This parsing functionality applies to 2-D Math editing (Math mode) only.

To specify rules, use the Typesetting Rule Assistant.

- From the View menu, select Typesetting Rules. The Typesetting Rule Assistant dialog opens.

For more information, see the ?Typesetting, ?TypesettingRuleAssist, and ?OptionsDialog help pages.

Using Tables for Layout

Tables allow you to organize content in a document.

Creating a Table

To create a table:

1. From the Insert menu, select Table.

2. Specify the number of rows and columns in the table creation dialog.

3. Click OK.

The default properties for the table include visible borders and auto-adjustment to 100% of the document width. These options, as well as the table
dimensions, can be modified after table creation. The following is an example table using the default settings.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
</table>

**Cell Contents**

Any content that can be placed into a document can also be placed into a table cell, including other sections and tables. Table cells can contain a mix of:

- Input commands
- 2-D Math
- Embedded components - buttons, sliders, check boxes, and more
- Plots
- Images

**Navigating Table Cells**

Use the Tab key to move to the next cell.

<table>
<thead>
<tr>
<th></th>
<th>Tab icon off. Allows you to move between cells using the Tab key.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Tab icon on. Allows you to indent in the table using the Tab key.</td>
</tr>
</tbody>
</table>

**Modifying the Structural Layout of a Table**

The number of rows and columns in a table are modified using the Insert and Delete submenus in the Table menu or by using the Cut and Paste tools.

**Inserting Rows and Columns**

Row and column insertion is relative to the table cell that currently contains the cursor. If the document has an active selection, insertion is relative to the selection boundaries.
• Column insertion can be to the left or right of the document position marker or selection.

• Row insertion can be above or below the marker or selection.

**Deleting Rows and Columns**

With deleting operations using the **Delete** key, the **Delete Table Contents** dialog opens allowing you to specify the desired behavior. For example, you can delete the selected rows, or delete the contents of the selected cells.

**Pasting**

Pasting a table subselection into a table may result in the creation of additional rows or columns, overwriting existing cell content, or the insertion of a subtable within the active table cell.

**Merging**

You can merge cells across row or column borders. See Figure 6.10. The resultant cell must be rectangular. The contents of the individual cells in the merge operation are concatenated in execution order. See Figure 6.11.

![Figure 6.10: Two cells](image)

![Figure 6.11: Merged Cells](image)

**Modifying the Physical Dimensions of a Table**

The overall width of the table can be controlled in several ways.

The most direct way is to press the left mouse button (press mouse button, for Macintosh) while hovering over the left or right table boundary and dragging the mouse left or right. Upon release of the mouse button, the table boundary is updated. This approach can also be used to resize the relative width of table columns.
Alternatively, the size of the table can be controlled from the *Table Properties* dialog. Select the **Table** menu and then **Properties**. Two sizing modes are supported.

1. **Fixed percentage of page width**. Using this option, the table width adjusts whenever the width of the document changes. This option is useful for ensuring that the entire content of the table fits in the screen or printed page.

2. **Scale with zoom factor**. This option is used to preserve the size and layout of the table regardless of the size of the document window or the zoom factor. If the table exceeds the width of the document window, the horizontal scroll bar can be used to view the rightmost columns. **Note**: Using this option, tables may be incomplete when printed.

**Modifying the Appearance of a Table**

**Table Borders**

The style of exterior and interior borders is set using the *Table Properties* dialog. Select **Table** and then **Properties**.

- You can set all, none, or only some of the borders to be visible in a table.
- You can control the visibility of interior borders by using the **Group** submenu of the **Table** menu.
- Grouping rows or columns suppresses interior borders within the table selection.
- Grouping rows and columns requires that the interior border style is set by row and column group.
- Hidden borders are visible when the mouse hovers over a table. Note that you can hide the visibility of lines on mouse pointer roll over by using the **View→Show/Hide Contents** dialog, and clearing the **Hidden Table Borders** check box.

**Alignment Options**

The table alignment tools control the horizontal alignment of columns and vertical alignment of rows.
For column alignment, the current selection is expanded to encompass all rows in the selected columns. The alignment choice applies to all cells within the expanded selection. If the document does not contain a selection, the cursor position is used to identify the column.

Similarly, the selection is expanded to include all columns in the selected rows for vertical alignment options. The following table illustrates the vertical alignment options. The baseline option is useful for aligning equations across multiple cells within a row of a table.

<table>
<thead>
<tr>
<th></th>
<th>Top</th>
<th>Center</th>
<th>Bottom</th>
<th>Baseline</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>( \frac{1}{y} )</td>
<td>( \frac{1}{x} )</td>
<td>( \frac{1}{y} )</td>
<td>( \frac{1}{x} )</td>
</tr>
<tr>
<td></td>
<td>( \frac{1}{y} )</td>
<td>( \frac{1}{x} )</td>
<td>( \frac{1}{y} )</td>
<td>( \frac{1}{x} )</td>
</tr>
<tr>
<td></td>
<td>( \frac{1}{y} )</td>
<td>( \frac{1}{x} )</td>
<td>( \frac{1}{y} )</td>
<td>( \frac{1}{x} )</td>
</tr>
<tr>
<td></td>
<td>( \frac{1}{y} )</td>
<td>( \frac{1}{x} )</td>
<td>( \frac{1}{y} )</td>
<td>( \frac{1}{x} )</td>
</tr>
</tbody>
</table>

**Controlling the Visibility of Cell Content**

The **Table Properties** dialog includes two options to control the visibility of cell content. These options allow control over the visibility of Maple input and execution group boundaries. Thus, Maple input can be hidden in a table even if input is set to visible for the document in the **View→Show/Hide Contents** dialog.
Printing Options

The **Table Properties** dialog contains options to control the placement of page breaks when printing. You can fit a table on a single page, allow page breaks between rows, or allow page breaks within a row.

**Execution Order Dependency**

The order in which cells are executed is set in the **Table Properties** dialog. The following tables illustrate the effect of execution order.

<table>
<thead>
<tr>
<th>Row-wise execution order</th>
<th>Column-wise execution order</th>
</tr>
</thead>
<tbody>
<tr>
<td>( \texttt{&gt; x:=1;} )</td>
<td>( \texttt{&gt; x:=1;} )</td>
</tr>
<tr>
<td>( x := 1 )</td>
<td>( x := 2 )</td>
</tr>
<tr>
<td>( &gt; )</td>
<td>( &gt; )</td>
</tr>
<tr>
<td>( \texttt{&gt; x:=x+1;} )</td>
<td>( \texttt{&gt; x:=x+1;} )</td>
</tr>
<tr>
<td>( x := 3 )</td>
<td>( x := 4 )</td>
</tr>
<tr>
<td>( &gt; )</td>
<td>( &gt; )</td>
</tr>
</tbody>
</table>
Tables and the Classic Worksheet

Tables are flattened on export to the Classic Worksheet interface. For example, the following table in the Standard Worksheet appears as one column in the Classic Worksheet interface.

<table>
<thead>
<tr>
<th>Table in Standard Worksheet</th>
<th>Table in Classic Worksheet</th>
</tr>
</thead>
<tbody>
<tr>
<td>a</td>
<td>d</td>
</tr>
<tr>
<td>b</td>
<td>e</td>
</tr>
<tr>
<td>c</td>
<td>f</td>
</tr>
</tbody>
</table>

Examples

Table of Values

This example illustrates how to set the visibility options for cell contents to display a table of values.

$> y := t \rightarrow \frac{1}{2}t^2;$

<table>
<thead>
<tr>
<th>t [s]</th>
<th>0</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
</tr>
</thead>
<tbody>
<tr>
<td>y(t) [m]</td>
<td>$&gt; y(0);$</td>
<td>$&gt; y(1);$</td>
<td>$&gt; y(2);$</td>
<td>$&gt; y(3);$</td>
<td>$&gt; y(4);$</td>
<td>$&gt; y(5);$</td>
<td>$&gt; y(6);$</td>
</tr>
<tr>
<td></td>
<td>0</td>
<td>1/2</td>
<td>2</td>
<td>9/2</td>
<td>8</td>
<td>25/2</td>
<td>18</td>
</tr>
</tbody>
</table>
### Formatting Table Headers

The following table uses cell merging for formatting row and column headers, and row and column grouping to control the visibility of cell boundaries.

By default, invisible cell boundaries are visible on mouse pointer roll over. You can hide the visibility of lines on mouse pointer roll over by using the `View → Show/Hide Contents` dialog, and clearing the `Hidden Table Borders` check box.

<table>
<thead>
<tr>
<th>t [s]</th>
<th>0</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
</tr>
</thead>
<tbody>
<tr>
<td>y(t) [m]</td>
<td>0</td>
<td>$\frac{1}{2}$</td>
<td>2</td>
<td>$\frac{9}{2}$</td>
<td>8</td>
<td>$\frac{25}{2}$</td>
<td>18</td>
</tr>
</tbody>
</table>

### Table settings:

1. Insert a table with 4 rows and 4 columns.

Using the **Table** menu:

2. **Merge** the following sets of (Row,Column) cells: (R1,C1) to (R2,C2), (R1,C3) to (R1,C4), and (R3,C1) to (R4,C1).

3. **Group** columns 1 and 2, and columns 3 and 4.

4. **Group** rows 1 and 2, and rows 3 and 4.

In the **Properties** dialog (**Table → Properties** menu):

5. Set **Exterior Borders** to **None**.
6. (Optional) Change **Table Size Mode** size option to **Scale with zoom factor**.

Using the **Table** menu:

7. Set **Alignment** of columns 3 and 4 to **Center**.

### 2-D Math and Plots

The following example illustrates the use of tables to display 2-D Math and plots side by side.

![Approximating \(e^{-x}\) as a rational polynomial using a 3rd order Padé approximation](image)

\[
e^{-x} \approx \frac{1 - \frac{1}{2}x + \frac{1}{10}x^2 - \frac{1}{120}x^3}{1 + \frac{1}{2}x + \frac{1}{10}x^2 + \frac{1}{120}x^3}
\]

**Table Settings:**

In the **Properties** dialog (**Table**→**Properties** menu):

1. Set **Exterior** and **Interior Borders** to **None**.

2. Hide Maple input and execution group boundaries: Clear the **Show input** and **Show execution group boundaries** check boxes.

Using the **Table** menu:
3. Change row **Alignment** to **Center**.

### Table of Mathematical Expressions

This example illustrates using the baseline alignment option to align equations across columns in a table.

<table>
<thead>
<tr>
<th>$f(x)$</th>
<th>$\int f(x) , dx$</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\frac{1}{1 + \frac{1}{1 + \frac{1}{1 + \frac{1}{x}}}}$</td>
<td>$\frac{2}{3} x - \frac{1}{9} \ln(3x + 2)$</td>
</tr>
<tr>
<td>$\sin(\omega t) e^{(-\alpha \tau)}$</td>
<td>$-\frac{\omega e^{-\alpha \tau} \cos(\omega t)}{a^2 + \omega^2} - \frac{a e^{-\alpha \tau} \sin(\omega t)}{a^2 + \omega^2}$</td>
</tr>
<tr>
<td>$\frac{d^2}{dx^2} f(x)$</td>
<td>$\frac{d}{dx} f(x)$</td>
</tr>
</tbody>
</table>

### Table Settings:

In the **Properties** dialog (**Table**→**Properties** menu):

1. Set **Exterior Border** to **Top** and **Bottom**.

Using the **Table** menu:

2. **Group** columns 1 and 2.

3. **Group** rows 2 to 4.

4. Set row **Alignment** to **Baseline** for all rows.
Bookmarks

Use a bookmark to designate a location in an active document. This bookmark can then be accessed from other regions in your document or by using hyperlinks in other documents.

To display bookmark formatting icons, activate the Marker feature.

- From the View menu, select Markers.

To insert a bookmark:

1. Place the cursor at the location at which to place the bookmark.

2. From the Format menu, select Bookmarks. The Bookmark dialog opens, listing existing bookmarks in the document.

3. Click New. The Create Bookmark dialog opens. Enter a bookmark name and click Create.

4. The new bookmark appears in the Bookmark dialog list. Click OK.

Note: You can also rename and delete bookmarks using the Bookmark dialog.

Go to a Bookmark

You can automatically move the cursor to the location of the bookmark in the active document.

1. From the Edit menu, select Go To Bookmark. The Go To Bookmark dialog opens with the current bookmarks listed.
2. Select the bookmark and click **OK**. The cursor moves to the bookmark.

**Inserting Images**

Images help illustrate ideas and enhance presentations. You can insert images in your document at a cursor location or in a table.

You can insert images in these file formats into your document.

- Graphics Interchange Format - gif
- Joint Photographic Experts Group - jpe, jpeg, jpg
- Portable Network Graphics - png
- Bitmap Graphics - bmp
- Tagged Image File Format - tif, tiff, jfx
- Portable aNyMap - pnm
- Kodak FlashPix - fpx

---

To insert an image into the document at the cursor location:

1. From the **Insert** menu, select **Image**. The **Load Image** dialog opens.

2. Specify a path or folder name.

3. Select a filename.

4. Click **Open**. The image is displayed in the document.

If the source file is altered, the embedded image does not change because the original object is pasted into the document.

To resize an inserted image:

1. Click the image. Resizing anchors appear at the sides and corners of the image.
2. Move the mouse over the resize anchor. Resizing arrows appear.

3. Click and drag the image to the desired size.

**ImageTools Package**

You can manipulate image data using the ImageTools package. This package is a collection of utilities for reading and writing common image file formats, and for performing basic image processing operations within Maple.

Within Maple, images are represented as dense, rectangular Arrays of 64-bit hardware floating-point numbers. Grayscale images are 2-D, whereas color images are 3-D (the third dimension representing the color channels).

In addition to the commands in the ImageTools package, many ordinary Array and Matrix operations are useful for image processing.

For details about this feature, refer to the ?ImageTools help page.

**Show or Hide Worksheet Content**

You can hide document elements of a specific type so that they are not visible. This does not delete them, but hides them from view. Hidden elements are not printed or exported, but they are copied and pasted.

In a document, use the Show Contents dialog to hide all spreadsheets, input, output, or graphics, plus section boundaries, execution group boundaries, and hidden table borders on mouse pointer roll over. The dialog is accessed from the View→Show/Hide Contents menu.

**Using the Show Contents Dialog**

A check mark beside the item indicates that all document elements of that type are displayed for the current document.

1. From the View menu, select Show/Hide Contents. The Show Contents dialog opens with all items selected for display.
2. Clear the check box associated with the document components or ranges to hide.

By clearing the **Input** check box, only Maple Input and 2-D Math input, that is, 2-D Math content that has been evaluated, are hidden. Clearing the **Graphics** check box ensures that a plot, an image, or the **Canvas** inserted in the document by using the **Insert** menu option is also hidden.

**Command Output Versus Insertion**

Output is considered an element that results from executing a command. Inserted components are not considered output.

Consider the following examples.

The plot resulting from executing the `plot(sin)` call is considered output.

- To show a plot from the `plot(sin)` call, select both the **Output** and **Graphics** check boxes in the **Show Contents** dialog.

If you insert a plot by using the **Insert** menu option, that plot is not considered output. Therefore, if you clear the **Output** check box in the **Show Contents** dialog, that plot will be visible in the document.

- To hide an inserted plot, clear the **Graphics** check box in the **Show Contents** dialog.

Inserted images and the **Canvas** are not considered output. As such, they are not hidden if you clear the **Output** check box.

- To hide an inserted image or canvas, clear the **Graphics** check box in the **Show Contents** dialog.

### 6.3 Embedded Components

You can embed simple graphical interface components, for example, a button, in your document. These components can then be associated with actions that are to be executed. For example, the value of a slider component can be
assigned to a document variable, or a text field can be part of an input equation.

**Adding Graphical Interface Components**

The graphical interface components can be inserted by using the *Components* palette (Figure 6.12) or by cutting/copying and pasting existing components to another area of the document. Although copied components have the same characteristics, they are distinct.

By default, palettes are displayed when you launch Maple. If palettes are not visible, use the following procedure.

**To view palettes:**

1. From the *View* menu, select *Palettes*.
2. Select *Expand Docks*.
3. If the *Components* palette is not displayed, right-click (Control-click, for Macintosh) the palette dock. From the context menu, select *Show Palette*, and then *Components*.

You can embed the following items.

- Button, Toggle Button
- Combo Box, Check Box, List Box, Radio Button
- Text Area, Label
- Slider, Plot, Mathematical Expression
- Dial, Meter, Rotary Gauge, Volume Gauge
 Editing Component Properties: General Process

To edit properties of components embedded in the document:

1. Right-click (Control-click, for Macintosh) the component to display the context menu.

2. Select Component Properties. The related dialog opens.

3. Enter values and contents in the fields as necessary.

4. For actions, such as Action When Value Changes in the Slider component dialog, click Edit. A blank dialog opens allowing you to enter Maple code that is executed when the event occurs. For details, refer to the Document-Tools help page.

Removing Graphical Interface Components

You can remove an embedded component by:

• Using the Delete key
Example Component Properties

The following example inserts a slider, and a label that indicates the current value of the slider.

1. Place the cursor in the location where the embedded component is to be inserted.

2. In the Components palette, click the Slider item. A slider is inserted into the document.

3. In the Components palette, click the Label item. A label is inserted next to the slider.

4. Right-click (Control-click, for Macintosh) the label component. Select Component Properties. The Label Properties dialog appears.

5. Name the component SliderLabel and click Ok.

6. Right-click (Control-click, for Macintosh) the slider component. Select Component Properties. The Slider Properties dialog opens.

7. Name the component Slider1.

8. Enter the value at the lowest position as 0 and the highest as 100.

9. Enter minor tick marks at 10 and major tick marks at 20.

10. To define an action, click the Edit button for the Action When Value Changes. The dialog that opens allows us to program the action of displaying the slider value in the label component. The dialog includes instructions on how to program embedded components. The use...in/end use; statement allows you to specify routines using the short form of accessing a package command without invoking the package. For details on this command, refer to the ?use help page.
11. Before the **end use**; statement at the bottom of the dialog, enter the following calling sequence.

```maple
Do(%SliderLabel(caption)=%Slider1(value));
```

12. Click **OK** until all of the dialogs are closed.

The value from the slider as you move the arrow indicator populates the **Label** caption field.

For details on this command, refer to the `?DocumentTools/Do` help page.

### Printing and Exporting a Document with Embedded Components

**Printing**: When printing a document, embedded components are rendered as they appear on screen.

**Exporting**: Exporting a document with embedded components to other formats produces the following results.

- HTML format - components are exported as `.gif` files.
- RTF format - components are rendered as **bitmap** images in the `.rtf` document.
- LaTeX - components are exported as `.eps` files.

### 6.4 Creating Graded Assignments

You can use Maple to create graded assignments. Question types include multiple choice, essay, true-or-false, fill-in-the-blanks, and Maple-graded.

**Note**: This feature can be used to create questions for Maple T.A.—an online automated testing and assessment system. For details about Maple T.A., see *Input, Output, and Interacting with Other Products* (page 369).
Creating a Question

To create a question:

1. Open the Task browser (Tools→Tasks→Browser).
2. From the Maple T.A. folder, select the appropriate question type.
3. Insert the question template into a document.
4. Enter the question content as described in the template.
5. Repeat steps 1 to 4 for each question to add to the document.

Viewing Questions in Maple

To view and test your questions in Maple:

- From the View menu, select Assignment. This view displays all of the questions in your assignment with access to hints, plotting, and grading.

After answering your questions, you can test the grading function by clicking the Grade button. A Maplet dialog is displayed indicating if the question was answered correctly. If hints were provided in the question, these are also displayed.

Saving Test Content

When you save a document with test content, the authoring and assignment modes determine what the user sees when opening your document.

- If you save the document in authoring mode (task template contents visible), the user sees this content when opening the document.
- If you save the document in assignment mode, the users sees only the assignment layout.

In both cases the View→Assignment menu is accessible. As such, users (students) can switch between the original document contents and the displayed assignment.
6.5 Auto-Execute

An execution group is a grouping of Maple input with its corresponding Maple output. It is distinguished by a large square bracket, called a *group boundary*, at the left. An execution group may also contain any or all of the following: a plot, a spreadsheet, and text.

Execution groups are the fundamental computation and documentation elements in the document. If you place the cursor in an input command and press the **Enter** or **Return** key, Maple executes all of the input commands in the current execution group.

The **Autoexecute** feature allows you to designate regions of a document for automatic execution. These regions are executed when the document opens. This is useful when sharing documents. Important commands can be executed as soon as the user opens your document. The user is not required to execute all commands.

**Setting the Auto-Execute Feature**

1. Select the region that must be automatically executed when the document opens.

2. From the **Format** menu, select **Autoexecute**, and then **Set**.

**Removing the Auto-Execute Setting**

To remove the setting in a region:

1. Select the region.

2. From the **Format** menu, select **Autoexecute**, and then **Clear**.

To remove all autoexecution in a document:

- From the **Format** menu, select **Autoexecute**, and then **Clear All**.
Repeating Auto-Execution

To execute all marked groups:

• From the Edit menu, select Execute, and then Repeat Autoexecution.

Security Levels

By default, Maple prompts the user before automatically executing the document.

To set security levels for the autoexecute feature, use the Security tab in the Options dialog. For details, refer to the ?OptionsDialog help page.

6.6 Canvas

Maple allows you to sketch an idea in a canvas, draw on plots, or even draw on images. See Figure 6.13. For details about the drawing feature, see the Maple help system.
Insert a Canvas

To insert a canvas:

1. Place the cursor where the canvas is to be inserted.

2. From the Insert menu, select Canvas. A canvas with grid lines appears in the document at the insertion point. The Drawing icon is available and associated context bar icons are displayed.

The tools include the following: selection tool, pencil (free style drawing), eraser, text insert, straight line, square, rounded square, ellipse, diamond, alignment, drawing outline, drawing fill, drawing linestyle, and drawing canvas properties.
Drawing

For details about the drawing feature, see the Maple help system.

To draw with the pencil tool in the canvas:

1. From the Drawing icons, select the pencil icon.

2. Click and drag your mouse in the canvas to draw lines. Release the mouse to complete the drawing.

To adjust the color of drawing tools:

1. From the Drawing icons, select the Drawing Outline icon. See Figure 6.14.

2. Select one of the color swatches available or select the color wheel, RGB ranges, or eye dropper icon at the bottom of the dialog and customize the color to your preference.

3. After selecting a new color, draw on the canvas using the pencil icon and notice the new color.

![Figure 6.14: Drawing Outline Icon](image)

Canvas Style

You can alter the Canvas in the following ways:

- Add a grid of horizontal and/or vertical lines. By default, the canvas opens with a grid of horizontal and vertical lines.
• Change the grid line color.
• Change the spacing between grid lines.
• Change the background color.

To alter the spacing of the gridlines:

1. Select the **Drawing Properties Canvas** icon.

2. Adjust the spacing for the horizontal and vertical gridlines by increasing or decreasing the value to the right. See Figure 6.15.

To alter the color of the gridlines:

1. To change the color of the gridlines, select the **Drawing Properties Canvas** icon and click the region to the right of **Line**. See Figure 6.15. This will display a list of options for you to choose a color from.

2. Select a color and notice the color of the gridlines change.

![Figure 6.15: Drawing Properties Canvas Icon - Change the Gridline Color](image)

To remove gridlines:

• Select the **Drawing Properties Canvas** icon, de-select the **Horizontal** and **Vertical** check boxes. See Figure 6.16.
To change the background color of the canvas:

1. Select the **Drawing Properties Canvas** icon and click the region to the right of **Canvas**. See Figure 6.15. This will display a list of options for you to choose a color from.

2. Select a color and notice the color of the canvas change.

6.7 Spell Checking

The **Spellcheck** utility examines all designated text regions of your document for potential spelling mistakes, including regions that are in collapsed sections. It does not check input, output, text in execution groups, or math in text regions. See Figure 6.17.

**Note:** The **Spellcheck** utility uses American spelling.
How to Use the Spellcheck Utility


2. If the Spellcheck utility finds a word that it does not recognize, that word is displayed in the Not Found text box.

You have six choices:

- To ignore the word, click Ignore.
- To ignore all instances of the word, click Ignore All.
- To change the word, that is, accept one of the suggested spellings for the word, to the one that is in the Change To text box, click Change.
- To change all instances of the word, that is, accept the suggested spelling to replace all instances of the word, click Change All.
• To add the word to your dictionary, click **Add**. For details, see the follow-
ing **User Dictionary** section.

• To close the **Spellcheck** dialog, that is, quit the **Spellcheck** utility, click **Cancel**.

3. When the **Spellcheck** is complete, a dialog containing the message "spellchecking complete" appears. Click **OK** to close this dialog.

**Selecting a Suggestion**

To select one of the suggestions as the correct spelling, click the appropriate word from the list in the **Suggestions** text box.

If none of the suggestions are correct, highlight the word in the **Change To** text box and enter the correct spelling. Click **Change** to accept this new spelling.

**Spellcheck Usage and the Document**

When using the **Spellcheck** utility, you can fix spelling errors in the **Spellcheck** dialog. You cannot change the text in the document while the **Spellcheck** utility is running.

The **Spellcheck** utility does not check grammar.

**User Dictionary**

You can create and maintain a custom dictionary that works with the Maple **Spellcheck** utility.

**Properties of the Custom Dictionary File**

- It must be a text file, that is, have the file extension **.txt**. For example, **mydictionary.txt**.

- It is a list of words, one word per line.

- It is case sensitive. This means that integer and Integer require individual entries in the dictionary file.
• It does not require manual maintenance. You build your dictionary file by using the **Add** functionality of the **Spellcheck**. However, you can manually edit the file if an error is introduced.

**To specify a custom dictionary to be used with the Maple Spellcheck utility:**

1. Create a `.txt` file using your favorite text editor in a directory/folder of your choice.

2. In Maple, open the **Options** dialog, **Tools** → **Options**, and select the **General** tab.

3. In the **User Dictionary** field, enter the path and name of the `.txt` file you created in step 1, or click **Browse** to select the location and filename.

4. To ignore Maple words that are command and function names, select the **Use Maple Words in spellchecker** check box. A check mark indicates that the **Spellcheck** ignores Maple words.

5. Click **Apply to Session**, **Apply Globally**, or **Cancel**.

**Adding a Word to Your Dictionary**

When running the spellcheck, if the word in the **Not Found** text box is correct, you can add the word to your dictionary.

1. Click the **Add** button. If this is the first time you are adding a word, the **Select User Dictionary** dialog opens.

2. Enter or select the custom dictionary (.txt file) you created. See **User Dictionary** (page 282).

3. Click **Select**. The word is automatically added to your custom dictionary file.

**Note:** Specifications in the **Options** dialog determine whether this word is recognized in your next Maple session. If you set your custom dictionary use to **Apply to Session**, then this word will **not** be recognized in a new
Maple session. If you set your custom dictionary use to **Apply Globally**, then this new word will be recognized. See *User Dictionary* (page 282).

## 6.8 Hyperlinks

Use a hyperlink in your document to access any of the following.

- Web Page (URL)
- Email
- Worksheet
- Help Topic
- Task
- Dictionary Topic
- Maplet

![Hyperlink Properties Dialog](image1.png)

**Figure 6.18: Hyperlink Properties Dialog**

### Inserting a Hyperlink in a Document

To insert a hyperlink in the document:

1. Highlight the text that you want to make a hyperlink.
2. From the **Format** menu, select **Convert To** and then **Hyperlink**.

3. In the **Hyperlink Properties** dialog box, the **Link Text** field is greyed out since the text region you highlighted is used as the link text. See Figure 6.18.

4. Optionally, use an image as the link. Select the **Image** check box and click **Choose Image** for the file. In .mw files, the image appears as the link, while in .mws files, the **Link Text** you entered appears as the link. You can resize the image as necessary. Click the image. Resizing anchors appear at the sides and corners of the image.

5. Specify the hyperlink **Type** and **Target** as described in the appropriate following section.

**Linking to a Web Page**

To link to a Web page:

1. In the **Type** drop-down list, select **URL**.
2. In the **Target** field, enter the URL, for example, **www.maplesoft.com**.
3. Click **OK**.

**Linking to an Email Address**

To link to an email address:

1. In the **Type** drop-down list, select **Email**.
2. In the **Target** field, enter the email address.
3. Click **OK**.

**Note:** For information about email hyperlinks in the Classic Worksheet interface, see *Worksheet Compatibility* (page 287).

**Linking to a Worksheet**

To link to a document:
1. In the **Type** drop-down list, select **Worksheet**.

2. In the **Target** field, enter the path and filename of the document or click **Browse** to locate the file. (Optional) In the **Bookmark** drop-down list, enter or select a bookmark.

**Note:** When linking to a custom document, the path is absolute. When sharing documents that contain hyperlinks, ensure that target documents are in the same directory.

3. Click **OK**.

**Linking to a Help Page**

To link to a help page:

1. In the **Type** drop-down list, select **Help Topic**.

2. In the **Target** field, enter the topic of the help page.

(Optional) In the **Bookmark** drop-down list, enter or select a bookmark.

3. Click **OK**.

**Linking to A Task**

To link to a task:

1. In the **Type** drop-down list, select **Task**.

2. In the **Target** field, enter the filename of the task template.

3. Click OK.

**Linking to a Dictionary Topic**

To link to a Dictionary topic:

1. In the **Type** drop-down list, select **Dictionary Topic**.

2. In the **Target** field, enter a topic name. Dictionary topics begin with the prefix **Definition/**, for example, **Definition/dimension**.
3. Click **OK**.

**Linking to a Maplet Application**

**To link to a Maplet application:**

1. In the **Type** drop-down list, select **Maplet**.

2. In the **Target** field, enter the local path to a file with the `.maplet` extension. Optionally, click **Browse** to locate the file.

If the Maplet application exists, clicking the link launches the Maplet application. If the Maplet application contains syntax errors, then error messages are displayed in a pop-up window.

When linking to a custom Maplet application, the path is absolute. When sharing documents that contain links to Maplet applications, ensure that target Maplet applications are in the same directory.

3. Click **OK**.

**Note:** To link to a Maplet application available on a MapleNet Web page, use the URL hyperlink type to link to the Web page. For information on MapleNet, see *Input, Output, and Interacting with Other Products* (page 369).

### 6.9 Worksheet Compatibility

Maple provides users with two worksheet interfaces: the Standard Worksheet and the Classic Worksheet. Both have access to the full mathematical engine of Maple and take advantage of the new functionality in Maple. The Classic Worksheet has the traditional Maple worksheet look and uses less memory.

If you create a document in the Standard Worksheet interface of Maple and then open it in the Classic Worksheet interface, you should note possible changes to your file. For example, a bulleted list in the Standard Worksheet will not be displayed with bullets in the Classic Worksheet.

If you are creating documents for distribution, refer to the ?**Compatibility** help page.
7 Maple Expressions

This chapter provides basic information on using Maple expressions, including an overview of the basic data structures. Many of the commands described in this chapter are useful for programming. For information on additional Maple programming concepts, such as looping, conditional execution, and procedures, see Basic Programming (page 325).

7.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating and Using Data Structures - How to define and use basic data structures</td>
<td>• Expression Sequences</td>
</tr>
<tr>
<td></td>
<td>• Sets</td>
</tr>
<tr>
<td></td>
<td>• Lists</td>
</tr>
<tr>
<td></td>
<td>• Tables</td>
</tr>
<tr>
<td></td>
<td>• Arrays</td>
</tr>
<tr>
<td></td>
<td>• Matrices and Vectors</td>
</tr>
<tr>
<td></td>
<td>• Functional Operators</td>
</tr>
<tr>
<td></td>
<td>• Strings</td>
</tr>
<tr>
<td>Working with Maple Expressions - Tools for manipu-</td>
<td>• Low-Level Operations</td>
</tr>
<tr>
<td>lating and controlling the evaluation of expres-</td>
<td>• Manipulating Expressions</td>
</tr>
<tr>
<td>sions</td>
<td>• Evaluating Expressions</td>
</tr>
</tbody>
</table>

7.2 Creating and Using Data Structures

Constants, data structures, mathematical expressions, and other objects are Maple expressions. For more information on expressions, refer to the Maple Help System.
This section describes the key data structures:

- Expression sequences
- Sets
- Lists
- Tables
- Arrays
- Matrices and Vectors
- Functional operators
- Strings

**Expression Sequences**

The fundamental Maple data structure is the *expression sequence*. It is a group of expressions separated by commas.

```
> S := 2, y, sin(x^2), l;
```

**Accessing Elements**

To access one of the expressions:

- Enter the sequence name followed by the position of the expression enclosed in brackets([ ]).

For example:

```
> S[2]
```

```
y
```

Using negative integers, you can select an expression from the end of a sequence.
You can select multiple expressions by specifying a range using the range operator (..).

\[
S[2..-2]
\]

\[
y, \sin(x^2)
\]

**Note:** This syntax is valid for most data structures.

### Sets

A set is an expression sequence enclosed in curly braces (\{\}).

\[
\{4, 12, i, \sin\left(\frac{2}{3}\right)\}
\]

A Maple set has the basic properties of a mathematical set.

- Each element is unique. Repeated elements are stored only once.
- The order of elements is not stored.

For example:

\[
\{c, a, a, a, b, c, a\}
\]

\[
\{a, b, c\}
\]

### Using Sets

To perform mathematical set operations, use the set data structure.
Note: The union operator is available in 1-D Math input as `union`. For more information, refer to the `?union` help page.

For more information on sets, refer to the `?set` help page.

**Lists**

A list is an expression sequence enclosed in brackets ([ ]).

```
> L := [2, 3, 3, 1, 0]

L := [2, 3, 3, 1, 0]
```

*Note:* Lists preserve both the order and repetition of elements.

**Accessing Entries**

To refer to an element in a list:

- Use square brackets.

For example:

```
> L[−2 ..−1]

[1, 0]
```

For more information, see *Accessing Elements* (page 290).

**Using Lists**

Some commands accept a list (or set) of expressions.

For example, you can solve a list (or set) of equations using a context menu or the `solve` command.
Arrays

Conceptually, the Array data structure is a generalized list. Each element has an index that you can use to access it.

The two important differences are:

- The indices can be any integers.
- The dimension can be greater than one.

Creating and Using Arrays

To define an Array, use the `Array` constructor.

Standard `Array` constructor arguments are:

- Expression sequences of ranges - Specify the indices for each dimension
- Nested lists - Specify the contents

For example:

```latex
> a := Array(1..3, 1..3, [[1,2,3], [4,5,6], [7,8,9]])

\[
a := \begin{bmatrix}
1 & 2 & 3 \\
4 & 5 & 6 \\
7 & 8 & 9
\end{bmatrix}
\]
```

For more information, see *Solving Equations and Inequations* (page 78).

For more information on sets and lists, refer to the `?set` help page.
The `Array` constructor supports other syntaxes. It also supports many options. For more information on the `Array` constructor and the Array data structure, refer to the `?Array` help page.

**Large Arrays**

Only one- and two-dimensional Arrays (with at most 10 indices in each dimension) display in the document. Larger Arrays display as a placeholder.

> `Array(0 .. 100)`

```
0 .. 100 Array
Data Type: anything
Storage: rectangular
Order: Fortran_order
```

To view large Arrays:

- Double-click the placeholder.

The Matrix Browser displays the Array. For more information, see *Editing and Viewing Large Matrices and Vectors* (page 138).

**Tables**

Tables are conceptually an extension of the Array data structure, but the table data structure is implemented using hash tables. Tables can be indexed by any values, not only integers.
### Defining Tables and Accessing Entries

> Greek := table(\{a = \alpha, b = \beta, c = \gamma\}):  

> Greek[b]

\[ \beta \]

You can also assign anything, for example, a list, to each element.

> Translation := table(\{one = [un, uno], two = [deux, dos], three = [trois, tres]\}):  

> Translation[two]

\[ [\text{deux, dos}] \]

For more information on tables, refer to the `?table` help page.

### Matrices and Vectors

Matrices and Vectors are specialized data structures used in linear algebra and vector calculus computations.

> M := \begin{bmatrix} 12 & 33 \\ 83 & 12 \end{bmatrix}; v := <2, 14>:

For information on defining Matrices and Vectors, see *Creating Matrices and Vectors* (page 136).

> M.v

\[ \begin{bmatrix} 486 \\ 334 \end{bmatrix} \]
For more information on these data structures, including how to access entries and perform linear algebra computations, see Linear Algebra (page 135).

**Functional Operators**

A functional operator is a mapping \( f : x \rightarrow y(x) \). The value of \( f(x) \) is the result of evaluating \( y(x) \).

Using functional operators, you can define mathematical functions.

**Defining a Function**

To define a function of one or two variables:

1. In the Expression palette, click one of the function definition items. See Figure 7.1. Maple inserts the function definition.

2. Replace the placeholder \( f \) with the function name. Press Tab. **Note:** If pressing the Tab key inserts a tab, click the Tab icon in the toolbar.

3. Replace the parameter placeholders, \( x \) or \( x1, x2 \), with the independent variable names. Press Tab.

4. Replace the final placeholder, \( y \), with the expression that defines the function value. Press Enter.
For example, define a function that adds 1 to its input.

\[ \text{add1 := } x \rightarrow x + 1 \; \]

**Note:** To insert the right arrow, you can enter the characters -&gt; . In 2-D Math, Maple replaces -&gt; with the right arrow symbol \( \rightarrow \). In 1-D Math, the characters are not replaced.

You can evaluate the function `add1` with symbolic or numeric arguments.

\[ \text{add1(12); add1(x + y)} \]

\[ x + y + 1 \]

**Distinction between Functional Operators and Other Expressions**

The expression \( x + 1 \) is different from the functional operator \( x \rightarrow x + 1 \).

Assign the functional operator \( x \rightarrow x + 1 \) to \( f \).

\[ f := x \rightarrow x + 1; \]

Assign the expression \( x + 1 \) to \( g \).

\[ g := x + 1; \]

**To evaluate the functional operator** \( f \) **at a value of** \( x \):

- Specify the value as an argument to \( f \).
To evaluate the expression $g$ at a value of $x$:

- You **must** use the `eval` command.

```maple
> eval(g, x = 22)
```

For more information on the `eval` command, and using palettes and context menus to evaluate an expression at a point, see Substituting a Value for a Subexpression (page 314).

## Multivariate and Vector Functions

To define a multivariate or vector function:

- Enclose coordinates or coordinate functions in parentheses (()).

For example, a multivariate function:

```maple
> f := (x, y) -> \frac{x^3}{y^2+1};
> f(0, 0); f(-2.1, 1.9)
```

A vector function:

```maple
> g := t -> (sin(t), cos(t), t);
```
Using Operators

To perform an operation on a functional operator, specify arguments to the operator. For example, for the operator $f$, specify $f(x)$, which Maple evaluates as an expression. See the following examples.

**Plot an Operator as an Expression** Plot a three-dimensional function using the `plot3d` command.

\[
> h := (x, y) \rightarrow x^2 \cos(y):
\]

\[
> \text{plot3d}(h(x,y), x = -2 .. 2, y = -2 \pi .. 2 \pi)
\]
For information on plotting, see *Plots and Animations* (page 189).

**Integration** Integrate a function using the `int` command.

\[
> k := x \rightarrow \sin(\cos(x)\pi):
\]

\[
> \text{int}(k(t), t=0..\frac{\pi}{2})
\]

\[
\frac{1}{2} \pi \text{StruveH}(0, \pi)
\]

For information on integration and other calculus operations, see *Calculus* (page 153).

**Strings**

A string is a sequence of characters enclosed in double quotes (" ").
Accessing Characters

You can access characters in a string using brackets.

\[ S[8..-2] \]

"sequence of characters"

Using Strings

The **StringTools** package is an advanced set of tools for manipulating and using strings.

\[ with(StringTools): \]

\[ Random(9) \]

"□□d8p!<v,."

\[ Stem("impressive") \]

"impress"

\[ Split("Create a list of strings from the words in a string") \]

[ "Create", "a", "list", "of", "strings", "from", "the", "words", "in", "a", "string"]

7.3 Working with Maple Expressions

This section describes how to manipulate expressions using context menus, palette items, and the underlying commands.

To display the context menu for an expression:
Right-click (Control-click, for Macintosh) the expression.

To view the palettes:
- From the View menu, select Palettes, and then Expand Docks.

Low-Level Operations

Expression Types

A Maple type is a broad class of expressions that share common properties. Maple contains over 200 types, including:

- `+`
- boolean
- constant
- integer
- Matrix
- trig
- truefalse

For more information and a complete list of Maple types, refer to the ?type help page.

The type commands return true if the expression satisfies the type check. Otherwise, they return false.

Testing the Type of an Expression

To test whether an expression is of a specified type:

- Use the type command.

  > type(sin(x), 'trig')
For information on enclosing keywords in right single quotes ('), see *Delaying Evaluation* (page 321).

Maple types are not mutually exclusive. An expression can be of more than one type.

\[
> \text{type}(\sin(x) + \cos(x), '\text{trig}')
\]

\textit{false}

For information on converting an expression to a different type, see *Converting* (page 311).

**Testing the Type of Subexpressions**

To test whether an expression has a subexpression of a specified type:

- Use the \texttt{hastype} command.
> hastype(sin(x) + cos(x), 'trig')

   true

Testing for a Subexpression

To test whether an expression contains an instance of a specified subexpression:

- Use the has command.

> has(sin(x + y), x)

   true

> has(sin(x + y), x + y)

   true

> has(sin(x + y), sin(x))

   false

The has command searches the structure of the expression for an exactly matching subexpression.

For example, the following calling sequence returns false.

> has(x + y + z, x + z)

   false

To return all subexpressions of a particular type, use the indets command. For more information, see Indeterminates (page 307).
Accessing Expression Components

Left and Right-Hand Side

The \texttt{lhs} and \texttt{rhs} commands return the left and right-hand side of an equation, inequality, or range.

To extract the left-hand side of an expression:

- Use the \texttt{lhs} command.

To extract the right-hand side of an expression:

- Use the \texttt{rhs} command.

For example:

\begin{verbatim}
> y := x + 1

\end{verbatim}

\begin{equation}
\begin{aligned}
y &= x + 1 \\
\text{lhs}(7.1)
\end{aligned}
\end{equation}

\begin{verbatim}
> rhs(7.1)

\end{verbatim}

\begin{equation}
\begin{aligned}
x + 1 \\
\text{rhs}(7.1)
\end{aligned}
\end{equation}

For the following equation, the left endpoint of the range is the left-hand side of the right-hand side of the equation.

\begin{verbatim}
> x := 3 .. 5

\end{verbatim}

\begin{equation}
\begin{aligned}
x = 3 .. 5 \\
\text{7.2}
\end{aligned}
\end{equation}
\[ \text{Numer} \text{ator and Denominator} \]

To extract the numerator of an expression:
- Use the \texttt{numer} command.

To extract the denominator of an expression:
- Use the \texttt{denom} command.

\[ e := \frac{1 + \sin(x)^3 - \frac{y}{x}}{y^2 - 1 + x} : \]

If the expression is not in normal form, Maple normalizes the expression before selecting the numerator or denominator. (For more information on normal form, refer to the \texttt{normal} help page.)

\[ \text{num}er(e) \]
\[ x + \sin(x)^3 x - y \]

\[ \text{denom}(e) \]
\[ x \left( y^2 - 1 + x \right) \]

\[ \text{denom}(\text{denom}(e)) \]
\[ 1 \]

The expression can be any algebraic expression. For information on the behavior for non-rational expressions, refer to the \texttt{numer} help page.
Components of an Expression

The components of an expression are called its operands.

To count the number of operands in an expression:

- Use the `nops` command.

For example, construct a list of solutions to an equation.

```
> solutions := [solve(6*x^3 - x^2 + 7, x)]
```

```
solutions := [-1, 7/12 + 1/12*119, 7/12 - 1/12*119]
```

Using the `nops` command, count the number of solutions.

```
> nops(solutions)
```

3

For more information on the `nops` command and operands, refer to the `?nops` help page.

Indeterminates

To find the indeterminates of an expression:

- Use the `indets` command.

The `indets` command returns the indeterminates as a set. Because the expression is expected to be rational, functions such as `sin(x)`, `f(x)`, and `sqrt(x)` are considered to be indeterminate.

```
> indets((3 + pi)*x^2*sin(sqrt(1 + y)))
```

```
{x, y, sqrt(1 + y), sin(sqrt(1 + y))}
```
To return all subexpressions of a particular type, specify the type as the second argument. For information on types, see *Testing the Type of an Expression* (page 302).

\[
> \text{indets}\left((3 + \pi) x^2 \sin\left(\sqrt{1 + y}\right), '\text{radical}'\right)
\]

\{\sqrt{1 + y}\}

To test whether an expressions has subexpressions of a specific type (without returning them), use the `has` command. For more information, see *Testing for a Subexpression* (page 304).

### Manipulating Expressions

This section introduces the most commonly used manipulation commands. For additional manipulation commands, see *Iterative Commands* (page 337).

#### Simplifying

To simplify an expression:

- Use the `simplify` command.

The `simplify` command applies simplification rules to an expression. Maple has simplification rules for various types of expressions and forms, including trigonometric functions, radicals, logarithmic functions, exponential functions, powers, and various special functions. You can also specify custom simplification rules using a set of *side relations*.

\[
> \text{simplify}\left(\sqrt{5 + 32} - 8\left(\frac{1}{3}\right)\right)
\]

35
To limit the simplification, specify the type of simplification to be performed.

```maple
> simplify(sin(x)^2 + ln(2y) + cos(x)^2)
1 + ln(2) + ln(y)
```

To factor a polynomial:

- Use the `factor` command.

```maple
> factor(x^6 - x^5 - 9 x^4 + x^3 + 20 x^2 + 12 x)
   (x - 2) (x - 3) (x + 2) (x + 1)^2
```

Maple can factor polynomials over the domain specified by the coefficients. You can also factor polynomials over algebraic extensions. For details, refer to the `?factor` help page.
For more information on polynomials, see *Polynomial Algebra (page 126)*.

**To factor an integer:**

- Use the *ifactor* command.

```
> ifactor(196911)
```

(3)^4 (11) (13) (17)

For more information on integers, see *Integer Operations (page 71)*.

**Expanding**

**To expand an expression:**

- Use the *expand* command.

The *expand* command distributes products over sums and expands expressions within functions.

```
> expand( (y-3) (x+1)^2 (x+y) )
```

x^3 y + x^2 y^2 - 3 x^3 - x^2 y + 2 x y^2 - 6 x^2 - 5 x y + y^2 - 3 x - 3 y

```
> expand(sin(x + y))
```

sin(x) cos(y) + cos(x) sin(y)

**Combining**

**To combine subexpressions in an expression:**

- Use the *combine* command.
The **combine** command applies transformations that combine terms in sums, products, and powers into a single term.

\[
\text{combine}(\sin(x) \cos(y) + \cos(x) \sin(y))
\]

\[
\sin(x + y)
\]

\[
\text{combine}\left(\left(x^a\right)^2 x\right)
\]

\[
\begin{bmatrix}
  x^3 & x^5 & x^7 \\
  x^9 & x^{11} & x^{13} \\
  x^{15} & x^{17} & x^{19}
\end{bmatrix}
\]

The **combine** command applies only transformations that are valid for all possible values of names in the expression.

\[
\text{combine}(4 \ln(x) - \ln(y))
\]

\[
4 \ln(x) - \ln(y)
\]

To perform the operation under assumptions on the names, use the **assuming** command. For more information about assumptions, see *Assumptions on Variables (page 116).*

\[
\text{combine}(4 \ln(x) - \ln(y)) \text{ assuming } x > 0, y > 0
\]

\[
\ln\left(\frac{x^4}{y}\right)
\]

**Converting**

**To convert an expression:**

- Use the **convert** command.
The `convert` command converts expressions to a new form, type (see *Expression Types (page 302)*), or in terms of a function. For a complete list of conversions, refer to the `?convert` help page.

Convert a measurement in radians to degrees:

```
> convert(π, 'degrees')
180 degrees
```

To convert measurements that use units, use the Unit Converter or the `convert/units` command.

```
> convert(450.2[kg], 'units', lb)
992.5211043 [lb]
```

For information on the Unit Converter and using units, see *Units (page 97)*.

Convert a list to a set:

```
> convert([a, b, c, d], 'set')
{a, b, c, d}
```

Maple has extensive support for converting mathematical expressions to a new function or function class.

```
> convert(cos(x), exp)
\frac{1}{2} e^{lx} + \frac{1}{2} e^{-lx}
```

Find an expression equivalent to the inverse hyperbolic cotangent function in terms of Legendre functions.

```
> convert(arccoth(z), Legendre)
```
For more information on converting to a class of functions, refer to the \texttt{?convert/to_special_function} help page.

**Normalizing**

To normalize an expression:

- Use the \texttt{normal} command.

The \texttt{normal} command converts expressions into \textit{factored normal form}.

\[
\text{normal} \left( \frac{x^2 - y^2}{(x-y)^3} \right)
\]

\[
\frac{x + y}{(x - y)^2}
\]

You can also use the \texttt{normal} command for zero recognition.

\[
\text{normal}\left( x^3 + 1 - (x + 1)^3 + 3x(1 + x) \right)
\]

\[
0
\]

To expand the numerator and denominator, use the \texttt{expanded} option.

\[
\text{normal}\left( \frac{x^2 - y^2}{(x-y)^3}, \text{\textquoteleft expanded\textquoteright} \right)
\]

\[
\frac{x + y}{x^2 - 2xy + y^2}
\]

\[
\text{normal}\left( \sin\left( 1 + \frac{1}{x} \right) \right)
\]
Sorting

To sort the elements of an expression:

- Use the `sort` command.

The `sort` command orders a list of values or terms of a polynomial.

\[
sort([4, 3, 2.1, -4, 43, 0])
\]

\[
[-4, 0, 2.1, 3, 4, 43]
\]

\[
sort(x + 4x^5 - 7x^2 + 1 + 9x^4 - 5x^3)
\]

\[
4x^5 + 9x^4 - 5x^3 - 7x^2 + x + 1
\]

\[
sort(xy - 6y^2 x + 2y^3 + 5x - 1)
\]

\[
-6xy^2 + 2y^3 + xy + 5x - 1
\]

For information on sorting polynomials, see Sorting Terms (page 128).

For more information on sorting, refer to the `?sort` help page.

Evaluating Expressions

Substituting a Value for a Subexpression

To evaluate an expression at a point, you must substitute a value for a variable.

To substitute a value for a variable:
1. Right-click (Control-click, for Macintosh) the expression. Maple displays a context menu.

2. From the context menu, select **Evaluate at a Point**. The **Evaluate at a Point** dialog is displayed.

3. In the drop-down list, select the variable to substitute.

4. In the text field, enter the value to substitute for the variable. Click **OK**.

Maple inserts the `eval` command calling sequence that performs the substitution. This is the most common use of the `eval` command.

For example, substitute $x = 3$ in the following polynomial.

\[
> x^3 + 4x^2 - 7x + 2
\]

\[
> eval(x^3 + 4x^2 - 7x + 2, [x = 3])
\]

\[44\]  

(7.3)

**To substitute a value for a variable using palettes:**

1. In the **Expression** palette, click the evaluation at a point item.

2. Specify the expression, variable, and value to be substituted.

For example:

\[
> \sqrt{x^2 - x - 3}_{x = 5}
\]

\[
\sqrt{17}
\]
Substitutions performed by the eval function are syntactical, not the more powerful algebraic form of substitution.

If the left-hand side of the substitution is a name, Maple performs the substitution.

\[ \text{eval} \left( \cos(abc), a = \frac{\pi}{6} \right) \]

\[ \cos \left( \frac{1}{6} \pi b c \right) \]

If the left-hand side of the substitution is not a name, Maple performs the substitution only if the left-hand side of the substitution is an operand of the expression.

\[ \text{eval} \left( \cos(ab), a b = \frac{\pi}{6} \right) \]

\[ \frac{1}{2} \sqrt{3} \]

\[ \text{eval} \left( \cos(abc), a b = \frac{\pi}{6} \right) \]

\[ \cos(ab c) \]

Maple did not perform the evaluation because \( ab \) is not an operand of \( \cos(ab c) \). For information on operands, refer to the ?op help page.

For algebraic substitution, use the algsubs command, or the simplify command with side relations.

\[ \text{algsubs} \left( a b = \frac{\pi}{6} , \cos(ab c) \right) \]
Numerical Approximation

To compute an approximate numerical value of an expression:

• Use the \texttt{evalf} command.

The \texttt{evalf} command returns a floating-point (or complex floating-point) number or expression.

\begin{align*}
\texttt{> evalf}\left( \cos\left( \frac{\pi}{6} \right) \right) & \\
& = 0.8660254040
\end{align*}
By default, Maple calculates the result to ten digits of accuracy, but you can specify any number of digits as an index, that is, in brackets ([ ]).

\[ \text{evalf}\left( \frac{17}{\sqrt{3}} x^2 + x - e^\pi \right) \]

\[ 9.8 x^2 + x - 1.0 e^{3.1} \]

\[ \text{evalf}(\pi) \]

\[ 3.141592654 \]  

By default, Maple calculates the result to ten digits of accuracy, but you can specify any number of digits as an index, that is, in brackets ([ ]).

\[ \text{evalf}[40](\pi) \]

\[ 3.141592653589793238462643383279502884197 \]

For more information, refer to the \texttt{?evalf} help page.

See also \textit{Numerically Computing a Limit (page 155)} and \textit{Numeric Integration (page 165)}.

**Evaluating Complex Expressions**

To evaluate a complex expression:

- Use the \texttt{evalc} command.

If possible, the \texttt{evalc} command returns the output in the canonical form $\texttt{expr1} + i \texttt{expr2}$.

You can enter the imaginary unit using the following two methods.

- In the \textbf{Common Symbols} palette, click the \texttt{i} or \texttt{j} item. See \textit{Palettes (page 12)}.
- Enter \texttt{i} or \texttt{j}, and then press the symbol completion key. See \textit{Symbol Names (page 17)}. 
In 1-D Math input, enter the imaginary unit as an uppercase i (I).

\[ \text{evalc}(\sqrt{1 + I}) \]

\[ \frac{1}{2} \sqrt{2 + 2\sqrt{2}} + \frac{1}{2} \sqrt{-2 + 2\sqrt{2}} \]

\[ \text{evalc}(\sin(3 + 5I)) \]

\[ \sin(3) \cosh(5) + I \cos(3) \sinh(5) \]

Evaluating Boolean Expressions

To evaluate an expression involving relational operators ( =, ≠, >, <, ≤, and ≥): 

- Use the evalb command.

Note: In 1-D Math input, enter ≠, ≤, and ≥ using the <> , <=, and >= operators.

The evalb command uses a three-valued logic system. The return values are true, false, and FAIL. If evaluation is not possible, an unevaluated expression is returned.

\[ \text{evalb}(x = x) \]

true

\[ \text{evalb}(x = y) \]
Important: The \texttt{evalb} command does not perform arithmetic for inequalities involving $<$, $\leq$, $>$, or $\geq$, and does not simplify expressions. Ensure that you perform these operations before using the \texttt{evalb} command.

\begin{verbatim}
\texttt{evalb(3 + 2 I < 2 + 3 I)}
\end{verbatim}

\texttt{FAIL}

\textbf{Important:} The \texttt{evalb} command does not perform arithmetic for inequalities involving $<$, $\leq$, $>$, or $\geq$, and does not simplify expressions. Ensure that you perform these operations before using the \texttt{evalb} command.

\begin{verbatim}
\texttt{evalb(Re(x) < Re(x + 1))}
\end{verbatim}

\texttt{Re(x) < 1 + Re(x)}

\begin{verbatim}
\texttt{evalb(Re(x) - Re(x + 1) < 0)}
\end{verbatim}

\texttt{true}

\textbf{Levels of Evaluation}

In a symbolic mathematics program such as Maple, you encounter the issue of \textit{levels of evaluation}. If you assign \texttt{y} to \texttt{x}, \texttt{z} to \texttt{y}, and then \texttt{5} to \texttt{z}, what is the value of \texttt{x}?

At the top-level, Maple \textit{fully evaluates} names. That is, Maple checks if the name or symbol has an assigned value. If it has a value, Maple substitutes the value for the name. If this value has an assigned value, Maple performs a substitution, recursively, until no more substitutions are possible.

For example:

\begin{verbatim}
\texttt{x := y:}
\end{verbatim}

\begin{verbatim}
\texttt{y := z:}
\end{verbatim}

\begin{verbatim}
\texttt{z := 5:}
\end{verbatim}
Maple fully evaluates the name `x`, and returns the value 5.

```maple
> x
5
```

**To control the level of evaluation of an expression:**

- Use the `eval` command with an integer second argument.

If passed a single argument, the `eval` command fully evaluates that expression. If you specify an integer second argument, Maple evaluates the expression to that level.

```maple
> eval(x)
5

> eval(x, 1)
y

> eval(x, 2)
z

> eval(x, 3)
5
```

For more details on levels of evaluation, refer to the `?lastnameevaluation`, `?assigned`, and `?evaln` help pages.

**Delaying Evaluation**

To prevent Maple from immediately evaluating an expression:

- Enclose the expression in right single quotes (`' '`).
Because right single quotes delay evaluation, they are referred to as *unevaluation quotes*.

> i := 4:

> i

4

> 'i'

i

**Using an Assigned Name as a Variable or Keyword**

If you use an assigned name as a variable, Maple evaluates the name to its value, and passes the value to the command.

> \[ \sum_{i=1}^{5} i^2 \]

55

(7.6)

**Note:** In general, it is recommended that you unassign a name to use it as a variable. See *Unassigning a Name Using Unevaluation Quotes* (page 324).

**To use an assigned name as a variable:**

- Enclose the name in unevaluation quotes. Maple passes the name to the command.

> \[ \sum_{'i'=1}^{5} 'i'^2 \]

55
Important: It is recommended that you enclose keywords in unevaluation quotes.

For example, if you enclose the keyword `left` in unevaluation quotes, Maple uses the name, not its assigned value.

\[ \texttt{limit}\left(\frac{1}{x}, x=0, 'left'\right) \]

\[ -\infty \]

**Full Evaluation of an Expression in Quotes**

Full evaluation of a quoted expression removes one set of right single quotes.

\[ \texttt{i := 4;} \]

\[ ' ' i ' + 1' \]

\[ 'i' + 1 \]  \hspace{1cm} (7.7)

\[ (7.7) \]

\[ i + 1 \]  \hspace{1cm} (7.8)

\[ (7.8) \]

\[ 5 \]

For information on equation labels and equation label references, see *Equation Labels* (page 59).

Enclosing an expression in unevaluation quotes delays evaluation, but does not prevent automatic simplification.
Unassigning a Name Using Unevaluation Quotes

To unassign a name:

• Assign the name enclosed in unevaluation quotes to itself.

```plaintext
> i := 'i';
```

```plaintext
i
```

You can also unassign a name using the `unassign` command. For more information, see Unassigning Names (page 57).
8 Basic Programming

You have used Maple interactively in the previous chapters, sequentially performing operations such as executing a single command. Because Maple has a complete programming language, you can also use sophisticated programming constructs.

**Important:** It is strongly recommended that you use the Worksheet mode and 1-D Math input when programming or using programming commands. Hence, all input in this chapter is entered as 1-D Math.

8.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flow Control - Basic programming constructs</td>
<td>• Conditional Execution (<em>if</em> Statement)</td>
</tr>
<tr>
<td></td>
<td>• Repetition (<em>for</em> Statement)</td>
</tr>
<tr>
<td>Iterative Commands - Specialized, efficient iterative commands</td>
<td>• Creating a sequence</td>
</tr>
<tr>
<td></td>
<td>• Adding and Multiplying Expressions</td>
</tr>
<tr>
<td></td>
<td>• Selecting Expression Operands</td>
</tr>
<tr>
<td></td>
<td>• Mapping a Command over a Set or List</td>
</tr>
<tr>
<td></td>
<td>• Mapping a Binary Command over Two Lists or Vectors</td>
</tr>
<tr>
<td>Procedures - Maple programs</td>
<td>• Defining and Running Simple Procedures</td>
</tr>
<tr>
<td></td>
<td>• Procedures with Inputs</td>
</tr>
<tr>
<td></td>
<td>• Procedure Return Values</td>
</tr>
<tr>
<td></td>
<td>• Displaying Procedure Definitions</td>
</tr>
<tr>
<td></td>
<td>• Displaying Maple Library Procedure Definitions</td>
</tr>
<tr>
<td></td>
<td>• Modules</td>
</tr>
</tbody>
</table>

325
8.2 Flow Control

Two basic programming constructs in Maple are the if statement, which controls the conditional execution of statement sequences, and the for statement, which controls the repeated execution of a statement sequence.

Conditional Execution (if Statement)

You can specify that Maple perform an action only if a condition holds. You can also perform an action, from a set of many, depending on which conditions hold.

Using the if statement, you can execute one statement from a series of statements based on a boolean (true, false, or FAIL) condition. Maple tests each condition in order. When a condition is satisfied, Maple executes the corresponding statement, and then exits the if statement.

Syntax

The if statement has the following syntax.

```maple
> if conditional_expression1 then
    statement_sequence1
elif conditional_expression2 then
    statement_sequence2
elif conditional_expression3 then
    statement_sequence3
... else
    statement_sequenceN
end if;
```

The conditional expressions (conditional_expression1, conditional_expression2, ...) can be any boolean expression. You can construct boolean expressions using:
• Relational operators - <, <=, =, >=, >, <>
• Logical operators - and, or, xor, implies, not
• Logical names - true, false, FAIL

The statement sequences (statement_sequence1, statement_sequence2, ..., statement_sequenceN) can be any sequence of Maple statements, including if statements.

The elif clauses are optional. You can specify any number of elif clauses.

The else clause is optional.

**Simple if Statements**

The simplest if statement has only one conditional expression.

```maple
> if conditional_expression then
    statement_sequence
  end if;
```

If the conditional expression evaluates to true, the sequence of statements is executed. Otherwise, Maple immediately exits the if statement.

For example:

```maple
> x := 1173;

> if not isprime(x) then
    ifactor(x);
  end if;
```

```
(3) (17) (23)
```
else Clause

In a simple if statement with an else clause, if the evaluation of the conditional expressions returns false or FAIL, Maple executes the statement sequence in the else clause.

For example:

```maple
> if false then
   "if statement";
else
   "else statement";
end if;

"else statement"
```

elif Clauses

In an if statement with elif clauses, Maple evaluates the conditional expressions in order until one returns true. Maple executes the corresponding statement sequence, and then exits the if statement. If no evaluation returns true, Maple exits the if statement.

```maple
> x := 11:

> if not type(x, integer) then
   printf("%a is not an integer.", x);
elif x >= 10 then
   printf("%a is an integer with more than one digit.", x);
elif x >= 0 then
   printf("%a is an integer with one digit.", x);
end if;

11 is an integer with more than one digit.
```

Order of elif Clauses

An elif clause's statement sequence is executed only if the evaluation of all previous conditional expressions returns false or FAIL, and the evaluation of its conditional expression returns true. This
means that changing the order of `elif` clauses may change the behavior of the `if` statement.

In the following `if` statement, the `elif` clauses are in the **wrong order**.

```maple
> if not(type(x, integer)) then
    printf("%a is not an integer.", x);
elif x >= 0 then
    printf("%a is an integer with one digit.", x);
elif x >= 10 then
    printf("%a is an integer with more than one digit.", x);
end if;
```

11 is an integer with one digit.

**elif and else Clauses**

In an `if` statement with `elif` and `else` clauses, Maple evaluates the conditional expressions in order until one returns `true`. Maple executes the corresponding statement sequence, and then exits the `if` statement. If no evaluation returns `true`, Maple executes the statement sequence in the `else` clause.

```maple
> x := -12:

> if not type(x, integer) then
    printf("%a is not an integer.", x);
elif x >= 10 then
    printf("%a is an integer with more than one digit.", x);
elif x >= 0 then
    printf("%a is an integer with one digit.", x);
else
    printf("%a is a negative integer.", x);
end if;
```

-12 is a negative integer.

For more information on the `if` statement, refer to the ?if help page.
Repetition (for Statement)

Using repetition statements, you can repeatedly execute a statement sequence. You can repeat the statements in three ways.

- Until a counter variable value exceeds a limit (for/from loop)
- For each operand of an expression (for/in loop)
- Until a boolean condition does not hold (while loop)

for/from Loop

The for/from loop statement repeats a statement sequence until a counter variable value exceeds a limit.

Syntax

The for/from loop has the following syntax.

```maple
> for counter from initial by increment to final do
    statement_sequence
    end do;
```

The behavior of the for/from loop is:

1. Assign the initial value to the name counter.

2. Compare the value of counter to the value of final. If the counter value exceeds the final value, exit the loop. (This is the loop bound test.)

3. Execute the statement_sequence.

4. Increment the counter value by the value of increment.

5. Repeat steps 2 to 4, until Maple exits the loop.

The from, by, and to clauses are optional and can be in any order between the for clause and the do keyword.

Table 8.1 lists the default clause values.
### Table 8.1: Default Clause Values

<table>
<thead>
<tr>
<th>Clause</th>
<th>Default Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>from initial</td>
<td>1</td>
</tr>
<tr>
<td>by increment</td>
<td>1</td>
</tr>
<tr>
<td>to final</td>
<td>infinity (∞)</td>
</tr>
</tbody>
</table>

### Examples

The following loop returns the square root of the integers 1 to 5 (inclusive).

```maple
> for n to 5 do
    evalf(sqrt(n));
end do;
```

1.

1.414213562

1.732050808

2.

2.236067977

When the value of the counter variable `n` is **strictly greater than 5**, Maple exits the loop.

```maple
> n;
```

6

The previous loop is equivalent to the following **for/from** statement.
> for n from 1 by 1 to 5 do
    evalf(sqrt(n));
end do;

1.
1.414213562
1.732050808

2.
2.236067977

The by value can be negative. The loop repeats until the value of the counter variable is strictly less than the final value.

> for n from 10 by -1 to 3 do
    if isprime(n) then
        print(n);
    end if;
end do;

7
5
3

> n;

2

for/in Loop

The for/in loop statement repeats a statement sequence for each component (operand) of an expression, for example, the elements of a list.
Syntax

The *for/in* loop has the following syntax.

\[
\text{for variable in expression do} \\
\quad \text{statement_sequence} \\
\quad \text{end do;}
\]

The *for* clause must appear first.

The behavior of the *for/in* loop is:

1. Assign the first operand of *expression* to the name *variable*.
2. Execute the *statement_sequence*.
3. Assign the next operand of *expression* to *variable*.
4. Repeat steps 2 and 3 for each operand in *expression*. If there are no more operands, exit the loop. (This is the *loop bound test*.)

Example

The following loop returns a floating-point approximation to the *sin* function at the angles (measured in degree) in the list *L*.

\[
\text{L := [23.4, 87.2, 43.0, 99.7]:} \\
\text{for i in L do} \\
\quad \text{evalf(sin(i*Pi/180));} \\
\quad \text{end do;}
\]

\[
0.3971478907 \\
0.9988061374 \\
0.6819983602
\]
while Loop

The while loop repeats a statement sequence until a boolean expression does not hold.

Syntax

The while loop has the following syntax.

```
> while conditional_expression do
    statement_sequence
end do;
```

A while loop repeats until its boolean expression conditional_expression evaluates to false or FAIL. For more information on boolean expressions, see Conditional Execution (if Statement) (page 326).

Example

The following loop computes the digits of 872, 349 in base 7 (in order of increasing significance).

```
> x := 872349:

> while x > 0 do
    irem(x, 7);
    x := iquo(x, 7);
end do;
```

```
2
x := 124621
```

```
0
```
To perform such conversions efficiently, use the `convert/base` command.

> convert(872349, base, 7);

\[
[2, 0, 2, 2, 6, 2, 0, 1]
\]

For information on non-base 10 numbers, see *Non-Base 10 Numbers* (page 74).

**General Loop Statements**

You can include a `while` statement in a `for/from` or `for/in` loop.
The general for/from loop has the following syntax.

```maple
> for counter from initial by increment to final
   while conditional_expression do
       statement_sequence
   end do;
```

The general for/in loop has the following syntax.

```maple
> for variable in expression
   while conditional_expression do
       statement_sequence
   end do;
```

After testing the loop bound condition at the beginning of each iteration of the for loop, Maple evaluates conditional_expression.

- If `conditional_expression` evaluates to false or FAIL, Maple exits the loop.
- If `conditional_expression` evaluates to true, Maple executes statement_sequence.

**Infinite Loops**

You can construct a loop for which there is no exit condition, for example, a while loop in which the conditional_expression always evaluates to true. This is called an infinite loop. Maple indefinitely executes an infinite loop unless it executes a break, quit, or return statement or you interrupt the computation. For more information, refer to the ?break, ?quit, ?return, and ?interrupt help pages.

**Additional Information**

For more information on the for statement and looping, refer to the ?do help page.
8.3 Iterative Commands

Maple has commands that perform common selection and repetition operations. These commands are more efficient than similar algorithms implemented using library commands. Table 8.2 lists the iterative commands.

Table 8.2: Iterative Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>seq</td>
<td>Create sequence</td>
</tr>
<tr>
<td>add</td>
<td>Compute numeric sum</td>
</tr>
<tr>
<td>mul</td>
<td>Compute numeric product</td>
</tr>
<tr>
<td>select</td>
<td>Return operands that satisfy a condition</td>
</tr>
<tr>
<td>remove</td>
<td>Return operands that do not satisfy a condition</td>
</tr>
<tr>
<td>selectremove</td>
<td>Return operands that satisfy a condition and separately return operands that do not satisfy a condition</td>
</tr>
<tr>
<td>map</td>
<td>Apply command to the operands of an expression</td>
</tr>
<tr>
<td>zip</td>
<td>Apply binary command to the operands of two lists or vectors</td>
</tr>
</tbody>
</table>

Creating a Sequence

The seq command creates a sequence of values by evaluating a specified expression over a range of index values or the operands of an expression. See Table 8.3.

Table 8.3: The seq Command

<table>
<thead>
<tr>
<th>Calling Sequence Syntax</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>seq(expression, name = initial .. final);</td>
<td>( &gt; \seq(\exp(x), x=-2..0); )</td>
</tr>
<tr>
<td></td>
<td>( e^{-2}, e^{-1}, 1 )</td>
</tr>
</tbody>
</table>
Adding and Multiplying Expressions

The `add` and `mul` commands add and multiply sequences of expressions over a range of index values or the operands of an expression. See Table 8.4.

Table 8.4: The `add` and `mul` Commands

<table>
<thead>
<tr>
<th>Calling Sequence Syntax</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>seq(expression, name in expression);</code></td>
<td><code>&gt; seq(u, u in [Pi/4, Pi^2/2, 1/Pi]);</code></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td><code>add(expression, name = initial .. final);</code></td>
<td><code>&gt; add(exp(x), x = 2..4);</code></td>
</tr>
<tr>
<td></td>
<td><code>e^2 + e^3 + e^4</code></td>
</tr>
<tr>
<td><code>mul(expression, name = initial .. final);</code></td>
<td><code>&gt; mul(2^x, x = 1 .. 10);</code></td>
</tr>
<tr>
<td></td>
<td><code>3715891200</code></td>
</tr>
<tr>
<td><code>add(expression, name in expression);</code></td>
<td><code>&gt; add(u, u in [Pi/4, Pi/2, Pi]);</code></td>
</tr>
<tr>
<td><code>mul(expression, name in expression);</code></td>
<td><code>&gt; mul(u, u in [Pi/4, Pi/2, Pi]);</code></td>
</tr>
<tr>
<td></td>
<td><code>7/4 π</code></td>
</tr>
<tr>
<td></td>
<td><code>1/8 π^3</code></td>
</tr>
</tbody>
</table>

The endpoints of the index range (`initial` and `final`) in the `add` and `mul` calling sequence must evaluate to numeric constants. For information on symbolic sums and products, refer to the `?sum` and `?product` help pages.
Selecting Expression Operands

The `select`, `remove`, and `selectremove` commands apply a boolean-valued procedure or command to the operands of an expression. For information on operands, refer to the `?op` help page.

- The `select` command returns the operands for which the procedure or command returns `true`.
- The `remove` command returns the operands for which the procedure or command returns `false`.
- The `selectremove` command returns two expressions of the same type as the input expression.

- The first consists of the operands for which the procedure or command returns `true`.
- The second consists of the operands for which the procedure or command returns `false` or `FAIL`.

See Table 8.5.

For information on Maple procedures, see *Procedures (page 342)*.

Table 8.5: The select, remove, and selectremove Commands

<table>
<thead>
<tr>
<th>Calling Sequence Syntax</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>select(proc_cmd, expression);</code></td>
<td>```</td>
</tr>
<tr>
<td></td>
<td>&gt; select(issqr, [198331, 889249, 11751184, 9857934]);</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>{889249, 11751184}</td>
</tr>
<tr>
<td><code>remove(proc_cmd, expression);</code></td>
<td>```</td>
</tr>
<tr>
<td></td>
<td>&gt; remove(var -&gt; degree(var) &gt; 3, 2<em>x^3</em>y - y^3*x + z);</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>z</td>
</tr>
</tbody>
</table>

8.3 Iterative Commands  •  339
Examples

Calling Sequence Syntax | Examples
---|---
`selectremove(proc_cmd, expression);` | `> selectremove(x -> evalb(x > round(x)), [sin(0.), sin(1.), sin(3.)]);
[0.1411200081, 0., 0.8414709848]`

For information on optional arguments to the selection commands, refer to the `?select` help page.

**Mapping a Command over a Set or List**

The `map` command applies a name, procedure, or command to each element in a set or list. See Table 8.6.

### Table 8.6: The `map` Command

<table>
<thead>
<tr>
<th>Calling Sequence Syntax</th>
<th>Examples</th>
</tr>
</thead>
</table>
| `map(name_proc_cmd, expression);` | `> map(f, {a, b, c});
{f(a), f(b), f(c)}`

`> map(u -> int(cos(x), x = 0 .. u), [Pi/4, Pi/7, Pi/3.0]);

\[
\left[ \frac{1}{2} \sqrt{2}, \cos\left(\frac{5}{14} \pi\right), 0.9 \right]
\]`

For information on mapping over the operands of other expressions, optional arguments to the `map` command, and other mapping commands, refer to the `?map` help page.
Mapping a Binary Command over Two Lists or Vectors

The `zip` command applies a name or binary procedure or command component-wise to two lists or vectors.

By default, the length of the returned object is that of the shorter list or vector. If you specify a value as the (optional) fourth argument, it is used as the value of the missing elements of the shorter list or vector. In this case, the length of the return value is that of the longer list or vector. See Table 8.7.

Table 8.7: The zip Command

<table>
<thead>
<tr>
<th>Calling Sequence Syntax</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>zip(proc_cmd, a, b);</code></td>
<td><code>&gt; zip(f, [i, j], [k, l]);</code></td>
</tr>
<tr>
<td><code>zip(proc_cmd, a, b, fill);</code></td>
<td><code>&gt; zip(AiryAi, [1, 2], [0], 1);</code></td>
</tr>
</tbody>
</table>
|                         | \[
|                         | \[-\frac{1}{2} \frac{3^{1/6} \Gamma\left(\frac{2}{3}\right)}{\pi}, \text{AiryAi}(2, 1)\] |

For more information on the `zip` command, refer to the `?zip` help page.

Additional Information

For more information on looping commands, refer to the corresponding command help page.
8.4 Procedures

A Maple procedure is a program consisting of Maple statements. Using procedures, you can quickly execute the contained sequence of statements.

Defining and Running Simple Procedures

To define a procedure, enclose a sequence of statements between `proc(...)` and `end proc` statements. In general, you assign a procedure definition to a name.

The following procedure returns the square root of 2.

```maple
> p := proc() sqrt(2); end proc;
```

Note: Maple returns the procedure definition.

To improve readability of procedures, it is recommended that you define a procedure using multiple lines, and indent the lines using space characters. To begin a new line (without evaluating the incomplete procedure definition), press Shift+Enter. When you have finished entering the procedure, press Enter to create the procedure.

For example:

```maple
> p := proc()
    sqrt(2);
    end proc:
```

To run the procedure \( p \), enter its name followed by parentheses (( )).

```maple
> p();
```

\[ \sqrt{2} \]
**Procedures with Inputs**

You can define a procedure that accepts user input. In the parentheses of the `proc` statement, specify the parameter names. For multiple parameters, separate the names with commas.

```
> geometric_mean := proc(x, y)
    sqrt(x*y);
end proc:
```

When the user runs the procedure, the parameter names are replaced by the argument values.

```
> geometric_mean(13, 17);

\sqrt{221}
```

```
> geometric_mean(13.5, 17.1);

15.19374871
```

For more information on writing procedures, including options and local and global variables, refer to the `?procedure` help page.

**Procedure Return Values**

When you run a procedure, Maple returns **only** the last statement result value computed. Maple does not return the output for each statement in the procedure. It is irrelevant whether you use semicolons or colons as statement separators.

```
> p := proc(a, b)
    a + b;
    a - b;
end proc:
```
> p(1, 2);

   -1

Displaying Procedure Definitions

Unlike simple Maple objects, you cannot display the value of a procedure by entering its name.

> geometric_mean;

geometric_mean

You must evaluate the name of the procedure using the print (or eval) command.

> print(geometric_mean);

proc(x, y) sqrt(x*y) end proc

Displaying Maple Library Procedure Definitions

Maple procedure definitions are a valuable learning tool. To learn how to program in Maple, it is recommended that you examine the procedures available in the Maple library.

By default, the print command returns only the proc and end proc statements and (if present) the description fields of a Maple procedure.

> print(assign);

proc(a) ... end proc

To display a Maple library procedure definition, first set the value of the interface verboseproc option to 2. Then re-execute the print calling sequence. See Figure 8.1.
> interface('verboseproc' = 2):

proc(a)

  option Copyright (c) 1990 by Waterloo Maple Inc. All rights reserved.;
  local i;
  if 1 <= nargs and type(a, {'::', 'name', 'function'}) then
    a := args[2..-1]
  elif nargs = 1 then
    if type(a, {'::', 'name', 'function'}) = 'anything' then
      assign/internal(op(a))
    elif type(a, `'` = `'`) then
      if type([lhs(a)], 'list'({'::', 'name', 'function'})) then
        if nops([lhs(a)]) = nops([rhs(a)]) then
          zip('assign/internal', [lhs(a)], [rhs(a)])
        else
          error "ambiguous multiple assignment"
        end if
      else
        error "invalid arguments"
      end if
    else
      error "invalid arguments"
    end if
  elif type(a, {'set', 'list'}) then
    map(procname, a)
  else
    seq(procname(i), i = args)
  end if;
  NULL
end proc
Figure 8.1: Displaying assign Procedure

Modules

Maple procedures associate a sequence of commands with a single command. The module, a more complex programming structure, allows you to associate related procedures and data.
A key feature of modules is that they *export* variables. This means that the variables are available outside the module in which they are created. Most Maple packages are implemented as modules. The package commands are exports of the module.

For more information on modules, refer to the `?module` help page.
9 Maplets

A Maplet is a graphical user interface that provides interactive access to the Maple engine through buttons, text regions, slider bars, and other visual interfaces. You can design custom Maplet applications to use and share with colleagues or students, or you can take advantage of the built-in Maplets that cover numerous academic and specialized topics. For information on some of the built-in Maplets, see Assistants and Tutors (page 27), Teaching and Learning with Maple (page 180), or Ordinary Differential Equations (ODEs) (page 89). Other methods of interaction with Maple are described in the Maple Getting Started Guide and throughout this book.

9.1 In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
<tbody>
<tr>
<td>Simple Maplet - Illustrating a simple Maplet</td>
<td>• Define and Run a Simple Maplet</td>
</tr>
<tr>
<td>Using Maplets - Methods for launching a Maplet</td>
<td>• Maplet File</td>
</tr>
<tr>
<td></td>
<td>• Maple Document</td>
</tr>
<tr>
<td>Authoring Maplets - Methods for authoring and saving a Maplet</td>
<td>• Maplet Builder</td>
</tr>
<tr>
<td></td>
<td>• Maplets Package</td>
</tr>
<tr>
<td></td>
<td>• Saving</td>
</tr>
</tbody>
</table>

9.2 Simple Maplet

A Maplet application can be defined using the commands in the Maplets[Elements] package and then launched using the Maplets[Display] command. The following commands define and run a very simple Maplet application that contains the text string "Hello World".

> with(Maplets[Elements]):
> MySimpleMaplet:= Maplet(["Hello World"])::

> Maplets[Display](MySimpleMaplet):

![Maplet](image)

Figure 9.1: A Simple Maplet

For more information on creating Maplets, including an overview of the point-and-click Maplet Builder Assistant, see Authoring Maplets (page 351).

### 9.3 Using Maplets

Maplet applications are launched by executing Maplet code. Maplet code can be saved in a Maplet (.maplet) file or Maple document (.mw).

#### Maplet File

To launch a Maplet application saved as a Maplet file:

- In Windows, double-click the file from a Windows file browser.
- In UNIX and on Macintosh, use the command-line interface. At the command-line, enter `maple -q maplet_filename`.

To view and edit the Maplet code contained within the .maplet file:

1. Start Maple.
2. From the **File** menu, select **Open**. Maple displays the **Open** dialog.
3. In the **Files of Type** drop-down list, select **.maplet**.
4. Navigate to the location of the .maplet file and select the file.
5. Click **Open**.
Maple Document

To launch a Maplet application for which the Maple code is contained in a Maple document, you need to execute the Maplet code. To display the Maplet application, you must use the `Maplets[Display]` command. **Note:** The Maplet code may be quite large if the Maplet application is complex. In this case, execute the document to ensure user-defined procedures that are referenced in the Maplet application are also defined.

**Typical procedure:**

1. If present, evaluate user-defined procedures.

   ```maple
   Myproc:=proc...
   ```


   ```maple
   with( Maplets[Elements] );
   ```

3. Evaluate the Maplet definition.

   ```maple
   Maplet_name:=Maplet( Maplet_definition );
   ```

4. Display the Maplet application.

   ```maple
   Maplets[Display]( Maplet_name );
   ```

**Important:** When a Maplet application is running, you cannot interact with the Maple document.

### 9.4 Authoring Maplets

When authoring Maplets, you can use the **Maplet Builder** (GUI-based) or the `Maplets` package (syntax-based). The **Maplet Builder** allows you to drag and drop buttons, sliders, text regions, and other elements to define the Maplet application and set the element properties to perform an action upon selection or update of the element. The **Maplet Builder** is designed to create
simple Maplets. The Maplets package offers more capabilities, control and options when designing complicated Maplet applications.

Designing a Maplet application is similar to constructing a house. When building a house, you first construct the skeletal structure (that is, foundation, floors, and walls) and then proceed to add the windows and doors. Constructing a Maplet is no different. First define the rows and columns of the Maplet application and then proceed to add the body elements (for example, buttons, text fields, and plotter regions).

**Maplet Builder**

To start the Maplet Builder:

- From the Tools menu, select Assistants, and then Maplet Builder.

![Figure 9.2: Maplet Builder Interface](image)
The **Maplet Builder** is divided into four different panes.

- The **Palette** pane displays palettes, which contain Maplet elements, organized by category. For a description of the elements, see the `?MapletBuilder/Palette` help page. The **Body** palette contains the most popular elements.

- The **Layout** pane displays the visual elements of the Maplet.

- The **Command** pane displays the commands and corresponding actions defined in the Maplet.

- The **Properties** pane displays the properties of an instance of a defined element in the Maplet.
Design a Maplet Using the Maplet Builder

In this example, shown in Figure 9.3, the Maplet user enters a function and plots the result.

Figure 9.3: Image of the Maplet

Figure 9.4: Body Elements Used When Defining This Maplet
Define the number of rows in the Maplet

1. In the Properties pane:
   a. In the drop-down list, select **BoxColumn1**.
   b. Change the numrows field to 2.

![Maplet Builder: Define Number of Rows](image)

Figure 9.5: Define the Number of Rows in the Maplet
Add a plot region to row 1

1. From the **Body** palette, drag the **Plotter** element to the first row in the **Layout** pane.

![Figure 9.6: Add a Plot to Row 1](image-url)
Add columns to row 2

1. In the Properties pane:
   
   a. In the drop-down list, select **BoxRow2**.
   
   b. Change the **numcolumns** field to 3.

Figure 9.7: Add Columns to Row 2
Add a label to row 2

1. From the **Body** palette, drag the **Label** element to the left column in the **Layout** pane.

2. In the **Properties** pane:
   
   a. In the drop-down list, select **Label1**.
   
   b. Change the **caption** field to **Enter a function of x**.

---

**Figure 9.8: Add a Label to Row 2**
Add a text region to row 2

1. From the **Body** palette, drag the **TextField** element to the middle column. The **TextField** element allows the Maplet user to enter input that can be retrieved in an action.

2. If necessary, resize the Maplet Builder to display the entire **Layout** pane.

![Figure 9.9: Add a Text Region to Row 2](image-url)
Add a button to row 2

1. From the **Body** palette, drag the **Button** element to the right column in the **Layout** pane.

2. In the **Properties** pane:
   
   a. In the drop-down list, select **Button1**.
   
   b. Change the **caption** field to **Plot**.
   
   c. In the **onclick** property drop-down list, select **<Evaluate>**.

---

**Figure 9.10: Add a Button to Row 2**
3. In the **Evaluate Expression** dialog that displays, the **Target** drop-down list contains the defined elements to which you can send information, in this case, **Plotter1** and **TextField1**. The **List** group box, located below the **Expression** group box, displays the defined elements to which you can retrieve information, in this case, **TextField1**.

   a. In the **Target** drop-down list, select **Plotter1**.

   b. In the **Command Form** tab, enter `plot(TextField1, x=-10..10)` in the **Expression** group box. (**Note**: Do not include a semicolon(;) at the end of the plot command). You can also double-click **TextField1** in the **List** group box to insert this element in the command syntax.

   c. Click **Ok**.

![Evaluate Expression Dialog](image-url)

**Figure 9.11: Evaluate Expression Dialog**
Run the Maplet

1. From the File menu, select Run. You are prompted to save the Maplet. Maplets created with the Maplet Builder are saved as .maplet files.

2. Click Yes and navigate to a location to save this Maplet.

For further information on the Maplet Builder, see the ?MapletBuilder help page. For more examples of designing Maplets using the Maplet Builder, see ?MapletBuilder/examples.

Maplets Package

When designing a complicated Maplet, the Maplets package offers greater control. The Maplets[Elements] subpackage contains the elements available when designing a Maplet application. After you define the Maplet, use the Maplets[Display] command to launch the Maplet.

Example 1 - Design a Maplet Using the Maplets Package

To introduce the structure of designing Maplets using the Maplets package, this example illustrates the equivalent syntax for the Design a Maplet Using the Maplet Builder (page 354).

Load the Maplets[Elements] package.

> with(Maplets[Elements]):

Define the Maplet application. To suppress the display of the data structure associated with the Maplet application, end the definition with a colon.
> PlottingMaplet := Maplet(  
  BoxLayout(  
    BoxColumn(  
      # First Box Row  
      BoxRow(  
        # Define a Plot region  
        Plotter('reference' = Plotter1)  
      )  
    ),  
    # Second Box Row  
    BoxRow(  
      # Define a Label  
      Label("Enter a function of x "),  
      # Define a Text Field  
      TextField('reference' = TextField1),  
      # Define a Button  
      Button(caption="Plot", Evaluate(value = 'plot(TextField1,  
                                           x = -10..10)', 'target' = Plotter1))  
    )  
  )  
):  

Launch the Maplet.

> Maplets[Display](PlottingMaplet);
Example 2 - Accessing User-Defined Procedures

When designing a Maplet, you can access user-designed procedures and send information bi-directionally to the Maplet. In this example, shown in Figure 9.12, the user enters a function in a MathML editor region, optionally selects a color from a color dialog, and plots the result.

![Maplet Example](image)

Figure 9.12: Image of the Maplet
User-Defined Procedure and Maplet Code

Define a procedure to be accessed in the Maplet.

> GetColor:=proc()
local R, G, B, result;
use Maplets[Tools] in

    # Convert the color value defined in the Color dialog
    result:=Get(ColorDialog1);
    # The result format is "#RRGGBB" in hexadecimal(base 16)
    # Convert to values in the range 0..1
    R:=convert(result[2..3], 'decimal', 16)/255;
    G:=convert(result[4..5], 'decimal', 16)/255;
    B:=convert(result[6..7], 'decimal', 16)/255;

    # Plot the function entered in the MathMLEditor region
    plot(MathML:-Import(Get(MathMLEditor1)), x=0..10,
         color=COLOR(RGB, R, G, B));

    end use:
end proc:

Load the Elements package.

> with(Maplets[Elements]):

Define the Maplet application.
> PlottingMaplet2 := Maplet(
  'onstartup' = Action(RunWindow(Window1)),
  Window('reference' = Window1,
    BoxLayout(
      BoxColumn(
        BoxRow(
          Plotter('reference' = Plotter1)),
        BoxRow(
          MathMLEditor('reference' = MathMLEditor1)),
        BoxRow(
          # Access the GetColor procedure and plot the result
          Button("Plot", Evaluate('function' = 'GetColor',
            'target' = 'Plotter1'))),
          # Launch the Color dialog
          Button("Color", RunDialog('dialog' = 'ColorDialog1'))),
          # Close the Maplet
          Button("Close", Shutdown()))
    )
  ),
  Action('reference' = 'approveColorDialog1'),
  Action('reference' = 'cancelColorDialog1'),
  ColorDialog('onapprove' = 'approveColorDialog1',
    'oncancel' = 'cancelColorDialog1',
    'reference' = 'ColorDialog1')
);

Display the Maplet
> Maplets[Display](PlottingMaplet2);

For more information on the Maplets package, refer to the ?MapletsPackage help page. For more examples of designing Maplets using the Maplets package, see the ?Maplets/Roadmap help page.
Saving

When saving a Maplet, you can save the document as an .mw file or you can export the document as a .maplet file.

**Maple Document**

To save the Maplet code as an .mw file:

1. From the File menu, select Save.
2. Navigate to the save location.
3. Enter a filename.
4. Click Save.

If the document contains only Maplet code, it is recommended that you export the document as a .maplet file.

**Maplet File**

To export the Maplet code as a .maplet file:

1. From the File menu, select Export As.
2. In the Files of Type drop-down list, select Maplet.
3. Navigate to the export location.
4. Enter the filename.
5. Click Save.
10  Input, Output, and Interacting with Other Products

10.1  In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Topics</th>
</tr>
</thead>
</table>
| **Writing to Files** - Saving to Maple file formats | • Saving Data to a File  
  • Saving Expressions to a File |
| **Reading from Files** - Opening Maple files   | • Reading Data from a File  
  • Reading Expressions from a File |
| **Exporting to Other Formats** - Exporting documents in file formats supported by other software | • Exporting Documents  
  • MapleNet  
  • Maple T.A. |
| **Connectivity** - Using Maple with other programming languages and software | • Translating Maple Code to Other Programming Languages  
  • Accessing External Products from Maple  
  • Accessing Maple from External Products |

10.2  Writing to Files

Maple supports file formats in addition to the standard .mw file format.

After using Maple to perform a computation, you can save the results to a file for later processing with Maple or another program.

**Saving Data to a File**

If the result of a Maple calculation is a long list or a large array of numbers, you can convert it to Matrix form and write the numbers to a file using the `ExportMatrix` command. This command writes columns of numerical data...
to a file, allowing you to import the numbers into another program. To convert a list or a list of lists to a Matrix, use the **Matrix** constructor. For more information, refer to the **Matrix** help page.

\[
\begin{bmatrix}
-81 & -98 & -76 & -4 & 29 \\
-38 & -77 & -72 & 27 & 44 \\
-18 & 57 & -2 & 8 & 92 \\
87 & 27 & -32 & 69 & -31 \\
33 & -93 & -74 & 99 & 67
\end{bmatrix}
\]

\[> \text{ExportMatrix}("\text{matrixdata.txt}", L) :\]

If the data is a Vector or any object that can be converted to type Vector, use the **ExportVector** command. To convert lists to Vectors, use the **Vector** constructor. For more information, refer to the **Vector** help page.

\[> R := [3, 3.1415, -65, 0] \]

\[R := [3, 3.1415, -65, 0] \]

\[> V := \text{Vector}(R) \]

\[V := \begin{bmatrix} 3 \\ 3.1415 \\ -65 \\ 0 \end{bmatrix} \]

\[> \text{ExportVector}("\text{vectordata.txt}", V) :\]

You can extend these routines to write more complicated data, such as complex numbers or symbolic expressions. For more information, refer to the **ExportMatrix** and **ExportVector** help pages.

For more information on matrices and vectors, see *Linear Algebra (page 135)*.
Saving Expressions to a File

If you construct a complicated expression or procedure, you can save them for future use in Maple. If you save the expression or procedure in the Maple internal format, Maple can retrieve it more efficiently than from a document. Use the `save` command to write the expression to a `.m` file. For more information on Maple internal file formats, refer to the `?file` help page.

\[ qbinomial := (n, k) \rightarrow \prod_{i=n-k+1}^{n} (1 - q^i) / \prod_{i=1}^{k} (1 - q^i) \]

In this example, small expressions are used. In practice, Maple supports expressions with thousands of terms.

\[ expr := qbinomial(10, 4) \]
\[ expr := \frac{(1 - q^7) (1 - q^8) (1 - q^9) (1 - q^{10})}{(1 - q) (1 - q^2) (1 - q^3) (1 - q^4)} \]

\[ nexpr := normal(expr) \]
\[ nexpr := (q^6 + q^5 + q^4 + q^3 + q^2 + q + 1) (q^4 + 1) (q^6 + q^3 + 1) (q^8 + q^6 + q^4 + q^2 + 1) \]

You can save these expressions to the file `qbinom.m`.

\[ \text{save \ qbinomial, expr, nexpr, "qbinom.m"} \]

Clear the memory using the `restart` command and retrieve the expressions using the `read` command.

\[ \text{restart} \]
> read "qbinom.m"

> expr

$$\frac{(1 - q^7)(1 - q^8)(1 - q^9)(1 - q^{10})}{(1 - q)(1 - q^2)(1 - q^3)(1 - q^4)}$$

For more information on writing to files, refer to the `?save` help page.

10.3 Reading from Files

The most common reason for reading files is to load data, for example, data generated in an experiment. You can store data in a text file, and then read it into Maple.

Reading Data from a File

Import Data Assistant

If you generate data outside Maple, you must read it into Maple for further manipulation. This data can be an image, a sound file, or columns of numbers in a test file. You can easily import this external data into Maple using the Import Data Assistant where the supported file formats include files of type Excel, Matlab (R), Image, Audio, Matrix Market, and Delimited.

To launch the Import Data Assistant:

- From the Tools menu, select Assistants, and then Import Data.
- A dialog window appears where you can navigate to your data file. Select the file that you wish to import data from and then select the file type before clicking Next.
- From the main window, you can preview the selected file and choose from the applicable options based on the format of the file read in before importing the data into Maple. See Figure 10.1 for an example.
Import Data Assistant

The **Import Data Assistant** provides a graphical interface to the **ImportMatrix** command. For more information, including options not available in the assistant, refer to the `?ImportMatrix` help page.

**Reading Expressions from a File**

You can write Maple programs in a text file using a text editor, and then import the file into Maple. You can paste the commands from the text file into your document or you can use the `read` command.

When you read a file with the `read` command, Maple treats each line in the file as a command. Maple executes the commands and displays the results in your document but it does *not*, by default, insert the commands from the file in your document.

For example, the file `ks.tst` contains the following Maple commands.

```maple
S := n -> sum( binomial( n, beta ) * ( ( 2*beta )! / 2^beta - beta!*beta ), beta=1..n );
```
When you read the file, Maple displays the results but not the commands.

```
> read "ks.txt"

\[ S(n) = n \sum_{k=1}^{n} \binom{n}{k} \left( \frac{(2k)!}{2^k} - k! \right) \]

102493736166644598071114328769317982774
```

If you set the `interface echo` option to 2, Maple inserts the commands from the file into your document.

```
> interface(echo = 2):
> read "ks.txt"

> S := n -> sum(binomial(n, beta) \cdot ((2 + beta)! / 2^beta - beta! + beta), beta=1..n);

\[ S(n) = n \sum_{k=1}^{n} \binom{n}{k} \left( \frac{(2k)!}{2^k} - k! \right) \]

> S(19); 102493736166644598071114328769317982774
```

For more information, refer to the `?read` and `?interface` help pages.

**10.4 Exporting to Other Formats**

**Exporting Documents**

You can save your documents by selecting Save or Save As from the File menu. By selecting Export As from the File menu, you can also export a document in the following formats: HTML, LaTeX, Maple input, Maplet application, Maple text, plain text, and Rich Text Format. This allows you to access your work outside Maple.
HTML

The .html file that Maple generates can be loaded into any HTML browser. Exported mathematical content can be displayed in one of the following formats: GIF, MathML 2.0 Presentation, MathML 2.0 Content, or Maple Viewer, and is saved in a separate folder. MathML is the Internet standard, sanctioned by the World Wide Web Consortium (W3C), for the communication of structured mathematical formulae between applications. For more information about MathML, refer to the ?MathML help page.

Maple documents that are exported to HTML translate into multiple documents when using frames. If the frames feature is not selected, Maple creates only one page that contains the document contents.

LaTeX

The .tex file generated by Maple is ready for processing by LaTeX. All distributions of Maple include the necessary style files. By default, the LaTeX style files are set for printing the .tex file using the dvips printer driver. You can change this behavior by specifying an option to the \usepackage LaTeX command in the preamble of your .tex file. For more information, refer to the ?exporttoLaTeX help page.

Maple Input

You can export a Maple document as Maple input so that it can be loaded using the Maple Command-line version.

**Important:** When exporting a document as Maple input for use in Command-line Maple, your document must contain explicit semicolons in 1-D Math input. If not, the exported .mpl file will not contain semicolons, and Command-line Maple will generate errors.

Maplet Application

The Export as Maplet facility saves a Maple document as a .maplet file, so that you can run it using the command-line interface or the MapletViewer. The MapletViewer is an executable program that can launch
saved Maplet applications. It displays and runs Maplet applications independently of the Maple Worksheet interface.

**Important:** When exporting a document as a Maplet Application for use in Command-line Maple or the MapletViewer, your document must contain explicit semicolons. If not, the exported `.maplet` file will not contain semicolons, and Command-line Maple and the MapletViewer will generate errors.

For information on using the MapletViewer, see *Using Maplets* (page 350).

**Maple Text**

Maple text is marked text that retains the distinction between text, Maple input, and Maple output. Thus, you can export a document as Maple text, send the text file by email, and the recipient can import the Maple text into a Maple session and regenerate the computations in the original document.

**Plain Text**

Export a Maple document as plain text so that you can open the text file in another application.

**Rich Text Format (RTF)**

The `.rtf` file generated by Maple can be loaded into any word processor that supports RTF.

**Summary of Translation**

Table 10.1: Summary of Content Translation When Exporting to Different Formats

<table>
<thead>
<tr>
<th>Content</th>
<th>HTML</th>
<th>LaTeX</th>
<th>Maple Input</th>
<th>Maplet Application</th>
<th>Maple Text</th>
<th>Plain Text</th>
<th>Rich Text Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Maintained</td>
<td>Maintained</td>
<td>Preceded by #</td>
<td>Preceded by #</td>
<td>Preceded by #</td>
<td>Maintained</td>
<td>Maintained</td>
</tr>
<tr>
<td>Content</td>
<td>HTML</td>
<td>LaTeX</td>
<td>Maple Input</td>
<td>Maplet Application</td>
<td>Maple Text</td>
<td>Plain Text</td>
<td>Rich Text Format</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-----------------</td>
<td>-----------------</td>
<td>-------------------</td>
<td>--------------------</td>
<td>---------------</td>
<td>-------------</td>
<td>------------------</td>
</tr>
<tr>
<td>1-D Math</td>
<td>Maintained</td>
<td>Maintained</td>
<td>Maintained</td>
<td>Preceded by &gt;</td>
<td>Preceded by &gt;</td>
<td>Static image</td>
<td></td>
</tr>
<tr>
<td>2-D Math</td>
<td>GIF or MathML</td>
<td>1-D Math or LaTeX 2e</td>
<td>1-D Math (if possible)</td>
<td>1-D Math or character-based typesetting</td>
<td>1-D Math or character-based typesetting</td>
<td>Static image</td>
<td></td>
</tr>
<tr>
<td>Plot</td>
<td>GIF</td>
<td>Postscript file</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Static image</td>
</tr>
<tr>
<td>Animation</td>
<td>Animated GIF</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
</tr>
<tr>
<td>Hidden content</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
</tr>
<tr>
<td>Manually inserted page break</td>
<td>Not supported</td>
<td>Not supported</td>
<td>Not supported</td>
<td>Not supported</td>
<td>Not supported</td>
<td>Not supported</td>
<td>RTF page break object</td>
</tr>
<tr>
<td>Hyperlink</td>
<td>Links to help pages become plain text. Links to documents are renamed and converted to HTML links</td>
<td>Plain text</td>
<td>Plain text</td>
<td>Plain text</td>
<td>Plain text</td>
<td>Plain text</td>
<td>Plain text</td>
</tr>
<tr>
<td>Embedded image or sketch output</td>
<td>GIF</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Not exported</td>
<td>Static image</td>
</tr>
</tbody>
</table>

10.4 Exporting to Other Formats • 377
Overview of MapleNet

Using MapleNet, you can deploy Maple content on the Web. Powered by the Maple computation engine, MapleNet allows you to embed dynamic formulas, models, and diagrams as live content in Web pages. The MapleNet software is not included with the Maple software. For more information on MapleNet, visit http://www.maplesoft.com/maplenet.

MapleNet Documents and Maplets

After you upload your Maple documents to the MapleNet server, it can be accessed by anyone in the world using a Web browser. Even if viewers do not have a copy of Maple installed, they can view documents and Maplets, manipulate 3-D plots, and execute code at the click of a button.

Custom Java™ Applets and JavaServer Pages™ Technology

MapleNet provides a programming interface to the Maple math engine so commands can be executed from a Java™ applet or using JavaServer Pages™ technology. Embed MapleNet into your Web application, and let Maple handle the math and visualization.
Maple T.A.

Overview of Maple T.A.

Maple T.A. is a Web-based automated testing system, based on the Maple engine. Instructors can use pre-written questions or create custom question banks and then choose from these questions to form quizzes and assignments. Maple T.A. automatically grades responses as students complete assignments and tests. For more information, visit http://www.maplesoft.com/mapleta.

Exporting Assignments to Maple T.A.

You can use Maple to create graded questions for use in Maple T.A. For information on creating and testing questions, see Creating Graded Assignments (page 273). Using the Maple T.A. export feature, you can create and test Maple T.A. content.

To export the document:

1. From the File menu, select Export As.
2. In the Export As dialog, specify a filename and the Maple T.A. (.zip) file type. The .zip file containing your questions and assignment can be uploaded to Maple T.A. as a course module.

Any document content outside Maple T.A. sections (indicated by green section markers) is ignored by the export process.

For more details, refer to the ?exporttoMapleTA help page.
10.5 Connectivity

Translating Maple Code To Other Programming Languages

Code Generation

The CodeGeneration package is a collection of commands and subpackages that enable the translation of Maple code to other programming languages. Languages currently supported include C, Fortran 77, Java, MATLAB®, and Visual Basic®.

For details on Code Generation, refer to the ?CodeGeneration help page.

Accessing External Products from Maple

External Calling

External calling allows you to use compiled C, Fortran 77, or Java code in Maple. Functions written in these languages can be linked and used as if they were Maple procedures. With external calling you can use pre-written optimized algorithms without the need to translate them into Maple commands. Access to the NAG library routines and other numerical algorithms is built into Maple using the external calling mechanism.

External calling can also be applied to functions other than numerical algorithms. Routines exist that accomplish a variety of non-mathematical tasks. You can use these routines in Maple to extend its functionality. For example, you can link to controlled hardware via a serial port or interface with another program. The Database Integration Toolbox uses external calling to allow you to query, create, and update databases in Maple. For more information, visit http://www.maplesoft.com/products/toolboxes.

For more information on using external calling, refer to the ?ExternalCalling help page.
Mathematica Translator

The **MmaTranslator** package provides translation tools for converting Mathematica® expressions, command operations, and notebooks to Maple. The package can translate Mathematica input to Maple input and Mathematica notebooks to Maple documents. The **Mma** subpackage contains commands that provide translation for Mathematica commands when no equivalent Maple command exists. In most cases, the command achieves the translation through minor manipulations of the input and output of similar Maple commands.

**Note:** The **MmaTranslator** package does not convert Mathematica programs.

There is a Maplet interface to the **MmaTranslator** package. For more information, refer to the **?MmaToMaple** help page.

Matlab Package

The **Matlab** package enables you to translate MATLAB code to Maple, as well as call selected MATLAB functions from a Maple session, provided you have MATLAB installed on your system.

For more information, refer to the **?Matlab** help page.

Accessing Maple from External Products

Microsoft Excel Add-In

Maple is available as an add-in to Microsoft Excel 2000, Excel 2003, and Excel XP for Windows, and provides the following features.

- Access to Maple commands from Excel
- Ability to copy and paste between Maple and Excel
- Access to a subset of the Maple help pages
- Maple Function Wizard to step you through the creation of a Maple function call
To enable the Maple Excel Add-in in Excel 2000, Excel 2003, or Excel XP:

1. From the Tools menu, choose Add-Ins.
2. If the Maple Excel Add-in is not listed:
   • Click Browse and navigate to the directory in which Maple is installed.
   • In the Excel directory, select the WMIMPLEX.xla file.
   • Click OK.
3. Select the Maple Excel Add-in check box.
4. Click OK.

More information is available in the Using Maple in Excel online help file within Excel.

To view this help file:

1. Enable the add-in.
2. From the View menu, select Toolbars, and then Maple.
3. On the Maple toolbar, click the Maple help icon.

OpenMaple

OpenMaple is a suite of functions that allows you to access Maple algorithms and data structures in your compiled C, Java, or Visual Basic programs. (This is the reverse of external calling, which allows access to compiled C, Fortran 77, and Java code from Maple.)

To run your application, Maple must be installed. You can distribute your application to any licensed Maple user. For additional terms and conditions on the use of OpenMaple, refer to extern/OpenMapleLicensing.txt in your Maple installation.

For more details on using OpenMaple functions, refer to the ?OpenMaple help page.
Index

Symbols

! toolbar icon, 11
!!! toolbar icon, 11
"", 300
%H, 148
%H, 148
&amp;x, 148
', 57, 321
(), 342
->, 57
., 146
1-D Math, 38
   switching to 2-D, 38
2-D Math, 37
   converting to 1-D, 39
   shortcuts, 7
   switching to 1-D, 38
:; 38–39
::, 117
:=, 55
;:, 38–39
<> 138
<default>, 40, 321
>, 37
[, 144, 290, 292
^, 5, 76
   entering, 76
_, 58
   entering, 58
.EnvAllSolutions environment variable, 82
~Z~, 83
\, 58


\{}\, 291
|, 138
~, 83, 117

A

about command, 117
abs command, 73
absolute value, 73
add
   word to your dictionary, 283
add command, 338
additionally command, 118
algebra, 126
   linear, 135
   polynomial, 126
algsubs command, 316
alignment format, 240
all content, 53
American spelling
   spellcheck, 280
and operator, 327
angle brackets, 138
angles, 312
animations
   creating, 224
   customizing, 230
Applications
   Units Calculator, 99
applications, 34
apply
   character styles, 244
   document blocks, 252
   paragraph styles, 246
approximation, 68
   least-squares, 151
numeric, 317
arguments, 343
arithmetic, 10
  finite-precision, 67
  interval, 111
  matrix and vector, 146
  modular, 73, 75
  polynomial, 126
Arrays, 293
  large, 294
arrow operator, 57
assign command, 87
assigned command, 321
assignment operator (:=), 55
Assistants, 27, 123
  Curve Fitting, 134
  Data Analysis, 173
  Import Data, 372
  menu access, 27
  ODE Analyzer, 89
  Optimization, 169
  Plot Builder, 29, 49, 191
  Unit Converter, 312
assuming command, 116
  adding assumptions, 118
  and procedure variables, 120
  imposing multiple assumptions, 118
  removing assumptions, 119
  setting relationships between variables, 117
  setting variable properties, 117
  testing property, 118
  using with assuming command, 120
  viewing assumptions, 117
assuming command, 116, 119, 164, 311
  additionally option, 120
  and procedure variables, 120
  applying to all names, 120
  using with assume command, 120
Attributes submenu
  character, 238
  paragraph, 240
  auto-execute, 275
  repeating, 276
  security levels, 276
Avogadro constant, 106

B
bar chart, 177
basis, 151
  vector space, 150
binary numbers, 74
Bohr radius, 106
bold format, 237
bookmarks
  using, 266
boolean expressions, 319, 326, 334
brackets
  angle, 138
break statement, 336
browser
  Matrix, 139, 294
  Task, 51
bullets
  format, 240
button
  embedding, 269
by clause, 330
  excluding, 331
negative, 332

C
calculus, 153
  multivariate, 166
  Student package, 168
of variations, 168
packages, 166
study guides, 181
teaching, 168, 181
  vector, 166
  Student package, 168
canvas
  inserting, 277
canvas style
  sketch pad, 278
caret
  entering, 76
central tendency, 111
character styles
  creating, 244
  description, 243
Cholesky decomposition, 149
choose styles dialog, 249
Classic Worksheet, xiii
tables, 262
coeff command, 133
coefficients
  polynomials, 132
coeffs command, 133
collect command, 132
colon, 38–39
color
  of plots, 221
combine command, 310
  errors option, 114
command completion, 8
  shortcut, 8
Command-line version, xiii
commands, 40
  and task templates, 50
displaying procedures, 344
iterative, 337
list, 124
  mapping over set or list, 340
package, 42
top-level, 40
Common Symbols palette, 12
compatibility
  worksheet, 287
complex expressions, 318
compoly command, 134
components
  adding GUI elements, 270
  palette, 270
  properties, 271
computations
  assistants, 48
  commands, 40
  context menus, 46
  errors, 70
    avoiding, 70
  integers, 71
  interrupting, 336
  linear algebra, 145
  mathematics, 123
numeric, 66
  palettes, 43
  performing, 65, 123
Real number system, 115
symbolic, 66
syntax-free, 20, 32
task templates, 50
tutors, 48
under assumptions, 116
  single evaluation, 119
updating, 10
with uncertainty, 114
with units, 102
conditional execution, 326
constants, 11
content command, 134
context
  of unit, 98
context menus, 21, 46, 123, 148, 301
  customizing animations, 230
equation, 78
integer, 46, 71
Plot Builder, 29
convert command, 311
  base option, 74, 335
degrees option, 312
  mathematical functions, 312
polynom option, 162
set option, 312
temperature option, 100
units option, 99, 312
copy, 240
correlation, 113
coulditbe command, 118
covariance, 113
cross product, 148
Curl command, 167
Curve Fitting
  Assistant, 134
package
    PolynomialInterpolation command, 134
cut and paste
  in tables, 258

D
D operator, 158
Data Analysis Assistant, 173
data structures, 11, 289
  creating, 289
Database Integration Toolbox, 380
datatype option, 142
default content, 53
default Maple style set, 251
degree
  command, 133
directional, 159
  polynomials, 132
denom command, 306
derivatives, 155
directional, 159
partial, 156
  Tutor, 181
dictionary, 34, 180
dictionary topic
  adding hyperlink to, 286
diff command, 89, 157
differential equations
  ordinary, 89
differentiation, 155
  with uncertainty, 114
dimension, 97, 149
  base, 97
Directional Derivative Tutor, 159
discrim command, 134
display
  bookmark, 266
  hidden formatting attributes, 242
distribution
  probability, 173
divide command, 128
divisors, 73
document blocks, 32, 251
Document mode, 1
  summary, 31
double colon operator, 117
dsolve command, 93

e
  e-notation, 68
eigenvalues, 149
eigenvectors, 149
elementary charge, 106
elements, 105
  definition, 107
  isotopes, 107
    definition, 107
    properties, 107
list, 107
properties
  list, 107
  uncertainty, 110
  units, 109
  using, 106
  value, 109
    value and units, 110
elif clauses, 328
  order, 328
else clause, 328
email
  adding hyperlink to, 285
embedded components, 269
end do keywords, 330, 333–334
end if keywords, 326
end proc keywords, 342
environment variables
  _EnvAllSolutions, 82
  Digits, 69
  Order, 162
equation labels, 59
  displaying, 59
  features, 62
  numbering schemes, 61
  references to, 59
  versus names, 62
  with multiple outputs, 60
equations
  solving, 78
    for real solutions, 115
    numerically, 84
    symbolically, 80
    transcendental, 82
errors
  quantities with, 111
Euclidean algorithm, 134
eval command, 315, 344
evalb command, 319
evalc command, 318
evalf command, 69, 83, 109, 112, 317
  with Int command, 165
  with Limit command, 155
evaln command, 321
evaluation
  boolean expressions, 319
  complex expressions, 318
delaying, 321
levels of, 320
Maple expressions, 314
  of expression at a point, 314
output below, 9, 22, 32
output inline, 9, 22, 32
updated computations, 10
exact
  computation, 67
numbers, 66
quantities
  converting to floating-point, 69
example worksheets, 34
execution group, 38
  auto-execute, 275
expand
  command, 310
document block, 254
  execution group, 255
series, 161
exponents
  entering, 5
export, 347
  to HTML, 375
to LaTeX, 375
to Maple input, 375
to Maple T.A., 379
to Maple text, 376
to Maplet application, 375
to other formats, 374
to plain text, 376
to Rich Text Format, 376
worksheets, 374
Expression palette, 13
expression sequences, 80, 290
  creating, 337
expressions, 11, 289
  adding, 338
  evaluating, 314
  manipulating, 308
  multiplying, 338
  versus functional operators, 297

F
factor
  integers, 71
  polynomials, 133
QR factorization, 151
factor command, 133, 309
factored normal form, 313
factorial command, 73
FAIL, 327, 334
false, 327, 334
Faraday constant, 106
files
  image formats, 267
  reading from, 372
  writing to, 369
fill option, 142
finite fields, 75
  solving equations, 95
finite rings, 75
floating-point
  computation, 68
    accuracy, 70
    hardware, 70
    significant digits, 69
  numbers, 67
  rational approximation, 47
Flux command, 167
font color, 237
foot-pound-second (FPS) system, 26, 98
  for/from loops, 330
for/in loops, 332
formal power series solutions, 93
Format menu
  bookmarks, 266
  document blocks, 252
  quick formatting, 237
frac command, 119
fractions
  approximating, 23
  entering, 5
frequency plot, 177
Frobenius form
  matrix, 151
from clause, 330
  excluding, 331
fsolve command, 84
full evaluation, 320, 323
Function Composition Tutor, 28
FunctionAdvisor command, 41, 123
functional operators, 14, 296
  differentiating, 158
  plotting, 299
  versus expressions, 297
functions
  converting between, 312
  defining, 14
  defining as functional operators, 296
G
Gaussian elimination, 151
Gaussian integers, 77
GaussInt package, 77
gcd command, 134
gcdex command, 134
Getting Started Guide, 33
Global Optimization Toolbox, 168
global variables, 343
glossiness
  of 3-D plots, 221
go to
  bookmark, 266
gradient, 184
Gradient Tutor, 183
Graphing Calculator
  Maplesoft, xiv
greatest common divisor, 73, 134

H
has command, 304
hastype command, 303
HazardRate command, 176
help
  dictionary, 34
  examples, 34
  pages, 34
  quick, 33
  quick reference card, 33
  task templates, 34
help page
  adding hyperlink to, 286
Hermitian transpose
  matrix and vector, 148
Hessenberg form, 151
hexadecimal numbers, 74
hidden formatting attributes, 74
hide
  worksheet content, 268
highlight color, 237
Hilbert Matrix, 151
histogram, 177
hyperlinks
images, 267
row and columns in tables, 257
section, 242
sketch pad, 277
table, 256
instructor resources, 180
Int command, 165
int command, 164
integers
commands, 73
computations, 71
context menu, 46
factoring, 71
Gaussian, 77
modulo m, 75
solving equations, 94
solving modular equations, 95
integration, 14, 19, 21, 44, 163
definite, 164
functional operators, 300
indefinite, 163
iterated, 166
line, 166, 186
numeric, 165
surface, 166
with units, 103
Interactive Plot Builder Assistant, 29, 49
creating animations, 225
creating plots, 191
customizing animations, 230
customizing plots, 217
interface command
rtablesize option, 141
verboseproc option, 344
international system (SI), 98
InterquartileRange command, 175
interval arithmetic, 111
iquo command, 73
iroot command, 73
is command, 118
isprime command, 73
isqrt command, 73
italic format, 237

J
j
  entering, 77
Jordan form, 149

L
labels, 59
last name evaluation, 321
Layout palette, 12
lcm command, 134
lcoeff command, 133
ldegree command, 133
least-squares, 151
left single quotes, 58
left-hand side, 305
levels of evaluation, 320
lexicographic order, 130
lhs command, 305
Limit command, 155
limit command, 154
limits, 153
  multidimensional, 154
line break, 240
line integrals, 186
linear algebra, 135
  computations, 145
  efficiency, 141, 152
  LinearAlgebra package, 150
teaching, 152, 181
linear systems
  solving, 95, 151
LinearAlgebra package, 148
  commands, 150
  numeric computations, 152
LinearSolve command, 95
lists, 145, 292
  returning solutions as, 81
local variables, 343
logical operators, 327
loops, 330
  general, 335
  infinite, 336

M
Macintosh
  command/symbol completion, 7–8
manuals
  Getting Started Guide, 33
  online, 33
map command, 340
Maple Application Center, 124, 180
Maple Getting Started Guide, 33
Maple Student Help Center, 181
Maplesoft Graphing Calculator, xiv
Maplesoft Web site, 33, 123
Maplet Builder
  launching, 352
  Maplet authoring, 352
Maplets
  adding hyperlink to, 287
  authoring, 351
    Maplet Builder, 352
Maplets package, 362
launching
  Maple worksheet, 351
  Maplet file type, 350
Maplets package
  Display command, 362
  Elements subpackage, 362
  Maplet authoring, 362
saving
  Maple worksheet, 367
  maplet file, 367
using, 350
markers
  bookmarks, 266
  displaying, 242
  for document blocks, 251
Math mode, 5
  shortcuts, 7
mathematical functions
  list, 41
mathematics
  computations, 123
  teaching and learning, 180
matrices, 295
  arithmetic, 146
  context menus, 148
  data type, 141, 143
  defining, 136
  efficiency, 141
  filling, 143
  Hermitian transpose, 148
  image, 141
  large, 139
  multiplication, 146
  operations, 148
  random, 142
scalar multiplication, 147
selecting submatrices, 145
shape, 141, 143
transpose, 148
type, 141
Matrix
  Browser, 138–139, 294
  constructor, 143
data structure, 135
  palette, 13, 95, 136, 141
max command, 73
maximize, 168
maximum, 73
Mean command, 175
merge
  table cells, 258
min command, 73
minimal content, 53
minimize, 168
minimum, 73
mod command, 73
mod operator, 75
modes
  Document, 1
  Math, 5
  switching between, 5
  Text, 5
  Worksheet, 1
modify
  character styles, 246
table, 257
modp command, 75
mods command, 75
modular arithmetic, 73, 75
modules, 346
MPS(X) files, 173
msolve command, 95
mul command, 338
multiplication
implied, 6

N
names, 11, 55
  adding assumptions, 117
  and symbols, 17
  assigned, 321
  assigning values to, 55
  logical, 327
  previously assigned, 322
  protected, 57
  removing assumptions, 119
  reserved, 57
  unassigning, 57, 119, 324
  valid, 58
  versus equation labels, 62
  with assumptions, 117
new style set, 249
nops command, 307
norm command, 134, 149
normal command, 313
normal form, 313
not operator, 327
numbers, 11
  exact, 66
  floating-point, 67
  non-base 10, 74
numer command, 306
numeric
  approximation, 317
  computation, 67
numtheory[divisors] command, 73

O
ODE Analyzer Assistant, 89
operands, 307
  selecting, 339
operators, 11
  functional, 296
  logical, 327
  relational, 327
optimization, 168
  efficiency, 171
  plotting, 170
  point-and-click interface, 169
Optimization Assistant, 169
  Plotter, 170
Options dialog, 53
or operator, 327
Order environment variable, 162
ordinary differential equations
  plotting solution, 92
  solving, 89
orthogonal matrix, 151
output
  suppressing, 38
  updating, 32

P
packages, 40
  list, 124
  loading, 42
  unloading, 43, 58
warnings, 43
page break, 240
palettes, 12, 20, 43, 123, 302, 315
  Common Symbols, 12
docks, 16
  adding palettes, 16
expanding, 16
Expression, 13
finding items, 16
inserting items, 13
Layout, 12
Matrix, 13, 136, 141
moving, 16
Symbol Recognition, 16
Units, 25, 100
viewing, 16
paragraph styles
creating, 247
description, 243
parameters, 343
parametric solutions, 83
partial differential equations
solving, 93
paste, 241
PDEs, 93
pdsolve command, 93
pencil
  sketch pad, 278
pi
  inserting, 13
pie chart, 177
piecewise command, 174
placeholders, 13
Planck constant, 106
Plot Builder Assistant, 29, 49
plot command, 162
plot3d command, 299
plots
  analyzing, 224
    pan, 224
    point probe, 224
    rotate, 224
  scale, 224
  code for color plates, 233
  creating, 190
    context menu, 205
    displaying multiple plots, 215
    insert plot, 208
    Interactive Plot Builder, 29, 49, 191
    plot command, 209
    plot3d command, 209
    plots package, 212
creating animations
  animate command, 226
  Interactive Plot Builder, 225
customizing, 217
  context menu, 219
  Interactive Plot Builder, 217
  plot options, 221
  plot3d options, 221
customizing animations, 230
  command-line options, 231
  context menu, 230
    Interactive Plot Builder, 230
  exporting, 232
  functional operators, 299
  gradient, 185
  line integral, 186
ODEs
  numeric solution, 91
  symbolic solution, 92
optimization problem, 170
playing animations, 228
plots package
  animate command, 226
  contourplot command, 215
display command, 216
matrixplot command, 213
pointplot command, 212
series, 162
statistics, 177
viewing animations
   animate context bar, 228
polynomial equations
   solving, 83
   numerically, 84
polynomials
   algebra, 126
   arithmetic, 126
   coefficients, 132
   collecting terms, 132
   degree, 132
   division, 126, 128
   efficient arithmetic, 135
   expanding, 127
   factoring, 133
   implied multiplication, 128
   numeric
      algebraic manipulation, 135
      operations, 134
      sorting, 128
         pure lexicographic, 130
         total degree, 129
   PolynomialTools package, 135
      IsSelfReciprocal command, 135
powers
   entering, 5
precalculus
   teaching, 181
precision, 69
prem command, 135
previously assigned, 322
primality testing, 73
primpart command, 135
print
   command, 344
   table, 261
probability distribution, 173
proc key word, 342
procedures, 342
   and assumptions, 120
   calling, 342
   defining, 342
   displaying, 344
   inputs, 343
   multiple lines, 342
   output, 343
   using, 342
product command, 338
products
   entering, 6
   implied, 6
programs, 325
   modules, 346
   procedures, 342
prompt
   input, 37
properties
   testing, 118
protected names, 57
Q
QPSolve command, 172
QR factorization, 151
quadratic programs, 172
quantities with uncertainty, 112
   accessing error, 112
   accessing value, 112
   computing with, 114
constructing, 112
element properties, 113
rounding the error, 113
scientific constants, 113
with units, 113
quick
character formatting, 237
help, 33
paragraph formatting, 239
reference card, 33
quit statement, 336
quo command, 126
quotes
double, 300
left single, 58
right single, 57, 321
unevaluation, 322
quotient
integer, 73
R
random
matrices, 142
variables, 173
randpoly command, 135
range
in plots, 220
operator, 145
rank, 149
rational expressions
entering, 5
read
from files, 372
recurrence relation
solving, 96
reference
equation labels, 59
names, 55
relational operators, 327
rem command, 126
remainder
integer, 73
remove command, 339
repetition statements, 330
reserved names, 57
restart command, 58
resultant command, 135
return
statement, 336
values, 343
rhs command, 305
right single quotes, 57, 321
right-hand side, 305
RootOf structure, 83
roots
command, 135
of equations, 83
row vector
creating, 143
resolve command, 96
S
scatter plot, 177
scientific constants, 105
list, 105
name, 106
symbol, 106
uncertainty, 110
units, 109
using, 106
value, 109
value and units, 110
ScientificConstants package, 105
  extensibility, 111
  objects, 108
ScientificErrorAnalysis package, 111
  extensibility, 115
  objects, 112
sections
  in worksheet, 241
security levels
  auto-execute, 276
security tab
  options dialog, 276
select command, 339
selectremove command, 339
semicolon, 38–39
seq command, 337
series, 161
  command, 161
  plotting, 162
  Taylor, 161
  type, 162
sets, 291
shape option, 142
show
  worksheet content, 268
show contents dialog
  using, 268
significant digits, 69
simplify command, 308, 316
sketch pad
  canvas style, 242
  gridline, 279
slider
  embedding, 269
solutions
  assigning as expression, 87
  assigning as function, 87
  details, 94
  formal, 93
  formal power series, 93
  integers, 94
  real, 115
  series, 93
  verifying, 86
solve
  equations, 78
    for real solutions, 115
    numerically, 84
    symbolically, 80
  inequations, 78
    for real solutions, 115
    symbolically, 80
  integer equations, 94
  linear system, 95, 151
  modular integer equations, 95
  ODEs, 89
  PDEs, 93
  recurrence relation, 96
  transcendental equations, 82
solve command, 80, 292
  finding all solutions, 82
  finding parametric solutions, 83
  real solutions, 115
  solving procedures, 83
sort
  lists, 314
  polynomials, 128, 314
sort command, 128, 314
  plex option, 130
spacing format, 240
spellcheck, 280
  American spelling, 280
dictionary, 283
square roots
  entering, 18
standard content, 53
Standard Units environment, 102
Standard Worksheet, xiii
statements
  multiple lines, 342
Statistics package, 173
  continuous distributions, 173
  discrete distributions, 174
  plots, 177
strings, 300
StringTools package, 301
Student package, 160, 180–181
  calculus subpackages, 168
  LinearAlgebra subpackage, 152
  Maplets, 180
  Tutors, 180
student resources, 180
study guides, 181
style set management, 249
subscripts
  entering, 7
  format, 237
substitute, 314
sum command, 338
superscript format, 237
Sylvester matrix, 151
symbol completion, 8
  shortcut, 8
symbolic
  computation, 66
  objects, 67
symbols
  entering, 17
  finding, 16
  names, 17
system of units, 98
  controlling, 103
systeme international (SI), 26, 98

T
  Tab
    icon, 44
    inserting, 44
    key, 13, 44
tables, 294
  alignment, 259
  and Classic worksheet, 262
  appearance, 259
  borders, 259
  contents, 257
  execution order, 261
  physical dimensions, 258
  printing, 261
  using, 256
  visibility of cell content, 260
Task Browser, 51
task templates, 50, 71, 97, 123, 135, 153
  default content, 53
  inserting, 53
taylor command, 161
Taylor series, 161
tcoeff command, 133
  teach, 180
temperature conversion, 100
text field
  embedding, 270
  Text mode, 5
text regions, 54
third-party products, 124
tilde, 83, 117
to clause, 330
  excluding, 331
Tolerances package, 111
toolbar, 5
toolbox
  Global Optimization, 124
toolboxes
  Database Integration, 380
  Global Optimization, 168
Tools menu
  Assistants and Tutors, 27, 48
  Tasks, 51
Torsion command, 167
total degree, 129
tour, 33
transparency
  of 3-D plots, 222
transpose
  matrices and vectors, 148
true, 327
Tutors, 27, 180–181, 183
  Derivatives, 181
  Differentiation Methods, 182
  Directional Derivative, 159
  Function Composition, 28
  Gradient, 183
  menu access, 28
type command, 302
types, 117, 302
  converting, 311
  series, 162
testing, 302
  subexpressions, 303
typesetting rule assistant, 242

U
unapply command, 87
unassign command, 57
unassigning names, 57, 324
uncertainty, 111
  quantities with, 111
underline format, 237
unevaluation quotes, 58, 322
union
  of sets, 292
Unit Converter Assistant, 312
units, 25, 97, 312
  adding to expressions, 26
  applying to expression, 100
  computing with, 102
  context, 98
  converting between, 99
  environment, 102
  evaluating with, 26
  in 1-D Math, 102
  inserting, 101
  overview, 97
  prefixes, 102
  system of
    controlling, 103
    systems of, 98
Units Calculator, 99
Units package, 97
  environments, 102
  extensibility, 104
UseSystem command, 104
UsingSystem command, 104
Units palettes, 25, 100
universal gravitational constant, 106
UNIX
command/symbol completion, 8
unwith command, 43
URL
adding hyperlink to, 285
user-defined style set, 251

V
variables, 11
variance, 113
VariationalCalculus package, 168
Vector
constructor
  vectorfield attribute, 166
data structure, 135
vector fields, 166
vector spaces
  basis, 150–151
VariationalCalculus package, 166
  Student version, 168
vectors, 295
  arithmetic, 146
column, 138
  context menus, 148
cross product, 148
data type, 142
defining, 138
efficiency, 141
filling, 142
large, 139
  multiplication, 146
row, 138, 143
scalar multiplication, 147
selecting entries, 144
shape, 142
  transpose, 148

View menu
  markers, 242

W
Web page
  adding hyperlink to, 285
Web site
  Application Center, 124, 180
  Maplesoft, 33, 123–124
  Student Center, 181
while loops, 334
Windows
  command/symbol completion, 8
with command, 42
worksheet
  adding hyperlink to, 285
Worksheet mode, 1, 35
write
to files, 369

X
xor operator, 327

Z
zero recognition, 313
zip command, 341