Web Publishing Basics 1

Website Maintenance Essentials

Jeff Pankin

Information Services and Technology
Course Objectives and Your Role As Site Maintainer ........................................... 3
  Course Objectives .................................................................................................. 3
  Your Role .................................................................................................................. 3
    Routine Tasks for Site Maintainers ........................................................................ 3
    Non-Routine Tasks for Site Maintainers ............................................................... 3
Safety Precautions ..................................................................................................... 4
Get Dreamweaver And Other Tools .......................................................................... 5
  Dreamweaver 8, CS3, CS4 or CS5 should be installed on your computer. .............. 5
  Dreamweaver has secure File Transfer capabilities (FTP). ...................................... 5
  Photoshop or Photoshop Elements prepare images for the web. ............................ 5
Get To Know Your Site ............................................................................................... 6
  To get to know your site print the home page and pages you will edit. ................. 6
  Click the links and note where they take you. ....................................................... 6
  Write the name and location of pages and images. ................................................ 7
  Spend extra time with the pages you will edit. ..................................................... 7
  Create a site map or outline. .................................................................................... 7
Create a New Folder for Your Web Site Files ............................................................ 9
  Create a single folder for storing ALL site files. .................................................... 9
  Become familiar with typical web file types. ......................................................... 9
  Become familiar with best practices for files and folders. ..................................... 9
Get to Know DreamWeaver ....................................................................................... 10
Web Hosting at MIT .................................................................................................. 11
  Web pages at MIT are “hosted” from dedicated computer space called lockers.. 11
  There are different types of lockers. ....................................................................... 11
  Guidelines govern the use of MIT lockers............................................................ 11
  For help contact accounts@mit.edu. ...................................................................... 11
Define Site In Dreamweaver ...................................................................................... 12
  Provide Dreamweaver with important information by Defining a Site. ............... 12
  Exercise: Create a Site Definition in Dreamweaver ............................................. 12
  Check in/Check out is a useful feature when multiple people edit the same pages. 13
Connect To Your Site Locker Using Secure FTP ..................................................... 14
  Click the Expand/Collapse tool to see files on your computer and on the server in a split screen .......................................................... 14
Download All (or Some) Of Your Web Site ............................................................... 16
  Save any existing files in a separate folder. ......................................................... 16
Download all of your site files into a new folder if possible. ........................................ 16
If you download less than the full site make sure your folder structures match. 16
Dependent files include images and .css files. .............................................................. 17
Create a backup of your site. ...................................................................................... 17

Perform File Operations in Dreamweaver ............................................................... 18

Perform File Operations in Dreamweaver
Once a site is defined perform all file operations inside Dreamweaver. .......... 18

Work Flow .................................................................................................................. 19

Work Flow
Follow the Get, Edit, Put work flow cycle. ............................................................ 19

Edit The Events Page ............................................................................................... 20

Edit The Events Page
Templates, only available inside Dreamweaver lock certain areas of web pages
preventing inadvertent editing. .................................................................................... 20

Working With Tables .................................................................................................. 21

Working With Tables
Sample Template Document ...................................................................................... 22

Sample Template Document
Formatting Text with HTML Tags .............................................................................. 23

Formatting Text with HTML Tags
Working With Styles .................................................................................................. 24

Working With Styles
Working With Styles
Sample Style Sheet (.css) Document ......................................................................... 25

Sample Style Sheet (.css) Document
Edit The Research Page .............................................................................................. 26

Edit The Research Page
Make a New Bio Page From an Existing Page ......................................................... 27

Make a New Bio Page From an Existing Page
Edit the Directory Page ............................................................................................. 28

Edit the Directory Page
Help Resources at MIT ............................................................................................... 29

Help Resources at MIT
Fill In The Blank! ........................................................................................................ 30

Fill In The Blank!

Copyright © 2012 by Massachusetts Institute of Technology. All Rights Reserved.
# Course Objectives and Your Role As Site Maintainer

## Course Objectives

1. To learn about MIT locker space, access rights, and web edit best practices
2. To learn to use the basic features of Dreamweaver to maintain web pages
3. To practice making the most typical types of web page edits

## Your Role

In your role as site maintainer for your DLC, professor, course or activity there will be several routine tasks you’ll be called upon to complete. Several are listed here.

### Routine Tasks for Site Maintainers

- define a site in Dreamweaver
- add content to an existing page
- update event info
- create a link to a research article
- add or edit staff directory information
- create a page from a page
- upload edited pages to the live web
- add images to a page

Be aware that other tasks may require additional skills (for which you might seek training) while other tasks (noted with an *) may require hiring a consultant.

### Non-Routine Tasks for Site Maintainers

- modify images using Photoshop
- create pages using templates
- modify templates or styles *
- redesign navigation or design of web site *
Safety Precautions

1. Back up all files – on MIT's TSM service, on a CD or a DVD.

2. Use the multi-step Undo in Dreamweaver to back out of unwanted edits.

3. Use Preview in Browser from Dreamweaver to view your page edits before uploading

4. Organize your files into folders.

5. Be careful about overwriting files with the same name.

6. **Do Not** change the stylesheet or template – unless you are really sure of what you are doing.

7. Do all file and folder management in Dreamweaver, not the operating system.
Get Dreamweaver And Other Tools

Dreamweaver 8, CS3, CS4 or CS5 should be installed on your computer. Make sure you have Dreamweaver on your computer. The latest version from Adobe is Dreamweaver. You may obtain either Dreamweaver 8 or CS3 by going to the IS&T site ist.mit.edu and selecting Volume Site Licensing in the Software box.

Dreamweaver has secure File Transfer capabilities (FTP). Dreamweaver has a built in secure file transfer option. Your local area may use and support an external file transfer program such as Fetch (Mac) or Secure FX (Windows). Both are available as free downloads from the IS&T software downloads page. https://web.mit.edu/software/ This page requires certificates.

Photoshop or Photoshop Elements prepare images for the web. You may also be asked to prepare photos for your web pages. You may wish to purchase Photoshop or Photoshop Elements. These products are available at an Academic discount through GovConnection.

Very low cost alternatives are iPhoto (free program with Mac OS), Picasa (free download from Google for Windows and Mac) and Picnik (Mac and Windows web-based photo editor).

Note: This class is being taught using Dreamweaver CS4. The latest version from Adobe is actually CS5.5. In Adobe Dreamweaver CS4 go to the Window menu, choose Workspace Layout and select Classic to use the layout most similar to versions 8 and CS3.
Get To Know Your Site

To get to know your site print the home page and pages you will edit.
The next step as a new site maintainer is to get to know your site. Print out the
pages of your site. Bring up each page in a browser and choose print. You can
begin with just the home page and the next level of pages.

The Center for Industrial Growth

Click the links and note where they take you.
With your printed pages in front of you carefully work your way from page to page
on the site following very link. Take notes on the printed pages. Where are the
navigation links? Note where the navigation and other links are on each page and
where they take you. Also note the images on each page.

Page 6
Write the name and location of pages and images.
Write the names of page and image files and their locations. After you click on a link, note the url of the destination in the address bar. This will tell you the location and file name. Right click (Windows) on an image to get properties which tells you the name and location of the image.

Control click (Mac) on an image, select copy image address, paste the address into the address bar and press return. View the image location and name in the new window.

Spend extra time with the pages you will edit.
You should pay close attention to the pages you are likely to edit. Note the content on each page and try to determine the likely source of the content.

Create a site map or outline.
Once you have explored your site you may want to document the site hierarchy with a tree diagram which would describe the overall structure of your site including actual file names and the folders in which they are located. Note any file naming protocols. See example below.
Create a New Folder for Your Web Site Files

Create a single folder for storing ALL site files.
The first step in working with your DLC web site is to create a single folder on your computer to hold all of your web site files. ALL files associated with this web site including web pages, images, pdf files and anything else should be kept in this folder.

Give this folder a name which will allow you and others to quickly understand its contents, such as cig-website, or stephens-lab-web-site.

Use lower case letters and the hyphen as word separators.

Become familiar with typical web file types.

<table>
<thead>
<tr>
<th>File Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.html (.htm)</td>
<td>file read by a browser to display a web page</td>
</tr>
<tr>
<td>.gif, .jpg</td>
<td>image file, photograph file</td>
</tr>
<tr>
<td>.pdf</td>
<td>file with information to be read (read only) – opens using Adobe Reader</td>
</tr>
<tr>
<td>.css</td>
<td>file which describes formatting for web page</td>
</tr>
<tr>
<td>.dwt</td>
<td>Dreamweaver file which describes page layout</td>
</tr>
</tbody>
</table>

Become familiar with best practices for files and folders.

<table>
<thead>
<tr>
<th>Folders</th>
<th>organize your files into folders (e.g., images, bios, research, news, styles, Templates)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>try to have no more than 15-20 loose files</td>
</tr>
<tr>
<td>index.html</td>
<td>this is the default file to launch in ANY directory</td>
</tr>
<tr>
<td></td>
<td>e.g., cig / news / index.html</td>
</tr>
<tr>
<td>Naming</td>
<td>• use <strong>lower case</strong></td>
</tr>
<tr>
<td></td>
<td>• use <strong>hyphens</strong> to separate words - <strong>do not use spaces</strong>!</td>
</tr>
<tr>
<td></td>
<td>e.g., johnson-bio.html</td>
</tr>
<tr>
<td></td>
<td>• avoid these characters     / \ @ &amp; $ + * ?</td>
</tr>
</tbody>
</table>
Get to Know DreamWeaver

- **Insert Panel**
- **Properties Panel**
- **Document Editing Area**
- **Additional Panels**
  - Double-click name to open and close
- **Files Panel**
- **Expand/Collapse Files Panel**

Click **Code** to view your html code. Click **Split** to show both Design view and Code view.

**The MIT Center for Industrial Growth**

About the Center

MIT and industry have a long record of cooperation through projects ranging from joint education and research (where student participation is often a strong component) to intensive continuing education programs.

The Center for Industrial Growth supports interdisciplinary research and education aimed at understanding and improving industrial innovation and efficiency and the education of future industrialists.

The collaboration is extensive; industry executives serve on the MIT Corporation and its committees; MIT faculty members serve as consultants for industry; and MIT educates and prepares its students for careers in industry. The relationship between MIT and industry has had an important effect on the direction of education at the Institute.
Web Hosting at MIT

Web pages at MIT are “hosted” from dedicated computer space called lockers.

Any organization, course, activity or individual at MIT may host web pages at no cost, on server space in an Athena locker. A locker is simply a directory in the web.mit.edu domain, which acts like the folders on a desktop computer, but is located on a remote hard drive.

There are different types of lockers.

Lockers are designated as org (for a DLC), user (for faculty, staff, and students), course (for course related content), or activity (for clubs and activities). A Stellar account would also provide space for academic course material.

User lockers are automatically set up and allocated with 1.5 gigabytes of locker space. They are located in a directory named the same as your username (e.g., web.mit.edu/sjones). This space may be used for file storage and for hosting web pages.

Note: User web pages are actually hosted from a subdirectory named /www (e.g., sjones/www). If you arrived at MIT prior to 1998 a /www subdirectory might not have been created. For help with this situation contact User Accounts.

Guidelines govern the use of MIT lockers.

The use of MIT web space is governed by guidelines on issues such as copyright, use of MIT space for political or private commercial purposes, and the commitment to user accessibility. You will find the url for the full set of guidelines in the Resources section of this document.

For help contact accounts@mit.edu.

For help with web lockers contact User Accounts by sending an email to accounts@mit.edu.
Define Site In Dreamweaver

Provide Dreamweaver with important information by Defining a Site.
You are now ready to begin working in Dreamweaver. Your first step is to define a site. This will let Dreamweaver know where your local files are located (the folder you designated in an earlier step) and also where your web locker is located. You will be working in the Site Definition Dialog box.

![Site Definition Dialog Box]

Exercise: Create a Site Definition in Dreamweaver

1. From the Site menu choose New Site
2. Click on the Advanced tab
3. Select Local Info from the Category list
4. Type a name for your project (e.g., same name as your project folder)
5. Locate the Local Root folder on your hard drive using the browse icon. Mac users can select the folder and then click Choose. Windows users must open the folder and then click Select.

6. Select Remote Info from the Category list

7. Select Access then FTP

8. Select or enter the following:

<table>
<thead>
<tr>
<th>FTP Host</th>
<th>athena.dialup.mit.edu</th>
</tr>
</thead>
<tbody>
<tr>
<td>Host Directory examples</td>
<td>/afs/athena.mit.edu/org/c/chemistry</td>
</tr>
<tr>
<td></td>
<td>/afs/athena.mit.edu/user/s/j/sjones/www</td>
</tr>
<tr>
<td></td>
<td>Note the use of the first letter for an org locker and the first two letters and the additional www for a user locker.</td>
</tr>
<tr>
<td>Login</td>
<td>your Kerberos username</td>
</tr>
<tr>
<td>Password</td>
<td>leave blank</td>
</tr>
<tr>
<td>Use Passive FTP</td>
<td>check this option</td>
</tr>
<tr>
<td>Use Firewall</td>
<td>uncheck this option</td>
</tr>
<tr>
<td>Use Secure FTP (SFTP)</td>
<td>check this option</td>
</tr>
</tbody>
</table>

With this information entered you are now ready to access your Athena locker. Click OK to close the Site Definition dialog box.

**Check in/Check out is a useful feature when multiple people edit the same pages.**
A feature within Dreamweaver which allows one person at a time to “check out” (i.e., download) a file to edit. While that file is checked out no one else may edit that page.
Connect To Your Site Locker Using Secure FTP

Click the Expand/Collapse tool to see files on your computer and on the server in a split screen.

Dreamweaver has a convenient view which lets you see local files and server files in a window with two columns. Click the Expand icon on the Files panel for this view.

The expanded panel opens to the two column window. On the Mac you can click the green circle to expand this two column window to full screen.

Mac users sometimes lose the small window behind the larger window or lose the list of files from the Files panel. Simply choose Files from the Window menu or press F8 to retrieve your two column window. Then click the collapse button.

To restore the default screen arrangement click on Windows > Workspace, and choose Default (Mac) or Designer (Windows).
To connect to the locker on the server click the Connect icon.

Click on the Connect icon on the toolbar. It looks like a plug.

This will launch the connection process. You will be asked for your password each time you connect for security reasons. Enter your Kerberos password. You will soon see the file listing of the files and folders in your web locker.

If you get an ftp error, chances are you mistyped some information on the Remote tab in the Site Definition dialog box. Choose Manage Sites from the Site menu. Select the site name and click the edit button. Click the Remote info category from the list on the right and locate and fix the error.
Download All (or Some) Of Your Web Site

Save any existing files in a separate folder.
If you already have a folder with site files which you have inherited, rename that folder and save it in case you need any of the files. Make sure the Site Definition points to the new folder on your computer. Then download the entire site into the new folder.

Download all of your site files into a new folder if possible.
A good rule of thumb when you first take on the site maintainer role is to download the entire contents of the web locker into a new folder. We created a new folder in an earlier step.

If you download less than the full site make sure your folder structures match.
If you know that you will only be working on a small number of pages you can download only those pages. It’s best to download the entire folder in which a page resides and any Dependent files so you will have all the necessary files for your page to be viewed on your computer, and you will mirror the file structure of your live web site.

To get (download) the entire site click on the locker name at the top of the file listing to select the entire site.

To select individual folders select one, hold down the Control key (Windows) or the Command key (Mac) while selecting files.

To get (download) one file, select it and click the Get button or double-click the file.

Click the Get button on the toolbar to start the download.
Dependent files include images and .css files.
You may be asked about downloading dependent files. These are files which would be loaded by a browser when loading the page (images, style sheet files). Unless you are sure you already have these on your computer it’s best to answer yes.

Create a backup of your site.
If not initially, then at some point you should create a backup of the full web site. This ensures that you have access to your site files should the internet be unavailable or your site files become corrupted. A periodic back up plan should be developed – for all of your files, not just your web page files! IS&T offers a backup service free of charge. See the Resources page.
Perform File Operations in Dreamweaver

Once a site is defined perform all file operations inside Dreamweaver. From this point on all file operations (new file, new folder, move, copy, rename) must be done within Dreamweaver so that links are maintained. If you perform any of these operations at the Desktop level your web site will not work properly.

To perform file operations in Dreamweaver make sure the Files panel is showing on the left of your screen.

If the Files panel is not visible choose Files from the Window menu or press F8.

To reset all the windows and panels choose:

Window > Workspace Layout > Designer (Windows) or Default (Mac).

If the Files panel is visible among the panels but not open, click on the word Files next to the triangle.

This will open and close a panel.

Right click (Windows) or Control-click (Mac) in the folder area of the Files panel to pop open the edit menu.
Work Flow

Follow the Get, Edit, Put work flow cycle.
You are now in a position to follow a proper work flow, which is...

1. Get the file(s) from the server
2. Edit the files
3. Preview your edits
4. Put the files back on the server making them live

Always assume that the latest version of a file is on the server. Assuming this, your first action would be to get (download) the file you need to edit.

Once it’s on your computer you can edit your pages. Remember, you can only edit pages on your computer, not directly on the server.

When your edits are complete, and the new pages have been previewed (more later) and approved if necessary, you can put (upload) the pages.

1. Expand your files panel as before.
2. Connect to your site locker if necessary.
3. Select the files and/or folders from the file list of your local root folder.
4. Click on the Put (upload) button.

Note: You may be in a situation where edits must be approved, where someone other than you will be uploading the new pages or where you are not the only one making page edits. In these cases you will need to modify the work plan to include others in the process but it should still follow the Get -> Edit -> Put cycle.
Edit The Events Page

In this exercise we will edit the Events page on the Center for Industrial Growth site.

When you first open this page you’ll notice that only certain parts of the page are live while the rest of the page is locked. This page is based on a Dreamweaver template which is a special file used to set the main design components which remain consistent from page to page.

**Templates, only available inside Dreamweaver lock certain areas of web pages preventing inadvertent editing.**
Templates allow a developer to lock most areas of a page leaving a designated editable region for content which changes.

Template files are set up in Dreamweaver and can be identified by their .dwt extension. Changing an element in the template file could change that element on ALL the pages using that template.* So, be very careful if you happen to find yourself in a template file!

* Actually, Dreamweaver would ask before updating all the pages. And, any changed pages would then have to be uploaded to the server.

A file which uses a template can be identified by a yellow notation in the top right corner of the page when viewed in Dreamweaver.

Exercise:

The new event information is located in edits.txt.

1. Open the events folder and the index file in that folder.
2. Open the working-files folder and the edits.txt.
3. Copy the information for the first event from edits.txt and paste it over the event info at the top of the index page.
4. Scroll to the bottom of the web page and note that the rest of the events are in a table.
5. Insert a new table row. See Working With Tables below.
6. Copy the second set of event info from the edits.txt to the appropriate cells of the new row.

To add a double space line break press Enter (Windows) or Return (Mac). To add a single space line break press shift-Enter (Windows) or shift-Return (Mac).

To complete the edit process save your file(s) and choose Preview in Browser from the File menu. Be sure to test your links.

To complete the Edit Cycle upload the files which have been changed.

**Working With Tables**

To **insert rows** into a table:

1. Click in a table row.

2. From the Modify menu choose Table, and then choose Insert Rows or Columns...

3. In the dialog box, enter the number of rows and choose above or below the selection (the cursor location).

To **delete a row** or rows:

1. Click in a table row.

2. From the Modify menu choose Table, and then choose Delete Row

3. Repeat as necessary.
The template document has **no content**. Instead, it has a placeholder for content called an **editable region**. The editable region on this template is named *cellmain*.

The template allows access to the items which on locked on the html content pages.
Formatting Text with HTML Tags

Web pages get their formatting from two sources – **html tags and styles**.

When you type or paste basic text Dreamweaver by default assigns the paragraph format to the text. It does this by adding the html tags open paragraph `<p>` and close paragraph `</p>` before and after the text.

You can see this by clicking on the Code view icon in the top left corner.

For a section title you can change the designation of text from paragraph to heading. Headings come in 6 levels each with a different relative size. Heading1 is the largest.

To **format as a heading**:

1. Click once on the text to format (no need to select the text).
2. Choose the heading level from the Format pop-up box in the Properties panel.

If you’d like to see the change in the html code switch to Code view.
Working With Styles

You may have noticed that when you pasted the information from the edits.txt into the index page the font and size changed to match the other formatting of the other event info in the table. The data in the table cells are formatted by use of a style.

**Styles contain formatting information and are applied across a website.**

A **style** is a collection of formatting attributes. By applying the style to some content all the formatting is applied at once. Changing the style formatting definition changes the formatting of all the content with that style applied, so be very careful with styles.

The same style is typically used on multiple pages to keep formatting consistent. It is likely stored in a stylesheet file which is identified by its `.css` extension.

Some styles are associated with html tags. Some styles are created by developers. To determine whether a style has been applied to some text, click on the text and look at the **Style** box in the **Properties** panel. If the **Style** box says none, then note the tag assigned in the **Format** box. The content is getting it’s formatting from this tag.

Be very careful with styles. Modifying a style’s formatting attributes will likely change the look of text on multiple pages. Ask for help if you are not sure. Undo any unwanted changes right away.
Sample Style Sheet (.css) Document

h1 {
  font-family: Georgia, "Times New Roman", serif;
  font-size: 26px;
  color: #000000;
}

.cellnav {
  background-color: #FFFFFF;
  vertical-align: top;
  width: 150px;
}

.cellmain {
  background-color: #FFFFFF;
  color: #000000;
  border-left: thin solid #993333;
  vertical-align: top;
}

h2 {
  font-family: Verdana, Arial, Helvetica, sans-serif;
  font-size: 18px;
  font-style: normal;
  color: #993333;
  font-weight: normal;
}

body {
  font-family: Verdana, Arial, Helvetica, sans-serif;
  color: #0033CC;
  font-size: 14px;
  background-color: #FFFFFF;
}

.maroon {
  color: #993300;
}

.cellheader {
  background-color: #FFFFFF;
  background-image: url(images/mitdome.jpg);
  background-repeat: no-repeat;
  height: 60px;
  vertical-align: middle;
  text-align: center;
  color: #000000;
  font-family: Arial, Helvetica, sans-serif;
  background-position: 600px;
}

#nav a:link, #nav a:visited {
  font-size: 12px;
  color: #000000;
  text-decoration: none;
  background-color: #FFFFFF;
  white-space: nowrap;
  display: block;
  font-weight: normal;
  padding: 5px;
  font-family: Arial, Helvetica, sans-serif;
  border-bottom: thin dotted #993333;
}

#nav a:hover {
  color: #FFFFFF;
  background-color: #993333;
  font-weight: normal;
}

h3 {
  font-family: Arial, Helvetica, sans-serif;
  font-size: 16px;
}

.research-text {
  font-family: "Times New Roman", serif;
  font-size: 14px;
}

.tabletext {
  font: 13px Arial, Helvetica, sans-serif;
}

.bioheader {
  font-size: 18px;
  color: #993333;
}

.biotext {
  font: 14px "Times New Roman", serif;
}

.newstext {
  font: 14px Arial, Helvetica, sans-serif;
  color: #888888;
}
**Edit The Research Page**

To edit the research page you will add a reference to a research paper and create a link from the reference to the actual research document.

**Exercise:**

1. Open the file *The Effects of Planning on Productivity.doc* and save this file as a .pdf file. **NOTE:** This step has actually been completed for you.

2. Name the new .pdf file *Sullivan-12-01.pdf* and save it in the *research* folder.
   
   This naming convention means Sullivan’s first research article of 2009. Using a similar naming convention will help you keep your files organized.
   
   On the Mac saving a files in the pdf format is part of the Print dialog box. On Windows a special utility must be added to allow saving as a pdf.

3. Open the *research* folder and open the *index* file.

4. Open the *edits.txt* file and copy the reference into the *index* page.

5. Highlight the name of the research article i.e., *The Effects of Planning on Industrial Productivity*. This text will become the link.

6. Press and drag from the Point to icon to the right of the link edit box to the name of the file in the Files panel. This allows Dreamweaver to automatically establish the link.

   ![Image of Dreamweaver interface highlighting the link process]

7. Press Enter or Return to complete the linking process or click on the content.

To complete the edit process save your file(s) and choose Preview in Browser from the **File** menu. Be sure to test your links.

To complete the Edit Cycle upload the files which have been changed. Don’t forget to upload the new pdf file!
Make a New Bio Page From an Existing Page

In this exercise you will create a new bio page from an existing page. You will then add a new person to the directory and link the directory entry to the new bio page. You’ll also add an email link.

**Exercise:**

1. Close any files used in the previous exercise.
2. Open the *faculty-bios* folder and open the *martin-bio.html* file.
   
   Note the consistent naming of these bio pages.
3. Choose Save As from the File menu and save the file as *pankin-bio.html*.
4. Open the *working-files* folder and open the *edits.txt* file.
5. Change the contact information to Pankin’s information. Change the other info for Pankin.
6. In the *working-files* folder, rename the *image-jeffpankin.jpg* file to *pankin.jpg*.
7. Move the *pankin.jpg* file to the *images* folder using drag and drop or cut and paste. Do this inside the Files panel on the right.
8. In the *pankin-bio.html* document delete the image of Professor Martin.
9. From the Insert panel click the icon to insert an image.

![Common](image-source-button)

10. Locate the *pankin.jpg* image and insert it. Add appropriate alternate text in the dialog box.
11. Save and close the file.

**Note:** You can also double click an image to open the Select Image Source dialog box. After inserting an image, click to select it and change the *alt* information in the Properties panel.

**This exercise continues on the next page.**
**Edit the Directory Page**

The next part of this exercise will be to add Professor Pankin to the Directory page, create a link to his bio page, and create an email link.

1. Close any files used in the previous part of this exercise.
2. Open the *directory* folder and open the *index* page.
3. Click in the table at the place where you would like to create a row to add Professor Pankin.
4. Choose *Table Objects* from the *Insert* menu and create a new row.
5. Enter the appropriate information for Pankin.
6. Highlight the full name which will become the link to the bio page.
7. In the Files panel make sure the *faculty-bios* folder is open.
8. Drag the *Point To* icon (to the right of the *Link edit box* in the *Properties* panel) to the *pankin-bio.html* file. Release the mouse when the file name is visible in the Link box. Press Enter or Return or click on the content.
9. Highlight the email address for *pankin@mit.edu* in the directory.
10. In the Link edit box type *mailto:pankin@mit.edu*. Press Enter or Return.

**Note:** The text “mailto:email@domain” creates a link which opens the default email program on a computer and automatically addresses a new message. There is no space between mailto: and the email address.

To complete the edit process save your file(s) and choose *Preview in Browser* from the *File* menu. Be sure to test your links.

To complete the Edit Cycle upload the files which have been changed.
Help Resources at MIT

1. MIT Legal and Policy Guidelines for the Use of Web Space
   ist.mit.edu/services/web/reference/requirements/legal-and-policy-guidelines

2. MIT Software Downloads
   ist.mit.edu/services/software/available-software

3. TSM Backup Service
   ist.mit.edu/services/backup/tsm

4. Web Publishing reference pages at MIT
   ist.mit.edu/services/web/reference
   ist.mit.edu/services/training/webpublishing

5. MIT IS&T Help Desk & Support
   ist.mit.edu/support

6. Departmental Consulting and Application Development (DCAD)
   ist.mit.edu/dcad

7. IS&T Training Resources
   ist.mit.edu/services/training
   lynda.mit.edu

8. Athena User Accounts
   ist.mit.edu/support/accounts
1. The language which determines how a page looks is called h___.

2. The html t___s give structure to the page content.

3. Styles specify formatting and page l___ t.

4. Web page documents are stored on a s___ r, a computer with special software.

5. Clicking a l___ k on a web page sends a request from your computer to the server.

6. The server sends the web page back to your computer using the protocol known as h__ p.

7. The b___ r on your computer constructs the web page from the html code.

8. You will use D___ r to edit web pages on your computer not directly on the server.

9. Web page documents are downloaded (copied) from the server to your computer using the protocol known as f p.

10. After editing, the web page document is u___ d (copied) to the server making the new version live.
Answer Key:

html, tags, layout, server, link, http, browser, Dreamweaver, ftp, uploaded